emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* LaTeX Export
@ 2009-01-05 12:42 Rasmus Pank Roulund
  2009-01-05 15:29 ` Carsten Dominik
  2009-01-05 15:43 ` Matthew Lundin
  0 siblings, 2 replies; 53+ messages in thread
From: Rasmus Pank Roulund @ 2009-01-05 12:42 UTC (permalink / raw)
  To: emacs-orgmode

Hello,
I have got two questions.
I am using Org-mode v. 3.16c. I usually use LaTeX but Org has been
really nice. However, I want to export to LaTeX.
Two features are bugging me though.
  1. Timestambs are really nice, but I don't want them in my final
     print (the LaTeX output). Is there an easy way to remove these? 
  2. The interpretation of $ is probably nice for American but for me
     it creates a lot of undesirable results, since a lot of math is
     not recognized as math for unknown reasons. It would be nice to
     be able to turn the $-feature off [1]. When I need a $-sign I
     would much rather use \$. Maybe the universal currency-symbol ¤
     could be used as a replacement, if the user desire.

If either of these are already possible I appoligize. I was not able
to find an answear to my questions in the manual.

[1] "To avoid conflicts with currency specifications, single '$'
     characters are only recognized as math delimiters if the enclosed
     text contains at most two line breaks, is directly attached to
     the '$' characters with no whitespace in between, and if the
     closing '$' is followed by whitespace or punctuation". 
     --From the Org manual.

Thanks,
Rasmus

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-01-05 12:42 LaTeX Export Rasmus Pank Roulund
@ 2009-01-05 15:29 ` Carsten Dominik
  2009-01-05 16:10   ` Rasmus Pank Roulund
  2009-01-05 15:43 ` Matthew Lundin
  1 sibling, 1 reply; 53+ messages in thread
From: Carsten Dominik @ 2009-01-05 15:29 UTC (permalink / raw)
  To: Rasmus Pank Roulund; +Cc: emacs-orgmode

Hi Rasmus,

First of all, org 3.16c is very old indeed so *maybe* this
works better in a more recent version?

Second, you could help with an example which demonstrates the problem.

- Carsten

On Jan 5, 2009, at 1:42 PM, Rasmus Pank Roulund wrote:

> Hello,
> I have got two questions.
> I am using Org-mode v. 3.16c. I usually use LaTeX but Org has been
> really nice. However, I want to export to LaTeX.
> Two features are bugging me though.
>  1. Timestambs are really nice, but I don't want them in my final
>     print (the LaTeX output). Is there an easy way to remove these?
>  2. The interpretation of $ is probably nice for American but for me
>     it creates a lot of undesirable results, since a lot of math is
>     not recognized as math for unknown reasons. It would be nice to
>     be able to turn the $-feature off [1]. When I need a $-sign I
>     would much rather use \$. Maybe the universal currency-symbol ¤
>     could be used as a replacement, if the user desire.
>
> If either of these are already possible I appoligize. I was not able
> to find an answear to my questions in the manual.
>
> [1] "To avoid conflicts with currency specifications, single '$'
>     characters are only recognized as math delimiters if the enclosed
>     text contains at most two line breaks, is directly attached to
>     the '$' characters with no whitespace in between, and if the
>     closing '$' is followed by whitespace or punctuation".
>     --From the Org manual.
>
> Thanks,
> Rasmus
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-01-05 12:42 LaTeX Export Rasmus Pank Roulund
  2009-01-05 15:29 ` Carsten Dominik
@ 2009-01-05 15:43 ` Matthew Lundin
  1 sibling, 0 replies; 53+ messages in thread
From: Matthew Lundin @ 2009-01-05 15:43 UTC (permalink / raw)
  To: Rasmus Pank Roulund; +Cc: emacs-orgmode


Hi Rasmus,

Rasmus Pank Roulund <rasmus.pank@gmail.com> writes:

> Hello,
> I have got two questions.
> I am using Org-mode v. 3.16c. I usually use LaTeX but Org has been
> really nice. However, I want to export to LaTeX.

I assume you mean org-mode 6.13c?

> Two features are bugging me though.
>   1. Timestambs are really nice, but I don't want them in my final
>      print (the LaTeX output). Is there an easy way to remove these? 

You can control this option either with global settings:

(setq org-export-with-timestamps nil)

or with in-buffer options[1]:

#+OPTIONS: <:nil

As I'm testing this myself, however, I'm finding that this option
works fine for html export, but is not working for LaTeX export in org
6.17a. (Just to be clear: I'm refreshing the buffer settings with C-c
C-c before exporting.)

Strangely, when export with timestamps is turned on, only the last
timestamped item appears in the LaTeX export (e.g., the CLOSED
timestamp on an item that had been scheduled). But when I turn the
timestamp option off, all timestamps appear in the exported LaTeX
(e.g., both SCHEDULED and CLOSED timestamps).

I'm also finding that TODO keywords do not appear in the latex output
with the following option turned on:

#+OPTIONS: todo:t

Can anyone else duplicate this behavior?

Thanks,
Matt

Footnotes (courtesy of the wonderful new org-footnote-action):

[1] http://orgmode.org/manual/Export-options.html#Export-options

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-01-05 15:29 ` Carsten Dominik
@ 2009-01-05 16:10   ` Rasmus Pank Roulund
  2009-01-06 12:00     ` Carsten Dominik
  0 siblings, 1 reply; 53+ messages in thread
From: Rasmus Pank Roulund @ 2009-01-05 16:10 UTC (permalink / raw)
  To: emacs-orgmode


> First of all, org 3.16c is very old indeed so *maybe* this works
> better in a more recent version?
Sorry, it is 6.16c :-) (Thanks Matthew!)
I believe it is the version bundled with the latest Emacsw32 from
ourcomments.org. I am using a Emacsw32 from December 2008.
Since I use win32 I am not able to use the provided update-script. 
Is is okay to overwrite the el files in the Emacs folder and recompile
them?

> Second, you could help with an example which demonstrates the problem.
Sorry. I should have included examples in the first post.
Here is an example from the notes I am working on.
The LaTeX output is:

    \begin{itemize}
    \item Indtegnes i et $x_1/x_2$-diagram, evt. med indifferentkurver.
    \item Kurve, der sammensætte alle de bedste løsninger \$(x_1^{*},
          x_2^{*})$ ved varierende indkomst $m$.
    \end{itemize}

Notice the \$ in the second item. Since I rarely use $ as a symbol but
use it all the time as math delimiter it would be more efficient to use
\$ when I actually need a $-sign.

Here is the corresponding Org code:

    - Indtegnes i et $x_1/x_2$-diagram, evt. med indifferentkurver.
    - Kurve, der sammensætte alle de bedste løsninger $(x_1^{*},
      x_2^{*})$ ved varierende indkomst $m$.

The trouble is probably caused by my auto-fill-mode hook, but I really
cannot stand long lines, and I absolutely love auto-fill-mode.

Here is an example of the information I would like to have washed out.
The LaTeX code contains the following:
    \section{Forbrugeroverskud}
    \label{sec-10}
      \texttt{SCHEDULED:} \texttt{<2008-12-30 ti>}
        \texttt{CLOCK:} [2008-12-30 ti 13:42]--[2008-12-30 ti 15:47] =>  2:05
    
Here is the corresponding Org code:
     * DONE Forbrugeroverskud
       SCHEDULED: <2008-12-30 ti>
         CLOCK: [2008-12-30 ti 13:42]--[2008-12-30 ti 15:47] =>  2:05

I have (setq org-export-with-timestamps t) btw.
With #+OPTIONS: <:nil time stamps are still present (after refreshing
and re-exporting).

Another thing on LaTeX Export: Why so much \texttt{}? Org stamps (and
tags) such as CLOSED are written with \texttt{}. I am not sure why.

On check boxes: Can their look be customized? I would rather use
\CheckedBox and \Square from the Wasysym package. It is LaTeX so there
is no reason to use ASCII persudo boxes (IMO, of course). 

Long post. Sorry. 
--Rasmus

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Re: LaTeX Export
  2009-01-05 16:10   ` Rasmus Pank Roulund
@ 2009-01-06 12:00     ` Carsten Dominik
  2009-01-08 17:48       ` Rasmus Pank Roulund
  0 siblings, 1 reply; 53+ messages in thread
From: Carsten Dominik @ 2009-01-06 12:00 UTC (permalink / raw)
  To: Rasmus Pank Roulund; +Cc: emacs-orgmode

Hi Rasmus,

I have tried to fix the issues with dollars, please download the  
latest GIT
version and check if your stuff is now converted better.

I have not yet looked at the issues with the timestamps.

- Carsten

On Jan 5, 2009, at 5:10 PM, Rasmus Pank Roulund wrote:

>
>> First of all, org 3.16c is very old indeed so *maybe* this works
>> better in a more recent version?
> Sorry, it is 6.16c :-) (Thanks Matthew!)
> I believe it is the version bundled with the latest Emacsw32 from
> ourcomments.org. I am using a Emacsw32 from December 2008.
> Since I use win32 I am not able to use the provided update-script.
> Is is okay to overwrite the el files in the Emacs folder and recompile
> them?
>
>> Second, you could help with an example which demonstrates the  
>> problem.
> Sorry. I should have included examples in the first post.
> Here is an example from the notes I am working on.
> The LaTeX output is:
>
>    \begin{itemize}
>    \item Indtegnes i et $x_1/x_2$-diagram, evt. med indifferentkurver.
>    \item Kurve, der sammensætte alle de bedste løsninger \$(x_1^{*},
>          x_2^{*})$ ved varierende indkomst $m$.
>    \end{itemize}
>
> Notice the \$ in the second item. Since I rarely use $ as a symbol but
> use it all the time as math delimiter it would be more efficient to  
> use
> \$ when I actually need a $-sign.
>
> Here is the corresponding Org code:
>
>    - Indtegnes i et $x_1/x_2$-diagram, evt. med indifferentkurver.
>    - Kurve, der sammensætte alle de bedste løsninger $(x_1^{*},
>      x_2^{*})$ ved varierende indkomst $m$.
>
> The trouble is probably caused by my auto-fill-mode hook, but I really
> cannot stand long lines, and I absolutely love auto-fill-mode.
>
> Here is an example of the information I would like to have washed out.
> The LaTeX code contains the following:
>    \section{Forbrugeroverskud}
>    \label{sec-10}
>      \texttt{SCHEDULED:} \texttt{<2008-12-30 ti>}
>        \texttt{CLOCK:} [2008-12-30 ti 13:42]--[2008-12-30 ti 15:47]  
> =>  2:05
>
> Here is the corresponding Org code:
>     * DONE Forbrugeroverskud
>       SCHEDULED: <2008-12-30 ti>
>         CLOCK: [2008-12-30 ti 13:42]--[2008-12-30 ti 15:47] =>  2:05
>
> I have (setq org-export-with-timestamps t) btw.
> With #+OPTIONS: <:nil time stamps are still present (after refreshing
> and re-exporting).
>
> Another thing on LaTeX Export: Why so much \texttt{}? Org stamps (and
> tags) such as CLOSED are written with \texttt{}. I am not sure why.
>
> On check boxes: Can their look be customized? I would rather use
> \CheckedBox and \Square from the Wasysym package. It is LaTeX so there
> is no reason to use ASCII persudo boxes (IMO, of course).
>
> Long post. Sorry.
> --Rasmus
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-01-06 12:00     ` Carsten Dominik
@ 2009-01-08 17:48       ` Rasmus Pank Roulund
  2009-01-08 21:38         ` Carsten Dominik
  0 siblings, 1 reply; 53+ messages in thread
From: Rasmus Pank Roulund @ 2009-01-08 17:48 UTC (permalink / raw)
  To: emacs-orgmode

> I have tried to fix the issues with dollars, please download the
> latest GIT version and check if your stuff is now converted better.

I have gotten the newest git version from today. I have Org v6.17trans.

There is still something funny with $-signs.

Here are a couple of examples:
------
LaTeX output: 
      \item Hvis en vare har input \$x\$ \dots

Org:
      - Hvis en vare har input $x$ \dots
------
LaTeX output:
       $$M\overline{V}=P\overline{Y}$$
       \$M\$ er bestemt af centralbanken, og det eneste den bestemmer er
       prisniveauet.

Org:
     - Produktionsfunktionen brugt af monetarister:
       $$M\overline{V}=P\overline{Y}$$
       $M$ er bestemt af centralbanken, og det eneste den bestemmer er
       prisniveauet.
------
LaTeX output (this one is particuarily troublesome):
      \item På arbejdsmarkedet bestemmes ligevægten imellem $L_d$ og $L_s\$
       Her ud fra findes ligevægten i udbudet.

Org:
     - På arbejdsmarkedet bestemmes ligevægten imellem $L_d$ og $L_s$
       Her ud fra findes ligevægten i udbudet.
------
LaTeX (also troublesome):
      \item Givet ved $y=f(l, k)\$

Org: 
     - Givet ved $y=f(l, k)$
------
There are lots of \$ in the end of math even though there is no line
break.

Cheers,
Rasmus

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Re: LaTeX Export
  2009-01-08 17:48       ` Rasmus Pank Roulund
@ 2009-01-08 21:38         ` Carsten Dominik
  2009-02-10 20:46           ` Rasmus Pank Roulund
  0 siblings, 1 reply; 53+ messages in thread
From: Carsten Dominik @ 2009-01-08 21:38 UTC (permalink / raw)
  To: Rasmus Pank Roulund; +Cc: emacs-orgmode

Hi Rasmus,

please keep testing!

I have fixed the issues you mentioned in you mail - I am
sure there will be more.

Parsing TeX is hard, parsing pseudo-TeX like in Org-mode
is even harder.  Note that this will never be perfect.
In particular, $-parsing is a bitch.  You can elagantly
cheat out by using \(...\) and \[...\] instead.

- Carsten

On Jan 8, 2009, at 6:48 PM, Rasmus Pank Roulund wrote:

>> I have tried to fix the issues with dollars, please download the
>> latest GIT version and check if your stuff is now converted better.
>
> I have gotten the newest git version from today. I have Org  
> v6.17trans.
>
> There is still something funny with $-signs.
>
> Here are a couple of examples:
> ------
> LaTeX output:
>      \item Hvis en vare har input \$x\$ \dots
>
> Org:
>      - Hvis en vare har input $x$ \dots
> ------
> LaTeX output:
>       $$M\overline{V}=P\overline{Y}$$
>       \$M\$ er bestemt af centralbanken, og det eneste den bestemmer  
> er
>       prisniveauet.
>
> Org:
>     - Produktionsfunktionen brugt af monetarister:
>       $$M\overline{V}=P\overline{Y}$$
>       $M$ er bestemt af centralbanken, og det eneste den bestemmer er
>       prisniveauet.
> ------
> LaTeX output (this one is particuarily troublesome):
>      \item På arbejdsmarkedet bestemmes ligevægten imellem $L_d$ og  
> $L_s\$
>       Her ud fra findes ligevægten i udbudet.
>
> Org:
>     - På arbejdsmarkedet bestemmes ligevægten imellem $L_d$ og $L_s$
>       Her ud fra findes ligevægten i udbudet.
> ------
> LaTeX (also troublesome):
>      \item Givet ved $y=f(l, k)\$
>
> Org:
>     - Givet ved $y=f(l, k)$
> ------
> There are lots of \$ in the end of math even though there is no line
> break.
>
> Cheers,
> Rasmus
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-01-08 21:38         ` Carsten Dominik
@ 2009-02-10 20:46           ` Rasmus Pank Roulund
  2009-02-11  9:58             ` Re: LaTeX Export "$"s Giovanni Ridolfi
  2009-02-11 10:34             ` Re: LaTeX Export Carsten Dominik
  0 siblings, 2 replies; 53+ messages in thread
From: Rasmus Pank Roulund @ 2009-02-10 20:46 UTC (permalink / raw)
  To: emacs-orgmode

Hello,
Sorry for the late reply. This is regarind a bug in LaTeX export.
The trouble seems to happen when autofill is used. It
might be caused by something else. I am not sure. The thing is
that Org sometimes misintpretate $ as the currency symbolar
rather than "math" as in LaTeX-lingu. IMO the use of $ as a
currency symbol should be optional.

Here is an example of the error:

Org source: 

   - Funktioner findes ved at sætte funktionen lige en given konstant
     $k$. Dermed bestemmes indifferentfunktion. Det ses nemt at
     $u(x_1, x_2)=k$.

LaTeX export: 

   \item Funktioner findes ved at sætte funktionen lige en given konstant
         \$k\$. Dermed bestemmes indifferentfunktion. Det ses nemt at
         $u(x_1, x_2)=k$.

I have pulled the newest revision of Org. The version is 6.22b.

Thanks,
Rasmus

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Re: LaTeX Export "$"s
  2009-02-10 20:46           ` Rasmus Pank Roulund
@ 2009-02-11  9:58             ` Giovanni Ridolfi
  2009-02-11 10:34             ` Re: LaTeX Export Carsten Dominik
  1 sibling, 0 replies; 53+ messages in thread
From: Giovanni Ridolfi @ 2009-02-11  9:58 UTC (permalink / raw)
  To: emacs-orgmode, Rasmus Pank Roulund

--- Mar 10/2/09, Rasmus Pank Roulund <rasmus.pank@gmail.com> ha scritto:
> Sorry for the late reply. This is regarind a bug in LaTeX
> export.
> The trouble seems to happen when autofill is used. It
> might be caused by something else. I am not sure. The thing
> is
> that Org sometimes misintpretate $ as the currency symbolar
> rather than "math" as in LaTeX-lingu. IMO the use
> of $ as a
> currency symbol should be optional.
hi, Rasmus,

you should use \(  \) for a "well-exported" math environment 
and not "$"  ;-)

as stated in the maual:

11.3 LaTeX fragments
====================
Text within the usual LaTeX math delimiters.  To avoid conflicts
     with currency specifications, single `$' characters are only
     recognized as math delimiters 
     if the enclosed text contains at most two line breaks, 
     is directly attached to the `$' characters
     with no whitespace in between, 
     and if the closing `$' is followed
     by whitespace, punctuation or a dash.  For the other delimiters,
     there is no such restriction, so when in doubt, use `\(...\)' as
     inline math delimiters.


Giovanni


      Passa a Yahoo! Mail.

La webmail che ti offre GRATIS spazio illimitato, 
antispam e messenger integrato.
http://it.mail..yahoo.com/              

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Re: LaTeX Export
  2009-02-10 20:46           ` Rasmus Pank Roulund
  2009-02-11  9:58             ` Re: LaTeX Export "$"s Giovanni Ridolfi
@ 2009-02-11 10:34             ` Carsten Dominik
  2009-02-11 15:56               ` Bernt Hansen
  2009-02-12 18:25               ` Rasmus Pank Roulund
  1 sibling, 2 replies; 53+ messages in thread
From: Carsten Dominik @ 2009-02-11 10:34 UTC (permalink / raw)
  To: Rasmus Pank Roulund; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 1574 bytes --]


On Feb 10, 2009, at 9:46 PM, Rasmus Pank Roulund wrote:

> Hello,
> Sorry for the late reply. This is regarind a bug in LaTeX export.
> The trouble seems to happen when autofill is used. It
> might be caused by something else. I am not sure. The thing is
> that Org sometimes misintpretate $ as the currency symbolar
> rather than "math" as in LaTeX-lingu. IMO the use of $ as a
> currency symbol should be optional.
>
> Here is an example of the error:
>
> Org source:
>
>   - Funktioner findes ved at sætte funktionen lige en given konstant
>     $k$. Dermed bestemmes indifferentfunktion. Det ses nemt at
>     $u(x_1, x_2)=k$.
>
> LaTeX export:
>
>   \item Funktioner findes ved at sætte funktionen lige en given  
> konstant
>         \$k\$. Dermed bestemmes indifferentfunktion. Det ses nemt at
>         $u(x_1, x_2)=k$.
>
> I have pulled the newest revision of Org. The version is 6.22b.

Please remove your customization of org-format-latex-options.
You can do this by doing

M-x customize-variable RET org-format-latex-options RET

and then clicking on "Erase customizations", then
"Set for current session", then "Save for future sessions".

After that, re-make any customizations you want in that variable.

Some time ago I added a new matcher "$1" for single characters
between dollars like in this case.  People who have
customized this option unfortunately do not get to see it.

That said, Giovanni's proposal to use \(....\) is excellent
advice, at least in cases where using $..$ causes trouble.

- Carsten


[-- Attachment #1.2: Type: text/html, Size: 2175 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-02-11 10:34             ` Re: LaTeX Export Carsten Dominik
@ 2009-02-11 15:56               ` Bernt Hansen
  2009-02-11 16:08                 ` Carsten Dominik
  2009-02-12 18:25               ` Rasmus Pank Roulund
  1 sibling, 1 reply; 53+ messages in thread
From: Bernt Hansen @ 2009-02-11 15:56 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode, Rasmus Pank Roulund

Carsten Dominik <dominik@science.uva.nl> writes:

> M-x customize-variable RET org-format-latex-options RET
>
> and then clicking on "Erase customizations", then
> "Set for current session", then "Save for future sessions".

On my version of Emacs

GNU Emacs 22.2.1 (i486-pc-linux-gnu, X toolkit, Xaw3d scroll bars) of
2008-11-09 on raven, modified by Debian

if I click on [Save for future sessions] it also sets the current
session data.  I don't need to click on both.

I used to do that but decided one day to figure out if that was really
necessary (since I was messing with lots of configuration variables
through the customize interface and clicking on both buttons was bugging
me :) )

HTH,
-Bernt

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-02-11 15:56               ` Bernt Hansen
@ 2009-02-11 16:08                 ` Carsten Dominik
  0 siblings, 0 replies; 53+ messages in thread
From: Carsten Dominik @ 2009-02-11 16:08 UTC (permalink / raw)
  To: Bernt Hansen; +Cc: emacs-orgmode, Rasmus Pank Roulund


On Feb 11, 2009, at 4:56 PM, Bernt Hansen wrote:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>> M-x customize-variable RET org-format-latex-options RET
>>
>> and then clicking on "Erase customizations", then
>> "Set for current session", then "Save for future sessions".
>
> On my version of Emacs
>
> GNU Emacs 22.2.1 (i486-pc-linux-gnu, X toolkit, Xaw3d scroll bars) of
> 2008-11-09 on raven, modified by Debian
>
> if I click on [Save for future sessions] it also sets the current
> session data.  I don't need to click on both.
>
> I used to do that but decided one day to figure out if that was really
> necessary (since I was messing with lots of configuration variables
> through the customize interface and clicking on both buttons was  
> bugging
> me :) )

Indeed, this is good to know.

- Carsten

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2009-02-11 10:34             ` Re: LaTeX Export Carsten Dominik
  2009-02-11 15:56               ` Bernt Hansen
@ 2009-02-12 18:25               ` Rasmus Pank Roulund
  1 sibling, 0 replies; 53+ messages in thread
From: Rasmus Pank Roulund @ 2009-02-12 18:25 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

> Some time ago I added a new matcher "$1" for single
> charactersbetween dollars like in this case.  People who
> havecustomized this option unfortunately do not get to see it.
That was probably the problem. It works a lot better now! Thanks. 


> That said, Giovanni's proposal to use \(....\) is excellentadvice, at least
> in cases where using $..$ causes trouble.- Carsten

Acctually, at first I used \(...\) but at that time Org had a harder
time picking up \(...\) than $...$ which caused a lot of \($...$\). I
have not checked whether it works better now.

Thanks,
Rasmus

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2017-08-10 15:35 ` Richard Lawrence
@ 2017-08-10 16:03   ` Scott Randby
  0 siblings, 0 replies; 53+ messages in thread
From: Scott Randby @ 2017-08-10 16:03 UTC (permalink / raw)
  To: Richard Lawrence, emacs-orgmode

On 08/10/2017 11:35 AM, Richard Lawrence wrote:> Hi Scott,
> 
> Scott Randby <srandby@gmail.com> writes:
> 
>> I tried this in the properties associated with a subtree: :export_latex_header: \hypersetup{pdfauthor={foo},pdftitle={foo},pdfsubject={foo},pdfkeywords={foo},pdfproducer={foo},pdfcreator={foo}} Unfortunately, all the other LaTeX headers are unrecognized when I do this.
> 
> If you put the subtree-specific hypersetup in each subtree's EXPORT_LATEX_HEADER_EXTRA property, and the common stuff in #+LATEX_HEADER lines, I think it should do what you want.  Org should combine these properties rather than using the subtree property to override the global ones.  Hope that helps!

Works perfectly. Thanks.

Scott

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX Export
  2017-08-10  2:01 Scott Randby
@ 2017-08-10 15:35 ` Richard Lawrence
  2017-08-10 16:03   ` Scott Randby
  0 siblings, 1 reply; 53+ messages in thread
From: Richard Lawrence @ 2017-08-10 15:35 UTC (permalink / raw)
  To: Scott Randby, emacs-orgmode

Hi Scott,
 
Scott Randby <srandby@gmail.com> writes:
 
> I tried this in the properties associated with a subtree:  
> 
> :export_latex_header: 
> \hypersetup{pdfauthor={foo},pdftitle={foo},pdfsubject={foo},pdfkeywords={foo},pdfproducer={foo},pdfcreator={foo}} 
> 
> Unfortunately, all the other LaTeX headers are unrecognized when 
> I do this.  

If you put the subtree-specific hypersetup in each subtree's 
EXPORT_LATEX_HEADER_EXTRA property, and the common stuff in 
#+LATEX_HEADER lines, I think it should do what you want.  Org 
should combine these properties rather than using the subtree 
property to override the global ones. 

Hope that helps!

-- 
Best,
Richard

^ permalink raw reply	[flat|nested] 53+ messages in thread

* LaTeX Export
@ 2017-08-10  2:01 Scott Randby
  2017-08-10 15:35 ` Richard Lawrence
  0 siblings, 1 reply; 53+ messages in thread
From: Scott Randby @ 2017-08-10  2:01 UTC (permalink / raw)
  To: emacs-orgmode

I have a file with a large number of top-level headlines. Each subtree corresponding to a top-level headline is exported to its own PDF file. The subtrees all use the same LaTeX headers except for \hypersetup. Right now, I have to uncomment the \hypersetup manually whenever I export a subtree. I would like to have the export engine automatically recognize which \hypersetup to use instead.

I tried this in the properties associated with a subtree: 

:export_latex_header: \hypersetup{pdfauthor={foo},pdftitle={foo},pdfsubject={foo},pdfkeywords={foo},pdfproducer={foo},pdfcreator={foo}}

Unfortunately, all the other LaTeX headers are unrecognized when I do this. I could put all of the LaTeX headers in the properties of each subtree, but that would make it difficult to make universal changes to the overall style.

Is there some way to do what I want? Something like this?

:export_add_latex_header: \hypersetup{pdfauthor={foo},pdftitle={foo},pdfsubject={foo},pdfkeywords={foo},pdfproducer={foo},pdfcreator={foo}}

Scott Randby

-- 
Scott Randby

srandby@gmail.com

http://srandby.org/

PGP key ID: 0xF2D38A63

Key server: http://pool.sks-keyservers.net/

Key fingerprint: 5418 123E DCD3 7DA0 1770  0BDE 301E E657 F2D3 8A63

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2011-12-31 23:37     ` Steve Hafner
@ 2012-01-01 19:52       ` York Zhao
  0 siblings, 0 replies; 53+ messages in thread
From: York Zhao @ 2012-01-01 19:52 UTC (permalink / raw)
  To: Steve Hafner; +Cc: emacs-orgmode

> Read Chapter 14 of the Org-mode manual. And go to
> http://orgmode.org/worg/ and search with the keyword "literate".

Thanks, I've read these already, they are helpful.

Happy New Year
York

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2011-12-31 18:07   ` York Zhao
@ 2011-12-31 23:37     ` Steve Hafner
  2012-01-01 19:52       ` York Zhao
  0 siblings, 1 reply; 53+ messages in thread
From: Steve Hafner @ 2011-12-31 23:37 UTC (permalink / raw)
  To: emacs-orgmode

>
> Hi Bastien,
>
> Thanks a lot, this really works, and it sounds like literate programming. Can
> you suggest some quick reading on using org-mode for literate programming?
>
> Happy new year,
>
> York
>

Read Chapter 14 of the Org-mode manual. And go to
http://orgmode.org/worg/ and search with the keyword "literate".

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2011-12-31  8:09 ` Bastien
@ 2011-12-31 18:07   ` York Zhao
  2011-12-31 23:37     ` Steve Hafner
  0 siblings, 1 reply; 53+ messages in thread
From: York Zhao @ 2011-12-31 18:07 UTC (permalink / raw)
  To: Bastien; +Cc: emacs-orgmode

> I would use code blocks tangling
>
> ,----
> | #+TITLE: Test
> |
> | * Test headline
> |
> | #+begin_src tex :tangle yes
> | \documentclass{article}
> | \begin{document}
> | ...
> | \end{document}
> | #+end_src
> `----
>
> `C-c C-v t' on the block will create a .tex file with the exact content
> of the #+begin_src block.
>
> HTH,
>
> --
>  Bastien

Hi Bastien,

Thanks a lot, this really works, and it sounds like literate programming. Can
you suggest some quick reading on using org-mode for literate programming?

Happy new year,

York

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2011-12-31  0:35 LaTeX export York Zhao
@ 2011-12-31  8:09 ` Bastien
  2011-12-31 18:07   ` York Zhao
  0 siblings, 1 reply; 53+ messages in thread
From: Bastien @ 2011-12-31  8:09 UTC (permalink / raw)
  To: York Zhao; +Cc: emacs-orgmode

Hi York,

York Zhao <gtdplatform@gmail.com> writes:

> I'm wondering if there is a way to export ONLY the LaTeX code within
> "#+begin_latex" and "#+end_latex". I want the exact literal export without
> adding anything before and after my code. The result should be exactly the same
> as if I have copied the block between "#+begin_latex" and "#+end_latex" and
> pasted to a new buffer.

I would use code blocks tangling

,----
| #+TITLE: Test
| 
| * Test headline
| 
| #+begin_src tex :tangle yes
| \documentclass{article}
| \begin{document}
| ...
| \end{document}
| #+end_src
`----

`C-c C-v t' on the block will create a .tex file with the exact content
of the #+begin_src block.

HTH,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* LaTeX export
@ 2011-12-31  0:35 York Zhao
  2011-12-31  8:09 ` Bastien
  0 siblings, 1 reply; 53+ messages in thread
From: York Zhao @ 2011-12-31  0:35 UTC (permalink / raw)
  To: emacs-orgmode

Hi there,

I'm wondering if there is a way to export ONLY the LaTeX code within
"#+begin_latex" and "#+end_latex". I want the exact literal export without
adding anything before and after my code. The result should be exactly the same
as if I have copied the block between "#+begin_latex" and "#+end_latex" and
pasted to a new buffer.

Thanks,


York

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2010-10-16 14:55 Chris Malone
@ 2010-10-16 21:18 ` Scot Becker
  0 siblings, 0 replies; 53+ messages in thread
From: Scot Becker @ 2010-10-16 21:18 UTC (permalink / raw)
  To: Chris Malone; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 1748 bytes --]

I guess you have an ancient version of org mode.  (do M-x org-version, after
org-mode has started.  Current release version is 7.01h).  See how to get
the latest version here:

http://orgmode.org/manual/Installation.html#Installation

And find the link to the latest version on:

http://orgmode.org

Org mode has expanded exponentially since the version it looks like you
have.

If you want the very latest, follow the instructions on installing the
development version.

Scot


On Sat, Oct 16, 2010 at 3:55 PM, Chris Malone <cmalone@mail.astro.sunysb.edu
> wrote:

> Hi,
>
> I'm using emacs version 22.2.1 on a Fedora Core 9 machine.  I'm new to
> org-mode and am interested in using it to write LaTeX documents/Beamer
> presentations.  When I load the export dispatcher with C-c C-e, however, I
> do not have the "l" option for LaTeX export; I only have the following:
>
> [t]   insert the export option template
> [v]   limit export to visible part of outline tree
>
> [a] export as ASCII
> [h] export as HTML
> [b] export as HTML and browse immediately
> [x] export as XOXO
>
> [i] export current file as iCalendar file
> [I] export all agenda files as iCalendar files
> [c] export agenda files into combined iCalendar file
>
> [F] publish current file
> [P] publish current project
> [X] publish... (project will be prompted for)
> [A] publish all projects
>
>
> Is there something that I need to turn on in my .emacs file or an
> additional module that needs to be installed to have access to the LaTeX
> exporter?
>
> Chris
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Please use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
>

[-- Attachment #1.2: Type: text/html, Size: 2432 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2010-10-16 18:53 Re: Re: Re: Latex Export chris.m.malone
@ 2010-10-16 19:14 ` Thomas S. Dye
  0 siblings, 0 replies; 53+ messages in thread
From: Thomas S. Dye @ 2010-10-16 19:14 UTC (permalink / raw)
  To: chris.m.malone; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 4182 bytes --]

Hi Chris,

Yes, 4.67c is old.  I think Org-mode is at version 7.01 now.

Have you found Worg?  http://orgmode.org/worg/index.php

There are tutorials there for configuring and using Org-mode for LaTeX  
and beamer export.  I think that is where I learned how to update Org- 
mode.

All the best,
Tom

On Oct 16, 2010, at 8:53 AM, chris.m.malone@gmail.com wrote:

> Which seems old...I'll try and update it. Thanks for the help.
>
> Chris
>
> On Oct 16, 2010 2:51pm, chris.m.malone@gmail.com wrote:
> > Sorry, I just checked the version: 4.67c
> >
> > Chris
> >
> > On Oct 16, 2010 2:48pm, chris.m.malone@gmail.com wrote:
> > > Hi Thomas,
> > >
> > > This may be as it is the version that comes with Emacs 22.2.1 -  
> is there an easy way to check the org-mode version?
> > >
> > > Chris
> > >
> > > On Oct 16, 2010 2:40pm, "Thomas S. Dye" tsd@tsdye.com> wrote:
> > > > Aloha Chris,
> > > >
> > > >
> > > >
> > > > Perhaps you have an older version of org-mode?
> > > >
> > > >
> > > >
> > > > All the best,
> > > >
> > > > Tom
> > > >
> > > >
> > > >
> > > > On Oct 16, 2010, at 8:10 AM, chris.m.malone@gmail.com wrote:
> > > >
> > > >
> > > >
> > > >
> > > > Hi Nick,
> > > >
> > > >
> > > >
> > > > It does not export anything. The message window displays: "No  
> command associated with key l"
> > > >
> > > >
> > > >
> > > > Chris
> > > >
> > > >
> > > >
> > > > On Oct 16, 2010 1:54pm, Nick Dokos nicholas.dokos@hp.com> wrote:
> > > >
> > > > > chris.m.malone@gmail.com wrote:
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > > > Hi,
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > I'm using emacs version 22.2.1 on a Fedora Core 9  
> machine.  I'm new to org-mode and am interested in using it to write  
> LaTeX documents/Beamer
> > > >
> > > > >
> > > >
> > > > > > presentations. When I load the export dispatcher with C-c  
> C-e, however, I do not have the "l" option for LaTeX export; I only  
> have the following:
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > [t]   insert the export option template
> > > >
> > > > >
> > > >
> > > > > > [v]   limit export to visible part of outline tree
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > [a] export as ASCII
> > > >
> > > > >
> > > >
> > > > > > [h] export as HTML
> > > >
> > > > >
> > > >
> > > > > > [b] export as HTML and browse immediately
> > > >
> > > > >
> > > >
> > > > > > [x] export as XOXO
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > [i] export current file as iCalendar file
> > > >
> > > > >
> > > >
> > > > > > [I] export all agenda files as iCalendar files
> > > >
> > > > >
> > > >
> > > > > > [c] export agenda files into combined iCalendar file
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > [F] publish current file
> > > >
> > > > >
> > > >
> > > > > > [P] publish current project
> > > >
> > > > >
> > > >
> > > > > > [X] publish... (project will be prompted for)
> > > >
> > > > >
> > > >
> > > > > > [A] publish all projects
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > > > Is there something that I need to turn on in my .emacs  
> file or an additional module that needs to be installed to have  
> access to the LaTeX exporter?
> > > >
> > > > >
> > > >
> > > > > >
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > > Not that I know of. What happens if you press l in any case?  
> If it does export
> > > >
> > > > >
> > > >
> > > > > to latex then it would seem to be some sort of display  
> problem perhaps (lots
> > > >
> > > > >
> > > >
> > > > > of weasel words here but I can't help it). If there is some  
> error, then post
> > > >
> > > > >
> > > >
> > > > > the error.
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > >
> > > >
> > > > > Nick
> > > >
> > > > >_______________________________________________
> > > >
> > > > Emacs-orgmode mailing list
> > > >
> > > > Please use `Reply All' to send replies to the list.
> > > >
> > > > Emacs-orgmode@gnu.org
> > > >
> > > > http://lists.gnu.org/mailman/listinfo/emacs-orgmode
> > > >
> > > >
> > > >
> > > >


[-- Attachment #1.2: Type: text/html, Size: 7267 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2010-10-16 18:10 chris.m.malone
@ 2010-10-16 18:40 ` Thomas S. Dye
  0 siblings, 0 replies; 53+ messages in thread
From: Thomas S. Dye @ 2010-10-16 18:40 UTC (permalink / raw)
  To: chris.m.malone; +Cc: Nick Dokos, emacs-orgmode

Aloha Chris,

Perhaps you have an older version of org-mode?

All the best,
Tom

On Oct 16, 2010, at 8:10 AM, chris.m.malone@gmail.com wrote:

> Hi Nick,
>
> It does not export anything. The message window displays: "No  
> command associated with key l"
>
> Chris
>
> On Oct 16, 2010 1:54pm, Nick Dokos <nicholas.dokos@hp.com> wrote:
> > chris.m.malone@gmail.com wrote:
> >
> >
> >
> > > Hi,
> >
> > >
> >
> > > I'm using emacs version 22.2.1 on a Fedora Core 9 machine.  I'm  
> new to org-mode and am interested in using it to write LaTeX  
> documents/Beamer
> >
> > > presentations. When I load the export dispatcher with C-c C-e,  
> however, I do not have the "l" option for LaTeX export; I only have  
> the following:
> >
> > >
> >
> > > [t]   insert the export option template
> >
> > > [v]   limit export to visible part of outline tree
> >
> > >
> >
> > > [a] export as ASCII
> >
> > > [h] export as HTML
> >
> > > [b] export as HTML and browse immediately
> >
> > > [x] export as XOXO
> >
> > >
> >
> > > [i] export current file as iCalendar file
> >
> > > [I] export all agenda files as iCalendar files
> >
> > > [c] export agenda files into combined iCalendar file
> >
> > >
> >
> > > [F] publish current file
> >
> > > [P] publish current project
> >
> > > [X] publish... (project will be prompted for)
> >
> > > [A] publish all projects
> >
> > >
> >
> > > Is there something that I need to turn on in my .emacs file or  
> an additional module that needs to be installed to have access to  
> the LaTeX exporter?
> >
> > >
> >
> >
> >
> > Not that I know of. What happens if you press l in any case? If it  
> does export
> >
> > to latex then it would seem to be some sort of display problem  
> perhaps (lots
> >
> > of weasel words here but I can't help it). If there is some error,  
> then post
> >
> > the error.
> >
> >
> >
> > Nick
> >_______________________________________________
> Emacs-orgmode mailing list
> Please use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2010-10-16 17:34 ` chris.m.malone
@ 2010-10-16 17:54   ` Nick Dokos
  0 siblings, 0 replies; 53+ messages in thread
From: Nick Dokos @ 2010-10-16 17:54 UTC (permalink / raw)
  To: chris.m.malone; +Cc: nicholas.dokos, emacs-orgmode

chris.m.malone@gmail.com wrote:

> Hi,
> 
> I'm using emacs version 22.2.1 on a Fedora Core 9 machine.  I'm new to org-mode and am interested in using it to write LaTeX documents/Beamer
> presentations. When I load the export dispatcher with C-c C-e, however, I do not have the "l" option for LaTeX export; I only have the following:
> 
> [t]   insert the export option template
> [v]   limit export to visible part of outline tree
> 
> [a] export as ASCII
> [h] export as HTML
> [b] export as HTML and browse immediately
> [x] export as XOXO
> 
> [i] export current file as iCalendar file
> [I] export all agenda files as iCalendar files
> [c] export agenda files into combined iCalendar file
> 
> [F] publish current file
> [P] publish current project
> [X] publish... (project will be prompted for)
> [A] publish all projects
> 
> Is there something that I need to turn on in my .emacs file or an additional module that needs to be installed to have access to the LaTeX exporter?
> 

Not that I know of. What happens if you press l in any case? If it does export
to latex then it would seem to be some sort of display problem perhaps (lots
of weasel words here but I can't help it). If there is some error, then post
the error.

Nick

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Latex Export
       [not found] <Pine.LNX.4.63.1010161331001.7948@scotty.ess.sunysb.edu>
@ 2010-10-16 17:34 ` chris.m.malone
  2010-10-16 17:54   ` Nick Dokos
  0 siblings, 1 reply; 53+ messages in thread
From: chris.m.malone @ 2010-10-16 17:34 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 916 bytes --]

Hi,

I'm using emacs version 22.2.1 on a Fedora Core 9 machine. I'm new to  
org-mode and am interested in using it to write LaTeX documents/Beamer  
presentations. When I load the export dispatcher with Cc Ce, however, I do  
not have the "l" option for LaTeX export; I only have the following:


[t] insert the export option template
[v] limit export to visible part of outline tree

[a] export as ASCII
[h] export as HTML
[b] export as HTML and browse immediately
[x] export as XOXO

[i] export current file as iCalendar file
[I] export all agenda files as iCalendar files
[c] export agenda files into combined iCalendar file

[F] publish current file
[P] publish current project
[X] publish... (project will be prompted for)
[A] publish all projects


Is there something that I need to turn on in my .emacs file or an  
additional module that needs to be installed to have access to the LaTeX  
exporter?

Chris

[-- Attachment #1.2: Type: text/html, Size: 1055 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Latex Export
@ 2010-10-16 14:55 Chris Malone
  2010-10-16 21:18 ` Scot Becker
  0 siblings, 1 reply; 53+ messages in thread
From: Chris Malone @ 2010-10-16 14:55 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

I'm using emacs version 22.2.1 on a Fedora Core 9 machine.  I'm new to 
org-mode and am interested in using it to write LaTeX documents/Beamer 
presentations.  When I load the export dispatcher with C-c C-e, however, I 
do not have the "l" option for LaTeX export; I only have the following:

[t]   insert the export option template
[v]   limit export to visible part of outline tree

[a] export as ASCII
[h] export as HTML
[b] export as HTML and browse immediately
[x] export as XOXO

[i] export current file as iCalendar file
[I] export all agenda files as iCalendar files
[c] export agenda files into combined iCalendar file

[F] publish current file
[P] publish current project
[X] publish... (project will be prompted for)
[A] publish all projects


Is there something that I need to turn on in my .emacs file or an 
additional module that needs to be installed to have access to the LaTeX 
exporter?

Chris

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2008-12-22  6:33 ` Carsten Dominik
@ 2008-12-22  8:58   ` Flávio de Souza
  0 siblings, 0 replies; 53+ messages in thread
From: Flávio de Souza @ 2008-12-22  8:58 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode


It is working now. 

I had only (require 'org) instead of (require 'org-install).

Thanks Carsten!

Carsten Dominik <carsten.dominik@gmail.com> writes:

> Do you have
>
>  (require 'org-install)
>
> in your .emacs file, as the installation instructions
> spell out?
>
> - Carsten
>

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2008-12-21 23:12 Flávio de Souza
@ 2008-12-22  6:33 ` Carsten Dominik
  2008-12-22  8:58   ` Flávio de Souza
  0 siblings, 1 reply; 53+ messages in thread
From: Carsten Dominik @ 2008-12-22  6:33 UTC (permalink / raw)
  To: Flávio de Souza; +Cc: emacs-orgmode

Do you have

  (require 'org-install)

in your .emacs file, as the installation instructions
spell out?

- Carsten

On Dec 22, 2008, at 12:12 AM, Flávio de Souza wrote:

>
> Hi,
>
> am trying to export my org file to latex, but I am getting this error:
>
> Debugger entered--Lisp error: (wrong-type-argument commandp org- 
> export-as-latex)
>  call-interactively(org-export-as-latex)
>  org-export(nil)
>  call-interactively(org-export)
>
> I am using org-mode version 6.16a. Please, help me.
>
>
> -- 
> Flávio de Souza
>
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Latex Export
@ 2008-12-21 23:12 Flávio de Souza
  2008-12-22  6:33 ` Carsten Dominik
  0 siblings, 1 reply; 53+ messages in thread
From: Flávio de Souza @ 2008-12-21 23:12 UTC (permalink / raw)
  To: emacs-orgmode


Hi,

 am trying to export my org file to latex, but I am getting this error:

Debugger entered--Lisp error: (wrong-type-argument commandp org-export-as-latex)
  call-interactively(org-export-as-latex)
  org-export(nil)
  call-interactively(org-export)

I am using org-mode version 6.16a. Please, help me.


-- 
Flávio de Souza

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: latex export
  2008-10-01 11:16 latex export Johanna Matschke
  2008-10-01 12:15 ` Russell Adams
@ 2008-10-10 21:13 ` Carsten Dominik
  1 sibling, 0 replies; 53+ messages in thread
From: Carsten Dominik @ 2008-10-10 21:13 UTC (permalink / raw)
  To: Johanna Matschke; +Cc: emacs-orgmode

Hi Johanna,

I think it still does export the full file.  Can you give
use more information, maybe an example file, details about
what your actions are, what results you are getting and what
you did expect.

- Carsten

On Oct 1, 2008, at 1:16 PM, Johanna Matschke wrote:

> Hi!
>
> Sofar (up to org-mode 5.xx) "C-c Ce l" would export the hole org  
> file. But now (I tested various versions 6.0x) it only exports the  
> first heading. Did something change there? How do I get back the  
> earlier behaviour?
>
> Thanks!
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: latex export
  2008-10-01 11:16 latex export Johanna Matschke
@ 2008-10-01 12:15 ` Russell Adams
  2008-10-10 21:13 ` Carsten Dominik
  1 sibling, 0 replies; 53+ messages in thread
From: Russell Adams @ 2008-10-01 12:15 UTC (permalink / raw)
  To: emacs-orgmode

On Wed, Oct 01, 2008 at 01:16:33PM +0200, Johanna Matschke wrote:
> Hi!
>
> Sofar (up to org-mode 5.xx) "C-c Ce l" would export the hole org file. 
> But now (I tested various versions 6.0x) it only exports the first 
> heading. Did something change there? How do I get back the earlier 
> behaviour?
>
> Thanks! 

Do you have your headers COMMENTed?

------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* latex export
@ 2008-10-01 11:16 Johanna Matschke
  2008-10-01 12:15 ` Russell Adams
  2008-10-10 21:13 ` Carsten Dominik
  0 siblings, 2 replies; 53+ messages in thread
From: Johanna Matschke @ 2008-10-01 11:16 UTC (permalink / raw)
  To: emacs-orgmode

Hi!

Sofar (up to org-mode 5.xx) "C-c Ce l" would export the hole org file. But 
now (I tested various versions 6.0x) it only exports the first heading. Did 
something change there? How do I get back the earlier behaviour?

Thanks! 

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2008-01-09 20:53             ` Russell Adams
@ 2008-01-15 11:26               ` Carsten Dominik
  0 siblings, 0 replies; 53+ messages in thread
From: Carsten Dominik @ 2008-01-15 11:26 UTC (permalink / raw)
  To: Russell Adams; +Cc: emacs-orgmode


On Jan 9, 2008, at 9:53 PM, Russell Adams wrote:

> On a note related to #+OPTIONS and exporting, I've taken to using
> sub-buffers (C-c C-x b) on a tree to limit my view to a specific
> tree. I've discovered that I can export in this mode, however, export
> doesn't honor the #+OPTIONS from the original file.
>
> I'm sure this is because the exporter is limiting its scope to the
> current buffer, as if I paste my #+OPTIONS at the top of the subtree
> buffer, it works fine. This is only temporary though, and doesn't
> survive reopening the subbuffer, and adds the text to the prior
> heading's content. ;]
>
> Other than temporarily adding an OPTIONS line, what are my options? I
> don't recall export options as a property yet. I suppose I could set
> common options in my .emacs.
>
> I welcome comments!

Hi Russel,

this is clearly a bug, thank for the report.  Will be fixed in the  
next release.

- Carsten

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-12-02 21:44           ` Bastien
  2007-12-21 22:36             ` Russell Adams
@ 2008-01-09 20:53             ` Russell Adams
  2008-01-15 11:26               ` Carsten Dominik
  1 sibling, 1 reply; 53+ messages in thread
From: Russell Adams @ 2008-01-09 20:53 UTC (permalink / raw)
  To: emacs-orgmode

On a note related to #+OPTIONS and exporting, I've taken to using
sub-buffers (C-c C-x b) on a tree to limit my view to a specific
tree. I've discovered that I can export in this mode, however, export
doesn't honor the #+OPTIONS from the original file.

I'm sure this is because the exporter is limiting its scope to the
current buffer, as if I paste my #+OPTIONS at the top of the subtree
buffer, it works fine. This is only temporary though, and doesn't
survive reopening the subbuffer, and adds the text to the prior
heading's content. ;]

Other than temporarily adding an OPTIONS line, what are my options? I
don't recall export options as a property yet. I suppose I could set
common options in my .emacs.

I welcome comments!

Thanks!

On Sun, Dec 02, 2007 at 09:44:33PM +0000, Bastien wrote:
> Hi Russell,
> 
> Russell Adams <RLAdams@AdamsInfoServ.Com> writes:
> 
> > The exporters all refuse to export text before the first headline. I
> > agree with that.
> 
> The exporters skip text before the first headline only if you set the
> relevant option:
> 
> #+OPTIONS: skip:t
> 
> If you don't specify anything about this in the #+OPTIONS line, then the
> exporters will fall back on `org-export-skip-text-before-1st-heading'.
> 
> This applies to normal text as well as text inside #+BEGIN_LaTeX and
> #+END_LaTeX markers.
> 
> But this does not apply to text after #+TEXT though.  This text is
> *always* exported.
> 
> > However I'm including per buffer options at the top of my file,
> > #+OPTIONS and the like. Turns out that #+BEGIN_LaTeX and #+END_LaTeX
> > before the first headline are considered comments and not exported.
> >
> > This is a problem where I'm trying to select a style or define
> > variables used later in LaTeX code.
> 
> I think the right way to do this is to set a local value for the
> variable `org-export-latex-append-header' at the end of your file:
> 
> ,----
> | * COMMENT LaTeX local variable
> | 
> | # Local Variables:
> | # org-export-latex-append-header: "\\usepackage{fancyhrd}"
> | # End:
> `----
> 
> This will append "\usepackage{fancyhrd}" to the LaTeX header that is
> defined in `org-export-latex-classes'.
> 
> > I think that BEGIN/END latex should be considered configuration data
> > like other /^#/ directives and exported before the first headline.
> >
> > Comments?
> 
> #+BEGIN_LaTeX and #+END_LaTeX have a more general purpose than just
>  adding "configuration" and you should be able to use them anywhere 
> in the Org source.  
> 
> I think the real question is: what people are doing of #+TEXT?  
> 
> Is it useful as it is now ("this text comes before the first heading,
> overriding the skip option")?  Or should it be redefined so as to mean
> "This piece of text should be inserted in the *header* of the target
> format?"
> 
> Comment?
> 
> -- 
> Bastien
> 
> 
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode


------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-12-21 22:36             ` Russell Adams
@ 2007-12-21 23:33               ` Bastien
  0 siblings, 0 replies; 53+ messages in thread
From: Bastien @ 2007-12-21 23:33 UTC (permalink / raw)
  To: emacs-orgmode

Russell Adams <RLAdams@AdamsInfoServ.Com> writes:

> I noticed today that the latex export does not honor the QUOTE
> directive in a heading (verbatim inclusion in fixed width mode).
>
> Could someone confirm? 

That's right.

> If thats the case, please consider this a feature request.

Consider this to be part of my (coming) christmas gift !

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-12-02 21:44           ` Bastien
@ 2007-12-21 22:36             ` Russell Adams
  2007-12-21 23:33               ` Bastien
  2008-01-09 20:53             ` Russell Adams
  1 sibling, 1 reply; 53+ messages in thread
From: Russell Adams @ 2007-12-21 22:36 UTC (permalink / raw)
  To: emacs-orgmode

I noticed today that the latex export does not honor the QUOTE
directive in a heading (verbatim inclusion in fixed width mode).

Could someone confirm? If thats the case, please consider this a
feature request.

Thanks.

------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-12-02 21:04         ` Russell Adams
@ 2007-12-02 21:44           ` Bastien
  2007-12-21 22:36             ` Russell Adams
  2008-01-09 20:53             ` Russell Adams
  0 siblings, 2 replies; 53+ messages in thread
From: Bastien @ 2007-12-02 21:44 UTC (permalink / raw)
  To: emacs-orgmode

Hi Russell,

Russell Adams <RLAdams@AdamsInfoServ.Com> writes:

> The exporters all refuse to export text before the first headline. I
> agree with that.

The exporters skip text before the first headline only if you set the
relevant option:

#+OPTIONS: skip:t

If you don't specify anything about this in the #+OPTIONS line, then the
exporters will fall back on `org-export-skip-text-before-1st-heading'.

This applies to normal text as well as text inside #+BEGIN_LaTeX and
#+END_LaTeX markers.

But this does not apply to text after #+TEXT though.  This text is
*always* exported.

> However I'm including per buffer options at the top of my file,
> #+OPTIONS and the like. Turns out that #+BEGIN_LaTeX and #+END_LaTeX
> before the first headline are considered comments and not exported.
>
> This is a problem where I'm trying to select a style or define
> variables used later in LaTeX code.

I think the right way to do this is to set a local value for the
variable `org-export-latex-append-header' at the end of your file:

,----
| * COMMENT LaTeX local variable
| 
| # Local Variables:
| # org-export-latex-append-header: "\\usepackage{fancyhrd}"
| # End:
`----

This will append "\usepackage{fancyhrd}" to the LaTeX header that is
defined in `org-export-latex-classes'.

> I think that BEGIN/END latex should be considered configuration data
> like other /^#/ directives and exported before the first headline.
>
> Comments?

#+BEGIN_LaTeX and #+END_LaTeX have a more general purpose than just
 adding "configuration" and you should be able to use them anywhere 
in the Org source.  

I think the real question is: what people are doing of #+TEXT?  

Is it useful as it is now ("this text comes before the first heading,
overriding the skip option")?  Or should it be redefined so as to mean
"This piece of text should be inserted in the *header* of the target
format?"

Comment?

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-12-01  7:14       ` Russell Adams
@ 2007-12-02 21:04         ` Russell Adams
  2007-12-02 21:44           ` Bastien
  0 siblings, 1 reply; 53+ messages in thread
From: Russell Adams @ 2007-12-02 21:04 UTC (permalink / raw)
  To: emacs-orgmode

Based on this discussion, I think I have a valid feature request.

The exporters all refuse to export text before the first headline. I
agree with that.

However I'm including per buffer options at the top of my file,
#+OPTIONS and the like. Turns out that #+BEGIN_LaTeX and #+END_LaTeX
before the first headline are considered comments and not exported.

This is a problem where I'm trying to select a style or define
variables used later in LaTeX code.

I think that BEGIN/END latex should be considered configuration data
like other /^#/ directives and exported before the first headline.

Comments?

On Sat, Dec 01, 2007 at 01:14:30AM -0600, Russell Adams wrote:
> > Actually, we really *lack* a tutorial on the LaTeX export.
> 
> A tutorial would be fantastic, I'd having issues with even basic
> customization.
> 
> Do you have any sample documents you could share?
> 
> Thanks.
> 
> ------------------------------------------------------------------
> Russell Adams                            RLAdams@AdamsInfoServ.com
> 
> PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/
> 
> Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3
> 
> 
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-11-30 12:40     ` Bastien
@ 2007-12-01  7:14       ` Russell Adams
  2007-12-02 21:04         ` Russell Adams
  0 siblings, 1 reply; 53+ messages in thread
From: Russell Adams @ 2007-12-01  7:14 UTC (permalink / raw)
  To: emacs-orgmode

> Actually, we really *lack* a tutorial on the LaTeX export.

A tutorial would be fantastic, I'd having issues with even basic
customization.

Do you have any sample documents you could share?

Thanks.

------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-11-30  7:27   ` Russell Adams
@ 2007-11-30 12:40     ` Bastien
  2007-12-01  7:14       ` Russell Adams
  0 siblings, 1 reply; 53+ messages in thread
From: Bastien @ 2007-11-30 12:40 UTC (permalink / raw)
  To: emacs-orgmode

Russell Adams <RLAdams@AdamsInfoServ.Com> writes:

> On Fri, Nov 30, 2007 at 07:21:26AM +0100, Giovanni Ridolfi wrote:
>> On Thu, Nov 29, 2007 at 09:15:06PM -0600, Russell Adams wrote:
>> >
>> I think that the Latex-exporter is *not* suited for such complex task.
>> I also think that it shouldn't (K.I.S.S.). 
>
> Actually, a basic TOC, sections, tables etc... I think it fits the
> bill. I'm moving into Latex because I kept doing an HTML export and
> moving that into Word so I could apply more formatting.
>
> If I can use an option to throw on a header/footer, or specify a
> separate document format, that'd do it.

Most of the LaTeX code you would insert in Org files will be exported
ok.  This LaTeX could be LaTeX fragments, or more complex commands.
Check `org-latex-entities' for a list of recognized commands.

If you want to insert several lines of LaTeX code, put them between
these markers:

#+BEGIN_LaTeX
...
#+END_LaTeX 

If you want to insert a specific LaTeX header, just define the variable
`org-export-latex-header' locally in your Org file.  See the Org manual
at (info "(org)CSS support") for an example on setting a local variable
in Org, and replace `org-export-html-style' by `org-export-latex-header'
in this example.

If you want to use your own customized LaTeX class then define it in
`org-export-latex-classes' and add #+LaTeX_CLASS: myclass as a local
option in your Org file.

Combining all these should provide a nearly complete environment to
write in Org and have a good LaTeX output.  It won't catch all the
complexity and flexibility of LaTeX (or TeX) but I guess it will be
enough as a start !

Actually, we really *lack* a tutorial on the LaTeX export.

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-11-30  6:21 ` Giovanni Ridolfi
@ 2007-11-30  7:27   ` Russell Adams
  2007-11-30 12:40     ` Bastien
  0 siblings, 1 reply; 53+ messages in thread
From: Russell Adams @ 2007-11-30  7:27 UTC (permalink / raw)
  To: emacs-orgmode

On Fri, Nov 30, 2007 at 07:21:26AM +0100, Giovanni Ridolfi wrote:
> On Thu, Nov 29, 2007 at 09:15:06PM -0600, Russell Adams wrote:
> >
> I think that the Latex-exporter is *not* suited for such complex task.
> I also think that it shouldn't (K.I.S.S.). 

Actually, a basic TOC, sections, tables etc... I think it fits the
bill. I'm moving into Latex because I kept doing an HTML export and
moving that into Word so I could apply more formatting.

If I can use an option to throw on a header/footer, or specify a
separate document format, that'd do it.

> IMHO you should either learn LaTeX (please, have a look to "A not so short
> introduction to LaTeX" ) and write your documents in Emacs or use an
> editor in which you can really define every parameter such as lyx.

I might use Emacs to write TeX. ;]

Russell

------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-11-30  3:15 Latex Export Russell Adams
@ 2007-11-30  6:21 ` Giovanni Ridolfi
  2007-11-30  7:27   ` Russell Adams
  0 siblings, 1 reply; 53+ messages in thread
From: Giovanni Ridolfi @ 2007-11-30  6:21 UTC (permalink / raw)
  To: emacs-orgmode

On Thu, Nov 29, 2007 at 09:15:06PM -0600, Russell Adams wrote:
>
> My ultimate goal is to be able to export quality documents written in
> Org with complete header/footer/letterhead and formatting in LaTeX in
> PDF.

I think that the Latex-exporter is *not* suited for such complex task.
I also think that it shouldn't (K.I.S.S.). 

IMHO you should either learn LaTeX (please, have a look to "A not so short
introduction to LaTeX" ) and write your documents in Emacs or use an
editor in which you can really define every parameter such as lyx.

Cheers,
Giovanni

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Latex Export
@ 2007-11-30  3:15 Russell Adams
  2007-11-30  6:21 ` Giovanni Ridolfi
  0 siblings, 1 reply; 53+ messages in thread
From: Russell Adams @ 2007-11-30  3:15 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 721 bytes --]

I'm starting to learn Latex, and thought I'd ask if anyone had
pointers regarding Org/Latex integration.

My ultimate goal is to be able to export quality documents written in
Org with complete header/footer/letterhead and formatting in LaTeX in
PDF.

I understand I need to learn more about TeX along the way, and am
already reading and experimenting.

I'm sure I'm not the first, and wanted to see what others had
accomplished with Latex.

Thanks.

------------------------------------------------------------------
Russell Adams                            RLAdams@AdamsInfoServ.com

PGP Key ID:     0x1160DCB3           http://www.adamsinfoserv.com/

Fingerprint:    1723 D8CA 4280 1EC9 557F  66E8 1154 E018 1160 DCB3

[-- Attachment #1.2: Digital signature --]
[-- Type: application/pgp-signature, Size: 189 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2007-11-02 16:05     ` Xiao-Yong Jin
@ 2007-11-02 19:04       ` Bastien
  0 siblings, 0 replies; 53+ messages in thread
From: Bastien @ 2007-11-02 19:04 UTC (permalink / raw)
  To: emacs-orgmode

Xiao-Yong Jin <xj2106@columbia.edu> writes:

> But I would like to propose a work-around.  How about make
> `^' and `_' in those regions marked as =this_code= or
> something similar not be interpreted as super- and
> subscripts?

You can already protect strings from conversion by playing with 
`org-export-latex-emphasis-alist', which default value is:

  '(("*" "\\textbf{%s}" nil)
    ("/" "\\emph{%s}" nil)
    ("_" "\\underline{%s}" nil)
    ("+" "\\texttt{%s}" nil)
    ("=" "\\texttt{%s}" nil))

If you use `t' instead of `nil' for the last element of this list, then
=this_string= will be converted as \texttt{this_string} instead of

  \texttt{$this_{string}$}  when ^:t
  \texttt{this\_{}string}   when ^:nil

I do agree that all this could be improved, and I hope I'll come with a
general solution for the next release.  Ideas welcome!

In the meanwhile, testing latest org-export-latex.el will help *a lot*:

  http://www.cognition.ens.fr/~guerry/u/org-export-latex.el

Thanks!

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2007-11-02 15:28   ` Daniel Dehennin
  2007-11-02 16:05     ` Xiao-Yong Jin
@ 2007-11-02 18:56     ` Bastien
  1 sibling, 0 replies; 53+ messages in thread
From: Bastien @ 2007-11-02 18:56 UTC (permalink / raw)
  To: emacs-orgmode

Daniel Dehennin <dad@baby-gnu.org> writes:

> Well, having "_" in my ORG file was litteraly a "_" in my LaTeX source
> and compiling the LaTex source complains about missing $.
>
> I'm not able to reproduce this I don't understand what happend :-/

:)

> But now, how can I have some\_thing in my LaTeX source ?

At least two solutions:

- directly write some\_thing in your Org source

- use ^:nil in your #+OPTIONS (this will turn off any sub/superscript
  conversion) 

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2007-11-02 15:28   ` Daniel Dehennin
@ 2007-11-02 16:05     ` Xiao-Yong Jin
  2007-11-02 19:04       ` Bastien
  2007-11-02 18:56     ` Bastien
  1 sibling, 1 reply; 53+ messages in thread
From: Xiao-Yong Jin @ 2007-11-02 16:05 UTC (permalink / raw)
  To: emacs-orgmode

Daniel Dehennin <dad@baby-gnu.org> writes:

> Le 5175 Septembre 1993, Bastien a tapoté:
>> Daniel Dehennin <dad@baby-gnu.org> writes:
>>
>>> I have 2 problems:
>>>
>>> - the underscore "_" is not escaped,
>>
>> Can you provide an example with context for both the input and the
>> output?  Maybe the #+OPTIONS: line could be useful as well.
>
> Well, having "_" in my ORG file was litteraly a "_" in my LaTeX source
> and compiling the LaTex source complains about missing $.
>
> I'm not able to reproduce this I don't understand what happend :-/
>
> But now, how can I have some\_thing in my LaTeX source ?
>
> I write many documents with something like:
>
> variable_name
>
>  and I don't want them to become:
>
> $variable_{name}$
>
> in my LaTeX source.

I've also spotted this.  I guess it's hard to make it right.
By default, org-mode doesn't require `$'s to recognize
certain region as math environment.  See info page

: 10.2 Subscripts and Superscripts
: ================================
: 
: Just like in LaTeX, `^' and `_' are used to indicate super- and
: subscripts.  Again, these can be used without embedding them in
: math-mode delimiters.  To increase the readability of ASCII text, it is
: not necessary (but OK) to surround multi-character sub- and superscripts
: with curly braces.  For example
: 
:      The mass if the sun is M_sun = 1.989 x 10^30 kg.  The radius of
:      the sun is R_{sun} = 6.96 x 10^8 m.
: 
:    To avoid interpretation as raised or lowered text, you can quote `^'
: and `_' with a backslash: `\_' and `\^'.
: 
:    During HTML export (*note HTML export::), subscript and superscripts
: are surrounded with `<sub>' and `<sup>' tags, respectively.

But I would like to propose a work-around.  How about make
`^' and `_' in those regions marked as =this_code= or
something similar not be interpreted as super- and
subscripts?


Xiao-Yong
-- 
    c/*    __o/*
    <\     * (__
    */\      <

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2007-11-02 15:13 ` Bastien
@ 2007-11-02 15:28   ` Daniel Dehennin
  2007-11-02 16:05     ` Xiao-Yong Jin
  2007-11-02 18:56     ` Bastien
  0 siblings, 2 replies; 53+ messages in thread
From: Daniel Dehennin @ 2007-11-02 15:28 UTC (permalink / raw)
  To: emacs-orgmode

Le 5175 Septembre 1993, Bastien a tapoté:
> Daniel Dehennin <dad@baby-gnu.org> writes:
>
>> I have 2 problems:
>>
>> - the underscore "_" is not escaped,
>
> Can you provide an example with context for both the input and the
> output?  Maybe the #+OPTIONS: line could be useful as well.

Well, having "_" in my ORG file was litteraly a "_" in my LaTeX source
and compiling the LaTex source complains about missing $.

I'm not able to reproduce this I don't understand what happend :-/

But now, how can I have some\_thing in my LaTeX source ?

I write many documents with something like:

variable_name

 and I don't want them to become:

$variable_{name}$

in my LaTeX source.

>
>> - I use non-breakable spaces in my input files, like « some text »,
>>   is-it possible to replace this by "~" ?
>
> Yes, I will add this to the list of special characters conversions.

Thanks.
-- 
Daniel Dehennin
Récupérer ma clef GPG:
gpg --keyserver pgp.mit.edu --recv-keys 0x2A408F69

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: LaTeX export
  2007-11-02 10:11 LaTeX export Daniel Dehennin
@ 2007-11-02 15:13 ` Bastien
  2007-11-02 15:28   ` Daniel Dehennin
  0 siblings, 1 reply; 53+ messages in thread
From: Bastien @ 2007-11-02 15:13 UTC (permalink / raw)
  To: emacs-orgmode

Daniel Dehennin <dad@baby-gnu.org> writes:

> I have 2 problems:
>
> - the underscore "_" is not escaped,

Can you provide an example with context for both the input and the
output?  Maybe the #+OPTIONS: line could be useful as well.

> - I use non-breakable spaces in my input files, like « some text »,
>   is-it possible to replace this by "~" ?

Yes, I will add this to the list of special characters conversions.

Thanks,

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* LaTeX export
@ 2007-11-02 10:11 Daniel Dehennin
  2007-11-02 15:13 ` Bastien
  0 siblings, 1 reply; 53+ messages in thread
From: Daniel Dehennin @ 2007-11-02 10:11 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

Using org mode for near everything, I want to use LaTeX export.

I have 2 problems:

- the underscore "_" is not escaped,
- I use non-breakable spaces in my input files, like « some text »,
  is-it possible to replace this by "~" ?

Regards.
-- 
Daniel Dehennin
Récupérer ma clef GPG:
gpg --keyserver pgp.mit.edu --recv-keys 0x2A408F69

^ permalink raw reply	[flat|nested] 53+ messages in thread

* LaTeX export
@ 2007-11-02  9:30 Daniel Dehennin
  0 siblings, 0 replies; 53+ messages in thread
From: Daniel Dehennin @ 2007-11-02  9:30 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

Using org mode for near everything, I want to use LaTeX export.

I have 2 problems:

- the underscore "_" is not escaped,
- I use non-breakable spaces in my input files, like « some text »,
  is-it possible to replace this by "~" ?

Regards.
-- 
Daniel Dehennin
Récupérer ma clef GPG:
gpg --keyserver pgp.mit.edu --recv-keys 0x2A408F69

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Re: Latex Export
  2007-09-28  7:19 Latex Export D. Kapetanakis
@ 2007-09-29 13:23 ` Bastien
  0 siblings, 0 replies; 53+ messages in thread
From: Bastien @ 2007-09-29 13:23 UTC (permalink / raw)
  To: emacs-orgmode

"D. Kapetanakis" <dkapeta@mednautilus.gr> writes:

> I am desperately trying to go from org to Latex without success. I am
> using org-mode 5.10b. I receive the following

Please check latest org-export-latex.el (5.10b):

  http://www.cognition.ens.fr/~guerry/u/org-export-latex.el

Let me know if the error still occurs, and please give me a backtrace
(and the source file, if relevant.e)

Thanks!

-- 
Bastien

^ permalink raw reply	[flat|nested] 53+ messages in thread

* Latex Export
@ 2007-09-28  7:19 D. Kapetanakis
  2007-09-29 13:23 ` Bastien
  0 siblings, 1 reply; 53+ messages in thread
From: D. Kapetanakis @ 2007-09-28  7:19 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 1301 bytes --]

Hello All,
I am desperately trying to go from org to Latex without success. I am using org-mode 5.10b. I receive the following

Exporting to LaTeX...
Loading latexenc...done
(New file)
Loading tex...done
Loading latex...done
Loading font-latex...
Loading bytecomp...done
Loading font-latex...done
Applying style hooks... done
Sorting environment...
Removing duplicates... done
Loading tex-bar...done
Loading reftex...done
Loading reftex-dcr...done
Automatic display of crossref information was turned on
Loading preview...
Loading byte-opt...done
Loading preview...done
Applying style hooks... done
format: Wrong type argument: number-or-marker-p, t

Can you please help? I think the same question was posted by Xiao-Yong Jin, on 26/09, but was never answered.
Dimitris

**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

**********************************************************************



[-- Attachment #1.2: Type: text/html, Size: 5642 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 53+ messages in thread

end of thread, other threads:[~2017-08-10 16:04 UTC | newest]

Thread overview: 53+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-05 12:42 LaTeX Export Rasmus Pank Roulund
2009-01-05 15:29 ` Carsten Dominik
2009-01-05 16:10   ` Rasmus Pank Roulund
2009-01-06 12:00     ` Carsten Dominik
2009-01-08 17:48       ` Rasmus Pank Roulund
2009-01-08 21:38         ` Carsten Dominik
2009-02-10 20:46           ` Rasmus Pank Roulund
2009-02-11  9:58             ` Re: LaTeX Export "$"s Giovanni Ridolfi
2009-02-11 10:34             ` Re: LaTeX Export Carsten Dominik
2009-02-11 15:56               ` Bernt Hansen
2009-02-11 16:08                 ` Carsten Dominik
2009-02-12 18:25               ` Rasmus Pank Roulund
2009-01-05 15:43 ` Matthew Lundin
  -- strict thread matches above, loose matches on Subject: below --
2017-08-10  2:01 Scott Randby
2017-08-10 15:35 ` Richard Lawrence
2017-08-10 16:03   ` Scott Randby
2011-12-31  0:35 LaTeX export York Zhao
2011-12-31  8:09 ` Bastien
2011-12-31 18:07   ` York Zhao
2011-12-31 23:37     ` Steve Hafner
2012-01-01 19:52       ` York Zhao
2010-10-16 18:53 Re: Re: Re: Latex Export chris.m.malone
2010-10-16 19:14 ` Thomas S. Dye
2010-10-16 18:10 chris.m.malone
2010-10-16 18:40 ` Thomas S. Dye
     [not found] <Pine.LNX.4.63.1010161331001.7948@scotty.ess.sunysb.edu>
2010-10-16 17:34 ` chris.m.malone
2010-10-16 17:54   ` Nick Dokos
2010-10-16 14:55 Chris Malone
2010-10-16 21:18 ` Scot Becker
2008-12-21 23:12 Flávio de Souza
2008-12-22  6:33 ` Carsten Dominik
2008-12-22  8:58   ` Flávio de Souza
2008-10-01 11:16 latex export Johanna Matschke
2008-10-01 12:15 ` Russell Adams
2008-10-10 21:13 ` Carsten Dominik
2007-11-30  3:15 Latex Export Russell Adams
2007-11-30  6:21 ` Giovanni Ridolfi
2007-11-30  7:27   ` Russell Adams
2007-11-30 12:40     ` Bastien
2007-12-01  7:14       ` Russell Adams
2007-12-02 21:04         ` Russell Adams
2007-12-02 21:44           ` Bastien
2007-12-21 22:36             ` Russell Adams
2007-12-21 23:33               ` Bastien
2008-01-09 20:53             ` Russell Adams
2008-01-15 11:26               ` Carsten Dominik
2007-11-02 10:11 LaTeX export Daniel Dehennin
2007-11-02 15:13 ` Bastien
2007-11-02 15:28   ` Daniel Dehennin
2007-11-02 16:05     ` Xiao-Yong Jin
2007-11-02 19:04       ` Bastien
2007-11-02 18:56     ` Bastien
2007-11-02  9:30 Daniel Dehennin
2007-09-28  7:19 Latex Export D. Kapetanakis
2007-09-29 13:23 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).