emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* OT: M-S-$ Not Working
@ 2021-02-04 23:25 Bo Grimes
  2021-02-05  3:20 ` Tim Cross
                   ` (2 more replies)
  0 siblings, 3 replies; 15+ messages in thread
From: Bo Grimes @ 2021-02-04 23:25 UTC (permalink / raw)
  To: emacs-orgmode

I beg your indulgence.  I am confident this isn't an Emacs problem, let
alone an org problem, but my eyes hurt from searching for an answer,
and this list, the only one I subscribe to, is populated with gurus.  I
promise never to use it this way again.

OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter 
GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)

M-S-$ does not spellcheck word.  It will work from the menu bar, and it
will work if I drop into a tty and run Emacs.  Emacs gives no
response in the minibuffer in the GUI when I press M-S-$. M-x
describe-key M-S-$ does nothing. C-h b C-s 'spell' reveals that indeed
M-S-$ is bound to spellcheck word. And other M-S- keys work like M-S->
just fine.

There has to be some keybinding outside Emacs taking precedence. I have
gone through dconf-editor until my eyes bleed. Done gsettings
list-recursively  org.gnome.desktop.wm.keybindings | sort | more and
gone line by line.  I have done dconf dump / > dconf.dump and read
through them all, in addition to checking PopOS' keybindings in
Settings. And trying a different keyboard.

Nothing in Tweeks, dconf, or Settings uses M-S-$, but I disabled
anything that uses Shift anyway (nothing uses $). No joy. I don't want
to rebind it for this machine only, nor do I want to go through the
hassle of installing a different DM/WM.

StackExchange, et.al are full of problems with the the M key, but not
one specific keychord only.

Any ideas? I will accept rebukes.  I'm desperate.  TIA!

Bo Grimes


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-04 23:25 OT: M-S-$ Not Working Bo Grimes
@ 2021-02-05  3:20 ` Tim Cross
  2021-02-05 14:34   ` Bo Grimes
  2021-02-05 14:40 ` Maxim Nikulin
  2021-02-06  6:13 ` Marcin Borkowski
  2 siblings, 1 reply; 15+ messages in thread
From: Tim Cross @ 2021-02-05  3:20 UTC (permalink / raw)
  To: emacs-orgmode


Bo Grimes <vcg3rd@fastmail.com> writes:

> I beg your indulgence.  I am confident this isn't an Emacs problem, let
> alone an org problem, but my eyes hurt from searching for an answer,
> and this list, the only one I subscribe to, is populated with gurus.  I
> promise never to use it this way again.
>
> OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter
> GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)
>
> M-S-$ does not spellcheck word.  It will work from the menu bar, and it
> will work if I drop into a tty and run Emacs.  Emacs gives no
> response in the minibuffer in the GUI when I press M-S-$. M-x
> describe-key M-S-$ does nothing. C-h b C-s 'spell' reveals that indeed
> M-S-$ is bound to spellcheck word. And other M-S- keys work like M-S->
> just fine.
>
> There has to be some keybinding outside Emacs taking precedence. I have
> gone through dconf-editor until my eyes bleed. Done gsettings
> list-recursively  org.gnome.desktop.wm.keybindings | sort | more and
> gone line by line.  I have done dconf dump / > dconf.dump and read
> through them all, in addition to checking PopOS' keybindings in
> Settings. And trying a different keyboard.
>
> Nothing in Tweeks, dconf, or Settings uses M-S-$, but I disabled
> anything that uses Shift anyway (nothing uses $). No joy. I don't want
> to rebind it for this machine only, nor do I want to go through the
> hassle of installing a different DM/WM.
>
> StackExchange, et.al are full of problems with the the M key, but not
> one specific keychord only.
>

Do you see the same behaviour if you run emacs -Q?

--
Tim Cross


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-05  3:20 ` Tim Cross
@ 2021-02-05 14:34   ` Bo Grimes
  0 siblings, 0 replies; 15+ messages in thread
From: Bo Grimes @ 2021-02-05 14:34 UTC (permalink / raw)
  To: emacs-orgmode

On Fri, 05 Feb 2021 14:20:46 +1100
Tim Cross <theophilusx@gmail.com> wrote:

> Do you see the same behaviour if you run emacs -Q?

I hadn't tried that, which should have been a first step, but I just
did, and yes. Nothing happens and Emacs gives no feedback.

I did go ahead and try a new DM (Regolith, because it's built on Ubuntu
and Gnome, so I thought it would easily integrate), and M-S-$ works
fine, so it has to be somewhere in Pop or Gnome shell, but I'll be
danged if I can figure it out.

At this point I'll probably either rebind it or install a DM like Mate
that won't require too much adaptation.  Thanks for the suggestion! 


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-04 23:25 OT: M-S-$ Not Working Bo Grimes
  2021-02-05  3:20 ` Tim Cross
@ 2021-02-05 14:40 ` Maxim Nikulin
  2021-02-05 17:38   ` [Resolved]Re: " Bo Grimes
  2021-02-06  6:13 ` Marcin Borkowski
  2 siblings, 1 reply; 15+ messages in thread
From: Maxim Nikulin @ 2021-02-05 14:40 UTC (permalink / raw)
  To: emacs-orgmode

On 05/02/2021 06:25, Bo Grimes wrote:
> 
> OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter
> GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)
> 
> M-S-$ does not spellcheck word.

Does C-h l view-lossage show something useful after an attempt to 
perform spellcheck? Is there anything in the *Message* buffer?

I could not suggest something in the case of wayland session, but if it 
is X11 then attempt to acquire key grab should fail if another 
application already set this shortcut. So you could try if e.g. 
xbindkeys would report a conflict if such keystroke is added to its 
config. I have never used it, but there is an interesting feature 
XF86LogGrabInfo: 
https://askubuntu.com/questions/406543/unable-to-set-a-shortcut-to-grab-screenshot-area 
Due to global shortcut emacs should lose focus for a moment and it 
should be noticeable. I would also check if xev reports expected key 
symbol. Just to be sure that $ is in its usual place yet.




^ permalink raw reply	[flat|nested] 15+ messages in thread

* [Resolved]Re: OT: M-S-$ Not Working
  2021-02-05 14:40 ` Maxim Nikulin
@ 2021-02-05 17:38   ` Bo Grimes
  2021-02-06 15:52     ` Maxim Nikulin
  0 siblings, 1 reply; 15+ messages in thread
From: Bo Grimes @ 2021-02-05 17:38 UTC (permalink / raw)
  To: emacs-orgmode

On Fri, 5 Feb 2021 21:40:25 +0700
Maxim Nikulin <manikulin@gmail.com> wrote:

> On 05/02/2021 06:25, Bo Grimes wrote:
> > 
> > OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter
> > GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)
> > 
> > M-S-$ does not spellcheck word.  
> 
> Does C-h l view-lossage show something useful after an attempt to 
> perform spellcheck? Is there anything in the *Message* buffer?

Thanks! I didn't know C-h l, and I never thought to check messages.
Sorry, I'm a non-tech, learn-what-I-need-as-I-go-but-committed-to-FOSS
guy.

Unfortunately, messages doesn't show anything, and here's the output of
C-h l, which I ran first as a marker, then typed a commonly misspelled
word, did M-S-$, and then ran it again:

 C-h l [view-lossage]
 m [org-self-insert-command]
 i [org-self-insert-command]
 s [org-self-insert-command]
 p [org-self-insert-command]
 e [org-self-insert-command]
 l [org-self-insert-command]
 l [org-self-insert-command]
 C-h l [view-lossage]

Nothing between the last two, which is when I did M-S-$

> 
> I could not suggest something in the case of wayland session, but if
> it is X11 then attempt to acquire key grab should fail if another 
> application already set this shortcut. So you could try if e.g. 
> xbindkeys would report a conflict if such keystroke is added to its 
> config. I have never used it, but there is an interesting feature 
> XF86LogGrabInfo: 
> https://askubuntu.com/questions/406543/unable-to-set-a-shortcut-to-grab-screenshot-area 
> Due to global shortcut emacs should lose focus for a moment and it 
> should be noticeable. I would also check if xev reports expected key 
> symbol. Just to be sure that $ is in its usual place yet.
> 

So, that took me down a rabbit hole that led me nowhere in terms of
understanding wayland, Xorg, or X11 configs, BUT, somewhere down there
I got to thinking about how one of the first things I do on a new
system is remap Ctrl to Caps Lock.  I usually just do setxkbmap -layout
us -option ctrl:nocaps, but in attempting to see if there was a
problem there I was led to closely examine Tweeks Additional Layout
Options, where I saw Shift Does Not Cancel Num Lock, choose 3rd lvl
instead.

I have no idea what 3rd level is, but before I ticked it I turned off
my number lock, and C-S-$ worked!  So I ticked it and it stopped
working.  So I unticked it and ticked Number keypad always enters
digits, which is, of course, why I use Num Lock to begin with.

With that ticked Emacs behaves as expected.  I have always used Num
Lock and never had that problems

Wow!  Thanks for taking the time to put me in the rabbit hole on an
OT message!!! Frustrating, but less frustrating than a new distro or DM,
and I learned some things!  I am really grateful!

Cheers,
Bo Grimes



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-04 23:25 OT: M-S-$ Not Working Bo Grimes
  2021-02-05  3:20 ` Tim Cross
  2021-02-05 14:40 ` Maxim Nikulin
@ 2021-02-06  6:13 ` Marcin Borkowski
  2021-02-06  6:28   ` Tim Cross
  2 siblings, 1 reply; 15+ messages in thread
From: Marcin Borkowski @ 2021-02-06  6:13 UTC (permalink / raw)
  To: Bo Grimes; +Cc: emacs-orgmode

Hi Bo,

I know your problem is resolved now, but in case you don't know, check
also what `C-h c' does (and `C-h k' is also useful at times).  In
general, spending 20 minutes on looking through what `C-h C-h' says
might save you some trouble later;-).

Hth,
mb



On 2021-02-05, at 00:25, Bo Grimes <vcg3rd@fastmail.com> wrote:

> I beg your indulgence.  I am confident this isn't an Emacs problem, let
> alone an org problem, but my eyes hurt from searching for an answer,
> and this list, the only one I subscribe to, is populated with gurus.  I
> promise never to use it this way again.
>
> OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter 
> GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)
>
> M-S-$ does not spellcheck word.  It will work from the menu bar, and it
> will work if I drop into a tty and run Emacs.  Emacs gives no
> response in the minibuffer in the GUI when I press M-S-$. M-x
> describe-key M-S-$ does nothing. C-h b C-s 'spell' reveals that indeed
> M-S-$ is bound to spellcheck word. And other M-S- keys work like M-S->
> just fine.
>
> There has to be some keybinding outside Emacs taking precedence. I have
> gone through dconf-editor until my eyes bleed. Done gsettings
> list-recursively  org.gnome.desktop.wm.keybindings | sort | more and
> gone line by line.  I have done dconf dump / > dconf.dump and read
> through them all, in addition to checking PopOS' keybindings in
> Settings. And trying a different keyboard.
>
> Nothing in Tweeks, dconf, or Settings uses M-S-$, but I disabled
> anything that uses Shift anyway (nothing uses $). No joy. I don't want
> to rebind it for this machine only, nor do I want to go through the
> hassle of installing a different DM/WM.
>
> StackExchange, et.al are full of problems with the the M key, but not
> one specific keychord only.
>
> Any ideas? I will accept rebukes.  I'm desperate.  TIA!
>
> Bo Grimes


-- 
Marcin Borkowski
http://mbork.pl


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-06  6:13 ` Marcin Borkowski
@ 2021-02-06  6:28   ` Tim Cross
  2021-02-06 15:53     ` Bo Grimes
  2021-02-06 16:14     ` Maxim Nikulin
  0 siblings, 2 replies; 15+ messages in thread
From: Tim Cross @ 2021-02-06  6:28 UTC (permalink / raw)
  To: emacs-orgmode


Marcin Borkowski <mbork@mbork.pl> writes:

> Hi Bo,
>
> I know your problem is resolved now, but in case you don't know, check
> also what `C-h c' does (and `C-h k' is also useful at times).  In
> general, spending 20 minutes on looking through what `C-h C-h' says
> might save you some trouble later;-).
>

This is good advice. I would add that if you find that Emacs does not
respond, even to say that the key is not bound or defined, it is
typically a sign that something in the environment e.g. window manager
or X (or Wayland) layer is not passing the key press through. These are
layers which are often overlooked and I've seen people spend hours
inside Emacs trying to work out what the issue is, only to later find it
is at a different layer (OS, windowing environment, window manager,
etc).

In general, standard Emacs key bindings are robust and reliable. If a
standard key binding like M-S $ doesn't work, first step is to try emacs
-Q. If that still does not work, odds are high it is an issue outside of
Emacs. Most common causes are WM shortcuts, modified input device
definitions (as seems to be the culprit here) and modified modmap
settings. Utilities like 'xev' can be useful here (not sure what wayland
has).

When I install a new system (regardless of platform, linux, mac,
windows), my first task is usually to remove or remap shortcuts. These
days, most environments use super, alt, meta and control based
shortcuts, many of which interfere with my Emacs. I rarely use super in
my Emacs key bindings, so often I remap useful WM shortcuts to use
super.
--
Tim Cross


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [Resolved]Re: OT: M-S-$ Not Working
  2021-02-05 17:38   ` [Resolved]Re: " Bo Grimes
@ 2021-02-06 15:52     ` Maxim Nikulin
  2021-02-06 19:18       ` Bo Grimes
  2021-02-08 14:31       ` Robert Pluim
  0 siblings, 2 replies; 15+ messages in thread
From: Maxim Nikulin @ 2021-02-06 15:52 UTC (permalink / raw)
  To: emacs-orgmode

On 06/02/2021 00:38, Bo Grimes wrote:
> 
> I have no idea what 3rd level is, but before I ticked it I turned off
> my number lock, and C-S-$ worked!  So I ticked it and it stopped
> working.  So I unticked it and ticked Number keypad always enters
> digits, which is, of course, why I use Num Lock to begin with.

Definitely "xev" is your friend if your want to realize actual effect of 
such changes, along with "setxkbmap -query" (or "setxkbmap -print") and 
"xkbcomp -xkb :0 -".

3rd level is intended to type some characters absent in regular layout 
using a special modifier key. Personally I use 2 keyboard layouts and 
compose key for some symbols that are not directly available, so I do 
not need 3rd level as well.

> With that ticked Emacs behaves as expected.  I have always used Num
> Lock and never had that problems

You could have a look into /usr/share/X11/xkb/rules/evdev.lst 
/usr/share/X11/xkb/symbols/keypad /usr/share/X11/xkb/types/numpad files. 
If I do not mistake, $ is mapped for keypad with keypad:oss_wang option. 
Likely you could achieve what you want with custom Xkb configuration. I 
have not tried such tricks however. The most comprehensive guide on Xkb, 
I have seen, was in Russian. Its English variant is incomplete, the 
author's site is down. 
https://web.archive.org/web/20121108145326/http://pascal.tsu.ru/en/xkb/

X Keyboard Extension Protocol and library specifications could be hard 
to read, XKB Configuration Guide hosted on x.org is too brief.

P.S. Have you checked that it is possible to swap Ctrl and Caps in 
wayland session? If not it is likely worth filing a bug. It seems 
wayland will be default soon. Some Xkb stuff is already broken in gnome 
(rather intentionally). My first experience with wayland was that it 
took enough time to realize why I could not authenticate. Gdm was using 
wayland by default and in password fields (hidden input!) shift does not 
allow several capital letters in a row.



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-06  6:28   ` Tim Cross
@ 2021-02-06 15:53     ` Bo Grimes
  2021-02-06 16:14     ` Maxim Nikulin
  1 sibling, 0 replies; 15+ messages in thread
From: Bo Grimes @ 2021-02-06 15:53 UTC (permalink / raw)
  To: emacs-orgmode

To consolidate I'm replying to both Marcin and Tim together, and if
anyone has further advice I welcome it!!!, but I feel guilty, so reply
to me off-list, please.

On Sat, 06 Feb 2021 17:28:52 +1100
Tim Cross <theophilusx@gmail.com> wrote:

> Marcin Borkowski <mbork@mbork.pl> writes:
> 
> > Hi Bo,
> >
> > I know your problem is resolved now, but in case you don't know,
> > check also what `C-h c' does (and `C-h k' is also useful at times).
> >  In general, spending 20 minutes on looking through what `C-h C-h'
> > says might save you some trouble later;-).

Thanks!  I resolve to work through the help files from time to time, but
life and attenuation... C-h c looks very useful! I have a couple of
simple capture templates that I copied into my init.el, but I didn't
know one could create them like that!

Right now I am slowly working my way through Harley Hahn's Emacs Field
Guide, and I am determined to master Emacs and Org, which I have been
using extensively for 10 years now, I'm embarrassed to say.

My biggest challenge is that I use Emacs for Org and Org because after
trying everything else, it simply meets all my demands (plain text,
FOSS, etc), all my needs (notes, agendas, and writing), and it is so
stable and configurable that I can grow with it.  However, the
challenge is that duties and obligations (willed and wanted) often keep
me from working on notes, knowledge base, writing stuff for days and
even weeks, so I am constantly relearning.

> >  
> 
> This is good advice. I would add that if you find that Emacs does not
> respond, even to say that the key is not bound or defined, it is
> typically a sign that something in the environment e.g. window manager
> or X (or Wayland) layer is not passing the key press through. These
> are layers which are often overlooked and I've seen people spend hours
> inside Emacs trying to work out what the issue is, only to later find
> it is at a different layer (OS, windowing environment, window manager,
> etc).

> In general, standard Emacs key bindings are robust and reliable. If a
> standard key binding like M-S $ doesn't work, first step is to try
> emacs -Q. If that still does not work, odds are high it is an issue
> outside of Emacs. Most common causes are WM shortcuts, modified input
> device definitions (as seems to be the culprit here) and modified
> modmap settings. Utilities like 'xev' can be useful here (not sure
> what wayland has).

Yeah, I knew that had to be the case, but the Internet is now so awash,
and *nixes so divergent, it's sometimes very difficult, no matter how
good one's searchFu is, to find a solution.  Once I saw that S-4 gave
me a $ in a buffer and M-S-$ in a shell spellchecked the word, I knew it
had to be outside Emacs.  I even made sure it happened with Right M and
Right S as well.

I used Unix in grad school in the early 90s for email, gopher, usenet,
etc so when I heard about Linux in '99 I switched.  The Gnome/KDE wars,
Unity, SystemD, Wayland and more...they all left me behind.

It is INSANE that the problem could have been in Wayland, X, Gnome,
PopShell, Mutter, and that it's all so hidden now.  I still have no
idea what was making the Num Lock prevent the $ from working when M was
pressed but not when S was pressed alone.

I am just not adept enough to switch to something like AwesomeWM or i3.
I have to shepherd my time to focus on Emacs and Org.

In desperation, I turned to a reliable, ancient (in Internet years)
resource: the mailing list, and I am grateful for the patience,
tolerance, and guidance I found.  I have used this list, the only one I
subscribe to, a few times for real org problems, and I learn a lot just
reading any subject that interest me.

> 
> 
> When I install a new system (regardless of platform, linux, mac,
> windows), my first task is usually to remove or remap shortcuts. These
> days, most environments use super, alt, meta and control based
> shortcuts, many of which interfere with my Emacs. I rarely use super
> in my Emacs key bindings, so often I remap useful WM shortcuts to use
> super.
> --
> Tim Cross

This is excellent!  I have a super on all my keyboards, so I could
easily do this on both my laptop (this one) and my desktop.  I usually
only remap caps lock to control and try to learn the shortcuts as
given, but since I really ever only use my two computers (my laptop and
desktop), it makes no sense to worry about muscle memory if I use
another, so I should just change them all to what fits me best.

Thanks again, and for reading this discursive ramble if you got this
far.  This list is an example of what drew me to Linux/Emacs/Org to
begin with!

Gratefully,  
Bo Grimes



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-06  6:28   ` Tim Cross
  2021-02-06 15:53     ` Bo Grimes
@ 2021-02-06 16:14     ` Maxim Nikulin
  2021-02-06 17:18       ` Tim Cross
  1 sibling, 1 reply; 15+ messages in thread
From: Maxim Nikulin @ 2021-02-06 16:14 UTC (permalink / raw)
  To: emacs-orgmode

On 06/02/2021 13:28, Tim Cross wrote:
> 
> In general, standard Emacs key bindings are robust and reliable. If a
> standard key binding like M-S $ doesn't work, first step is to try emacs
> -Q.

Sorry, but I do not agree that key bindings are robust in emacs. I use 
English and Russian keyboard layouts. Last years most of application 
could handle shortcuts independently of active layout (E.g. Ctrl+C and 
Ctrl+V works for copy-paste even if Russian layout is currently chosen.)
In Emacs, only Control + Latin C works, Control + Cyrillic S (the same 
physical key) is undefined. Location of punctuation symbols depends on 
active layout, "$" is absent in Russian layout at all. It is extremely 
inconvenient to switch to US layout before any shortcut. Emacs uses its 
own input methods, but it means that desktop environment should treat 
emacs in a special way in respect to keyboard layouts. I have a kind of 
solution, I found its variants in blog posts. It is quite tricky, so I 
do not consider it as reliable and suitable for any user.



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-06 16:14     ` Maxim Nikulin
@ 2021-02-06 17:18       ` Tim Cross
  2021-02-10 17:15         ` Maxim Nikulin
  0 siblings, 1 reply; 15+ messages in thread
From: Tim Cross @ 2021-02-06 17:18 UTC (permalink / raw)
  To: emacs-orgmode


Maxim Nikulin <manikulin@gmail.com> writes:

> On 06/02/2021 13:28, Tim Cross wrote:
>>
>> In general, standard Emacs key bindings are robust and reliable. If a
>> standard key binding like M-S $ doesn't work, first step is to try emacs
>> -Q.
>
> Sorry, but I do not agree that key bindings are robust in emacs. I use
> English and Russian keyboard layouts. Last years most of application
> could handle shortcuts independently of active layout (E.g. Ctrl+C and
> Ctrl+V works for copy-paste even if Russian layout is currently chosen.)
> In Emacs, only Control + Latin C works, Control + Cyrillic S (the same
> physical key) is undefined. Location of punctuation symbols depends on
> active layout, "$" is absent in Russian layout at all. It is extremely
> inconvenient to switch to US layout before any shortcut. Emacs uses its
> own input methods, but it means that desktop environment should treat
> emacs in a special way in respect to keyboard layouts. I have a kind of
> solution, I found its variants in blog posts. It is quite tricky, so I
> do not consider it as reliable and suitable for any user.

As I'm limited by the weakness of only understanding one alphabet, I
don't have any experience of things once you move away from an 'english'
based alphabet. However, I do find it surprising there isn't a simpler
solution to switch between the different layouts in a consistent way
which updates key bindings to something appropriate. I've not seen many
editors with the same level of support for different alphabets and
writing direction as Emacs and there are many keyborad layouts which
don't include the '$' key. At the end of the day, it really just comes
down to mapping of key codes - the 'image' on the key itself (and even
the location) is largely irrelevant. I imagine 'live' switching between
different input methods could be very complicated, but making the
complicated easy is something Emacs tends to be good at.

Were you able to get any assistance with this on the Emacs devel list?
Like it or not, computers are very english centric (and US english at
that). Maybe the issues you have encountered just need to be highlighted
and for there to be someone able to assist to enable the situation to be
improved? It may be a simple as improving the mapping of key codes and
tweaking the key translation table to improve the situation? If you
haven't done so, I would encourage you to start a new thread on
emacs-devel where you outline your key binding issues. I have frequently
found solutions on blogs and other forums only to find later there is a
far easier solution. I would expect many Russian speaking users have
encountered the same challenges. The Emacs devs have always seemed
pretty open to improving support for different languages and character
sets and once they understand the issue, will typically respond with
improvements fairly quickly provided someone is will ing to help test
etc. The hard part is defining the issue - once it is understood, a
solution is often not too far away.

--
Tim Cross


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [Resolved]Re: OT: M-S-$ Not Working
  2021-02-06 15:52     ` Maxim Nikulin
@ 2021-02-06 19:18       ` Bo Grimes
  2021-02-08 14:31       ` Robert Pluim
  1 sibling, 0 replies; 15+ messages in thread
From: Bo Grimes @ 2021-02-06 19:18 UTC (permalink / raw)
  To: emacs-orgmode

On Sat, 6 Feb 2021 22:52:17 +0700
Maxim Nikulin <manikulin@gmail.com> wrote:

> On 06/02/2021 00:38, Bo Grimes wrote:
> > 
> > I have no idea what 3rd level is, but before I ticked it I turned
> > off my number lock, and C-S-$ worked!  So I ticked it and it stopped
> > working.  So I unticked it and ticked Number keypad always enters
> > digits, which is, of course, why I use Num Lock to begin with.  
> 
> Definitely "xev" is your friend if your want to realize actual effect
> of such changes, along with "setxkbmap -query" (or "setxkbmap
> -print") and "xkbcomp -xkb :0 -".
> 
> 3rd level is intended to type some characters absent in regular
> layout using a special modifier key. Personally I use 2 keyboard
> layouts and compose key for some symbols that are not directly
> available, so I do not need 3rd level as well.
> 
> > With that ticked Emacs behaves as expected.  I have always used Num
> > Lock and never had that problems  
> 
> You could have a look into /usr/share/X11/xkb/rules/evdev.lst 
> /usr/share/X11/xkb/symbols/keypad /usr/share/X11/xkb/types/numpad
> files. If I do not mistake, $ is mapped for keypad with
> keypad:oss_wang option. Likely you could achieve what you want with
> custom Xkb configuration. I have not tried such tricks however. The
> most comprehensive guide on Xkb, I have seen, was in Russian. Its
> English variant is incomplete, the author's site is down. 
> https://web.archive.org/web/20121108145326/http://pascal.tsu.ru/en/xkb/
> 
> X Keyboard Extension Protocol and library specifications could be
> hard to read, XKB Configuration Guide hosted on x.org is too brief.
> 
> P.S. Have you checked that it is possible to swap Ctrl and Caps in 
> wayland session? If not it is likely worth filing a bug. It seems 
> wayland will be default soon. Some Xkb stuff is already broken in
> gnome (rather intentionally). My first experience with wayland was
> that it took enough time to realize why I could not authenticate. Gdm
> was using wayland by default and in password fields (hidden input!)
> shift does not allow several capital letters in a row.
> 
> 

Completely missed this.  Thanks!  I'm using Claws ATM because I'm still
setting up Mu4e, with which I will capture this into a org file for
later reference and notes.  I would love to be able to help file a bug
report, so I will *definitely* do this after I get my Emacs set-up fully
on this new OS!

Cheers,
Bo Grimes


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [Resolved]Re: OT: M-S-$ Not Working
  2021-02-06 15:52     ` Maxim Nikulin
  2021-02-06 19:18       ` Bo Grimes
@ 2021-02-08 14:31       ` Robert Pluim
  1 sibling, 0 replies; 15+ messages in thread
From: Robert Pluim @ 2021-02-08 14:31 UTC (permalink / raw)
  To: Maxim Nikulin; +Cc: emacs-orgmode

>>>>> On Sat, 6 Feb 2021 22:52:17 +0700, Maxim Nikulin <manikulin@gmail.com> said:

    Maxim> P.S. Have you checked that it is possible to swap Ctrl and Caps in
    Maxim> wayland session? If not it is likely worth filing a bug. It seems
    Maxim> wayland will be default soon. Some Xkb stuff is already broken in
    Maxim> gnome (rather intentionally). My first experience with wayland was
    Maxim> that it took enough time to realize why I could not authenticate. Gdm
    Maxim> was using wayland by default and in password fields (hidden input!)
    Maxim> shift does not allow several capital letters in a row.

I donʼt know about swapping Ctrl and Caps, but I have Caps -> Meta,
Alt -> Ctrl, Ctrl -> Meta, Windows -> Super under Wayland, so I
suspect you'll be ok.

Robert


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-06 17:18       ` Tim Cross
@ 2021-02-10 17:15         ` Maxim Nikulin
  2021-02-10 18:42           ` Tim Cross
  0 siblings, 1 reply; 15+ messages in thread
From: Maxim Nikulin @ 2021-02-10 17:15 UTC (permalink / raw)
  To: emacs-orgmode

On 07/02/2021 00:18, Tim Cross wrote:
> 
> I've not seen many
> editors with the same level of support for different alphabets and
> writing direction as Emacs and there are many keyborad layouts which
> don't include the '$' key. At the end of the day, it really just comes
> down to mapping of key codes - the 'image' on the key itself (and even
> the location) is largely irrelevant.

To have reliable shortcuts, it necessary to have a way to obtain 
"canonical" Latin key when another layout is chosen. E.g. comma position 
depends on layout. In emacs only key symbol from current layout is 
available, information on symbols in other groups for the same keycode 
is lost. Even layout change events are hidden from lisp code.

> Were you able to get any assistance with this on the Emacs devel list?

There was a thread in 2009, no results however. Unsure if it reasonable 
to raise the question again without a proposal how to solve the problem.

https://lists.gnu.org/archive/html/emacs-devel/2009-05/msg00031.html

I have found a couple more workarounds on github. E.g. listening dbus 
messages related to keyboard layout changes (specific to particular 
desktop environment). In some sense they are similar to mine setup.

> Like it or not, computers are very english centric (and US english at
> that).

In gnome some Xkb-related features suitable for layouts (groups) are 
broken due to their focus on input methods for Chinese-Korean-Japanese 
scripts.



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: OT: M-S-$ Not Working
  2021-02-10 17:15         ` Maxim Nikulin
@ 2021-02-10 18:42           ` Tim Cross
  0 siblings, 0 replies; 15+ messages in thread
From: Tim Cross @ 2021-02-10 18:42 UTC (permalink / raw)
  To: emacs-orgmode


Maxim Nikulin <manikulin@gmail.com> writes:

>> Were you able to get any assistance with this on the Emacs devel list?
>
> There was a thread in 2009, no results however. Unsure if it reasonable
> to raise the question again without a proposal how to solve the problem.
>
> https://lists.gnu.org/archive/html/emacs-devel/2009-05/msg00031.html
>

I think it would be worth raising again. There has been significant
changes since 2009 (that message was prior to Emacs 23 release),
especially with respect to CJK, MULE, UTF-8 and input methods. It is
possible new solutions are now available.

--
Tim Cross


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2021-02-10 18:59 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-04 23:25 OT: M-S-$ Not Working Bo Grimes
2021-02-05  3:20 ` Tim Cross
2021-02-05 14:34   ` Bo Grimes
2021-02-05 14:40 ` Maxim Nikulin
2021-02-05 17:38   ` [Resolved]Re: " Bo Grimes
2021-02-06 15:52     ` Maxim Nikulin
2021-02-06 19:18       ` Bo Grimes
2021-02-08 14:31       ` Robert Pluim
2021-02-06  6:13 ` Marcin Borkowski
2021-02-06  6:28   ` Tim Cross
2021-02-06 15:53     ` Bo Grimes
2021-02-06 16:14     ` Maxim Nikulin
2021-02-06 17:18       ` Tim Cross
2021-02-10 17:15         ` Maxim Nikulin
2021-02-10 18:42           ` Tim Cross

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).