emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Bo Grimes <vcg3rd@fastmail.com>
To: emacs-orgmode@gnu.org
Subject: [Resolved]Re: OT: M-S-$ Not Working
Date: Fri, 5 Feb 2021 12:38:56 -0500	[thread overview]
Message-ID: <20210205123856.0cc226a1@faramir.fios-router.home> (raw)
In-Reply-To: <rvjlcr$7s9$1@ciao.gmane.io>

On Fri, 5 Feb 2021 21:40:25 +0700
Maxim Nikulin <manikulin@gmail.com> wrote:

> On 05/02/2021 06:25, Bo Grimes wrote:
> > 
> > OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter
> > GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)
> > 
> > M-S-$ does not spellcheck word.  
> 
> Does C-h l view-lossage show something useful after an attempt to 
> perform spellcheck? Is there anything in the *Message* buffer?

Thanks! I didn't know C-h l, and I never thought to check messages.
Sorry, I'm a non-tech, learn-what-I-need-as-I-go-but-committed-to-FOSS
guy.

Unfortunately, messages doesn't show anything, and here's the output of
C-h l, which I ran first as a marker, then typed a commonly misspelled
word, did M-S-$, and then ran it again:

 C-h l [view-lossage]
 m [org-self-insert-command]
 i [org-self-insert-command]
 s [org-self-insert-command]
 p [org-self-insert-command]
 e [org-self-insert-command]
 l [org-self-insert-command]
 l [org-self-insert-command]
 C-h l [view-lossage]

Nothing between the last two, which is when I did M-S-$

> 
> I could not suggest something in the case of wayland session, but if
> it is X11 then attempt to acquire key grab should fail if another 
> application already set this shortcut. So you could try if e.g. 
> xbindkeys would report a conflict if such keystroke is added to its 
> config. I have never used it, but there is an interesting feature 
> XF86LogGrabInfo: 
> https://askubuntu.com/questions/406543/unable-to-set-a-shortcut-to-grab-screenshot-area 
> Due to global shortcut emacs should lose focus for a moment and it 
> should be noticeable. I would also check if xev reports expected key 
> symbol. Just to be sure that $ is in its usual place yet.
> 

So, that took me down a rabbit hole that led me nowhere in terms of
understanding wayland, Xorg, or X11 configs, BUT, somewhere down there
I got to thinking about how one of the first things I do on a new
system is remap Ctrl to Caps Lock.  I usually just do setxkbmap -layout
us -option ctrl:nocaps, but in attempting to see if there was a
problem there I was led to closely examine Tweeks Additional Layout
Options, where I saw Shift Does Not Cancel Num Lock, choose 3rd lvl
instead.

I have no idea what 3rd level is, but before I ticked it I turned off
my number lock, and C-S-$ worked!  So I ticked it and it stopped
working.  So I unticked it and ticked Number keypad always enters
digits, which is, of course, why I use Num Lock to begin with.

With that ticked Emacs behaves as expected.  I have always used Num
Lock and never had that problems

Wow!  Thanks for taking the time to put me in the rabbit hole on an
OT message!!! Frustrating, but less frustrating than a new distro or DM,
and I learned some things!  I am really grateful!

Cheers,
Bo Grimes



  reply	other threads:[~2021-02-05 18:18 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-04 23:25 Bo Grimes
2021-02-05  3:20 ` Tim Cross
2021-02-05 14:34   ` Bo Grimes
2021-02-05 14:40 ` Maxim Nikulin
2021-02-05 17:38   ` Bo Grimes [this message]
2021-02-06 15:52     ` [Resolved]Re: " Maxim Nikulin
2021-02-06 19:18       ` Bo Grimes
2021-02-08 14:31       ` Robert Pluim
2021-02-06  6:13 ` Marcin Borkowski
2021-02-06  6:28   ` Tim Cross
2021-02-06 15:53     ` Bo Grimes
2021-02-06 16:14     ` Maxim Nikulin
2021-02-06 17:18       ` Tim Cross
2021-02-10 17:15         ` Maxim Nikulin
2021-02-10 18:42           ` Tim Cross

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210205123856.0cc226a1@faramir.fios-router.home \
    --to=vcg3rd@fastmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='[Resolved]Re: OT: M-S-$ Not Working' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).