emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Bo Grimes <vcg3rd@fastmail.com>
To: emacs-orgmode@gnu.org
Subject: OT: M-S-$ Not Working
Date: Thu, 4 Feb 2021 18:25:18 -0500	[thread overview]
Message-ID: <20210204182518.70916d47@faramir.fios-router.home> (raw)

I beg your indulgence.  I am confident this isn't an Emacs problem, let
alone an org problem, but my eyes hurt from searching for an answer,
and this list, the only one I subscribe to, is populated with gurus.  I
promise never to use it this way again.

OS: PopOS 20.10, DE: GNOME 3.38.2 WM: Mutter 
GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14)

M-S-$ does not spellcheck word.  It will work from the menu bar, and it
will work if I drop into a tty and run Emacs.  Emacs gives no
response in the minibuffer in the GUI when I press M-S-$. M-x
describe-key M-S-$ does nothing. C-h b C-s 'spell' reveals that indeed
M-S-$ is bound to spellcheck word. And other M-S- keys work like M-S->
just fine.

There has to be some keybinding outside Emacs taking precedence. I have
gone through dconf-editor until my eyes bleed. Done gsettings
list-recursively  org.gnome.desktop.wm.keybindings | sort | more and
gone line by line.  I have done dconf dump / > dconf.dump and read
through them all, in addition to checking PopOS' keybindings in
Settings. And trying a different keyboard.

Nothing in Tweeks, dconf, or Settings uses M-S-$, but I disabled
anything that uses Shift anyway (nothing uses $). No joy. I don't want
to rebind it for this machine only, nor do I want to go through the
hassle of installing a different DM/WM.

StackExchange, et.al are full of problems with the the M key, but not
one specific keychord only.

Any ideas? I will accept rebukes.  I'm desperate.  TIA!

Bo Grimes


             reply	other threads:[~2021-02-04 23:26 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-04 23:25 Bo Grimes [this message]
2021-02-05  3:20 ` Tim Cross
2021-02-05 14:34   ` Bo Grimes
2021-02-05 14:40 ` Maxim Nikulin
2021-02-05 17:38   ` [Resolved]Re: " Bo Grimes
2021-02-06 15:52     ` Maxim Nikulin
2021-02-06 19:18       ` Bo Grimes
2021-02-08 14:31       ` Robert Pluim
2021-02-06  6:13 ` Marcin Borkowski
2021-02-06  6:28   ` Tim Cross
2021-02-06 15:53     ` Bo Grimes
2021-02-06 16:14     ` Maxim Nikulin
2021-02-06 17:18       ` Tim Cross
2021-02-10 17:15         ` Maxim Nikulin
2021-02-10 18:42           ` Tim Cross

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210204182518.70916d47@faramir.fios-router.home \
    --to=vcg3rd@fastmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: OT: M-S-$ Not Working' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).