emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Maxim Nikulin <manikulin@gmail.com>
To: emacs-orgmode@gnu.org
Subject: Re: [Resolved]Re: OT: M-S-$ Not Working
Date: Sat, 6 Feb 2021 22:52:17 +0700	[thread overview]
Message-ID: <rvmdvj$r03$1@ciao.gmane.io> (raw)
In-Reply-To: <20210205123856.0cc226a1@faramir.fios-router.home>

On 06/02/2021 00:38, Bo Grimes wrote:
> 
> I have no idea what 3rd level is, but before I ticked it I turned off
> my number lock, and C-S-$ worked!  So I ticked it and it stopped
> working.  So I unticked it and ticked Number keypad always enters
> digits, which is, of course, why I use Num Lock to begin with.

Definitely "xev" is your friend if your want to realize actual effect of 
such changes, along with "setxkbmap -query" (or "setxkbmap -print") and 
"xkbcomp -xkb :0 -".

3rd level is intended to type some characters absent in regular layout 
using a special modifier key. Personally I use 2 keyboard layouts and 
compose key for some symbols that are not directly available, so I do 
not need 3rd level as well.

> With that ticked Emacs behaves as expected.  I have always used Num
> Lock and never had that problems

You could have a look into /usr/share/X11/xkb/rules/evdev.lst 
/usr/share/X11/xkb/symbols/keypad /usr/share/X11/xkb/types/numpad files. 
If I do not mistake, $ is mapped for keypad with keypad:oss_wang option. 
Likely you could achieve what you want with custom Xkb configuration. I 
have not tried such tricks however. The most comprehensive guide on Xkb, 
I have seen, was in Russian. Its English variant is incomplete, the 
author's site is down. 
https://web.archive.org/web/20121108145326/http://pascal.tsu.ru/en/xkb/

X Keyboard Extension Protocol and library specifications could be hard 
to read, XKB Configuration Guide hosted on x.org is too brief.

P.S. Have you checked that it is possible to swap Ctrl and Caps in 
wayland session? If not it is likely worth filing a bug. It seems 
wayland will be default soon. Some Xkb stuff is already broken in gnome 
(rather intentionally). My first experience with wayland was that it 
took enough time to realize why I could not authenticate. Gdm was using 
wayland by default and in password fields (hidden input!) shift does not 
allow several capital letters in a row.



  reply	other threads:[~2021-02-06 15:53 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-04 23:25 Bo Grimes
2021-02-05  3:20 ` Tim Cross
2021-02-05 14:34   ` Bo Grimes
2021-02-05 14:40 ` Maxim Nikulin
2021-02-05 17:38   ` [Resolved]Re: " Bo Grimes
2021-02-06 15:52     ` Maxim Nikulin [this message]
2021-02-06 19:18       ` Bo Grimes
2021-02-08 14:31       ` Robert Pluim
2021-02-06  6:13 ` Marcin Borkowski
2021-02-06  6:28   ` Tim Cross
2021-02-06 15:53     ` Bo Grimes
2021-02-06 16:14     ` Maxim Nikulin
2021-02-06 17:18       ` Tim Cross
2021-02-10 17:15         ` Maxim Nikulin
2021-02-10 18:42           ` Tim Cross

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='rvmdvj$r03$1@ciao.gmane.io' \
    --to=manikulin@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: [Resolved]Re: OT: M-S-$ Not Working' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).