emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* how do you compose mails in Gnus with org-mode
@ 2018-03-01 13:37 Joseph Vidal-Rosset
  2018-03-01 14:10 ` Eric S Fraga
  2018-03-03 11:57 ` Thorsten Jolitz
  0 siblings, 2 replies; 42+ messages in thread
From: Joseph Vidal-Rosset @ 2018-03-01 13:37 UTC (permalink / raw)
  To: emacs-orgmode list

Hello,

I know that the subject of my email exists already.
[[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]

But  I'm  loosing  to  much  time   in  searching  the  solution  of  my
"problem". I would be happy to get in Gnus the same function that exists
in mu4e that is org-mu4e-compose-org-mode.  Supposing that I want to reply
to an email, I  would be glad to write my reply in  a org file and, once
finished this reply,  going back to gnus to be  able to org-mime-htmlize
it and send it.
At the moment the only solution that I  have is to quit gnus in order to
make an org file that I copy and paste in the reply. I am convinced that
a better solution  exists, but I am  unable to find it  (ideally the org
file for such a reply would contain the bibliography link by default).

Your help will be very welcome,

Best wishes,

Jo. 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-01 13:37 how do you compose mails in Gnus with org-mode Joseph Vidal-Rosset
@ 2018-03-01 14:10 ` Eric S Fraga
       [not found]   ` <87vaef97ze.fsf@gmail.com>
  2018-03-03 11:57 ` Thorsten Jolitz
  1 sibling, 1 reply; 42+ messages in thread
From: Eric S Fraga @ 2018-03-01 14:10 UTC (permalink / raw)
  To: Joseph Vidal-Rosset; +Cc: emacs-orgmode list

[-- Attachment #1: Type: text/plain, Size: 698 bytes --]

On Thursday,  1 Mar 2018 at 14:37, Joseph Vidal-Rosset wrote:
> Supposing that I want to reply
> to an email, I  would be glad to write my reply in  a org file and, once
> finished this reply,  going back to gnus to be  able to org-mime-htmlize
> it and send it.
> At the moment the only solution that I  have is to quit gnus in order to
> make an org file that I copy and paste in the reply. 

You don't have to quit gnus or even switch to another
buffer/file.  Simply change the mode to org (M-x org-mode RET), compose
your email, switch back to message mode (M-x message-mode RET), htmlize
the email and send it.

-- 
Eric S Fraga via Emacs 27.0.50, Org release_9.1.6-352-g92176c

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Fwd:  how do you compose mails in Gnus with org-mode
       [not found]   ` <87vaef97ze.fsf@gmail.com>
@ 2018-03-01 14:40     ` Joseph Vidal-Rosset
  2018-03-01 15:10       ` Eric S Fraga
  0 siblings, 1 reply; 42+ messages in thread
From: Joseph Vidal-Rosset @ 2018-03-01 14:40 UTC (permalink / raw)
  To: Liste-emacs-orgmode@gnu.org

[-- Attachment #1: Type: text/plain, Size: 1393 bytes --]

Le jeu.  01 mars 2018 à  02:10:15 , Eric S  Fraga <esflists@gmail.com> a
envoyé ce message:
> On Thursday,  1 Mar 2018 at 14:37, Joseph Vidal-Rosset wrote:
>> Supposing that I want to reply
>> to an email, I  would be glad to write my reply in  a org file and, once
>> finished this reply,  going back to gnus to be  able to org-mime-htmlize
>> it and send it.
>> At the moment the only solution that I  have is to quit gnus in order to
>> make an org file that I copy and paste in the reply.
>
> You don't have to quit gnus or even switch to another
> buffer/file.  Simply change the mode to org (M-x org-mode RET), compose
> your email, switch back to message mode (M-x message-mode RET), htmlize
> the email and send it.

Many thanks Eric! I suspected that  there should be a simple solution,
but I did not expected that it was so much simple!

I am applying what you say in replying to you. And it works perfectly!

I am going  to define two keybindings  for this and I would  be happy if
you could suggest to me how adding automatically this link

[[bibliography:/home/joseph/MEGA/org/reforg.bib]]

with the command M-x org-mode RET . But if you need time for this last
point, forget it, you helped me a lot already .

Thanks again !

Jo.

PS: After  an upgrade, my "org-mime-htmlize"  does not work any  more at
the moment, but that is another topic.

[-- Attachment #2: Type: text/html, Size: 1842 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 14:40     ` Fwd: " Joseph Vidal-Rosset
@ 2018-03-01 15:10       ` Eric S Fraga
  2018-03-01 15:29         ` Joseph Vidal-Rosset
  0 siblings, 1 reply; 42+ messages in thread
From: Eric S Fraga @ 2018-03-01 15:10 UTC (permalink / raw)
  To: Joseph Vidal-Rosset; +Cc: Liste-emacs-orgmode@gnu.org

[-- Attachment #1: Type: text/plain, Size: 1061 bytes --]

On Thursday,  1 Mar 2018 at 15:40, Joseph Vidal-Rosset wrote:

[...]

> Many thanks Eric! I suspected that there should be a simple solution,
> but I did not expected that it was so much simple!
>
> I am applying what you say in replying to you. And it works perfectly!

Excellent.  Glad I could help.

> I am going to define two keybindings for this and I would be happy if
> you could suggest to me how adding automatically this link
>
> [[bibliography:/home/joseph/MEGA/org/reforg.bib]]
>
> with the command M-x org-mode RET .

I am not sure I understand what you wish to do.  If it is to always add
that line to the message you are composing when you switch to org-mode,
the natural way would be through a hook but that hook would apply to any
other org files as well.  Alternatively, you could use the signature
methods in gnus?

In any case, I'm not sure what you would gain by adding that link to an
email as htmlize will not do anything reasonable with it?

-- 
Eric S Fraga via Emacs 27.0.50, Org release_9.1.7-466-ga16590

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 15:10       ` Eric S Fraga
@ 2018-03-01 15:29         ` Joseph Vidal-Rosset
  2018-03-01 16:59           ` Eric S Fraga
  0 siblings, 1 reply; 42+ messages in thread
From: Joseph Vidal-Rosset @ 2018-03-01 15:29 UTC (permalink / raw)
  To: Liste-emacs-orgmode@gnu.org, Eric Fraga

[-- Attachment #1: Type: text/plain, Size: 979 bytes --]

Le jeu.  01 mars 2018 à  03:10:48 , Eric S  Fraga <esflists@gmail.com> a
envoyé ce message:

> I am not sure I understand what you wish to do.  If it is to always add
> that line to the message you are composing when you switch to org-mode,
> the natural way would be through a hook but that hook would apply to any
> other org files as well.  Alternatively, you could use the signature
> methods in gnus?

The first option would be the best for me: because my use of org-mode is
mainly for my work and I am always pasting this link in new org file. It
is boring. If you  could me help to define such a hook,  I will be again
indebted to you. But  please do it only if it is  not time consuming for
you. 

> In any case, I'm not sure what you would gain by adding that link to an
> email as htmlize will not do anything reasonable with it?

htmlize works  again now  in my  setup. Strangely  I saw  that I  had to
install jupyter...

Best wishes,

Jo. 

[-- Attachment #2.1: Type: text/html, Size: 1200 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 15:29         ` Joseph Vidal-Rosset
@ 2018-03-01 16:59           ` Eric S Fraga
  2018-03-01 18:04             ` Joseph Vidal-Rosset
  0 siblings, 1 reply; 42+ messages in thread
From: Eric S Fraga @ 2018-03-01 16:59 UTC (permalink / raw)
  To: Joseph Vidal-Rosset; +Cc: Liste-emacs-orgmode@gnu.org

[-- Attachment #1: Type: text/plain, Size: 1040 bytes --]

On Thursday,  1 Mar 2018 at 16:29, Joseph Vidal-Rosset wrote:
> The first option would be the best for me: because my use of org-mode is
> mainly for my work and I am always pasting this link in new org file. It
> is boring. If you could me help to define such a hook, I will be again
> indebted to you. But please do it only if it is not time consuming for
> you.

I use autoinsert to automatically insert contents into new files.  Look
at autoinsert.el in your emacs distribution.  I do the following:

  (require 'autoinsert)
  (push '(org-mode . "/SOMEPATH/orgskeleton.org") auto-insert-alist)
  (add-hook 'find-file-hook 'auto-insert)

where orgskeleton.org has the initial contents I want inserted into any
new org file.  These include settings and some default headlines in my
case.

> htmlize works again now in my setup. Strangely I saw that I had to
> install jupyter…

Very strange.  I do not have jupyter installed, as far as I know.

-- 
Eric S Fraga via Emacs 27.0.50, Org release_9.1.7-466-ga16590

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 16:59           ` Eric S Fraga
@ 2018-03-01 18:04             ` Joseph Vidal-Rosset
  2018-03-01 18:17               ` Brian Shine
  2018-03-02  7:25               ` Eric S Fraga
  0 siblings, 2 replies; 42+ messages in thread
From: Joseph Vidal-Rosset @ 2018-03-01 18:04 UTC (permalink / raw)
  To: Liste-emacs-orgmode@gnu.org, Eric Fraga

Le jeu.  01 mars 2018 à  04:59:27 , Eric S  Fraga <esflists@gmail.com> a
envoyé ce message:
> On Thursday,  1 Mar 2018 at 16:29, Joseph Vidal-Rosset wrote:
>> The first option would be the best for me: because my use of org-mode is
>> mainly for my work and I am always pasting this link in new org file. It
>> is boring. If you could me help to define such a hook, I will be again
>> indebted to you. But please do it only if it is not time consuming for
>> you.
>
> I use autoinsert to automatically insert contents into new files.  Look
> at autoinsert.el in your emacs distribution.  I do the following:
>
>   (require 'autoinsert)
>   (push '(org-mode . "/SOMEPATH/orgskeleton.org") auto-insert-alist)
>   (add-hook 'find-file-hook 'auto-insert)
>
> where orgskeleton.org has the initial contents I want inserted into any
> new org file.  These include settings and some default headlines in my
> case.

Many thanks Eric, it is very kind of you to help me so much.

autoinsert works well  for new org files,  it is a first  good point for
me. I receive this message: Perform org-mode auto-insertion? (y or n)
and after replying "y" I get my org file with the bibliography link.

Unfortunately, it does not work in Gnus with the command M-x org-mode on
a reply to a message, and I do not understand why.

Regards, and thanks again !

-- 
Joseph Vidal-Rosset

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 18:04             ` Joseph Vidal-Rosset
@ 2018-03-01 18:17               ` Brian Shine
  2018-03-01 18:46                 ` Joseph Vidal-Rosset
  2018-03-02  7:25               ` Eric S Fraga
  1 sibling, 1 reply; 42+ messages in thread
From: Brian Shine @ 2018-03-01 18:17 UTC (permalink / raw)
  To: Liste-emacs-orgmode@gnu.org; +Cc: Brian Shine

[-- Attachment #1: Type: text/plain, Size: 1991 bytes --]

This is a wonderful resource, but I wonder if I can ask how to set up email using emacs?   I’ve failed multiple times to do this using several solutions that are suggested. My main accounts are with iCloud and Exchange and I have never managed to log in through the suggested methods.  I’m obviously doing something basic incorrectly. 

Is there a really simple guide to setting this up?  

Best wishes,
Brian


> On 1 Mar 2018, at 18:04, Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> wrote:
> 
> Le jeu.  01 mars 2018 à  04:59:27 , Eric S  Fraga <esflists@gmail.com <mailto:esflists@gmail.com>> a
> envoyé ce message:
>> On Thursday,  1 Mar 2018 at 16:29, Joseph Vidal-Rosset wrote:
>>> The first option would be the best for me: because my use of org-mode is
>>> mainly for my work and I am always pasting this link in new org file. It
>>> is boring. If you could me help to define such a hook, I will be again
>>> indebted to you. But please do it only if it is not time consuming for
>>> you.
>> 
>> I use autoinsert to automatically insert contents into new files.  Look
>> at autoinsert.el in your emacs distribution.  I do the following:
>> 
>>  (require 'autoinsert)
>>  (push '(org-mode . "/SOMEPATH/orgskeleton.org") auto-insert-alist)
>>  (add-hook 'find-file-hook 'auto-insert)
>> 
>> where orgskeleton.org has the initial contents I want inserted into any
>> new org file.  These include settings and some default headlines in my
>> case.
> 
> Many thanks Eric, it is very kind of you to help me so much.
> 
> autoinsert works well  for new org files,  it is a first  good point for
> me. I receive this message: Perform org-mode auto-insertion? (y or n)
> and after replying "y" I get my org file with the bibliography link.
> 
> Unfortunately, it does not work in Gnus with the command M-x org-mode on
> a reply to a message, and I do not understand why.
> 
> Regards, and thanks again !
> 
> -- 
> Joseph Vidal-Rosset


[-- Attachment #2: Type: text/html, Size: 11939 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 18:17               ` Brian Shine
@ 2018-03-01 18:46                 ` Joseph Vidal-Rosset
  2018-03-01 19:01                   ` Brian Shine
  0 siblings, 1 reply; 42+ messages in thread
From: Joseph Vidal-Rosset @ 2018-03-01 18:46 UTC (permalink / raw)
  To: Brian Shine; +Cc: Liste-emacs-orgmode@gnu.org

[-- Attachment #1: Type: text/plain, Size: 1169 bytes --]

Le jeu.  01 mars 2018  à 06:17:48  , Brian Shine  <brianshine@mac.com> a
envoyé ce message:
> This is a wonderful resource, but I wonder  if I can ask how to set up
> email  using emacs?   I’ve  failed  multiple times  to  do this  using
> several solutions that are suggested. My main accounts are with iCloud
> and Exchange and I have never  managed to log in through the suggested
> methods.  I’m obviously doing something basic incorrectly. 
>
> Is there a really simple guide to setting this up?  
>
> Best wishes,
> Brian

Hello,

It is difficult  to give you and  advice, because as you  know there are
many email clients for emacs.

Maybe you can  read this web page  first, that could help you  to make a
choice:

[[https://wwwtech.de/articles/2016/jul/my-personal-mail-setup]]

I am using  Gnus with Gmail, and  it works smoothly. I  do not believe
that I will change now. But it is time consuming to get the convenient
setup. 

If Gnus  can be you  choice, I will  be happy to  help you, as  I can,
because there many  people in this list that are  more experts than me
(Eric Fraga for example). 

Best wishes, 

Jo. 

[-- Attachment #2.1: Type: text/html, Size: 1516 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 18:46                 ` Joseph Vidal-Rosset
@ 2018-03-01 19:01                   ` Brian Shine
  2018-03-02  7:27                     ` Roland Everaert
  0 siblings, 1 reply; 42+ messages in thread
From: Brian Shine @ 2018-03-01 19:01 UTC (permalink / raw)
  To: Joseph Vidal-Rosset; +Cc: Liste-emacs-orgmode@gnu.org, Brian Shine

[-- Attachment #1: Type: text/plain, Size: 1484 bytes --]

Thank you so much.  This looks like a great website.  I’ll have a read and see whether I can get it to work.  I may well call on you!

Best wishes,
Brian

> On 1 Mar 2018, at 18:46, Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> wrote:
> 
> Le jeu. 01 mars 2018 à 06:17:48 , Brian Shine <brianshine@mac.com> a
> envoyé ce message:
> > This is a wonderful resource, but I wonder if I can ask how to set up
> > email using emacs? I’ve failed multiple times to do this using
> > several solutions that are suggested. My main accounts are with iCloud
> > and Exchange and I have never managed to log in through the suggested
> > methods. I’m obviously doing something basic incorrectly.
> >
> > Is there a really simple guide to setting this up?
> >
> > Best wishes,
> > Brian
> Hello,
> It is difficult to give you and advice, because as you know there are
> many email clients for emacs.
> Maybe you can read this web page first, that could help you to make a
> choice:
> https://wwwtech.de/articles/2016/jul/my-personal-mail-setup <https://wwwtech.de/articles/2016/jul/my-personal-mail-setup>
> I am using Gnus with Gmail, and it works smoothly. I do not believe
> that I will change now. But it is time consuming to get the convenient
> setup.
> If Gnus can be you choice, I will be happy to help you, as I can,
> because there many people in this list that are more experts than me
> (Eric Fraga for example).
> Best wishes,
> Jo.
> 


[-- Attachment #2: Type: text/html, Size: 2571 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd:  how do you compose mails in Gnus with org-mode
  2018-03-01 18:04             ` Joseph Vidal-Rosset
  2018-03-01 18:17               ` Brian Shine
@ 2018-03-02  7:25               ` Eric S Fraga
  1 sibling, 0 replies; 42+ messages in thread
From: Eric S Fraga @ 2018-03-02  7:25 UTC (permalink / raw)
  To: Joseph Vidal-Rosset; +Cc: Liste-emacs-orgmode@gnu.org

[-- Attachment #1: Type: text/plain, Size: 2067 bytes --]

On Thursday,  1 Mar 2018 at 19:04, Joseph Vidal-Rosset wrote:

[...]

> autoinsert works well  for new org files,  it is a first  good point for
> me. I receive this message: Perform org-mode auto-insertion? (y or n)
> and after replying "y" I get my org file with the bibliography link.
>
> Unfortunately, it does not work in Gnus with the command M-x org-mode on
> a reply to a message, and I do not understand why.

Because switching to org mode is not creating a new file but simply
changing the mode of an existing buffer.  Autoinsert is only for new
files.  What you could do is customise gnus to create your email buffer
with the right content instead.

If there is a predictable circumstance when you want to effect this
auto-insertion in emails, I would suggest you look at gnus posting
styles (section 5.6 of the gnus info manual).  You can specify a default
"body" for an email when created (along with other things, typically a
signature).  For instance, the signature on this email is automatically
inserted by gnus when I respond to an email in the org mailing list.

#+begin_src emacs-lisp
  (setq gnus-posting-styles
        '((".*:lists.org"
           (signature esf/orgmode-signature-version))))
#+end_src 

(much abridged) where lists.org is the group in which org emails are
split to (by gnus) and

#+begin_src emacs-lisp
  (defun esf/orgmode-signature-version ()
    (format "Eric S Fraga via Emacs %s, Org %s\n"
            emacs-version (org-git-version)))
#+end_src 

You could also consider defining entries in *gnus-alias-identity-alist*
which you can then invoke manually on specific emails using
gnus-alias-use-identity, which I have bound to C-c i.  This can insert
default text in the body as well as do other things, much like posting
styles.

gnus is much like org in that if there's something you want to do,
there's more than likely a solution already!  Well, actually, I guess
this is really a feature of emacs...

-- 
Eric S Fraga via Emacs 27.0.50, Org release_9.1.6-191-g90607d

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 194 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: Fwd: how do you compose mails in Gnus with org-mode
  2018-03-01 19:01                   ` Brian Shine
@ 2018-03-02  7:27                     ` Roland Everaert
  0 siblings, 0 replies; 42+ messages in thread
From: Roland Everaert @ 2018-03-02  7:27 UTC (permalink / raw)
  To: Brian Shine; +Cc: Liste-emacs-orgmode@gnu.org, Joseph Vidal-Rosset

[-- Attachment #1: Type: text/plain, Size: 1654 bytes --]

I also want to thank you for the last link, notmuch seems waht I was search
for too.


Regards,


Roland.

On Thu, Mar 1, 2018 at 8:01 PM, Brian Shine <brianshine@mac.com> wrote:

> Thank you so much.  This looks like a great website.  I’ll have a read and
> see whether I can get it to work.  I may well call on you!
>
> Best wishes,
> Brian
>
> On 1 Mar 2018, at 18:46, Joseph Vidal-Rosset <
> joseph.vidal.rosset@gmail.com> wrote:
>
> Le jeu. 01 mars 2018 à 06:17:48 , Brian Shine <brianshine@mac.com> a
> envoyé ce message:
> > This is a wonderful resource, but I wonder if I can ask how to set up
> > email using emacs? I’ve failed multiple times to do this using
> > several solutions that are suggested. My main accounts are with iCloud
> > and Exchange and I have never managed to log in through the suggested
> > methods. I’m obviously doing something basic incorrectly.
> >
> > Is there a really simple guide to setting this up?
> >
> > Best wishes,
> > Brian
>
> Hello,
>
> It is difficult to give you and advice, because as you know there are
> many email clients for emacs.
>
> Maybe you can read this web page first, that could help you to make a
> choice:
>
> https://wwwtech.de/articles/2016/jul/my-personal-mail-setup
>
> I am using Gnus with Gmail, and it works smoothly. I do not believe
> that I will change now. But it is time consuming to get the convenient
> setup.
>
> If Gnus can be you choice, I will be happy to help you, as I can,
> because there many people in this list that are more experts than me
> (Eric Fraga for example).
>
> Best wishes,
>
> Jo.
>
>
>

[-- Attachment #2: Type: text/html, Size: 2669 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-01 13:37 how do you compose mails in Gnus with org-mode Joseph Vidal-Rosset
  2018-03-01 14:10 ` Eric S Fraga
@ 2018-03-03 11:57 ` Thorsten Jolitz
  2018-03-06  9:58   ` [Error] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
  2018-03-06 10:12   ` how do you compose mails in Gnus with org-mode Uwe Brauer
  1 sibling, 2 replies; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-03 11:57 UTC (permalink / raw)
  To: emacs-orgmode

Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:

Hallo

> I know that the subject of my email exists already.
> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]

This works perfectly for your subject:

,----[ C-h f outorg-edit-as-org RET ]
| outorg-edit-as-org is an interactive Lisp function in ‘outorg.el’.
| 
| It is bound to M-# #, <menu-bar> <Outshine> <Edit As Org>.
| 
| (outorg-edit-as-org &optional ARG)
| 
| Convert and copy to temporary Org buffer
| 
| With ARG, act conditional on the raw value of ARG:
| 
| | prefix | raw | action 1          | action 2                       |
| |--------+-----+-------------------+--------------------------------|
| | C-u    | (4) | edit-whole-buffer | ---                            |
| | C-1    |   1 | edit-whole-buffer | insert default export-template |
| | C-2    |   2 | edit-whole-buffer | prompt user for template-file  |
| | C-3    |   3 | edit-whole-buffer | insert & keep default template |
| | C-4    |   4 | edit-whole-buffer | insert & keep template-file    |
| | C-5    |   5 | propagate changes | ---                            |
| 
| [back]
`----

It has already been described several time how to configure
outshine/outorg that it works with message-mode too.

Its actually quite easy. Configure outshine like described in the
README, and add outline-minor-mode to message-mode-hook in your .emacs.

,----
| (add-hook 'emacs-lisp-mode-hook 'outline-minor-mode)
| (add-hook 'message-mode-hook 'outline-minor-mode))
`----

Then with M-# # your email (open in message-mode, gnus) will be opened
in an org-mode buffer for editing in org-mode.

Looks very similar to opening a source-block in org-mode to edit the
sources in the programming language mode.

,----
| [ *unsent followup to Joseph Vidal-Rosset on gmane.emacs.orgmode* ] 
| Exit with M-# (Meta-Key and #)
| * --text follows this line--
| Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
| 
| Hallo
| 
| > I know that the subject of my email exists already.
| > https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html
| 
| This works perfectly for your subject:  [...]
`----

and tells you how to exit again: M-#

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* [Error] (was: how do you compose mails in Gnus with org-mode)
  2018-03-03 11:57 ` Thorsten Jolitz
@ 2018-03-06  9:58   ` Uwe Brauer
  2018-03-06 18:12     ` [Error] Thorsten Jolitz
  2018-03-06 10:12   ` how do you compose mails in Gnus with org-mode Uwe Brauer
  1 sibling, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-06  9:58 UTC (permalink / raw)
  To: emacs-orgmode

>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:

   > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
   > Hallo

   >> I know that the subject of my email exists already.
   >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]

   > This works perfectly for your subject:

   > ,----[ C-h f outorg-edit-as-org RET ]

Thanks for the pointer, but alas it does not work in a gnus message/mail
buffer.

When I use that function I obtain the following error:

Debugger entered--Lisp error: (error "Before first heading")
  signal(error ("Before first heading"))
  error("Before first heading")
  outline-back-to-heading()
  outline-end-of-subtree()
  outorg-save-markers((point-marker beg-of-subtree-marker mark-marker
  org-clock-marker org-clock-hd-marker org-clock-default-task
  org-clock-interrupted-task selected-task org-open-link-marker
  org-log-note-marker org-log-note-return-to
  org-entry-property-inherited-from)) 
  outorg-edit-as-org(nil)
  funcall-interactively(outorg-edit-as-org nil)
  call-interactively(outorg-edit-as-org nil nil)
  command-execute(outorg-edit-as-org)


Did you check this command, how do you use it?

Regards

Uwe Brauer

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-03 11:57 ` Thorsten Jolitz
  2018-03-06  9:58   ` [Error] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
@ 2018-03-06 10:12   ` Uwe Brauer
  2018-03-06 18:24     ` Thorsten Jolitz
  1 sibling, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-06 10:12 UTC (permalink / raw)
  To: emacs-orgmode

>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:

   > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
   > Hallo

   >> I know that the subject of my email exists already.
   >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]

   > This works perfectly for your subject:

I just realised that you are the author of that package. Sorry.

I set

(require 'outorg)  
(require 'outshine)
(add-hook 'outline-minor-mode-hook 'outshine-hook-function)

(add-hook 'message-mode-hook 'outline-minor-mode)

But when I fire up outorg-edit-as-org in a reply message I obtain the
error I described in my earlier message.

Uwe Brauer 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [Error]
  2018-03-06  9:58   ` [Error] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
@ 2018-03-06 18:12     ` Thorsten Jolitz
  0 siblings, 0 replies; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-06 18:12 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>
>    > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
>    > Hallo
>
>    >> I know that the subject of my email exists already.
>    >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]
>
>    > This works perfectly for your subject:
>
>    > ,----[ C-h f outorg-edit-as-org RET ]
>
> Thanks for the pointer, but alas it does not work in a gnus message/mail
> buffer.

Hello,
I' pretty sure your outshine config is not complete:

Here is what I have:

at the top of my .emacs:

,----
| ;; *** Global Keys
| 
| ;; must be set before outline is loaded
| (defvar outline-minor-mode-prefix "\M-#")
`----

then somewhere inside my .emacs (don't worry about "try-require", simply
use "require" in your code). outorg-export is optional too (but useful
for special needs in outorg exporting), I would highly recomment
navi-mode though (very fast navigation in outshine buffers).

,----
| ;; ** Outline
| 
| (message "\n------ entering outline ------")
| 
| (when (try-require 'outline)
| (add-hook 'emacs-lisp-mode-hook 'outline-minor-mode)
| (add-hook 'message-mode-hook 'outline-minor-mode))
| 
| ;; outorg-export
| (try-require 'outorg-export)
| 
| ;; outshine
| (try-require 'outshine)
| (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
| 
| (setq outshine-use-speed-commands t)
| 
| ;; navi-mode
| (try-require 'navi-mode)
`----

most likely this line is missing, add it:

,----
| (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
`----

Note that I did this:

,----
| (add-hook 'xyz-mode-hook 'outline-minor-mode)
`----

for many other modes too, like ESS, picolisp, ledger, latex ... etc

HTH

> When I use that function I obtain the following error:
>
> Debugger entered--Lisp error: (error "Before first heading")
>   signal(error ("Before first heading"))
>   error("Before first heading")
>   outline-back-to-heading()
>   outline-end-of-subtree()
>   outorg-save-markers((point-marker beg-of-subtree-marker mark-marker
>   org-clock-marker org-clock-hd-marker org-clock-default-task
>   org-clock-interrupted-task selected-task org-open-link-marker
>   org-log-note-marker org-log-note-return-to
>   org-entry-property-inherited-from)) 
>   outorg-edit-as-org(nil)
>   funcall-interactively(outorg-edit-as-org nil)
>   call-interactively(outorg-edit-as-org nil nil)
>   command-execute(outorg-edit-as-org)
>
>
> Did you check this command, how do you use it?
>
> Regards
>
> Uwe Brauer
>
>
>

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 10:12   ` how do you compose mails in Gnus with org-mode Uwe Brauer
@ 2018-03-06 18:24     ` Thorsten Jolitz
  2018-03-06 18:38       ` Thorsten Jolitz
  2018-03-06 19:01       ` Uwe Brauer
  0 siblings, 2 replies; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-06 18:24 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>
>    > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
>    > Hallo
>
>    >> I know that the subject of my email exists already.
>    >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]
>
>    > This works perfectly for your subject:
>
> I just realised that you are the author of that package. Sorry.
>
> I set
>
> (require 'outorg)  
> (require 'outshine)
> (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
>
> (add-hook 'message-mode-hook 'outline-minor-mode)

ok, maybe I answered the wrong message, does not look that incomplete
actually. Maybe try a copy of my config.

I used outorg-edit-as-org to insert and evaluate these source blocks
directly in this email, so for me it works:

#+BEGIN_SRC emacs-lisp  
 (emacs-version)
#+END_SRC

#+results:
: GNU Emacs 25.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.22.26)
:  of 2018-02-09

#+BEGIN_SRC emacs-lisp  
 (org-version)
#+END_SRC

#+results:
: 8.2.10

#+BEGIN_SRC emacs-lisp  
 (gnus-version)
#+END_SRC

#+results:
: Gnus v5.13

> But when I fire up outorg-edit-as-org in a reply message I obtain the
> error I described in my earlier message.
>
> Uwe Brauer 


-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 18:24     ` Thorsten Jolitz
@ 2018-03-06 18:38       ` Thorsten Jolitz
  2018-03-06 19:02         ` Uwe Brauer
  2018-03-06 19:01       ` Uwe Brauer
  1 sibling, 1 reply; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-06 18:38 UTC (permalink / raw)
  To: emacs-orgmode

Thorsten Jolitz <tjolitz@gmail.com> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
>
>>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>>
>>    > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
>>    > Hallo
>>
>>    >> I know that the subject of my email exists already.
>>    >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]
>>
>>    > This works perfectly for your subject:
>>
>> I just realised that you are the author of that package. Sorry.
>>
>> I set
>>
>> (require 'outorg)  
>> (require 'outshine)
>> (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
>>
>> (add-hook 'message-mode-hook 'outline-minor-mode)

PS
you do have this variable defined, right?

,----
| mail-header-separator is a variable defined in ‘sendmail.el’.
| Its value is "--text follows this line--"
| 
| Documentation:
| Line used to separate headers from text in messages being composed.
| 
| You can customize this variable.
`----

the value is not important, but it can't be nil.

> ok, maybe I answered the wrong message, does not look that incomplete
> actually. Maybe try a copy of my config.
>
> I used outorg-edit-as-org to insert and evaluate these source blocks
> directly in this email, so for me it works:
>
> #+BEGIN_SRC emacs-lisp  
>  (emacs-version)
> #+END_SRC
>
>
> #+results:
> : GNU Emacs 25.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.22.26)
> :  of 2018-02-09
>
> #+BEGIN_SRC emacs-lisp  
>  (org-version)
> #+END_SRC
>
>
> #+results:
> : 8.2.10
>
> #+BEGIN_SRC emacs-lisp  
>  (gnus-version)
> #+END_SRC
>
> #+results:
> : Gnus v5.13
>
>> But when I fire up outorg-edit-as-org in a reply message I obtain the
>> error I described in my earlier message.
>>
>> Uwe Brauer 

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 18:24     ` Thorsten Jolitz
  2018-03-06 18:38       ` Thorsten Jolitz
@ 2018-03-06 19:01       ` Uwe Brauer
  2018-03-06 19:36         ` Thorsten Jolitz
  1 sibling, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-06 19:01 UTC (permalink / raw)
  To: emacs-orgmode

>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
>>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>> 
>> > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
>> > Hallo
>> 
>> >> I know that the subject of my email exists already.
>> >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]
>> 
>> > This works perfectly for your subject:
>> 
>> I just realised that you are the author of that package. Sorry.
>> 
>> I set
>> 
>> (require 'outorg)  
>> (require 'outshine)
>> (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
>> 
>> (add-hook 'message-mode-hook 'outline-minor-mode)

> ok, maybe I answered the wrong message, does not look that incomplete
> actually. Maybe try a copy of my config.

> I used outorg-edit-as-org to insert and evaluate these source blocks
> directly in this email, so for me it works:
I still can't

> #+BEGIN_SRC emacs-lisp  
>  (emacs-version)
> #+END_SRC


> #+results:
> : GNU Emacs 25.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.22.26)
> :  of 2018-02-09


GNU Emacs 27.0.50 (build 1, x86_64-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2018-01-25"



> #+BEGIN_SRC emacs-lisp  
>  (org-version)
> #+END_SRC

Git master from June 2017 so relatively recent

> #+results:
> : 8.2.10

> #+BEGIN_SRC emacs-lisp  
>  (gnus-version)
> #+END_SRC

> #+results:
> : Gnus v5.13

The same here.

>> But when I fire up outorg-edit-as-org in a reply message I obtain the
>> error I described in my earlier message.
>> 
>> Uwe Brauer 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 18:38       ` Thorsten Jolitz
@ 2018-03-06 19:02         ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2018-03-06 19:02 UTC (permalink / raw)
  To: emacs-orgmode


   > Thorsten Jolitz <tjolitz@gmail.com> writes:

   > PS
   > you do have this variable defined, right?

   > ,----
   > | mail-header-separator is a variable defined in ‘sendmail.el’.
   > | Its value is "--text follows this line--"
   > | 
   > | Documentation:
   > | Line used to separate headers from text in messages being composed.
   > | 
   > | You can customize this variable.
   > `----

   > the value is not important, but it can't be nil.

Yes 

,----
| mail-header-separator is a variable defined in ‘sendmail.el’.
| Its value is "--text follows this line--"
| 
| Documentation:
| Line used to separate headers from text in messages being composed.
| 
| You can customize this variable.
| 
| [back]
`----

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 19:01       ` Uwe Brauer
@ 2018-03-06 19:36         ` Thorsten Jolitz
  2018-03-07  9:57           ` Uwe Brauer
  0 siblings, 1 reply; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-06 19:36 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>
>> Uwe Brauer <oub@mat.ucm.es> writes:
>>>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>>> 
>>> > Joseph Vidal-Rosset <joseph.vidal.rosset@gmail.com> writes:
>>> > Hallo
>>> 
>>> >> I know that the subject of my email exists already.
>>> >> [[https://lists.gnu.org/archive/html/emacs-orgmode/2009-08/msg00855.html]]
>>> 
>>> > This works perfectly for your subject:
>>> 
>>> I just realised that you are the author of that package. Sorry.
>>> 
>>> I set
>>> 
>>> (require 'outorg)  
>>> (require 'outshine)
>>> (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
>>> 
>>> (add-hook 'message-mode-hook 'outline-minor-mode)
>
>> ok, maybe I answered the wrong message, does not look that incomplete
>> actually. Maybe try a copy of my config.
>
>> I used outorg-edit-as-org to insert and evaluate these source blocks
>> directly in this email, so for me it works:
> I still can't
>
>> #+BEGIN_SRC emacs-lisp  
>>  (emacs-version)
>> #+END_SRC
>
>
>> #+results:
>> : GNU Emacs 25.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.22.26)
>> :  of 2018-02-09
>
>
> GNU Emacs 27.0.50 (build 1, x86_64-pc-linux-gnu, X toolkit, Xaw3d
> scroll bars)
>  of 2018-01-25"

Wow, emacs 27 ... I'm on Archlinux and always thought packages a pretty
up-to-date.

Maybe outline has changed somehow between Emacs 25 and Emacs 27?
But I don't think so, the error you send is pretty typical for
incomplete configuration.

> Debugger entered--Lisp error: (error "Before first heading")
>   signal(error ("Before first heading"))
>   error("Before first heading")
>   outline-back-to-heading()

is typical when 

,----
| outorg-prepare-message-mode-buffer-for-editing ()
`----

has not run, it turns this line into a 1st level org headline thus
converting any kind of message body into an org file.

,----
| * --text follows this line--
| Uwe Brauer <oub@mat.ucm.es> writes:
`----

without this, the error is justified - an org file without a single 
org headline is no org file at all.

You could try to write an email with these lines:

,----
| * 1st level
| ** 2nd level
| some text
`----

put point on some text an call outorg, to see if it works.

Another option would be to use edebug:
open outorg.el, put point into 'outorg-edit-as-org', and call M-x
edebug-defun. Then convert an email again, and go step-by-step with
SPACE key, and see how far you get.

When done, call 'load-library' on outorg.el to get rid of edebug
instrumentation.

>> #+BEGIN_SRC emacs-lisp  
>>  (org-version)
>> #+END_SRC
>
> Git master from June 2017 so relatively recent
>
>> #+results:
>> : 8.2.10
>
>> #+BEGIN_SRC emacs-lisp  
>>  (gnus-version)
>> #+END_SRC
>
>> #+results:
>> : Gnus v5.13
>
> The same here.
>
>>> But when I fire up outorg-edit-as-org in a reply message I obtain the
>>> error I described in my earlier message.
>>> 
>>> Uwe Brauer 
>
>
>

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-06 19:36         ` Thorsten Jolitz
@ 2018-03-07  9:57           ` Uwe Brauer
  2018-03-07 17:46             ` Thorsten Jolitz
  2018-03-07 21:10             ` how do you compose mails in Gnus with org-mode Tim Cross
  0 siblings, 2 replies; 42+ messages in thread
From: Uwe Brauer @ 2018-03-07  9:57 UTC (permalink / raw)
  To: emacs-orgmode


   > Uwe Brauer <oub@mat.ucm.es> writes:

   > Wow, emacs 27 ... I'm on Archlinux and always thought packages a pretty
   > up-to-date.

Right Ubuntu officially only ships 24, which is pretty old.

Well it is directly form git master, so it is a pre release.
The official release is 26.

   > Maybe outline has changed somehow between Emacs 25 and Emacs 27?
   > But I don't think so, the error you send is pretty typical for
   > incomplete configuration.

I think at the weekend, I will debug the problem. It might be that there
some parts of my init file which are in conflict with your package.

   > is typical when 

   > ,----
   > | outorg-prepare-message-mode-buffer-for-editing ()
   > `----

   > has not run, it turns this line into a 1st level org headline thus
   > converting any kind of message body into an org file.

   > ,----
   > | * --text follows this line--
   > | Uwe Brauer <oub@mat.ucm.es> writes:
   > `----

   > without this, the error is justified - an org file without a single 
   > org headline is no org file at all.

   > You could try to write an email with these lines:

   > ,----
   > | * 1st level
   > | ** 2nd level
   > | some text
   > `----

   > put point on some text an call outorg, to see if it works.

ok
   > Another option would be to use edebug:
   > open outorg.el, put point into 'outorg-edit-as-org', and call M-x
   > edebug-defun. Then convert an email again, and go step-by-step with
   > SPACE key, and see how far you get.

Right.

BTW, you recommended
  (require 'outorg-export)

I installed your package via the package system, so I don't see that
file. Where can I obtain it from?

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-07  9:57           ` Uwe Brauer
@ 2018-03-07 17:46             ` Thorsten Jolitz
  2018-03-08  8:50               ` Uwe Brauer
  2018-03-07 21:10             ` how do you compose mails in Gnus with org-mode Tim Cross
  1 sibling, 1 reply; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-07 17:46 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>    > Uwe Brauer <oub@mat.ucm.es> writes:
>
>    > Wow, emacs 27 ... I'm on Archlinux and always thought packages a
>    > pretty
>    > up-to-date.
>
> Right Ubuntu officially only ships 24, which is pretty old.
>
> Well it is directly form git master, so it is a pre release.
> The official release is 26.

Then Archlinux is not that much out of date.

>    > Maybe outline has changed somehow between Emacs 25 and Emacs 27?
>    > But I don't think so, the error you send is pretty typical for
>    > incomplete configuration.
>
> I think at the weekend, I will debug the problem. It might be that there
> some parts of my init file which are in conflict with your package.

A good start would be to try outshine with emacs-lisp mode.
With your outshine config done, write a file like foo.el

,----
| ;;; 1st level header
| ;;;; Sum
| (+ 1 1)
| ;;;; Subtract
| (- 2 1)
`----

or

,----
| ;; * 1st level header
| ;; ** Sum
| (+ 1 1)
| ;; ** Subtract
| (- 2 1)
`----

and see if you got headline fontification and all the outshine
functionality.

If that works, its a message-mode problem.
If not, a genereal problem with your config.

> [...]
> BTW, you recommended
>   (require 'outorg-export)
>
> I installed your package via the package system, so I don't see that
> file. Where can I obtain it from?

It's an extension to outorg:

,----
| ;;; outorg-export.el -- Automated exporting through org
| 
| ;; Author: Jonathan Leech-Pepin <jonathan.leechpepin AT gmail DOT com
| ;; Version: 0.1
| ;; URL: https://github.com/jleechpe/outorg-export
| 
| ;;;; MetaData
| ;; :PROPERTIES:
| ;; :copyright: Jonathan Leech-Pepin
| ;; :copyright-years: 2014+
| ;; :version:  0.3
| ;; :licence:  GPLv3 or later
| ;; :licence-url: http://www.gnu.org/licenses/
| ;; :part-of-emacs: no
| ;; :author:   Jonathan Leech-Pepin
| ;; :author_email: jonathan.leechpepin AT gmail DOT com
| ;; :keywords: emacs org-mode export
| ;; :END:
`----

This is the README

,----
| outorg-export
| =============
| 
| Automated exporting of sections of source files to any format org can export to.
`----

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-07  9:57           ` Uwe Brauer
  2018-03-07 17:46             ` Thorsten Jolitz
@ 2018-03-07 21:10             ` Tim Cross
  2018-03-08  8:57               ` Uwe Brauer
  1 sibling, 1 reply; 42+ messages in thread
From: Tim Cross @ 2018-03-07 21:10 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-orgmode


Uwe Brauer <oub@mat.ucm.es> writes:

>    > Uwe Brauer <oub@mat.ucm.es> writes:
>
>    > Wow, emacs 27 ... I'm on Archlinux and always thought packages a pretty
>    > up-to-date.
>
> Right Ubuntu officially only ships 24, which is pretty old.
>
> Well it is directly form git master, so it is a pre release.
> The official release is 26.
>
To avoid confusion, the official release is still 25.3. The next
release, which is probably still a ways off, will be 26.1 The 27 version
is really bleeding edge, containing changes which are considered too
risky for the next release. I'm not sure how frequently bug fixes for
26.1 are merged into the development branch.

>    > Maybe outline has changed somehow between Emacs 25 and Emacs 27?
>    > But I don't think so, the error you send is pretty typical for
>    > incomplete configuration.
>

From a previous post, I think you mentioned you were running from git
master from mid/late last year. If your running from git master, I think
you need to pull fairly regularly as bugs are frequently fixed and you
could be tripping over something which has already been addressed. 

I suspect you are likely to run into a number of bugs with the latest
development version of emacs and you are probably one of the very few
who are looking at bugs in that version. Good luck.

-- 
Tim Cross

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-07 17:46             ` Thorsten Jolitz
@ 2018-03-08  8:50               ` Uwe Brauer
  2018-03-08 16:58                 ` Thorsten Jolitz
  0 siblings, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-08  8:50 UTC (permalink / raw)
  To: emacs-orgmode

>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:

   > Uwe Brauer <oub@mat.ucm.es> writes:
   >> > Uwe Brauer <oub@mat.ucm.es> writes:
   >> 
   >> > Wow, emacs 27 ... I'm on Archlinux and always thought packages a
   >> > pretty
   >> > up-to-date.
   >> 
   >> Right Ubuntu officially only ships 24, which is pretty old.
   >> 
   >> Well it is directly form git master, so it is a pre release.
   >> The official release is 26.

   > Then Archlinux is not that much out of date.

   >> > Maybe outline has changed somehow between Emacs 25 and Emacs 27?
   >> > But I don't think so, the error you send is pretty typical for
   >> > incomplete configuration.
   >> 
   >> I think at the weekend, I will debug the problem. It might be that there
   >> some parts of my init file which are in conflict with your package.

   > A good start would be to try outshine with emacs-lisp mode.
   > With your outshine config done, write a file like foo.el

   > ,----
   > | ;;; 1st level header
   > | ;;;; Sum
   > | (+ 1 1)
   > | ;;;; Subtract
   > | (- 2 1)
   > `----

   > or

   > ,----
   > | ;; * 1st level header
   > | ;; ** Sum
   > | (+ 1 1)
   > | ;; ** Subtract
   > | (- 2 1)
   > `----

   > and see if you got headline fontification and all the outshine
   > functionality.

That seems to work, I opened your outorg buffer and there everything
worked as expected.


   > If that works, its a message-mode problem.
   > If not, a genereal problem with your config.

   >> [...]
   >> BTW, you recommended
   >> (require 'outorg-export)
   >> 
   >> I installed your package via the package system, so I don't see that
   >> file. Where can I obtain it from?

   > It's an extension to outorg:

Where can I find it, only in that site? It seems not to be in elpa/melpa
and marmelade.

Thanks for the pointer

Uwe 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-07 21:10             ` how do you compose mails in Gnus with org-mode Tim Cross
@ 2018-03-08  8:57               ` Uwe Brauer
  2018-03-08 11:48                 ` Tim Cross
  0 siblings, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-08  8:57 UTC (permalink / raw)
  To: emacs-orgmode


   > Uwe Brauer <oub@mat.ucm.es> writes:

   > To avoid confusion, the official release is still 25.3. The next
   > release, which is probably still a ways off, will be 26.1

Thanks for the clarification. But in order to compile 26, I would need
to checkout the 26 from the git repo? Do I understand that correctly?


   > The 27 version is really bleeding edge, containing changes which
   > are considered too risky for the next release. I'm not sure how
   > frequently bug fixes for 26.1 are merged into the development
   > branch.

Well I started to use that version at a time a specific BIDI function
was only in master but not in the official release. Later a similar
thing occurred with vc.el. 

   > From a previous post, I think you mentioned you were running from
   > git master from mid/late last year. If your running from git
   > master, I think you need to pull fairly regularly as bugs are
   > frequently fixed and you could be tripping over something which has
   > already been addressed.

Ah no. I am running emacs git master from end of January. I am running
the git/master version of org mode from last june. Why? Well Nic put in
some very useful stuff in org-table (not in the official release now),
but then later in September/October the whole template engine was
changed in master and I could not find out you to make it work again,
that is why I stick to that very particular org version.

   > I suspect you are likely to run into a number of bugs with the
   > latest development version of emacs and you are probably one of the
   > very few who are looking at bugs in that version. Good luck.


Yeah maybe. At least this way reporting them I could contribute a bit to
GNU emacs. :-D

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-08  8:57               ` Uwe Brauer
@ 2018-03-08 11:48                 ` Tim Cross
  2018-03-08 14:16                   ` Uwe Brauer
  0 siblings, 1 reply; 42+ messages in thread
From: Tim Cross @ 2018-03-08 11:48 UTC (permalink / raw)
  To: Org-mode

[-- Attachment #1: Type: text/plain, Size: 2445 bytes --]

Yes, you need to checkout the 26 branch to get the next version to be
released. A git branch -a will probably list all the branches and you
should see one labelled 26 (I'm not running emacs from git at present, so
cannot check). I believe git 26 has been in 'feature freeze' for a while
while they try to sort out the main bugs needing to be fixed before 26.1
can be released.

Note also that I believe the template changes in org are not in the maint
branch, only master. So you could try  the maint btranch as that would at
least have known bugs fixed.

On 8 March 2018 at 19:57, Uwe Brauer <oub@mat.ucm.es> wrote:

>
>    > Uwe Brauer <oub@mat.ucm.es> writes:
>
>    > To avoid confusion, the official release is still 25.3. The next
>    > release, which is probably still a ways off, will be 26.1
>
> Thanks for the clarification. But in order to compile 26, I would need
> to checkout the 26 from the git repo? Do I understand that correctly?
>
>
>    > The 27 version is really bleeding edge, containing changes which
>    > are considered too risky for the next release. I'm not sure how
>    > frequently bug fixes for 26.1 are merged into the development
>    > branch.
>
> Well I started to use that version at a time a specific BIDI function
> was only in master but not in the official release. Later a similar
> thing occurred with vc.el.
>
>    > From a previous post, I think you mentioned you were running from
>    > git master from mid/late last year. If your running from git
>    > master, I think you need to pull fairly regularly as bugs are
>    > frequently fixed and you could be tripping over something which has
>    > already been addressed.
>
> Ah no. I am running emacs git master from end of January. I am running
> the git/master version of org mode from last june. Why? Well Nic put in
> some very useful stuff in org-table (not in the official release now),
> but then later in September/October the whole template engine was
> changed in master and I could not find out you to make it work again,
> that is why I stick to that very particular org version.
>
>    > I suspect you are likely to run into a number of bugs with the
>    > latest development version of emacs and you are probably one of the
>    > very few who are looking at bugs in that version. Good luck.
>
>
> Yeah maybe. At least this way reporting them I could contribute a bit to
> GNU emacs. :-D
>
>
>
>


-- 
regards,

Tim

--
Tim Cross

[-- Attachment #2: Type: text/html, Size: 3321 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-08 11:48                 ` Tim Cross
@ 2018-03-08 14:16                   ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2018-03-08 14:16 UTC (permalink / raw)
  To: emacs-orgmode

>>> "Tim" == Tim Cross <theophilusx@gmail.com> writes:

    > Yes, you need to checkout the 26 branch to get the next version to be
    > released. A git branch -a will probably list all the branches and you
    > should see one labelled 26 (I'm not running emacs from git at present, so
    > cannot check). I believe git 26 has been in 'feature freeze' for a while
    > while they try to sort out the main bugs needing to be fixed before 26.1
    > can be released.

    > Note also that I believe the template changes in org are not in
    > the maint branch, only master. So you could try the maint btranch
    > as that would at least have known bugs fixed.

Problem with the main branch is that the nice feature for the org
tables, namely very wide columns get somehow hidden, is not included....

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-08  8:50               ` Uwe Brauer
@ 2018-03-08 16:58                 ` Thorsten Jolitz
  2018-03-09 18:44                   ` Uwe Brauer
  2018-03-09 21:49                   ` [SOLVED] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
  0 siblings, 2 replies; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-08 16:58 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>>>> "Thorsten" == Thorsten Jolitz <tjolitz@gmail.com> writes:
>
>    > A good start would be to try outshine with emacs-lisp mode.
>    > With your outshine config done, write a file like foo.el
>
>    > ,----
>    > | ;;; 1st level header
>    > | ;;;; Sum
>    > | (+ 1 1)
>    > | ;;;; Subtract
>    > | (- 2 1)
>    > `----
>
>    > or
>
>    > ,----
>    > | ;; * 1st level header
>    > | ;; ** Sum
>    > | (+ 1 1)
>    > | ;; ** Subtract
>    > | (- 2 1)
>    > `----
>
>    > and see if you got headline fontification and all the outshine
>    > functionality.
>
> That seems to work, I opened your outorg buffer and there everything
> worked as expected.
>
>
>    > If that works, its a message-mode problem.
>    > If not, a genereal problem with your config.

When I do M-# # writing this mail I see:
,----
| [ *unsent followup to Uwe Brauer on gmane.emacs.orgmode* ] Exit with M-#
| (Meta-Key and #)
| * --text follows this line--
| Uwe Brauer <oub@mat.ucm.es> writes: ...[]
`----

I suggest edebug then, as written, this must run successfully:

,----[ C-h f outorg-prepare-message-mode-buffer-for-editing RET ]
| outorg-prepare-message-mode-buffer-for-editing is a Lisp function in
| ‘outorg.el’.
| 
| (outorg-prepare-message-mode-buffer-for-editing)
| 
| Prepare an unsent-mail in a message-mode buffer for outorg.
| 
| This function assumes that ’--text follows this line--’ (or
| whatever is found inside variable ‘mail-header-separator’) is the
| first line below the message header, is always present, and never
| modified by the user. It turns this line into an ‘outshine’
| headline and out-comments all text below this line - if any.
`----

>    >> [...]
>    >> BTW, you recommended
>    >> (require 'outorg-export)
>    >> 
>    >> I installed your package via the package system, so I don't see that
>    >> file. Where can I obtain it from?
>
>    > It's an extension to outorg:
>
> Where can I find it, only in that site? It seems not to be in elpa/melpa
> and marmelade.

Only available via github I think ....

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-08 16:58                 ` Thorsten Jolitz
@ 2018-03-09 18:44                   ` Uwe Brauer
  2018-03-09 22:58                     ` Thorsten Jolitz
  2018-03-09 21:49                   ` [SOLVED] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
  1 sibling, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-09 18:44 UTC (permalink / raw)
  To: emacs-orgmode


   > Uwe Brauer <oub@mat.ucm.es> writes:

   > When I do M-# # writing this mail I see:
   > ,----
   > | [ *unsent followup to Uwe Brauer on gmane.emacs.orgmode* ] Exit with M-#
   > | (Meta-Key and #)
   > | * --text follows this line--
   > | Uwe Brauer <oub@mat.ucm.es> writes: ...[]
   > `----

I almost see the same but indented since I user supercite. I will
deactivate it for the moment being, but I doubt this is the problem
since your function also should work for a new mail buffer not just a
reply one, am I right? So supercite should be irrelevant there.

I tried to do what I always do in such cases (at least if memory serves
me right). I put all outorg startup code in a file
start emacs -q and then load that file.

However when I do that, emacs tells me he does not find outshine and
outorg, although they are in $HOME/.emacs.d/elpa


So does emacs -q not ready anymore those files installed via the package
system. I am confused.

My outorg_init file is

,----
| 
| (defvar outline-minor-mode-prefix "\M-#")
| 
| (require 'outline)
| (require 'outshine)
| 
| (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
| (add-hook 'message-mode-hook 'outline-minor-mode)
| 
| (require 'outorg)
|  
| (when (require 'outline)
|  (add-hook 'emacs-lisp-mode-hook 'outline-minor-mode)
|  (add-hook 'message-mode-hook 'outline-minor-mode))
|  
|  ;; outorg-export
|  (require 'outorg-export)
|  (require 'navi-mode)
|  ;; outshine
| 
| 
|  
|  (setq outshine-use-speed-commands t)
|  
|  ;; navi-mode
| (add-hook 'outline-minor-mode-hook 'outshine-hook-function)
| 
| (provide 'outorg_init)
`----


   > I suggest edebug then, as written, this must run successfully:

   > ,----[ C-h f outorg-prepare-message-mode-buffer-for-editing RET ]
   > | outorg-prepare-message-mode-buffer-for-editing is a Lisp function in
   > | ‘outorg.el’.
   > | 
   > | (outorg-prepare-message-mode-buffer-for-editing)
   > | 
   > | Prepare an unsent-mail in a message-mode buffer for outorg.
   > | 
   > | This function assumes that ’--text follows this line--’ (or
   > | whatever is found inside variable ‘mail-header-separator’) is the
   > | first line below the message header, is always present, and never
   > | modified by the user. It turns this line into an ‘outshine’
   > | headline and out-comments all text below this line - if any.
   > `----


   > Only available via github I think ....

^ permalink raw reply	[flat|nested] 42+ messages in thread

* [SOLVED] (was: how do you compose mails in Gnus with org-mode)
  2018-03-08 16:58                 ` Thorsten Jolitz
  2018-03-09 18:44                   ` Uwe Brauer
@ 2018-03-09 21:49                   ` Uwe Brauer
  2018-03-09 22:59                     ` [SOLVED] Thorsten Jolitz
  1 sibling, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2018-03-09 21:49 UTC (permalink / raw)
  To: emacs-orgmode


   > Uwe Brauer <oub@mat.ucm.es> writes:

   > When I do M-# # writing this mail I see:
   > ,----
   > | [ *unsent followup to Uwe Brauer on gmane.emacs.orgmode* ] Exit with M-#
   > | (Meta-Key and #)
   > | * --text follows this line--
   > | Uwe Brauer <oub@mat.ucm.es> writes: ...[]
   > `----


I found the culprit

(setq message-yank-prefix "   > ")

No idea why I had this, but may be it is ages there. Just moving it out
my init files and everything worked as expected. Thanks

Uwe 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: how do you compose mails in Gnus with org-mode
  2018-03-09 18:44                   ` Uwe Brauer
@ 2018-03-09 22:58                     ` Thorsten Jolitz
  0 siblings, 0 replies; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-09 22:58 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>    > Uwe Brauer <oub@mat.ucm.es> writes:
>
>    > When I do M-# # writing this mail I see:
>    > ,----
>    > | [ *unsent followup to Uwe Brauer on gmane.emacs.orgmode* ] Exit
>    > | with M-#
>    > | (Meta-Key and #)
>    > | * --text follows this line--
>    > | Uwe Brauer <oub@mat.ucm.es> writes: ...[]
>    > `----
>
> I almost see the same but indented since I user supercite.

Isn't that the problem already?

In an org file, this:

,----
| * headline
|  * headline
| hello
`----

has only one headline, indentation for the * is not allowed.

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2018-03-09 21:49                   ` [SOLVED] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
@ 2018-03-09 22:59                     ` Thorsten Jolitz
  2018-03-10  8:37                       ` [a outline regexp problem] (was: [SOLVED]) Uwe Brauer
  0 siblings, 1 reply; 42+ messages in thread
From: Thorsten Jolitz @ 2018-03-09 22:59 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>    > Uwe Brauer <oub@mat.ucm.es> writes:
>
>    > When I do M-# # writing this mail I see:
>    > ,----
>    > | [ *unsent followup to Uwe Brauer on gmane.emacs.orgmode* ] Exit
>    > | with M-#
>    > | (Meta-Key and #)
>    > | * --text follows this line--
>    > | Uwe Brauer <oub@mat.ucm.es> writes: ...[]
>    > `----
>
>
> I found the culprit
>
> (setq message-yank-prefix "   > ")
>
> No idea why I had this, but may be it is ages there. Just moving it out
> my init files and everything worked as expected. Thanks

Ok, good ... ;-)

-- 
cheers,
Thorsten

^ permalink raw reply	[flat|nested] 42+ messages in thread

* [a outline regexp problem] (was: [SOLVED])
  2018-03-09 22:59                     ` [SOLVED] Thorsten Jolitz
@ 2018-03-10  8:37                       ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2018-03-10  8:37 UTC (permalink / raw)
  To: emacs-orgmode

 
   > Uwe Brauer <oub@mat.ucm.es> writes: 
 
   > Ok, good ... ;-) 
 
However I run into a problem with my daily workflow. I am using 
very often bookmark.el by Karl Fogel.   Especially I have the 
following setting 
   
(defun my-set-outline-bookmark () 
   (interactive) (message "Now the outline-regexp is set to \" 
   [A-Z]*:1.1\" ")) 
  
 (add-hook 'bookmark-bmenu-mode-hook 'hide-body) (add-hook 
 'bookmark-bmenu-mode-hook 'turn-on-outline-minor-mode) (add-hook 
 'bookmark-bmenu-mode-hook 'my-set-outline-bookmark) 
 
However with the outorg setting and the outline mode, I obtain now 
an  Cannot calculate outcommented outline-regexp without 
’comment-start’ character defined!   The culprit is
 
(add-hook 'outline-minor-mode-hook 'outshine-hook-function)
I will write Adam Porter.


Uwe Brauer 

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2021-12-29  8:06         ` [SOLVED] Uwe Brauer
@ 2021-12-29  8:18           ` Ihor Radchenko
  0 siblings, 0 replies; 42+ messages in thread
From: Ihor Radchenko @ 2021-12-29  8:18 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

> So if I understand you correctly. I do load my org package too late for
> org-real?

I think so. My speculation:

If the newest Org is not yet in load-path when you load org-real,
org-real's (require 'org) will pull-in built-in version of org-compat.

Later, when load-path points to the newest version of Org, you load
org-persist (org-persist does not exist in built-in version of Org),
which relies on org-file-name-concat to be defined in the newest version
of org-compat. However, built-in version of org-compat is already loaded
by emacs and (require 'org-compat) inside org-persist does not trigger
loading. Hence, you are getting

> Debugger entered--Lisp error: (void-function org-file-name-concat)

Best,
Ihor


^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2021-12-29  5:11       ` [SOLVED] Ihor Radchenko
@ 2021-12-29  8:06         ` Uwe Brauer
  2021-12-29  8:18           ` [SOLVED] Ihor Radchenko
  0 siblings, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2021-12-29  8:06 UTC (permalink / raw)
  To: emacs-orgmode

>>> "IR" == Ihor Radchenko <yantar92@gmail.com> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
>>> Hmm. I suspect that org-real might not be the problem by itself.
>>> Rather you may load it too early and pull-in built-in org.
>> 
>> Well I don't load anything, that is all done by the package system.

> I was just guessing. But do you really have init.el with no requires?

I have a lot of requires in my init file, but non for org-real besides I
have installed a lot of org addons from MELPA and none have caused me
any problem.

So if I understand you correctly. I do load my org package too late for
org-real?

Regards

Uwe 



^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2021-12-28 17:28     ` [SOLVED] Uwe Brauer
@ 2021-12-29  5:11       ` Ihor Radchenko
  2021-12-29  8:06         ` [SOLVED] Uwe Brauer
  0 siblings, 1 reply; 42+ messages in thread
From: Ihor Radchenko @ 2021-12-29  5:11 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>> Hmm. I suspect that org-real might not be the problem by itself. Rather
>> you may load it too early and pull-in built-in org.
>
> Well I don't load anything, that is all done by the package system.

I was just guessing. But do you really have init.el with no requires?

Best,
Ihor


^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2021-12-28 14:49   ` Ihor Radchenko
@ 2021-12-28 17:28     ` Uwe Brauer
  2021-12-29  5:11       ` [SOLVED] Ihor Radchenko
  0 siblings, 1 reply; 42+ messages in thread
From: Uwe Brauer @ 2021-12-28 17:28 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 426 bytes --]

>>> "IR" == Ihor Radchenko <yantar92@gmail.com> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
>> I found the culprit, the recently installed org-real pkg.
>> 
>> I uninstalled it and everything was back to normally.

> Hmm. I suspect that org-real might not be the problem by itself. Rather
> you may load it too early and pull-in built-in org.

Well I don't load anything, that is all done by the package system.

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2021-09-29  4:07   ` Timothy
@ 2021-09-29  6:30     ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2021-09-29  6:30 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 447 bytes --]

>>> "T" == Timothy  <tecosaur@gmail.com> writes:

> Hello,
>>> Any idea how to export checkboxes to odt?
>>> I mean not just simply having [ ] in the odt document but having them translated as actual boxes.
>> 
>> Either using latex ⊠
>> or   UTF8 ☒

> I’m wondering, would this be worth adding to ox-odt?

I think Juan's solution would be nice, however it does not work for me write now, so I have to see what is wrong with it.

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2019-12-11 22:20   ` John Kitchin
@ 2019-12-12  8:13     ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2019-12-12  8:13 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 348 bytes --]

>>> "JK" == John Kitchin <jkitchin@andrew.cmu.edu> writes:

> That is the default value of that variable. I guess you had set it
> elsewhere to be getting citep before.

Right, moreover in some obscure place which was not easy to find, and
the setting was also not commented, so it unclear to me why I did this.

Bad bad practise.

Uwe 

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5025 bytes --]

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2018-11-29 17:27   ` [SOLVED] (was: org babel: %% [removed source block]) Uwe Brauer
@ 2018-11-29 22:20     ` Nick Dokos
  0 siblings, 0 replies; 42+ messages in thread
From: Nick Dokos @ 2018-11-29 22:20 UTC (permalink / raw)
  To: emacs-orgmode

Uwe Brauer <oub@mat.ucm.es> writes:

>>>> "Berry," == Berry, Charles <ccberry@ucsd.edu> writes:
>
>    > I cannot reproduce your export issue with org 9.1.14.
>    > You need to provide more details.
>
> Sorry for the noise. I just realised that a very very long time ago I
> installed a function  remove-src-blk-export, which, uhh, removes source
> blocks. 
>
> I removed that function and everything works as expected.

I was going to ask who produced that unfamiliar-looking "%% [removed
source block]" :-) Glad you figured it out.

-- 
Nick

"There are only two hard problems in computer science: cache
invalidation, naming things, and off-by-one errors." -Martin Fowler

^ permalink raw reply	[flat|nested] 42+ messages in thread

* Re: [SOLVED]
  2018-04-04 13:25 ` [SOLVED] (was: export table to html, don't display certain columns) Uwe Brauer
@ 2018-04-04 13:29   ` Uwe Brauer
  0 siblings, 0 replies; 42+ messages in thread
From: Uwe Brauer @ 2018-04-04 13:29 UTC (permalink / raw)
  To: emacs-orgmode




   > To answer my own question

   > | / | /     |     |       | /   |
   > |   | Name  | Res | Letra | Obs |
   > |---+-------+-----+-------+-----|
   > |   | Smith |   0 |       |     |
   > |   | Jones | 1.4 |       |     |
   > |   | Bond  | 5.6 | *     |     |

   > All columns starting with / are ignored when exporting. Sorry for the
   > noise and the double posting.


That is not entirely correct. Someone (I forgot who it was, sorry)
provided me with the following hack


(add-hook 'org-export-before-processing-hook
           'f-ox-filter-table-column-del)


(defun f-ox-filter-table-column-del (back-end)
   "Delete the columns $2 to $> marked as \"/\" on a row with \"/\" in $1.
 If you want a non-empty column $1 to be deleted make it $2 by
 inserting an empty column before or rearrange column order in
 some other way. Make sure \"/\" is in $1 again after that."
   (while (re-search-forward
           "^[ \t]*| +/ +|\\(.*?|\\)?? +\\(/\\) +|" nil t)
     (goto-char (match-beginning 2))
     (org-table-delete-column)
     (beginning-of-line)))


That is very useful and I wonder why there is nothing in org vanilla
(but then it might and I did not find it.)

^ permalink raw reply	[flat|nested] 42+ messages in thread

end of thread, other threads:[~2021-12-29  8:17 UTC | newest]

Thread overview: 42+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-01 13:37 how do you compose mails in Gnus with org-mode Joseph Vidal-Rosset
2018-03-01 14:10 ` Eric S Fraga
     [not found]   ` <87vaef97ze.fsf@gmail.com>
2018-03-01 14:40     ` Fwd: " Joseph Vidal-Rosset
2018-03-01 15:10       ` Eric S Fraga
2018-03-01 15:29         ` Joseph Vidal-Rosset
2018-03-01 16:59           ` Eric S Fraga
2018-03-01 18:04             ` Joseph Vidal-Rosset
2018-03-01 18:17               ` Brian Shine
2018-03-01 18:46                 ` Joseph Vidal-Rosset
2018-03-01 19:01                   ` Brian Shine
2018-03-02  7:27                     ` Roland Everaert
2018-03-02  7:25               ` Eric S Fraga
2018-03-03 11:57 ` Thorsten Jolitz
2018-03-06  9:58   ` [Error] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
2018-03-06 18:12     ` [Error] Thorsten Jolitz
2018-03-06 10:12   ` how do you compose mails in Gnus with org-mode Uwe Brauer
2018-03-06 18:24     ` Thorsten Jolitz
2018-03-06 18:38       ` Thorsten Jolitz
2018-03-06 19:02         ` Uwe Brauer
2018-03-06 19:01       ` Uwe Brauer
2018-03-06 19:36         ` Thorsten Jolitz
2018-03-07  9:57           ` Uwe Brauer
2018-03-07 17:46             ` Thorsten Jolitz
2018-03-08  8:50               ` Uwe Brauer
2018-03-08 16:58                 ` Thorsten Jolitz
2018-03-09 18:44                   ` Uwe Brauer
2018-03-09 22:58                     ` Thorsten Jolitz
2018-03-09 21:49                   ` [SOLVED] (was: how do you compose mails in Gnus with org-mode) Uwe Brauer
2018-03-09 22:59                     ` [SOLVED] Thorsten Jolitz
2018-03-10  8:37                       ` [a outline regexp problem] (was: [SOLVED]) Uwe Brauer
2018-03-07 21:10             ` how do you compose mails in Gnus with org-mode Tim Cross
2018-03-08  8:57               ` Uwe Brauer
2018-03-08 11:48                 ` Tim Cross
2018-03-08 14:16                   ` Uwe Brauer
2018-04-04  9:08 export table to html, don't display certain columns Uwe Brauer
2018-04-04 13:25 ` [SOLVED] (was: export table to html, don't display certain columns) Uwe Brauer
2018-04-04 13:29   ` [SOLVED] Uwe Brauer
2018-11-29 11:38 org babel: %% [removed source block] Uwe Brauer
2018-11-29 16:32 ` Berry, Charles
2018-11-29 17:27   ` [SOLVED] (was: org babel: %% [removed source block]) Uwe Brauer
2018-11-29 22:20     ` [SOLVED] Nick Dokos
2019-12-11 21:50 org-ref-insert-cite-link inserts citep Uwe Brauer
2019-12-11 21:58 ` [SOLVED] (was: org-ref-insert-cite-link inserts citep) Uwe Brauer
2019-12-11 22:20   ` John Kitchin
2019-12-12  8:13     ` [SOLVED] Uwe Brauer
2021-09-28 16:46 how to export checkboxes to odt? Uwe Brauer
2021-09-28 20:21 ` [SOLVED] (was: how to export checkboxes to odt?) Uwe Brauer
2021-09-29  4:07   ` Timothy
2021-09-29  6:30     ` [SOLVED] Uwe Brauer
2021-12-28 13:41 [BUG] org-persist [9.5 (release_9.5-194-gdb302d @ /home/oub/emacs/site-lisp/packages/org/)] Uwe Brauer
2021-12-28 13:53 ` [SOLVED] (was: [BUG] org-persist [9.5 (release_9.5-194-gdb302d @ /home/oub/emacs/site-lisp/packages/org/)]) Uwe Brauer
2021-12-28 14:49   ` Ihor Radchenko
2021-12-28 17:28     ` [SOLVED] Uwe Brauer
2021-12-29  5:11       ` [SOLVED] Ihor Radchenko
2021-12-29  8:06         ` [SOLVED] Uwe Brauer
2021-12-29  8:18           ` [SOLVED] Ihor Radchenko

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).