emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-mode not loading properly on startup
@ 2009-01-30  9:40 Paul Mead
  2009-01-30  9:54 ` Carsten Dominik
  0 siblings, 1 reply; 11+ messages in thread
From: Paul Mead @ 2009-01-30  9:40 UTC (permalink / raw)
  To: emacs-orgmode

Just a niggling issue here, I have a function set up to load my main org
file work.org.

(defun gtd()
  (interactive)
  (find-file "~/.gtd/work.org")
)

Straightforward enough, but since I downloaded v6.20 I then have to
manually switch using M-x org-mode. Otherwise the faces are all wrong,
hidden stars don't work, etc. Interestingly the mode line shows 'org'
before and after. Once I manually switch it on, everything is fine.

Paul

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30  9:40 org-mode not loading properly on startup Paul Mead
@ 2009-01-30  9:54 ` Carsten Dominik
  2009-01-30 10:05   ` Paul Mead
  2009-02-10  9:37   ` Paul Mead
  0 siblings, 2 replies; 11+ messages in thread
From: Carsten Dominik @ 2009-01-30  9:54 UTC (permalink / raw)
  To: Paul Mead; +Cc: emacs-orgmode


On Jan 30, 2009, at 10:40 AM, Paul Mead wrote:

> Just a niggling issue here, I have a function set up to load my main  
> org
> file work.org.
>
> (defun gtd()
>  (interactive)
>  (find-file "~/.gtd/work.org")
> )
>
> Straightforward enough, but since I downloaded v6.20 I then have to
> manually switch using M-x org-mode. Otherwise the faces are all wrong,
> hidden stars don't work, etc. Interestingly the mode line shows 'org'
> before and after. Once I manually switch it on, everything is fine.

There was a problem with faces, can you try to get 6.20g
and let me know if it works there?

Also, can you look at the messages buffer, to see if there
is anything strange in there???

- Carsten

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30  9:54 ` Carsten Dominik
@ 2009-01-30 10:05   ` Paul Mead
  2009-01-30 11:34     ` Carsten Dominik
  2009-02-10  9:37   ` Paul Mead
  1 sibling, 1 reply; 11+ messages in thread
From: Paul Mead @ 2009-01-30 10:05 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

> On Jan 30, 2009, at 10:40 AM, Paul Mead wrote:
>
>> Just a niggling issue here, I have a function set up to load my main  org
>> file work.org.
>>
>> (defun gtd()
>>  (interactive)
>>  (find-file "~/.gtd/work.org")
>> )
>>
>> Straightforward enough, but since I downloaded v6.20 I then have to
>> manually switch using M-x org-mode. Otherwise the faces are all wrong,
>> hidden stars don't work, etc. Interestingly the mode line shows 'org'
>> before and after. Once I manually switch it on, everything is fine.
>
> There was a problem with faces, can you try to get 6.20g
> and let me know if it works there?
>
> Also, can you look at the messages buffer, to see if there
> is anything strange in there???
>
> - Carsten
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

Hi Carsten,

I am already using 6.20g and the behaviour is the same. I can't see
anything funny in the *Messages* buffer, but here are the contents
immediately after running M-x gtd

("C:\\Program Files\\emacs-22.3\\bin\\emacs.exe")
Loading encoded-kb...done
Loading easy-mmode...done
Loading advice...done
Loading regexp-opt...done
Loading edmacro...done
Loading cl-macs...done
Loading cl-seq...done
Loading cl-extra...done
Loading g:/home/paul/elisp/ledger.el (source)...
Loading derived...done
Loading g:/home/paul/elisp/ledger.el (source)...done
Loading server...done
For information about GNU Emacs and the GNU system, type C-h C-a.
OVERVIEW

Paul

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: Re: org-mode not loading properly on startup
  2009-01-30 10:05   ` Paul Mead
@ 2009-01-30 11:34     ` Carsten Dominik
  2009-01-30 11:49       ` Paul Mead
  0 siblings, 1 reply; 11+ messages in thread
From: Carsten Dominik @ 2009-01-30 11:34 UTC (permalink / raw)
  To: Paul Mead; +Cc: emacs-orgmode

Do you have set up to make .org files automatically enter org-mode?

What happens if you use C-x C-f to open the file?

- Carsten

On Jan 30, 2009, at 11:05 AM, Paul Mead wrote:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>> On Jan 30, 2009, at 10:40 AM, Paul Mead wrote:
>>
>>> Just a niggling issue here, I have a function set up to load my  
>>> main  org
>>> file work.org.
>>>
>>> (defun gtd()
>>> (interactive)
>>> (find-file "~/.gtd/work.org")
>>> )
>>>
>>> Straightforward enough, but since I downloaded v6.20 I then have to
>>> manually switch using M-x org-mode. Otherwise the faces are all  
>>> wrong,
>>> hidden stars don't work, etc. Interestingly the mode line shows  
>>> 'org'
>>> before and after. Once I manually switch it on, everything is fine.
>>
>> There was a problem with faces, can you try to get 6.20g
>> and let me know if it works there?
>>
>> Also, can you look at the messages buffer, to see if there
>> is anything strange in there???
>>
>> - Carsten
>>
>>
>>
>> _______________________________________________
>> Emacs-orgmode mailing list
>> Remember: use `Reply All' to send replies to the list.
>> Emacs-orgmode@gnu.org
>> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
>
> Hi Carsten,
>
> I am already using 6.20g and the behaviour is the same. I can't see
> anything funny in the *Messages* buffer, but here are the contents
> immediately after running M-x gtd
>
> ("C:\\Program Files\\emacs-22.3\\bin\\emacs.exe")
> Loading encoded-kb...done
> Loading easy-mmode...done
> Loading advice...done
> Loading regexp-opt...done
> Loading edmacro...done
> Loading cl-macs...done
> Loading cl-seq...done
> Loading cl-extra...done
> Loading g:/home/paul/elisp/ledger.el (source)...
> Loading derived...done
> Loading g:/home/paul/elisp/ledger.el (source)...done
> Loading server...done
> For information about GNU Emacs and the GNU system, type C-h C-a.
> OVERVIEW
>
> Paul
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30 11:34     ` Carsten Dominik
@ 2009-01-30 11:49       ` Paul Mead
  2009-01-30 12:29         ` Carsten Dominik
  2009-01-30 18:27         ` Mark Elston
  0 siblings, 2 replies; 11+ messages in thread
From: Paul Mead @ 2009-01-30 11:49 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

> Do you have set up to make .org files automatically enter org-mode?
>
> What happens if you use C-x C-f to open the file?
>
> - Carsten
>

I have the following:

(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))

If I use C-x C-f the behaviour is the same for the first .org file which
I open. Any subsequent files that I open behave normally, whether or not
I manually start org-mode. 

I have also tried opening files in different order - work.org and
home.org. Which ever one I open first after starting emacs fails to show
the faces, hide stars, etc. There doesn't appear to be anything wrong
with the files themselves therefore.

Other org-mode functions such as TAB to hide/show contents work fine.

Paul

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: Re: org-mode not loading properly on startup
  2009-01-30 11:49       ` Paul Mead
@ 2009-01-30 12:29         ` Carsten Dominik
  2009-01-30 19:05           ` Paul Mead
  2009-01-30 18:27         ` Mark Elston
  1 sibling, 1 reply; 11+ messages in thread
From: Carsten Dominik @ 2009-01-30 12:29 UTC (permalink / raw)
  To: Paul Mead; +Cc: emacs-orgmode


On Jan 30, 2009, at 12:49 PM, Paul Mead wrote:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>> Do you have set up to make .org files automatically enter org-mode?
>>
>> What happens if you use C-x C-f to open the file?
>>
>> - Carsten
>>
>
> I have the following:
>
> (add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
>
> If I use C-x C-f the behaviour is the same for the first .org file  
> which
> I open. Any subsequent files that I open behave normally, whether or  
> not
> I manually start org-mode.
>
> I have also tried opening files in different order - work.org and
> home.org. Which ever one I open first after starting emacs fails to  
> show
> the faces, hide stars, etc. There doesn't appear to be anything wrong
> with the files themselves therefore.


I don't have enough to work on here.

Any other ideas anyone?  Maybe more windows people to test this?
Maybe Paul needs to share his full setup, or try to minimize it while  
keeping the error?

- Carsten

>
>
> Other org-mode functions such as TAB to hide/show contents work fine.
>
> Paul
>
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: Re: org-mode not loading properly on startup
  2009-01-30 11:49       ` Paul Mead
  2009-01-30 12:29         ` Carsten Dominik
@ 2009-01-30 18:27         ` Mark Elston
  2009-01-30 19:03           ` Paul Mead
  1 sibling, 1 reply; 11+ messages in thread
From: Mark Elston @ 2009-01-30 18:27 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: Paul Mead

Paul,

Try changing the org-mode line below to:

   (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))

See if that makes a difference.  I don't understand the use of \\'
in your line below.

Mark

* Paul Mead wrote (on 1/30/2009 3:49 AM):
> Carsten Dominik <dominik@science.uva.nl> writes:
> 
>> Do you have set up to make .org files automatically enter org-mode?
>>
>> What happens if you use C-x C-f to open the file?
>>
>> - Carsten
>>
> 
> I have the following:
> 
> (add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
> 
> If I use C-x C-f the behaviour is the same for the first .org file which
> I open. Any subsequent files that I open behave normally, whether or not
> I manually start org-mode. 
> 
> I have also tried opening files in different order - work.org and
> home.org. Which ever one I open first after starting emacs fails to show
> the faces, hide stars, etc. There doesn't appear to be anything wrong
> with the files themselves therefore.
> 
> Other org-mode functions such as TAB to hide/show contents work fine.
> 
> Paul
> 
> 
> 
> 
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
> 
> 
> 

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30 18:27         ` Mark Elston
@ 2009-01-30 19:03           ` Paul Mead
  0 siblings, 0 replies; 11+ messages in thread
From: Paul Mead @ 2009-01-30 19:03 UTC (permalink / raw)
  To: emacs-orgmode

Mark Elston <m.elston@advantest-ard.com> writes:

> Paul,
>
> Try changing the org-mode line below to:
>
>   (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
>
> See if that makes a difference.  I don't understand the use of \\'
> in your line below.
>
> Mark

Hi Mark, just tried that and it made no difference.

Paul

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30 12:29         ` Carsten Dominik
@ 2009-01-30 19:05           ` Paul Mead
  2009-01-30 19:16             ` Eric Schulte
  0 siblings, 1 reply; 11+ messages in thread
From: Paul Mead @ 2009-01-30 19:05 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <dominik@science.uva.nl> writes:

>
>
> I don't have enough to work on here.
>
> Any other ideas anyone?  Maybe more windows people to test this?
> Maybe Paul needs to share his full setup, or try to minimize it while  keeping
> the error?
>
> - Carsten

All my org-mode customizations are in one file:

;; pdm-org.el
;; setup and customization of org-mode
(require 'org-export-latex)


;; The following lines are always needed. Choose your own keys.
(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
(global-set-key "\C-cl" 'org-store-link)
(global-set-key "\C-ca" 'org-agenda)
(global-set-key "\C-cb" 'org-iswitchb)





; hooks
(add-hook 'org-mode-hook 'turn-on-font-lock)
(add-hook 'org-mode-hook 'turn-on-auto-fill) ; turn on auto-fill for files in org-mode
;(add-hook 'org-mode-hook 'longlines-mode) ; turn on longlines mode for files in org-mode
(add-hook 'org-mode-hook (lambda ()
                           (local-set-key "\M-n" 'outline-forward-same-level)
                           (local-set-key "\M-p" 'outline-backward-same-level)
))

;(setq org-refile-targets '((org-agenda-files . (:maxlevel . 2))))
(setq org-refile-targets '((org-agenda-files :maxlevel . 3)))
(setq org-hide-leading-stars t)
(setq org-odd-levels-only t) ; must use 2 stars to separate heading levels

;; Tag settings
(setq org-tag-alist '(("ANYWHERE" . ?a) ("COMPUTER" . ?c) (" HOME" . ?h) ("OFFICE" . ?o) ("PHONE" . ?t) ("ERRANDS" . ?e) ("ONLINE" . ?w))) ;; setup default 'context' tags
(setq org-tags-exclude-from-inheritance '("project"))
(setq org-tags-column 100)
(setq org-enforce-todo-dependencies t)

;; TODO settings
(setq org-log-done t) ;; turn on logging of times when TODO is marked DONE
(setq org-todo-keywords
      '((sequence "TODO(t@/!)" "PENDING(p/!)" "STARTED(s!)" "WAITING(w@/!)" "CHASE(c@!)" "|" "DONE(d@/!)" "CANCELLED(x@/!)")))
(setq org-use-fast-todo-selection t)

;; Agenda settings
(setq org-agenda-include-diary t)
(setq org-agenda-ndays 7)
(setq org-agenda-start-on-weekday nil)
(setq org-agenda-align-tags-to-column 100)
(setq org-agenda-todo-ignore-scheduled t)
(setq org-agenda-todo-ignore-deadlines t)
(setq org-enforce-todo-dependencies t)
(setq org-agenda-dim-blocked-tasks t)
(setq org-agenda-skip-deadline-if-done t)
(setq org-agenda-skip-scheduled-if-done t)
(setq org-agenda-skip-timestamp-if-done t)

(setq org-agenda-custom-commands
      '(("g" . "GTD contexts")
        ("go" "Office" tags-todo "office")
        ("gc" "Computer" tags-todo "computer")
        ("gp" "Phone" tags-todo "phone")
        ("gh" "Home" tags-todo "home")
        ("ge" "Errands" tags-todo "errands")
        ("G" "GTD Block Agenda"
         ((tags-todo "office")
          (tags-todo "computer")
          (tags-todo "phone")
          (tags-todo "online")
          (tags-todo "home")
          (tags-todo "errands")))
        ("O" "In the office"
         ((tags-todo "office")
          (tags-todo "computer")
          (tags-todo "phone")
          (tags-todo "anywhere")
          (tags-todo "online")))
        ("H" "Working from home"
         ((tags-todo "anywhere")
          (tags-todo "computer")
          (tags-todo "phone")
          (tags-todo "home")
          (tags-todo "online")))
        ))


;; function to open work.org
(defun gtd()
  (interactive)
  (find-file "~/.gtd/work.org")
)




(provide 'pdm-org)

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: Re: org-mode not loading properly on startup
  2009-01-30 19:05           ` Paul Mead
@ 2009-01-30 19:16             ` Eric Schulte
  0 siblings, 0 replies; 11+ messages in thread
From: Eric Schulte @ 2009-01-30 19:16 UTC (permalink / raw)
  To: Paul Mead; +Cc: emacs-orgmode

Paul Mead <paul.d.mead@gmail.com> writes:

> Carsten Dominik <dominik@science.uva.nl> writes:
>
>>
>>
>> I don't have enough to work on here.
>>
>> Any other ideas anyone?  Maybe more windows people to test this?
>> Maybe Paul needs to share his full setup, or try to minimize it while  keeping
>> the error?

Two quick ideas,

1. Try starting Emacs with the -Q option.  That disables any of your
   personal initialization/customizations.  If it is working with -Q
   then you know the problem lies somewhere in your own personal setup,
   and you can start adding things back in one at a time.

2. When you open a file you can try (\C-hv major-mode) which will tell
   you if org-mode is actually turned on.

Best of Luck -- Eric

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: org-mode not loading properly on startup
  2009-01-30  9:54 ` Carsten Dominik
  2009-01-30 10:05   ` Paul Mead
@ 2009-02-10  9:37   ` Paul Mead
  1 sibling, 0 replies; 11+ messages in thread
From: Paul Mead @ 2009-02-10  9:37 UTC (permalink / raw)
  To: emacs-orgmode


> On Jan 30, 2009, at 10:40 AM, Paul Mead wrote:
> 
> > Just a niggling issue here, I have a function set up to load my main  
> > org
> > file work.org.
> >
> > (defun gtd()
> >  (interactive)
> >  (find-file "~/.gtd/work.org")
> > )
> >
> > Straightforward enough, but since I downloaded v6.20 I then have to
> > manually switch using M-x org-mode. Otherwise the faces are all wrong,
> > hidden stars don't work, etc. Interestingly the mode line shows 'org'
> > before and after. Once I manually switch it on, everything is fine.
> 


Just to let you know, for unrelated reasons I deleted and re-cloned the
repository and recompiled from scratch, and this problem disappeared.

Just one of those things I guess...
Paul

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2009-02-10  9:37 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-30  9:40 org-mode not loading properly on startup Paul Mead
2009-01-30  9:54 ` Carsten Dominik
2009-01-30 10:05   ` Paul Mead
2009-01-30 11:34     ` Carsten Dominik
2009-01-30 11:49       ` Paul Mead
2009-01-30 12:29         ` Carsten Dominik
2009-01-30 19:05           ` Paul Mead
2009-01-30 19:16             ` Eric Schulte
2009-01-30 18:27         ` Mark Elston
2009-01-30 19:03           ` Paul Mead
2009-02-10  9:37   ` Paul Mead

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).