emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Re: org-plot : interaction problem with gnuplot
@ 2009-06-29 22:05 d.tchin
  2009-06-30  1:14 ` Eric Schulte
  0 siblings, 1 reply; 5+ messages in thread
From: d.tchin @ 2009-06-29 22:05 UTC (permalink / raw)
  To: Eric Schulte; +Cc: emacs-orgmode

Hi 

Thank you for your help.

1°) I try to use comint buffer and to launch few commands. I don't
    really understand the way comint works but it seems that each 
    time that I use a command, there is a freeze, and to access 
    back to the emacs  buffer I have to use \C-g several times. 

2°) I put the instruction you suggested. I try to use org-plot/gnuplot 
    and I have the following output on message buffer:

OVERVIEW
org-plot/gnuplot
CHILDREN
Loading d:/perso/home/emacs/emacs-22.2/lisp/org/lisp/org-plot.el (source)...done
script is reset
set title 'Citas'
set yrange [0:]
progn: Wrong number of arguments: (lambda (line) (block add-to-script (setf script (format "%s
%s" script line)))), 2
Mark set


Thanks


> Message du 26/06/09 à 03h37
> De : "Eric Schulte" 
> A : d.tchin@voila.fr
> Copie à : emacs-orgmode@gnu.org
> Objet : Re: [Orgmode] org-plot : interaction problem with gnuplot
> 
> 
> d.tchin@voila.fr writes:
> 
> > Hi,
> >
> > I would like to use gnuplot with org-mode tabular function.But I
> > haven't managed to use it until now. 
> > I would like to submit to you few remarks I have done.
> >
> > I use GNU Emacs 22.2.1 (i386-mingw-nt5.1.2600) on Microsoft Windows XP OS.
> > I have installed gnuplot and I can use it with gnuplot-mode. 
> >
> > I tried to follow the tutorial of Eric Schulte but I didn't manage to get a plot of
> > simple example extracted from the tutorial.
> >
> > I use these data defined in a file orgplot.org :
> > #+PLOT: title:"Citas" ind:1 deps:(3) type:2d with:histograms set:"yrange [0:]"
> > | Sede | Max cites | H-index |
> > |------------+-----------+---------|
> > | Chile | 257.72 | 21.39 |
> > | Leeds | 165.77 | 19.68 |
> > | São Paolo | 71.00 | 11.50 |
> > | Stockholm | 134.19 | 14.33 |
> > | Morelia | 257.56 | 17.67 |
> >
> >
> > When I use org-plot/gnuplot, gnuplot is launched with only the reset command
> > and emacs is totally freezed. To get back to emacs, I use \C-g command. 
> >
> 
> Hmm, it is not clear to me what is happening here. It is possible that
> the problem is somehow related to running on a windows machine, as I
> have only personally tested org-plot on linux and Mac OS's.
> 
> The only two things I can think of at the moment are
> 1. the reset command is freezing on your machine, you could test this
> out by starting up a gnuplot comint buffer and entering the "reset"
> command 
> 2. for some reason the script is not being set to the correct value, you
> could test this by adding the following line
> 
> (message "script is %s" script)
> 
> right after line 263 in lisp/org-plot.el, then reloading that
> function (with C-M-x) and running org-plot-gnuplot again, checking
> the message buffer to see the contents of the script variable.
> 
> Sorry I can't be of more help. If I find time I may re-write org-plot
> to use org-babel (see any of my other recent emails for more information
> on org-babel) which could eliminate this problem.
> 
> Please do let me know the results of looking into the above suggestions,
> or if you have any ideas breakthroughs.
> 
> Thanks -- Eric
> 
> >
> > I have checked few things :
> >
> > - org-plot/gnuplot managed to build a temporay file org-plot???? with the following 
> > data
> >
> > "Chile" 257.72 21.39
> > "Leeds" 165.77 19.68
> > "São Paolo" 71.00 11.50
> > "Stockholm" 134.19 14.33
> > "Morelia" 257.56 17.67
> >
> 
> That looks right
> 
> > >
> > - I suppose that org-plot/gnuplot builds a temporary buffer with the instructions 
> > that will be sent to gnuplot. I checked that *gnuplot* buffer with 
> > gnuplot-show-gnuplot-buffer. There is only the reset command.
> >
> 
> That makes sense, it is still possible that the entire command is being
> constructed, but that Emacs is freezing before anything after the
> "reset" line are evaluated and dropped into the *gnuplot* buffer. The
> above `message' statement should resolve whether this is the case.
> 
> >
> > Do you have any idea to solve this problem ?
> >
> > Regards
> >
> > Tchin
> >
> >
> >
> >
> >
> > ____________________________________________________
> >
> > Découvrez Cocoon et Catpower dans notre sélection musicale folk sur Voila http://musiline.voila.fr
> >
> >
> >
> >
> > _______________________________________________
> > Emacs-orgmode mailing list
> > Remember: use `Reply All' to send replies to the list.
> > Emacs-orgmode@gnu.org
> > http://lists.gnu.org/mailman/listinfo/emacs-orgmode
> 
> 

____________________________________________________

Retrouvez les meilleurs titres de Michael Jackson sur http://musiline.voila.fr/player/createtag/935918

^ permalink raw reply	[flat|nested] 5+ messages in thread
* Re: org-plot : interaction problem with gnuplot
@ 2009-06-26  7:43 Giovanni Ridolfi
  0 siblings, 0 replies; 5+ messages in thread
From: Giovanni Ridolfi @ 2009-06-26  7:43 UTC (permalink / raw)
  To: d.tchin, Eric Schulte; +Cc: emacs-orgmode


--- Ven 26/6/09, Eric Schulte <schulte.eric@gmail.com> ha scritto:
> d.tchin@voila.fr writes:
> 
> > Hi,
> >
> > I would like to use gnuplot with org-mode tabular
> > function.But I haven't managed to use it until now. 
> > I use GNU Emacs 22.2.1 (i386-mingw-nt5.1.2600) on
> > Microsoft Windows XP OS.
[...]
> > When I use org-plot/gnuplot, gnuplot is launched with
> > only the reset command
> > and emacs is totally freezed. To get back to emacs, I
> > use \C-g command. 

When I tried Emacs 22.2 it frozen.

Now I use Emacs 23.0.94
   you can download 23.0.95 from 
   http://alpha.gnu.org/gnu/emacs/pretest/windows/
   ;-)

and Emacs 23.0.  doesn't freeze anymore. But I still 
have no output from gnuplot. 
To be sincere I gave it up.

cheers,

Giovanni


 

^ permalink raw reply	[flat|nested] 5+ messages in thread
* org-plot : interaction problem with gnuplot
@ 2009-06-17  9:55 d.tchin
  2009-06-26  1:30 ` Eric Schulte
  0 siblings, 1 reply; 5+ messages in thread
From: d.tchin @ 2009-06-17  9:55 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

I would like to use gnuplot with org-mode tabular function.But I
haven't managed to use it until now. 
I would like to submit to you few remarks I have done.

I use GNU Emacs 22.2.1 (i386-mingw-nt5.1.2600) on Microsoft Windows XP OS.
I have installed gnuplot and I can use it with gnuplot-mode. 

I tried to follow the tutorial of Eric Schulte but I didn't manage to get a plot of
simple example extracted from the tutorial.

I use these data defined in a file orgplot.org :
#+PLOT: title:"Citas" ind:1 deps:(3) type:2d with:histograms set:"yrange [0:]"
| Sede       | Max cites | H-index |
|------------+-----------+---------|
| Chile      |    257.72 |   21.39 |
| Leeds      |    165.77 |   19.68 |
| São Paolo |     71.00 |   11.50 |
| Stockholm  |    134.19 |   14.33 |
| Morelia    |    257.56 |   17.67 |


When I use org-plot/gnuplot, gnuplot is launched with only the reset command
and emacs is totally freezed. To get back to emacs, I use \C-g command. 

I have checked few things :

- org-plot/gnuplot managed to build a temporay file org-plot???? with the following 
  data

"Chile"	257.72	21.39
"Leeds"	165.77	19.68
"São Paolo"	71.00	11.50
"Stockholm"	134.19	14.33
"Morelia"	257.56	17.67


- I suppose that org-plot/gnuplot builds a temporary buffer with the instructions 
  that will be sent to gnuplot. I checked that *gnuplot* buffer with 
  gnuplot-show-gnuplot-buffer. There is only the reset command.

Do you have any idea to solve this problem ?

Regards

Tchin





____________________________________________________

Découvrez Cocoon et Catpower dans notre sélection musicale folk sur Voila http://musiline.voila.fr

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2009-06-30  1:14 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-06-29 22:05 org-plot : interaction problem with gnuplot d.tchin
2009-06-30  1:14 ` Eric Schulte
  -- strict thread matches above, loose matches on Subject: below --
2009-06-26  7:43 Giovanni Ridolfi
2009-06-17  9:55 d.tchin
2009-06-26  1:30 ` Eric Schulte

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).