emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: DOI links are broken in HTML exports
@ 2020-09-21 17:34 yarnton--- via General discussions about Org-mode.
  2020-09-23  7:14 ` Bastien
  0 siblings, 1 reply; 4+ messages in thread
From: yarnton--- via General discussions about Org-mode. @ 2020-09-21 17:34 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 599 bytes --]

Hi,

I've found a small bug in org-html-export-to-html. Minimal document to reproduce:

---

Foo [fn:1]

* Footnotes

[fn:1] doi:10.1186/s12864-016-2377-z

---

When I export this document to HTML the DOI link gets converted into a broken hyperlink. It should be converted into https://doi.org/10.1186/s12864-016-2377-z as explained in https://www.doi.org/. <https://www.doi.org/>

Following the link from the org file with C-c C-o works fine, though.

It'd be great if this could get fixed, as DOI links are incredibly helpful when dealing with bibliographic items.

Thanks


[-- Attachment #2: Type: text/html, Size: 1057 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Bug: DOI links are broken in HTML exports
  2020-09-21 17:34 Bug: DOI links are broken in HTML exports yarnton--- via General discussions about Org-mode.
@ 2020-09-23  7:14 ` Bastien
  2020-09-23 16:39   ` yarnton--- via General discussions about Org-mode.
  0 siblings, 1 reply; 4+ messages in thread
From: Bastien @ 2020-09-23  7:14 UTC (permalink / raw)
  To: yarnton--- via General discussions about Org-mode.; +Cc: yarnton

Hi,

yarnton--- via "General discussions about Org-mode."
<emacs-orgmode@gnu.org> writes:

> I've found a small bug in org-html-export-to-html. Minimal document to reproduce:
>
> ---
>
> Foo [fn:1]
>
> * Footnotes
>
> [fn:1] doi:10.1186/s12864-016-2377-z
>
> ---

Do you use a link abbreviation for doi: links ?

> When I export this document to HTML the DOI link gets converted into a
> broken hyperlink. It should be converted into
> https://doi.org/10.1186/s12864-016-2377-z as explained
> in https://www.doi.org/. <https://www.doi.org/>

If you use a link abbreviation.

> Following the link from the org file with C-c C-o works fine, though.
>
> It'd be great if this could get fixed, as DOI links are incredibly
> helpful when dealing with bibliographic items.

What version of Emacs and Org are you using?

-- 
 Bastien


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Bug: DOI links are broken in HTML exports
  2020-09-23  7:14 ` Bastien
@ 2020-09-23 16:39   ` yarnton--- via General discussions about Org-mode.
  2021-04-18 12:06     ` Nicolas Goaziou
  0 siblings, 1 reply; 4+ messages in thread
From: yarnton--- via General discussions about Org-mode. @ 2020-09-23 16:39 UTC (permalink / raw)
  To: Bastien; +Cc: yarnton--- viaGeneral discussions about Org-mode.

[-- Attachment #1: Type: text/plain, Size: 887 bytes --]

Thanks Bastien.


> Do you use a link abbreviation for doi: links ?
>
>> When I export this document to HTML the DOI link gets converted into a
>> broken hyperlink. It should be converted into
>> https://doi.org/10.1186/s12864-016-2377-z as explained
>> in https://www.doi.org/. <https://www.doi.org/>
>>
>
> If you use a link abbreviation.
>
>> Following the link from the org file with C-c C-o works fine, though.
>>
>> It'd be great if this could get fixed, as DOI links are incredibly
>> helpful when dealing with bibliographic items.
>>
>
> What version of Emacs and Org are you using?
>

I'm not using a link abbreviation for doi: links.

I can reproduce this bug running a stock Emacs (27.1) and stock Org (9.4-elpa) i.e., no init file.

I encountered this bug for the first time a few months ago, when I first used doi: links.

I hope this helps.


[-- Attachment #2: Type: text/html, Size: 1467 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Bug: DOI links are broken in HTML exports
  2020-09-23 16:39   ` yarnton--- via General discussions about Org-mode.
@ 2021-04-18 12:06     ` Nicolas Goaziou
  0 siblings, 0 replies; 4+ messages in thread
From: Nicolas Goaziou @ 2021-04-18 12:06 UTC (permalink / raw)
  To: yarnton--- via General discussions about Org-mode.; +Cc: Bastien, yarnton

Hello,

yarnton--- via "General discussions about Org-mode."
<emacs-orgmode@gnu.org> writes:

> I encountered this bug for the first time a few months ago, when
> I first used doi: links.

AFAICT Org never implemented export for DOI links. It just provides
a way to follow them, as you observed already.

I added a rough export for doi links in master. I hope this fixes your
issue.

Regards,
-- 
Nicolas Goaziou


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-04-18 12:07 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-21 17:34 Bug: DOI links are broken in HTML exports yarnton--- via General discussions about Org-mode.
2020-09-23  7:14 ` Bastien
2020-09-23 16:39   ` yarnton--- via General discussions about Org-mode.
2021-04-18 12:06     ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).