emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Re: Org-Mode in Windows
       [not found] <497BD2E2.3080306@gmail.com>
@ 2009-01-25  6:45 ` Carsten Dominik
  2009-01-25 10:56   ` David Lord
  2009-01-25 11:49   ` Manish
  0 siblings, 2 replies; 8+ messages in thread
From: Carsten Dominik @ 2009-01-25  6:45 UTC (permalink / raw)
  To: Manager Leader; +Cc: Org Mode List

Hi,

please send your message to emacs-orgmode@gnu.org (I am
CC-ing the mailing list).
There you will find people who work on Windows, I do not.

- Carsten

On Jan 25, 2009, at 3:48 AM, Manager Leader wrote:

> Dear Mr. Dominik,
>
> Thank you for your work in Org-Mode, I started researching about it  
> a month ago and I have started using it 10 days ago (used to work in  
> outlook but it just can't cope with my life now). And so far am  
> happy with it except for some things that's not working as expected.
>
> I am using Windows XP and have downloaded the latest release version  
> for emacs (22.3.1) and org-mode (6.18c). But when I type M-x org- 
> version 5.23a.
> * Org-Mode does not start by itself when emacs is started - I always  
> have to type "ALT-X org-mode" (in your book convention: M-x) or put  
> on each file "MY PROJECTS    -*- mode: org; -*-"
> * Agenda view does not come out with the shortcut C-c a - I always  
> have to use the mouse and org->agenda command -> t
> * I want my default org file to open when I start emacs or org-mode  
> but don't know how to do this. I always have to browse to the  
> correct directory and open the file.
> * Other things but I think should be resolved if those above can work.
>
> I consider myself competent with computers and normally can easily  
> make things work with reading documentation and searching through  
> newsgroups, web. But this is taking a bit too long.
>
> Some info and Things I have done to try to resolve it:
> * I placed emacs in directory c:/emacs, downloaded 6.18c orgmode  
> file to c:/emacs/org
> * I am logged in with admin rights on Windows
> * I have added the path to emacs in environment variables. C:/emacs/ 
> bin
> * I have watched your video at google 3 times, gone through the  
> manual particularly installation and activation parts, searched the  
> newsgroups and google searched whatever I can...
> * I can't find any file named emacs or *.emacs so I created ".emacs"  
> file and placed it in c:/emacs - I attach my emacs file.
> * Make command from the installation manual does not work (even  
> inside emacs Tools-> Make) - I attach my makefile which I have  
> edited based on the installation manual.
>
> But, I still can't get things to work properly.  I hope that you can  
> help.
>
> Thank you for a great software!
>
> Regards,
>
>
> Bailey
>
> # Makefile - for the org-mode distribution
> #
> # Maintainer: Carsten Dominik <dominik@science.uva.nl>
> # Version: VERSIONTAG
> #
> # To install org-mode, edit the Makefile, type `make', then `make  
> install'.
> # To create the PDF and HTML documentation files, type `make doc'.
>
> ##----------------------------------------------------------------------
> ##  YOU MUST EDIT THE FOLLOWING LINES
> ##----------------------------------------------------------------------
>
> # Name of your emacs binary
> EMACS=emacs
>
> # Where local software is found
> prefix=C:/emacs
>
> # Where local lisp files go.
> lispdir = $(prefix)/site-lisp
>
> # Where info files go.
> infodir = $(prefix)/info
>
> ##----------------------------------------------------------------------
> ## YOU MAY NEED TO EDIT THESE
> ##----------------------------------------------------------------------
>
> # Using emacs in batch mode.
> # BATCH=$(EMACS) -batch -q
> # BATCH=$(EMACS) -batch -q -eval "(add-to-list (quote load-path) \". 
> \")"
>
> BATCH=$(EMACS) -batch -q -eval                             \
> "(progn (add-to-list (quote load-path) (expand-file-name \"./lisp/ 
> \")) \
>        (add-to-list (quote load-path) \"$(lispdir)\"))"
>
> # Specify the byte-compiler for compiling org-mode files
> ELC= $(BATCH) -f batch-byte-compile
>
> # How to make a pdf file from a texinfo file
> TEXI2PDF = texi2pdf
>
> # How to create directories
> MKDIR = mkdir -p
>
> # How to create the info files from the texinfo file
> MAKEINFO = makeinfo
>
> # How to create the HTML file
> TEXI2HTML = makeinfo --html --number-sections
>
> # How to copy the lisp files and elc files to their distination.
> CP = cp -p
>
> # Name of the program to install info files
> INSTALL_INFO=install-info
>
> ##----------------------------------------------------------------------
> ##  BELOW THIS LINE ON YOUR OWN RISK!
> ##----------------------------------------------------------------------
>
> # The following variables need to be defined by the maintainer
> LISPF      = 	org.el			\
> 		org-agenda.el		\
> 	     	org-attach.el		\
> 	     	org-archive.el		\
> 		org-bbdb.el		\
> 		org-bibtex.el		\
> 	     	org-clock.el		\
> 	     	org-colview.el		\
> 	     	org-colview-xemacs.el	\
> 	     	org-compat.el		\
> 		org-exp.el		\
> 		org-export-latex.el	\
> 		org-faces.el		\
> 		org-footnote.el		\
> 		org-gnus.el		\
> 		org-id.el		\
> 		org-info.el		\
> 		org-jsinfo.el		\
> 		org-irc.el		\
> 		org-list.el		\
> 		org-mac-message.el	\
> 	     	org-macs.el		\
> 		org-mew.el              \
> 		org-mhe.el		\
> 		org-mouse.el		\
> 		org-publish.el		\
> 		org-plot.el		\
> 		org-remember.el		\
> 		org-rmail.el		\
> 		org-table.el		\
> 		org-timer.el		\
> 		org-vm.el		\
> 		org-w3m.el              \
> 		org-wl.el
>
> LISPFILES0 = $(LISPF:%=lisp/%)
> LISPFILES  = $(LISPFILES0) lisp/org-install.el
> ELCFILES0  = $(LISPFILES0:.el=.elc)
> ELCFILES   = $(LISPFILES:.el=.elc)
> DOCFILES   = doc/org.texi doc/org.pdf doc/org doc/dir doc/.nosearch
> CARDFILES  = doc/orgcard.tex doc/orgcard.pdf doc/orgcard_letter.pdf
> TEXIFILES  = doc/org.texi
> INFOFILES  = doc/org
>
>
> .SUFFIXES: .el .elc .texi
> SHELL = /bin/sh
>
> # Additional distribution files
> DISTFILES_extra=  Makefile ChangeLog request-assign-future.txt contrib
> DISTFILES_xemacs=  xemacs/noutline.el xemacs/ps-print-invisible.el  
> xemacs/README
>
> default: $(ELCFILES)
>
> all:	$(ELCFILES) $(INFOFILES)
>
> compile: $(ELCFILES0)
>
> install: install-lisp
>
> doc: doc/org.html doc/org.pdf doc/orgcard.pdf doc/orgcard_letter.pdf
>
> p:
> 	make pdf && open doc/org.pdf
>
> c:
> 	make card && gv doc/orgcard.ps
>
> install-lisp: $(LISPFILES) $(ELCFILES)
> 	if [ ! -d $(lispdir) ]; then $(MKDIR) $(lispdir); else true; fi ;
> 	$(CP) $(LISPFILES) $(lispdir)
> 	$(CP) $(ELCFILES)  $(lispdir)
>
> install-info: $(INFOFILES)
> 	if [ ! -d $(infodir) ]; then $(MKDIR) $(infodir); else true; fi ;
> 	$(CP) $(INFOFILES) $(infodir)
> 	$(INSTALL_INFO) --info-file=$(INFOFILES) --info-dir=$(infodir)
>
> install-noutline: xemacs/noutline.elc
> 	if [ ! -d $(lispdir) ]; then $(MKDIR) $(lispdir); else true; fi ;
> 	$(CP) xemacs/noutline.el xemacs/noutline.elc $(lispdir)
>
> autoloads: lisp/org-install.el
>
> lisp/org-install.el: $(LISPFILES0) Makefile
> 	$(BATCH) --eval "(require 'autoload)" \
> 		--eval '(find-file "org-install.el")'  \
> 		--eval '(erase-buffer)' \
> 		--eval '(mapc (lambda (x) (generate-file-autoloads (symbol-name  
> x))) (quote ($(LISPFILES0))))' \
> 		--eval '(insert "\n(provide (quote org-install))\n")' \
> 		--eval '(save-buffer)'
> 	mv org-install.el lisp
>
> xemacs/noutline.elc: xemacs/noutline.el
>
> doc/org: doc/org.texi
> 	(cd doc; $(MAKEINFO) --no-split org.texi -o org)
>
> doc/org.pdf: doc/org.texi
> 	(cd doc; $(TEXI2PDF) org.texi)
>
> doc/org.html: doc/org.texi
> 	(cd doc; $(TEXI2HTML) --no-split -o org.html org.texi)
> 	UTILITIES/manfull.pl doc/org.html
>
> doc/orgcard.dvi: doc/orgcard.tex
> 	(cd doc; tex orgcard.tex)
>
> doc/orgcard.pdf: doc/orgcard.dvi
> 	dvips -q -f -t landscape doc/orgcard.dvi | gs -q -dNOPAUSE -dBATCH - 
> sDEVICE=pdfwrite -sOutputFile=doc/orgcard.pdf -c .setpdfwrite -
>
> doc/orgcard.ps: doc/orgcard.dvi
> 	dvips -t landscape -o doc/orgcard.ps doc/orgcard.dvi
>
> doc/orgcard_letter.dvi: doc/orgcard.tex
> 	perl -pe 's/letterpaper=0/letterpaper=1/' doc/orgcard.tex > doc/ 
> orgcard_letter.tex
> 	(cd doc; tex orgcard_letter.tex)
>
> doc/orgcard_letter.pdf: doc/orgcard_letter.dvi
> 	dvips -q -f -t landscape doc/orgcard_letter.dvi | gs -q -dNOPAUSE - 
> dBATCH -sDEVICE=pdfwrite -sOutputFile=doc/orgcard_letter.pdf - 
> c .setpdfwrite -
>
> doc/orgcard_letter.ps: doc/orgcard_letter.dvi
> 	dvips -t landscape -o doc/orgcard_letter.ps doc/orgcard_letter.dvi
>
> # Below here are special targets for maintenance only
>
> updateweb:
> 	ssh cdominik@caprisun.dreamhost.com 'pull-worg-org.sh && publish- 
> worg-org.sh'
>
> html: doc/org.html
>
> html_manual: doc/org.texi
> 	rm -rf doc/manual
> 	mkdir doc/manual
> 	$(TEXI2HTML) -o doc/manual doc/org.texi
> 	UTILITIES/mansplit.pl doc/manual/*.html
>
> info:	doc/org
>
> pdf:	doc/org.pdf
>
> card:	doc/orgcard.pdf doc/orgcard.ps doc/orgcard_letter.pdf doc/ 
> orgcard_letter.ps
>
> distfile:
> 	@if [ "X$(TAG)" = "X" ]; then echo "*** No tag ***"; exit 1; fi
> 	touch doc/org.texi doc/orgcard.tex # force update
> 	make cleancontrib
> 	make info
> 	make doc
> 	make lisp/org-install.el
> 	rm -rf org-$(TAG) org-$(TAG).zip
> 	$(MKDIR) org-$(TAG)
> 	$(MKDIR) org-$(TAG)/xemacs
> 	$(MKDIR) org-$(TAG)/doc
> 	$(MKDIR) org-$(TAG)/lisp
> 	cp -r $(LISPFILES) org-$(TAG)/lisp
> 	cp -r $(DOCFILES) $(CARDFILES) org-$(TAG)/doc
> 	cp -r $(DISTFILES_extra) org-$(TAG)/
> 	cp -r README_DIST org-$(TAG)/README
> 	cp -r ORGWEBPAGE/Changes.org org-$(TAG)/
> 	cp -r $(DISTFILES_xemacs) org-$(TAG)/xemacs/
> 	zip -r org-$(TAG).zip org-$(TAG)
> 	gtar zcvf org-$(TAG).tar.gz org-$(TAG)
>
> release:
> 	@if [ "X$(TAG)" = "X" ]; then echo "*** No tag ***"; exit 1; fi
> 	make distfile
> 	make doc
> 	UTILITIES/gplmanual.pl
> 	make html_manual
> 	rm -rf RELEASEDIR
> 	$(MKDIR) RELEASEDIR
> 	cp org-$(TAG).zip org-$(TAG).tar.gz RELEASEDIR
> 	cp doc/org.pdf doc/orgcard.pdf doc/org.texi doc/org.html RELEASEDIR
> 	cp RELEASEDIR/org-$(TAG).zip    RELEASEDIR/org.zip
> 	cp RELEASEDIR/org-$(TAG).tar.gz RELEASEDIR/org.tar.gz
>
> upload_release:
> 	(cd RELEASEDIR; lftp -f ../../org-mode-proprietary/ 
> ftp_upload_release_legito)
>
> upload_manual:
> 	lftp -f ../org-mode-proprietary/ftp_upload_manual_legito
>
> relup0:
> 	make release
> 	make upload_release
>
> relup:
> 	make release
> 	make upload_release
> 	make upload_manual
>
> db:
> 	grep -e '(debug)' lisp/*el
>
> cleancontrib:
> 	find contrib -name \*~ -exec rm {} \;
>
> cleanelc:
> 	rm -f $(ELCFILES)
> cleandoc:
> 	(cd doc; rm -f org.pdf org org.html orgcard.pdf orgcard.ps)
> 	(cd doc; rm -f *.aux *.cp *.cps *.dvi *.fn *.fns *.ky *.kys *.pg  
> *.pgs)
> 	(cd doc; rm -f *.toc *.tp *.tps *.vr *.vrs *.log *.html *.ps)
> 	(cd doc; rm -f orgcard_letter.tex orgcard_letter.pdf)
> 	(cd doc; rm -rf manual)
>
> cleanrel:
> 	rm -rf RELEASEDIR
> 	rm -rf org-6.*
> 	rm -f org-6*zip org-6*tar.gz
>
> clean:
> 	make cleanelc
> 	make cleandoc
> 	make cleanrel
> 	rm -f *~ */*~ */*/*~
>
> cleanall:
> 	make clean
> 	rm -f lisp/org-install.el
>
> .el.elc:
> 	$(ELC) $<
>
>
> push:
> 	git-push git+ssh://repo.or.cz/srv/git/org-mode.git master
>
> pushtag:
> 	git-tag -m "Adding tag" -a $(TAG)
> 	git-push git+ssh://repo.or.cz/srv/git/org-mode.git $(TAG)
>
> pushreleasetag:
> 	git-tag -m "Adding release tag" -a release_$(TAG)
> 	git-push git+ssh://repo.or.cz/srv/git/org-mode.git release_$(TAG)
>
> dummy:
> 	echo ${prefix}
>
> # Dependencies
>
> lisp/org.elc:           lisp/org-macs.elc lisp/org-compat.elc lisp/ 
> org-faces.elc
> lisp/org-agenda.elc:       lisp/org.elc
> lisp/org-attach.elc:       lisp/org.elc lisp/org-id.elc
> lisp/org-archive.elc:      lisp/org.elc
> lisp/org-bbdb.elc:         lisp/org.elc
> lisp/org-bibtex.elc:       lisp/org.elc
> lisp/org-clock.elc:        lisp/org.elc
> lisp/org-colview.elc:      lisp/org.elc
> lisp/org-colview-xemacs.elc:      lisp/org.elc
> lisp/org-compat.elc:       lisp/org-macs.elc
> lisp/org-exp.elc:          lisp/org.elc lisp/org-agenda.elc
> lisp/org-export-latex.elc: lisp/org.elc lisp/org-exp.elc
> lisp/org-faces.elc:        lisp/org-macs.elc lisp/org-compat.elc
> lisp/org-footnotes.elc:    lisp/org-macs.elc lisp/org-compat.elc
> lisp/org-gnus.elc:         lisp/org.elc
> lisp/org-id.elc:           lisp/org.elc
> lisp/org-info.elc:         lisp/org.elc
> lisp/org-irc.elc:          lisp/org.elc
> lisp/org-jsinfo.elc:       lisp/org.elc lisp/org-exp.elc
> lisp/org-list.elc:         lisp/org-macs.elc lisp/org-compat.elc
> lisp/org-mac-message.elc:  lisp/org.elc
> lisp/org-macs.elc:
> lisp/org-mew.elc:          lisp/org.elc
> lisp/org-mhe.elc:          lisp/org.elc
> lisp/org-mouse.elc:        lisp/org.elc
> lisp/org-plot.elc:         lisp/org.elc lisp/org-exp.elc lisp/org- 
> table.elc
> lisp/org-publish.elc:
> lisp/org-remember.elc:     lisp/org.elc
> lisp/org-rmail.elc:        lisp/org.elc
> lisp/org-table.elc:        lisp/org.elc
> lisp/org-timer.el:         lisp/org.elc
> lisp/org-vm.elc:           lisp/org.elc
> lisp/org-w3m.elc:          lisp/org.elc
> lisp/org-wl.elc:           lisp/org.elc
> ;; The following lines are always needed.  Choose your own keys.
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> (global-set-key "\C-cl" 'org-store-link)
> (global-set-key "\C-ca" 'org-agenda)
> (global-set-key "\C-cb" 'org-iswitchb)
>
> (global-font-lock-mode 1)                     ; for all buffers
> (transient-mark-mode 1)

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
  2009-01-25  6:45 ` Org-Mode in Windows Carsten Dominik
@ 2009-01-25 10:56   ` David Lord
       [not found]     ` <497C5E28.9070706@gmail.com>
  2009-01-25 11:49   ` Manish
  1 sibling, 1 reply; 8+ messages in thread
From: David Lord @ 2009-01-25 10:56 UTC (permalink / raw)
  To: Manager Leader; +Cc: Org Mode List

Bailey,

I think the first thing you need to do is find your .emacs: start  
emacs and type Ctrl-x Ctrl-f, make sure it says something like 'Find  
file: ~/' at the bottom of the screen and press enter.  A 'dired'  
buffer should open up in which you should see your .emacs file (if  
you want to put it in a different directory, you can set the HOME  
environment variable).

Next, you need to open the file and follow the instructions in http:// 
orgmode.org/manual/Installation.html#Installation to set the load- 
path to the new version of org-mode and require org-install (don't  
worry about the make commands: you will need to install cygwin or  
something like it to get that working).

You may need to get rid of the old version of org-mode before it will  
pick up the new one.  If so, you can open the old file by typing Alt- 
x find-library, press enter, type 'org' and press enter again.  Then  
type Ctrl-x Ctrl-f and press enter to find its location.  Delete the  
file (after backing it up somewhere of course) and restart emacs.

Regards
David Lord

>
> On Jan 25, 2009, at 3:48 AM, Manager Leader wrote:
>
>> Dear Mr. Dominik,
>>
>> Thank you for your work in Org-Mode, I started researching about  
>> it a month ago and I have started using it 10 days ago (used to  
>> work in outlook but it just can't cope with my life now). And so  
>> far am happy with it except for some things that's not working as  
>> expected.
>>
>> I am using Windows XP and have downloaded the latest release  
>> version for emacs (22.3.1) and org-mode (6.18c). But when I type M- 
>> x org-version 5.23a.
>> * Org-Mode does not start by itself when emacs is started - I  
>> always have to type "ALT-X org-mode" (in your book convention: M- 
>> x) or put on each file "MY PROJECTS    -*- mode: org; -*-"
>> * Agenda view does not come out with the shortcut C-c a - I always  
>> have to use the mouse and org->agenda command -> t
>> * I want my default org file to open when I start emacs or org- 
>> mode but don't know how to do this. I always have to browse to the  
>> correct directory and open the file.
>> * Other things but I think should be resolved if those above can  
>> work.
>>
>> I consider myself competent with computers and normally can easily  
>> make things work with reading documentation and searching through  
>> newsgroups, web. But this is taking a bit too long.
>>
>> Some info and Things I have done to try to resolve it:
>> * I placed emacs in directory c:/emacs, downloaded 6.18c orgmode  
>> file to c:/emacs/org
>> * I am logged in with admin rights on Windows
>> * I have added the path to emacs in environment variables. C:/ 
>> emacs/bin
>> * I have watched your video at google 3 times, gone through the  
>> manual particularly installation and activation parts, searched  
>> the newsgroups and google searched whatever I can...
>> * I can't find any file named emacs or *.emacs so I created  
>> ".emacs" file and placed it in c:/emacs - I attach my emacs file.
>> * Make command from the installation manual does not work (even  
>> inside emacs Tools-> Make) - I attach my makefile which I have  
>> edited based on the installation manual.
>>
>> But, I still can't get things to work properly.  I hope that you  
>> can help.
>>
>> Thank you for a great software!
>>
>> Regards,
>>
>>
>> Bailey
>>

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
  2009-01-25  6:45 ` Org-Mode in Windows Carsten Dominik
  2009-01-25 10:56   ` David Lord
@ 2009-01-25 11:49   ` Manish
  2009-01-25 15:02     ` Manager Leader
  1 sibling, 1 reply; 8+ messages in thread
From: Manish @ 2009-01-25 11:49 UTC (permalink / raw)
  To: Manager Leader; +Cc: Org Mode List

> On Jan 25, 2009, at 3:48 AM, Manager Leader wrote:
>
>> Dear Mr. Dominik,
>>
>> Thank you for your work in Org-Mode, I started researching about it a
>> month ago and I have started using it 10 days ago (used to work in outlook
>> but it just can't cope with my life now). And so far am happy with it except
>> for some things that's not working as expected.
>>
>> I am using Windows XP and have downloaded the latest release version for
>> emacs (22.3.1) and org-mode (6.18c). But when I type M-x org-version 5.23a.

Adding this will cause the new Org to come before system supplied Org.
Of course, update the path for your machine.

--8<---------------cut here---------------start------------->8---
(add-to-list 'load-path "C:/path/to/org-mode/lisp")
--8<---------------cut here---------------end--------------->8---

Please ensure you have "(require 'org-install)" and not "(require 'org)'
in your .emacs.

>> * Org-Mode does not start by itself when emacs is started - I always have
>> to type "ALT-X org-mode" (in your book convention: M-x) or put on each file
>> "MY PROJECTS  -*- mode: org; -*-"

This should make all .org files open in Org mode.

--8<---------------cut here---------------start------------->8---
(add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
--8<---------------cut here---------------end--------------->8---

>>
>> * Agenda view does not come out with the shortcut C-c a - I always
>> have to use the mouse and org->agenda command -> t *

Following should help bring agenda options with C-c a.

--8<---------------cut here---------------start------------->8---
(global-set-key "\C-ca" 'org-agenda)
--8<---------------cut here---------------end--------------->8---


>> I want my default org file to open when I start emacs or org-mode but
>> don't know how to do this. I always have to browse to the correct
>> directory and open the file.  * Other things but I think should be
>> resolved if those above can work.

Once you use the agenda command it will open required org files
automatically.  You may also want to take a look at
http://www.emacswiki.org/emacs/DeskTop

>>
>>
>> I consider myself competent with computers and normally can easily make
>> things work with reading documentation and searching through newsgroups,
>> web. But this is taking a bit too long.
>>
>> Some info and Things I have done to try to resolve it:
>> * I placed emacs in directory c:/emacs, downloaded 6.18c orgmode file to
>> c:/emacs/org
>> * I am logged in with admin rights on Windows

Admin rights should not be necessary to use Emacs and Org mode.

>>
>> * I have added the path to emacs in environment
>> variables. C:/emacs/bin * I have watched your video at google 3
>> times, gone through the manual particularly installation and
>> activation parts, searched the newsgroups and google searched
>> whatever I can...

Following article by John Weigley is what eased the eay for me.

http://www.newartisans.com/blog/2007/08/using-org-mode-as-a-day-planner.html

>> * I can't find any file named emacs or *.emacs so I created ".emacs"
>> file and placed it in c:/emacs - I attach my emacs file.

I am afraid I did not find your .emacs file but the link cited above
will help you get started with one.  I prefer to define an environment
variable "HOME" and keep my stuff under that.  Emacs will also read
.emacs from the location if it can find the file there.

>> * Make command from the installation manual does not work (even
>> inside emacs
>> Tools-> Make) - I attach my makefile which I have edited based on the
>> installation manual.

I would suggest skipping the make part for now.  Everything should still
function without compiling.  What you do not get is the info and HTML
documentation (that you can access online.)

HTH
-- 
Manish

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
  2009-01-25 11:49   ` Manish
@ 2009-01-25 15:02     ` Manager Leader
  2009-01-25 15:11       ` Manish
  0 siblings, 1 reply; 8+ messages in thread
From: Manager Leader @ 2009-01-25 15:02 UTC (permalink / raw)
  To: Manish; +Cc: Org Mode List

Hi Manish,

Thank you for your reply.

I tried what you said:
(add-to-list 'load-path "C:/path/to/org-mode/lisp")
(require 'org-install)
(add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
(global-set-key "\C-ca" 'org-agenda)

But I had to create a .emacs file (.emacs filename and no extension - 
not sure if this is right). I placed 2 copies - 1 where runemacs.exe is 
located (c:/emacs/bin) and another in c:/emacs - but it seems like 
there's no effect on the behaviour of org-mode... So I think there's a 
problem with reading the .emacs..

I have already set the path: C:\emacs\bin\ and Added environmental 
variables HOME = c:\emacs\

I have a feeling I'm doing something simple wrong...

Thanks,


Bailey

Manish wrote:

>> On Jan 25, 2009, at 3:48 AM, Manager Leader wrote:
>>
>>     
>>> Dear Mr. Dominik,
>>>
>>> Thank you for your work in Org-Mode, I started researching about it a
>>> month ago and I have started using it 10 days ago (used to work in outlook
>>> but it just can't cope with my life now). And so far am happy with it except
>>> for some things that's not working as expected.
>>>
>>> I am using Windows XP and have downloaded the latest release version for
>>> emacs (22.3.1) and org-mode (6.18c). But when I type M-x org-version 5.23a.
>>>       
>
> Adding this will cause the new Org to come before system supplied Org.
> Of course, update the path for your machine.
>
> --8<---------------cut here---------------start------------->8---
> (add-to-list 'load-path "C:/path/to/org-mode/lisp")
> --8<---------------cut here---------------end--------------->8---
>
> Please ensure you have "(require 'org-install)" and not "(require 'org)'
> in your .emacs.
>
>   
>>> * Org-Mode does not start by itself when emacs is started - I always have
>>> to type "ALT-X org-mode" (in your book convention: M-x) or put on each file
>>> "MY PROJECTS  -*- mode: org; -*-"
>>>       
>
> This should make all .org files open in Org mode.
>
> --8<---------------cut here---------------start------------->8---
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> --8<---------------cut here---------------end--------------->8---
>
>   
>>> * Agenda view does not come out with the shortcut C-c a - I always
>>> have to use the mouse and org->agenda command -> t *
>>>       
>
> Following should help bring agenda options with C-c a.
>
> --8<---------------cut here---------------start------------->8---
> (global-set-key "\C-ca" 'org-agenda)
> --8<---------------cut here---------------end--------------->8---
>
>
>   
>>> I want my default org file to open when I start emacs or org-mode but
>>> don't know how to do this. I always have to browse to the correct
>>> directory and open the file.  * Other things but I think should be
>>> resolved if those above can work.
>>>       
>
> Once you use the agenda command it will open required org files
> automatically.  You may also want to take a look at
> http://www.emacswiki.org/emacs/DeskTop
>
>   
>>> I consider myself competent with computers and normally can easily make
>>> things work with reading documentation and searching through newsgroups,
>>> web. But this is taking a bit too long.
>>>
>>> Some info and Things I have done to try to resolve it:
>>> * I placed emacs in directory c:/emacs, downloaded 6.18c orgmode file to
>>> c:/emacs/org
>>> * I am logged in with admin rights on Windows
>>>       
>
> Admin rights should not be necessary to use Emacs and Org mode.
>
>   
>>> * I have added the path to emacs in environment
>>> variables. C:/emacs/bin * I have watched your video at google 3
>>> times, gone through the manual particularly installation and
>>> activation parts, searched the newsgroups and google searched
>>> whatever I can...
>>>       
>
> Following article by John Weigley is what eased the eay for me.
>
> http://www.newartisans.com/blog/2007/08/using-org-mode-as-a-day-planner.html
>
>   
>>> * I can't find any file named emacs or *.emacs so I created ".emacs"
>>> file and placed it in c:/emacs - I attach my emacs file.
>>>       
>
> I am afraid I did not find your .emacs file but the link cited above
> will help you get started with one.  I prefer to define an environment
> variable "HOME" and keep my stuff under that.  Emacs will also read
> .emacs from the location if it can find the file there.
>
>   
>>> * Make command from the installation manual does not work (even
>>> inside emacs
>>> Tools-> Make) - I attach my makefile which I have edited based on the
>>> installation manual.
>>>       
>
> I would suggest skipping the make part for now.  Everything should still
> function without compiling.  What you do not get is the info and HTML
> documentation (that you can access online.)
>
> HTH
>   

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
  2009-01-25 15:02     ` Manager Leader
@ 2009-01-25 15:11       ` Manish
  2009-01-25 15:30         ` Manager Leader
  0 siblings, 1 reply; 8+ messages in thread
From: Manish @ 2009-01-25 15:11 UTC (permalink / raw)
  To: Manager Leader; +Cc: Org Mode List

On Sun, Jan 25, 2009 at 8:32 PM, Manager Leader wrote:
> Hi Manish,
>
> Thank you for your reply.
>
> I tried what you said:
> (add-to-list 'load-path "C:/path/to/org-mode/lisp")
> (require 'org-install)
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> (global-set-key "\C-ca" 'org-agenda)
>
> But I had to create a .emacs file (.emacs filename and no extension - not
> sure if this is right). I placed 2 copies - 1 where runemacs.exe is located
> (c:/emacs/bin) and another in c:/emacs - but it seems like there's no effect
> on the behaviour of org-mode... So I think there's a problem with reading
> the .emacs..
>
> I have already set the path: C:\emacs\bin\ and Added environmental variables
> HOME = c:\emacs\

How are you setting up the environment variable?  I set it up a user
variable under:

1. Windows Explorer
2. My Computer
3. (right click)
4. Properties
5. Advanced Tab
6. Environment Variables

Do restart Emacs for this to take effect.

You can load .emacs using "M-x laod-file <RET>" and navigating to the
file as well while you resolve the issue.

HTH
-- 
Manish

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
  2009-01-25 15:11       ` Manish
@ 2009-01-25 15:30         ` Manager Leader
       [not found]           ` <497C8B92.8010706@firstscales.com>
  0 siblings, 1 reply; 8+ messages in thread
From: Manager Leader @ 2009-01-25 15:30 UTC (permalink / raw)
  To: Manish; +Cc: Org Mode List

[-- Attachment #1: Type: text/plain, Size: 1665 bytes --]

Hi Manish,

Thanks for the tip on loading the .emacs using M-x load-file (ENTER), 
after that I type "c:/emacs/.emacs" and the agenda command worked.

With regards to the environmental settings - we're doing it the same 
place - see attached screenshot.

With regards to my .emacs, its very empty - I attached it as well... I 
just created the .emacs file myself. Is there supposed to be something 
inside .emacs by default?

How do you think I should make the .emacs load by itself?

Thanks,


Bailey

Manish wrote:
> On Sun, Jan 25, 2009 at 8:32 PM, Manager Leader wrote:
>   
>> Hi Manish,
>>
>> Thank you for your reply.
>>
>> I tried what you said:
>> (add-to-list 'load-path "C:/path/to/org-mode/lisp")
>> (require 'org-install)
>> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
>> (global-set-key "\C-ca" 'org-agenda)
>>
>> But I had to create a .emacs file (.emacs filename and no extension - not
>> sure if this is right). I placed 2 copies - 1 where runemacs.exe is located
>> (c:/emacs/bin) and another in c:/emacs - but it seems like there's no effect
>> on the behaviour of org-mode... So I think there's a problem with reading
>> the .emacs..
>>
>> I have already set the path: C:\emacs\bin\ and Added environmental variables
>> HOME = c:\emacs\
>>     
>
> How are you setting up the environment variable?  I set it up a user
> variable under:
>
> 1. Windows Explorer
> 2. My Computer
> 3. (right click)
> 4. Properties
> 5. Advanced Tab
> 6. Environment Variables
>
> Do restart Emacs for this to take effect.
>
> You can load .emacs using "M-x laod-file <RET>" and navigating to the
> file as well while you resolve the issue.
>
> HTH
>   

[-- Attachment #2: emacs environent.jpg --]
[-- Type: image/jpeg, Size: 80755 bytes --]

[-- Attachment #3: .emacs --]
[-- Type: text/plain, Size: 373 bytes --]

;; The following lines are always needed.  Choose your own keys.
(add-to-list 'load-path "c:/emacs/org")
(add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
(global-set-key "\C-cl" 'org-store-link)
(global-set-key "\C-ca" 'org-agenda)
(global-set-key "\C-cb" 'org-iswitchb)

(global-font-lock-mode 1)                     ; for all buffers
(transient-mark-mode 1)

[-- Attachment #4: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
       [not found]           ` <497C8B92.8010706@firstscales.com>
@ 2009-01-25 18:45             ` Manish
  0 siblings, 0 replies; 8+ messages in thread
From: Manish @ 2009-01-25 18:45 UTC (permalink / raw)
  To: Bailey, Manager Leader; +Cc: Org Mode List

On Sun, Jan 25, 2009 at 9:26 PM, Bailey wrote:
> Hi Manish,
>
> I tried putting in the configuration from John Wigley on the link you gave:
>
> http://www.newartisans.com/blog/2007/08/using-org-mode-as-a-day-planner.html
>
> and then use M-x load-file...
>
> Unfortunately, I got the following messages:
> Loading c:/emacs/.emacs...
> eval-buffer: Cannot open load file: remember
>
> Seems like my copy of emacs have a lot of missing things. I did a file
> search and there's no remember... and also no diff
>
> Do you think emacs 22.3.1 version that I downloaded is the problem?

No, Emacs is not the problem here.

You could just add minimal configuration (some emailed earlier) and
start using it (load .emacs) manually if need be till you understand the
beast some more.  Org should be usable even with that.

I would highly recommend going through the series of tutorials here
first.
http://www.ibm.com/developerworks/views/aix/libraryview.jsp?search_by=emacs+editing+environment

And then going through various tutorials and articles in Worg and keep
adding stuff that you like and find useful to your .emacs incrementally
as you understand more about Emacs and Org-mode.  Emacswiki is also a
rich source of information and resources.

HTH
-- 
Manish

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Re: Org-Mode in Windows
       [not found]     ` <497C5E28.9070706@gmail.com>
@ 2009-01-25 20:01       ` David Lord
  0 siblings, 0 replies; 8+ messages in thread
From: David Lord @ 2009-01-25 20:01 UTC (permalink / raw)
  To: Manager Leader; +Cc: Org Mode List

Bailey,

I'm surprised you are seeing c:/emacs/bin as your home directory -  
perhaps its a peculiarity of the official GNU release.  `C:\Documents  
and Settings\USERNAME\Application Data' is the default on XP I  
believe.  Personally, I like the EmacsW32 release (http:// 
ourcomments.org/Emacs/EmacsW32.html).  It is customized to work well  
with windows and includes a more up-to-date version of org-mode by  
default.

The file is called '.emacs' - no extension.  You can create it if it  
doesn't exist by typing 'C-x C-f ~/.emacs <RET>'.

It might also be worth looking up the Windows section in the emacs  
manual (see 'Read the Emacs Manual' on the help menu).

Regards
David Lord

On 25 Ion 2009, at 12:42, Manager Leader wrote:

> Hi David,
>
> Thank you for your reply.
>
> I downloaded emacs from: http://ftp.gnu.org/gnu/emacs/windows/ and  
> the file I got is emacs-22.3-bin-i386.zip
>
> When I did as you said C-x C-f and enter, I get this file list:
>  c:/emacs/bin:
>  total used in directory 14253 available 6281388
>  drwxrwxrwx   1 Bailey   root             0 01-25 09:31 .
>  drwxrwxrwx   1 Bailey   root             0 01-25 19:49 ..
>  -rw-rw-rw-   1 Bailey   root         35147 09-07 01:27 COPYING
>  -rwxrwxrwx   1 Bailey   root        208024 09-07 01:27 addpm.exe
>  -rwxrwxrwx   1 Bailey   root        213712 09-07 01:27 cmdproxy.exe
>  -rwxrwxrwx   1 Bailey   root        415691 09-07 01:26 ctags.exe
>  -rwxrwxrwx   1 Bailey   root        201154 09-07 01:27 ddeclient.exe
>  -rwxrwxrwx   1 Bailey   root         23196 09-07 01:26 digest-doc.exe
>  -rwxrwxrwx   1 Bailey   root        303837 09-07 01:26 ebrowse.exe
>  -rwxrwxrwx   1 Bailey   root      10584469 09-07 01:26 emacs.exe
>  -rwxrwxrwx   1 Bailey   root        470906 09-07 01:26  
> emacsclient.exe
>  -rwxrwxrwx   1 Bailey   root        494988 09-07 01:26  
> emacsclientw.exe
>  -rwxrwxrwx   1 Bailey   root        411930 09-07 01:26 etags.exe
>  -rwxrwxrwx   1 Bailey   root         30055 09-07 01:26 hexl.exe
>  -rw-rw-rw-   1 Bailey   root        502117 08-10 23:22 libXpm.dll
>  -rwxrwxrwx   1 Bailey   root        444386 09-07 01:26 movemail.exe
>  -rwxrwxrwx   1 Bailey   root        224236 09-07 01:27 runemacs.exe
>  -rwxrwxrwx   1 Bailey   root         31209 09-07 01:26 sorted-doc.exe
>
> No .emacs... I also attach the file list of the whole emacs  
> subdirectory (I downloaded it again just to be sure).
>
> Is the .emacs file a file with name ".emacs" with no extension? or  
> is emacs the extension with no filename?
>
> Can I create my own emacs? I did and put it in c:/emacs and c:/ 
> emacs/bin but seems like no effect... i.e. When org file opened,  
> its not in org-mode. Where can I download the .emacs file?
>
> Thank you,
>
>
> Bailey
>

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2009-01-25 20:01 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <497BD2E2.3080306@gmail.com>
2009-01-25  6:45 ` Org-Mode in Windows Carsten Dominik
2009-01-25 10:56   ` David Lord
     [not found]     ` <497C5E28.9070706@gmail.com>
2009-01-25 20:01       ` David Lord
2009-01-25 11:49   ` Manish
2009-01-25 15:02     ` Manager Leader
2009-01-25 15:11       ` Manish
2009-01-25 15:30         ` Manager Leader
     [not found]           ` <497C8B92.8010706@firstscales.com>
2009-01-25 18:45             ` Manish

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).