emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)]
@ 2022-03-25 19:37 Roi Holtzman
  2022-03-26  9:34 ` Ihor Radchenko
  0 siblings, 1 reply; 5+ messages in thread
From: Roi Holtzman @ 2022-03-25 19:37 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1091 bytes --]

Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     https://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org mailing list.
------------------------------------------------------------------------

This is the first time I am submitting a bug report here. I am not sure
this is the proper place. I just took the advice of the warning message
I got.

When I am in latex mode (writing a tex document) and I run
`org-toggle-latex-fragment` I get the error
```
Warning (org-element-cache): org-element--cache: Org parser error in
main.tex::38463. Resetting.
The error was: (error "rx ‘**’ range error")
Backtrace:
nil
Please report this to Org mode mailing list (M-x org-submit-bug-report).
```


Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin19.6.0, NS
appkit-1894.60 Version 10.15.7 (Build 19H2))
of 2021-04-28
Package: Org mode version 9.6 (9.6-??-e7ea951 @
/Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)

[-- Attachment #2: Type: text/html, Size: 16693 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)]
  2022-03-25 19:37 [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)] Roi Holtzman
@ 2022-03-26  9:34 ` Ihor Radchenko
  2022-03-26  9:44   ` Roi Holtzman
  0 siblings, 1 reply; 5+ messages in thread
From: Ihor Radchenko @ 2022-03-26  9:34 UTC (permalink / raw)
  To: Roi Holtzman; +Cc: emacs-orgmode

Roi Holtzman <roi.holtzman@gmail.com> writes:

> This is the first time I am submitting a bug report here. I am not sure
> this is the proper place. I just took the advice of the warning message
> I got.

Thank a lot for the report! This is indeed the right place.

> When I am in latex mode (writing a tex document) and I run
> `org-toggle-latex-fragment` I get the error
> ```
> Warning (org-element-cache): org-element--cache: Org parser error in
> main.tex::38463. Resetting.
> The error was: (error "rx ‘**’ range error")
> Backtrace:
> nil
> Please report this to Org mode mailing list (M-x org-submit-bug-report).
> ```

You cannot run `org-toggle-latex-fragment' outside of Org buffers. It
used to work, but we made some changes that expect the major-mode to be
org-mode when analysing buffer text.

Best,
Ihor


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)]
  2022-03-26  9:34 ` Ihor Radchenko
@ 2022-03-26  9:44   ` Roi Holtzman
  2022-03-26  9:58     ` Ihor Radchenko
  0 siblings, 1 reply; 5+ messages in thread
From: Roi Holtzman @ 2022-03-26  9:44 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1129 bytes --]

Hi Ihor,

Thank you very much for your reply!
I understand the answer.
Is there a proper way to render latex fragments in latex mode?

Thanks,
Roi

On Sat, 26 Mar 2022 at 12:34, Ihor Radchenko <yantar92@gmail.com> wrote:

> Roi Holtzman <roi.holtzman@gmail.com> writes:
>
> > This is the first time I am submitting a bug report here. I am not sure
> > this is the proper place. I just took the advice of the warning message
> > I got.
>
> Thank a lot for the report! This is indeed the right place.
>
> > When I am in latex mode (writing a tex document) and I run
> > `org-toggle-latex-fragment` I get the error
> > ```
> > Warning (org-element-cache): org-element--cache: Org parser error in
> > main.tex::38463. Resetting.
> > The error was: (error "rx ‘**’ range error")
> > Backtrace:
> > nil
> > Please report this to Org mode mailing list (M-x org-submit-bug-report).
> > ```
>
> You cannot run `org-toggle-latex-fragment' outside of Org buffers. It
> used to work, but we made some changes that expect the major-mode to be
> org-mode when analysing buffer text.
>
> Best,
> Ihor
>

[-- Attachment #2: Type: text/html, Size: 1660 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)]
  2022-03-26  9:44   ` Roi Holtzman
@ 2022-03-26  9:58     ` Ihor Radchenko
  2022-03-26 10:01       ` Roi Holtzman
  0 siblings, 1 reply; 5+ messages in thread
From: Ihor Radchenko @ 2022-03-26  9:58 UTC (permalink / raw)
  To: Roi Holtzman; +Cc: emacs-orgmode

Roi Holtzman <roi.holtzman@gmail.com> writes:

> Is there a proper way to render latex fragments in latex mode?

AFAIK, auctex does have such a feature. See https://www.gnu.org/software/auctex/manual/preview-latex.html#Keys-and-lisp


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)]
  2022-03-26  9:58     ` Ihor Radchenko
@ 2022-03-26 10:01       ` Roi Holtzman
  0 siblings, 0 replies; 5+ messages in thread
From: Roi Holtzman @ 2022-03-26 10:01 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 395 bytes --]

Perfect! I forgot about "preview-at-point"! Works like a charm! Thank you!

On Sat, 26 Mar 2022 at 12:58, Ihor Radchenko <yantar92@gmail.com> wrote:

> Roi Holtzman <roi.holtzman@gmail.com> writes:
>
> > Is there a proper way to render latex fragments in latex mode?
>
> AFAIK, auctex does have such a feature. See
> https://www.gnu.org/software/auctex/manual/preview-latex.html#Keys-and-lisp
>

[-- Attachment #2: Type: text/html, Size: 892 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-03-26 10:02 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-03-25 19:37 [BUG] rendering latex fragment in latex mode is not working [9.6 (9.6-??-e7ea951 @ /Users/roiholtzman/.emacs.d/.local/straight/build-27.2/org/)] Roi Holtzman
2022-03-26  9:34 ` Ihor Radchenko
2022-03-26  9:44   ` Roi Holtzman
2022-03-26  9:58     ` Ihor Radchenko
2022-03-26 10:01       ` Roi Holtzman

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).