emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Problem with latest orgmode ascii export
@ 2009-06-23 18:37 Robert Goldman
  2009-06-23 23:30 ` Bernt Hansen
  2009-06-27  7:20 ` Carsten Dominik
  0 siblings, 2 replies; 4+ messages in thread
From: Robert Goldman @ 2009-06-23 18:37 UTC (permalink / raw)
  To: emacs-orgmode

Just pulled a git update this morning, and was trying to do an
org-export as ascii.  Got the following error:

(invalid-function (interblock (start end type) (save-match-data (when
(setf func (cadr (assoc type org-export-interblocks))) (funcall func
start end)))))

This is a function that's defined by the FLET in
org-export-blocks-preprocess.  See org-exp-blocks.el, line 184.

I'm not exactly sure what is going wrong here --- is it possible that
this requires 'cl and somehow CL is not properly available?  Or the
version of CL in my emacs (Aquamacs 1.8) is not compatible?

I'll be happy to do some debugging if someone can give me some
suggestions about what line to pursue...

thanks,
r

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Problem with latest orgmode ascii export
  2009-06-23 18:37 Problem with latest orgmode ascii export Robert Goldman
@ 2009-06-23 23:30 ` Bernt Hansen
  2009-06-27  7:20 ` Carsten Dominik
  1 sibling, 0 replies; 4+ messages in thread
From: Bernt Hansen @ 2009-06-23 23:30 UTC (permalink / raw)
  To: Robert Goldman; +Cc: emacs-orgmode

Robert Goldman <rpgoldman@sift.info> writes:

> Just pulled a git update this morning, and was trying to do an
> org-export as ascii.  Got the following error:
>
> (invalid-function (interblock (start end type) (save-match-data (when
> (setf func (cadr (assoc type org-export-interblocks))) (funcall func
> start end)))))
>
> This is a function that's defined by the FLET in
> org-export-blocks-preprocess.  See org-exp-blocks.el, line 184.
>
> I'm not exactly sure what is going wrong here --- is it possible that
> this requires 'cl and somehow CL is not properly available?  Or the
> version of CL in my emacs (Aquamacs 1.8) is not compatible?
>
> I'll be happy to do some debugging if someone can give me some
> suggestions about what line to pursue...

I've run into this twice too -- restarting Emacs made it magically go
away for me.  I was exporting to HTML.

-Bernt

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Problem with latest orgmode ascii export
  2009-06-23 18:37 Problem with latest orgmode ascii export Robert Goldman
  2009-06-23 23:30 ` Bernt Hansen
@ 2009-06-27  7:20 ` Carsten Dominik
  2009-06-27 10:57   ` Eric S Fraga
  1 sibling, 1 reply; 4+ messages in thread
From: Carsten Dominik @ 2009-06-27  7:20 UTC (permalink / raw)
  To: Robert Goldman; +Cc: emacs-orgmode


On Jun 23, 2009, at 8:37 PM, Robert Goldman wrote:

> Just pulled a git update this morning, and was trying to do an
> org-export as ascii.  Got the following error:
>
> (invalid-function (interblock (start end type) (save-match-data (when
> (setf func (cadr (assoc type org-export-interblocks))) (funcall func
> start end)))))
>
> This is a function that's defined by the FLET in
> org-export-blocks-preprocess.  See org-exp-blocks.el, line 184.
>
> I'm not exactly sure what is going wrong here --- is it possible that
> this requires 'cl and somehow CL is not properly available?

This may be it, org-exp-blocks does not say (require 'cl)

it does now, please upgrade and let me know if it fixes the problem.

- Carsten


> Or the
> version of CL in my emacs (Aquamacs 1.8) is not compatible?
>
> I'll be happy to do some debugging if someone can give me some
> suggestions about what line to pursue...
>
> thanks,
> r
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Problem with latest orgmode ascii export
  2009-06-27  7:20 ` Carsten Dominik
@ 2009-06-27 10:57   ` Eric S Fraga
  0 siblings, 0 replies; 4+ messages in thread
From: Eric S Fraga @ 2009-06-27 10:57 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode, Robert Goldman

At Sat, 27 Jun 2009 09:20:10 +0200,
Carsten Dominik wrote:
> 
> 
> On Jun 23, 2009, at 8:37 PM, Robert Goldman wrote:
> 
> > Just pulled a git update this morning, and was trying to do an
> > org-export as ascii.  Got the following error:
> >
> > (invalid-function (interblock (start end type) (save-match-data (when
> > (setf func (cadr (assoc type org-export-interblocks))) (funcall func
> > start end)))))
> >
> > This is a function that's defined by the FLET in
> > org-export-blocks-preprocess.  See org-exp-blocks.el, line 184.
> >
> > I'm not exactly sure what is going wrong here --- is it possible that
> > this requires 'cl and somehow CL is not properly available?
> 
> This may be it, org-exp-blocks does not say (require 'cl)
> 
> it does now, please upgrade and let me know if it fixes the problem.

Carsten,

just to add a data point to this:  I had exactly the OP's problem
yesterday when I pulled the git updates and did a make.  The problem
was resolved by doing a 'make clean' first for some reason.

eric

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2009-06-27 10:57 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-06-23 18:37 Problem with latest orgmode ascii export Robert Goldman
2009-06-23 23:30 ` Bernt Hansen
2009-06-27  7:20 ` Carsten Dominik
2009-06-27 10:57   ` Eric S Fraga

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).