emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [PATCH] org-attach-store-link-p gets wrong value for attach when using customize-variable
@ 2012-03-12 21:17 Henning Weiss
  2012-03-14  5:42 ` David Maus
  0 siblings, 1 reply; 2+ messages in thread
From: Henning Weiss @ 2012-03-12 21:17 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 823 bytes --]

Hi,

I have attached a very small patch fixing the value
that org-attach-store-link-p gets through the customize interface. The
additional quote prevented org-attach-attach from
calling org-attach-store-link when org-attach-store-link-p was configured
to "Link to the attach-dir location".

best regards,
Henning Weiss

diff --git a/lisp/org-attach.el b/lisp/org-attach.el
index 1816a07..7ba3d72 100644
--- a/lisp/org-attach.el
+++ b/lisp/org-attach.el
@@ -105,7 +105,7 @@ ln    create a hard link.  Note that this is not
supported
   :type '(choice
          (const :tag "Don't store link" nil)
          (const :tag "Link to origin location" t)
-         (const :tag "Link to the attach-dir location" 'attached)))
+         (const :tag "Link to the attach-dir location" attached)))

 ;;;###autoload
 (defun org-attach ()

[-- Attachment #2: Type: text/html, Size: 1119 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-03-14  5:42 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-03-12 21:17 [PATCH] org-attach-store-link-p gets wrong value for attach when using customize-variable Henning Weiss
2012-03-14  5:42 ` David Maus

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).