emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: org-mode tables and orgtbl-mode [7.9.2 (7.9.2-166-g40cb44-elpaplus @ /home/vdyadov/Work/Tools/emacs/share/emacs/24.2/lisp/org/)]
@ 2013-01-11 10:19 Дядов Васил Стоянов
  2013-01-11 16:35 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Дядов Васил Стоянов @ 2013-01-11 10:19 UTC (permalink / raw)
  To: emacs-orgmode


Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     http://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org-mode mailing list.
------------------------------------------------------------------------

The bug is easily reproducible with folowing algorithm:

1. I have an org file with verilog code embedded in 
   #+begin_src verilog
   ... 
   #+end_src
2. Then I hit C-' to edit this verilog code in separate buffer
3. During editing code I shwitch on orgtbl-mode to edit some tables in
   verilog comments, then I switch off orgtbl-mode
4. Then I hit C-' again to return to the org file
5. And I discover that I cannot edited tables in org file anymore
5a. orgtbl-mode could not be run in org file
6. I hit C-' again on verilog code
7. Switch on orgtbl-mode in buffer with verilog code
8. Hit C-' again to return to org file (without switching off orgtbl-mode)
9. Now editing of tables in org file works as it should to

Emacs  : GNU Emacs 24.2.1 (x86_64-unknown-linux-gnu, GTK+ Version 2.18.9)
 of 2012-12-25 on canopus-pc.elvees.com
Package: Org-mode version 7.9.2 (7.9.2-166-g40cb44-elpaplus @ /home/vdyadov/Work/Tools/emacs/share/emacs/24.2/lisp/org/)

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Bug: org-mode tables and orgtbl-mode [7.9.2 (7.9.2-166-g40cb44-elpaplus @ /home/vdyadov/Work/Tools/emacs/share/emacs/24.2/lisp/org/)]
  2013-01-11 10:19 Bug: org-mode tables and orgtbl-mode [7.9.2 (7.9.2-166-g40cb44-elpaplus @ /home/vdyadov/Work/Tools/emacs/share/emacs/24.2/lisp/org/)] Дядов Васил Стоянов
@ 2013-01-11 16:35 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2013-01-11 16:35 UTC (permalink / raw)
  To: Дядов
	Васил
	Стоянов
  Cc: emacs-orgmode

Hi,

vdyadov@elvees.com (Дядов Васил Стоянов) writes:

> The bug is easily reproducible with folowing algorithm:
>
> 1. I have an org file with verilog code embedded in 
>    #+begin_src verilog
>    ... 
>    #+end_src
> 2. Then I hit C-' to edit this verilog code in separate buffer
> 3. During editing code I shwitch on orgtbl-mode to edit some tables in
>    verilog comments, then I switch off orgtbl-mode
> 4. Then I hit C-' again to return to the org file
> 5. And I discover that I cannot edited tables in org file anymore
> 5a. orgtbl-mode could not be run in org file
> 6. I hit C-' again on verilog code
> 7. Switch on orgtbl-mode in buffer with verilog code
> 8. Hit C-' again to return to org file (without switching off orgtbl-mode)
> 9. Now editing of tables in org file works as it should to

Thanks for the detailed recipe -- I cannot reproduce the bug here
with Org 7.9.3a, I tried with emacs-lisp instead of verilog... 

Maybe you can share a minimal file?  If not, I hope someone else
can try to reproduce.

Best,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2013-01-11 16:35 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-01-11 10:19 Bug: org-mode tables and orgtbl-mode [7.9.2 (7.9.2-166-g40cb44-elpaplus @ /home/vdyadov/Work/Tools/emacs/share/emacs/24.2/lisp/org/)] Дядов Васил Стоянов
2013-01-11 16:35 ` Bastien

Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).