emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* links cause table misalignment
@ 2018-04-07  7:33 Thomas P
  2018-04-07  7:38 ` Nicolas Goaziou
  0 siblings, 1 reply; 4+ messages in thread
From: Thomas P @ 2018-04-07  7:33 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 445 bytes --]

Hello,

With org-mode 9.1.9, my tables sometimes become misaligned when I press TAB and the cursor is in a cell with a link.

In an org-mode buffer, enter:

| aa | aa |
| [[a][a]] | |

The lower-left cell becomes misaligned when I press TAB and the cursor is on the link "a".

I get no misalignment with org-mode 8.2.10.

emacs-version: GNU Emacs 25.3.2 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9) of 2017-09-12

Regards,
Thomas

[-- Attachment #2: Type: text/html, Size: 2586 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: links cause table misalignment
  2018-04-07  7:33 links cause table misalignment Thomas P
@ 2018-04-07  7:38 ` Nicolas Goaziou
  2018-04-07  8:00   ` Thomas P
  0 siblings, 1 reply; 4+ messages in thread
From: Nicolas Goaziou @ 2018-04-07  7:38 UTC (permalink / raw)
  To: Thomas P; +Cc: emacs-orgmode

Hello,

Thomas P <datalogen@hotmail.com> writes:

> With org-mode 9.1.9, my tables sometimes become misaligned when I press TAB and the cursor is in a cell with a link.
>
> In an org-mode buffer, enter:
>
> | aa | aa |
> | [[a][a]] | |
>
> The lower-left cell becomes misaligned when I press TAB and the cursor
> is on the link "a".

FWIW, I cannot reproduce it. The table is correctly aligned.

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: links cause table misalignment
  2018-04-07  7:38 ` Nicolas Goaziou
@ 2018-04-07  8:00   ` Thomas P
  2018-04-07  8:08     ` Nicolas Goaziou
  0 siblings, 1 reply; 4+ messages in thread
From: Thomas P @ 2018-04-07  8:00 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1308 bytes --]

Curious. Not even if you set your cursor on the a and press TAB again? (I sometimes have to do it twice).

This is what I did:

Downloaded https://orgmode.org/org-9.1.9.zip and unzipped to ~/tmp/org-9.1.9

Ran:
emacs -Q

In the scratch-buffer:
  (add-to-list 'load-path "~/tmp/org-9.1.9/lisp")
  (require 'org)

Switched to a new buffer and did
M-x org-mode RET

Now if I enter that table (e.g. by copy-pasting from my earlier email) and align it, the table becomes misaligned for me when I press TAB when cursor is on the link "a".

I think I'm gonna try to reproduce it with org-mode versions between 8.2.10 and 9.1.9, see what happens.
________________________________
Från: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Skickat: den 7 april 2018 09:38
Till: Thomas P
Kopia: emacs-orgmode@gnu.org
Ämne: Re: links cause table misalignment

Hello,

Thomas P <datalogen@hotmail.com> writes:

> With org-mode 9.1.9, my tables sometimes become misaligned when I press TAB and the cursor is in a cell with a link.
>
> In an org-mode buffer, enter:
>
> | aa | aa |
> | [[a][a]] | |
>
> The lower-left cell becomes misaligned when I press TAB and the cursor
> is on the link "a".

FWIW, I cannot reproduce it. The table is correctly aligned.

Regards,

--
Nicolas Goaziou

[-- Attachment #2: Type: text/html, Size: 4336 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: links cause table misalignment
  2018-04-07  8:00   ` Thomas P
@ 2018-04-07  8:08     ` Nicolas Goaziou
  0 siblings, 0 replies; 4+ messages in thread
From: Nicolas Goaziou @ 2018-04-07  8:08 UTC (permalink / raw)
  To: Thomas P; +Cc: emacs-orgmode

Thomas P <datalogen@hotmail.com> writes:

> Curious. Not even if you set your cursor on the a and press TAB again? (I sometimes have to do it twice).
>
> This is what I did:
>
> Downloaded https://orgmode.org/org-9.1.9.zip and unzipped to ~/tmp/org-9.1.9
>
> Ran:
> emacs -Q
>
> In the scratch-buffer:
>   (add-to-list 'load-path "~/tmp/org-9.1.9/lisp")
>   (require 'org)
>
> Switched to a new buffer and did
> M-x org-mode RET
>
> Now if I enter that table (e.g. by copy-pasting from my earlier email)
> and align it, the table becomes misaligned for me when I press TAB
> when cursor is on the link "a".

I did the following, from a fresh Emacs, with :

    (find-file "/tmp/bug-align.org")

    (insert "| aa | aa |
    | [[a][a]] | |
    ")

    (search-backward "a][")

    (org-table-align)

without being able to reproduce your issue.

I also tried searching backward for "][" instead, without any luck
either.

I tried in both master and maint.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2018-04-07  8:08 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-04-07  7:33 links cause table misalignment Thomas P
2018-04-07  7:38 ` Nicolas Goaziou
2018-04-07  8:00   ` Thomas P
2018-04-07  8:08     ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).