emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org footnote bug?
@ 2011-09-28 10:30 henry atting
  2011-09-28 12:20 ` Nicolas Goaziou
  0 siblings, 1 reply; 7+ messages in thread
From: henry atting @ 2011-09-28 10:30 UTC (permalink / raw)
  To: emacs-orgmode

With org from cvs (Org-mode version 7.7
(release_7.7.326.g32cf8.dirty)) footnotes don't work properly when
inserted in non org files. The first footnote appears above the
footnote tag, all the others underneath:

text [1] ... more text [2]

[1] footnote 

___

[2] footnote

This does not happen with the stable version

henry

-- 
http://literaturlatenight.de

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-28 10:30 org footnote bug? henry atting
@ 2011-09-28 12:20 ` Nicolas Goaziou
  2011-09-28 13:09   ` henry atting
  0 siblings, 1 reply; 7+ messages in thread
From: Nicolas Goaziou @ 2011-09-28 12:20 UTC (permalink / raw)
  To: henry atting; +Cc: emacs-orgmode

Hello,

henry atting <nsmp_02@online.de> writes:

> With org from cvs (Org-mode version 7.7
> (release_7.7.326.g32cf8.dirty)) footnotes don't work properly when
> inserted in non org files. The first footnote appears above the
> footnote tag, all the others underneath:
>
> text [1] ... more text [2]
>
> [1] footnote 
>
> ___
>
> [2] footnote

I currently don't see that behaviour. Could you try to post
a step-by-step recipe to reproduce the problem? Also, what's your value
for `org-footnote-tag-for-non-org-mode-files'?

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-28 12:20 ` Nicolas Goaziou
@ 2011-09-28 13:09   ` henry atting
  2011-09-28 17:10     ` Nicolas Goaziou
  0 siblings, 1 reply; 7+ messages in thread
From: henry atting @ 2011-09-28 13:09 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> Hello,

Hi Nicolas,

> henry atting <nsmp_02@online.de> writes:
>
>> With org from cvs (Org-mode version 7.7
>> (release_7.7.326.g32cf8.dirty)) footnotes don't work properly when
>> inserted in non org files. The first footnote appears above the
>> footnote tag, all the others underneath:
>>
>> text [1] ... more text [2]
>>
>> [1] footnote 
>>
>> ___
>>
>> [2] footnote
>
> I currently don't see that behaviour. Could you try to post
> a step-by-step recipe to reproduce the problem? Also, what's your value
> for `org-footnote-tag-for-non-org-mode-files'?

Tag for non orgmode files is:

(setq org-footnote-tag-for-non-org-mode-files "___")

Well, I open a file, type some text and then add a footnote with
org-footnote-action which is bound to C-cf:

---------------------------------------------------------------------
Some Text, then adding a footnote [1] then adding a second footnote [2] and
after a while a third footnote [3]

[1] this footnote appears above the footnote tag

___

[2] this footnote appears beneath the footnote tag

[3] from now on all footnotes appear beneath the footnote tag
----------------------------------------------------------------------

This is reproducible apparently with every file type except org files
or when writing mail within gnus

As a workaround I currently use org-footnote.el from the stable
release which works flawlessly.

Regards,
henry

-- 
http://literaturlatenight.de

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-28 13:09   ` henry atting
@ 2011-09-28 17:10     ` Nicolas Goaziou
  2011-09-29 12:12       ` henry atting
  0 siblings, 1 reply; 7+ messages in thread
From: Nicolas Goaziou @ 2011-09-28 17:10 UTC (permalink / raw)
  To: henry atting; +Cc: emacs-orgmode

henry atting <nsmp_02@online.de> writes:

> Tag for non orgmode files is:
>
> (setq org-footnote-tag-for-non-org-mode-files "___")
>
> Well, I open a file, type some text and then add a footnote with
> org-footnote-action which is bound to C-cf:
>
> ---------------------------------------------------------------------
> Some Text, then adding a footnote [1] then adding a second footnote [2] and
> after a while a third footnote [3]
>
> [1] this footnote appears above the footnote tag
>
> ___
>
> [2] this footnote appears beneath the footnote tag
>
> [3] from now on all footnotes appear beneath the footnote tag
> ----------------------------------------------------------------------
>
> This is reproducible apparently with every file type except org files
> or when writing mail within gnus

This should be fixed now in master. Thank you for reporting this.

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-28 17:10     ` Nicolas Goaziou
@ 2011-09-29 12:12       ` henry atting
  2011-09-29 13:35         ` Nicolas Goaziou
  0 siblings, 1 reply; 7+ messages in thread
From: henry atting @ 2011-09-29 12:12 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> henry atting <nsmp_02@online.de> writes:
>
>> Tag for non orgmode files is:
>>
>> (setq org-footnote-tag-for-non-org-mode-files "___")
>>
>> Well, I open a file, type some text and then add a footnote with
>> org-footnote-action which is bound to C-cf:
>>
>> ---------------------------------------------------------------------
>> Some Text, then adding a footnote [1] then adding a second footnote [2] and
>> after a while a third footnote [3]
>>
>> [1] this footnote appears above the footnote tag
>>
>> ___
>>
>> [2] this footnote appears beneath the footnote tag
>>
>> [3] from now on all footnotes appear beneath the footnote tag
>> ----------------------------------------------------------------------
>>
>> This is reproducible apparently with every file type except org files
>> or when writing mail within gnus
>
> This should be fixed now in master. Thank you for reporting this.
> [...]

Thanks. Two things still differ from the stable version though:

1. When the first footnote is created the tag remains invisible:

---------------------------------------------------------------
Text... then I create a first footnote [1]

[1] which appears without tag
---------------------------------------------------------------

With the second footnote the tag appears, both footnotes underneath:

----------------------------------------------------------------
Text... then I create a first footnote [1] ... then a second footnote [2]

Footnotes:

[1] which appears without tag

[2] now the tag appears, with both footnotes underneath
------------------------------------------------------------------

2. When going back to the footnote marker with org-footnote-action the
cursor stays on the left side of the marker. 

henry

-- 
http://literaturlatenight.de

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-29 12:12       ` henry atting
@ 2011-09-29 13:35         ` Nicolas Goaziou
  2011-09-29 14:02           ` henry atting
  0 siblings, 1 reply; 7+ messages in thread
From: Nicolas Goaziou @ 2011-09-29 13:35 UTC (permalink / raw)
  To: henry atting; +Cc: emacs-orgmode

henry atting <nsmp_02@online.de> writes:

> Thanks. Two things still differ from the stable version though:
>
> 1. When the first footnote is created the tag remains invisible:
>
> ---------------------------------------------------------------
> Text... then I create a first footnote [1]
>
> [1] which appears without tag
> ---------------------------------------------------------------
>
> With the second footnote the tag appears, both footnotes underneath:
>
> ----------------------------------------------------------------
> Text... then I create a first footnote [1] ... then a second footnote [2]
>
> Footnotes:
>
> [1] which appears without tag
>
> [2] now the tag appears, with both footnotes underneath
> ------------------------------------------------------------------

Right. I have pushed another fix for that. Could you confirm that it is
working now?

> 2. When going back to the footnote marker with org-footnote-action the
> cursor stays on the left side of the marker. 

Yes, it's a feature. This way, you can move back and forth between
reference and definition without creating new footnotes each time.

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: org footnote bug?
  2011-09-29 13:35         ` Nicolas Goaziou
@ 2011-09-29 14:02           ` henry atting
  0 siblings, 0 replies; 7+ messages in thread
From: henry atting @ 2011-09-29 14:02 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Nicolas Goaziou <n.goaziou@gmail.com> writes:

> henry atting <nsmp_02@online.de> writes:
>
>> Thanks. Two things still differ from the stable version though:
>>
>> 1. When the first footnote is created the tag remains invisible:
>>
>> ---------------------------------------------------------------
>> Text... then I create a first footnote [1]
>>
>> [1] which appears without tag
>> ---------------------------------------------------------------
>>
>> With the second footnote the tag appears, both footnotes underneath:
>>
>> ----------------------------------------------------------------
>> Text... then I create a first footnote [1] ... then a second footnote [2]
>>
>> Footnotes:
>>
>> [1] which appears without tag
>>
>> [2] now the tag appears, with both footnotes underneath
>> ------------------------------------------------------------------
>
> Right. I have pushed another fix for that. Could you confirm that it is
> working now?

Yes, it's working fine now.

>> 2. When going back to the footnote marker with org-footnote-action the
>> cursor stays on the left side of the marker. 
>
> Yes, it's a feature. This way, you can move back and forth between
> reference and definition without creating new footnotes each time.

I see, but too bad nevertheless. That way you always have to `jump'
over the marker when you keep up writing.

> Regards,

Thanks,

henry

-- 
http://literaturlatenight.de

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2011-09-29 14:02 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-28 10:30 org footnote bug? henry atting
2011-09-28 12:20 ` Nicolas Goaziou
2011-09-28 13:09   ` henry atting
2011-09-28 17:10     ` Nicolas Goaziou
2011-09-29 12:12       ` henry atting
2011-09-29 13:35         ` Nicolas Goaziou
2011-09-29 14:02           ` henry atting

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).