emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* New user experience ct'd: exporting citations into LaTeX (9.5)
@ 2021-10-13 21:23 Leszek Wroński
  2021-10-13 21:34 ` Bruce D'Arcus
  2021-10-13 21:50 ` [OT] Ebib file field [was: New user experience ct'd: exporting citations into LaTeX (9.5)] Joost Kremers
  0 siblings, 2 replies; 5+ messages in thread
From: Leszek Wroński @ 2021-10-13 21:23 UTC (permalink / raw)
  To: emacs-orgmode

Guys,

thank you very much for your responses to my previous query. (I will
study the ebib package more closely; as of now it does not seem to
work with the file fields in my Mendeley-created .bib file. (Yes, I
promise will stop using Mendeley.))

I wanted to try the two LaTeX export processors mentioned in the 15.2
section of the manual: natbib and biblatex. My .org file has a
#+bibliography line specifying my .bib (which is correct, since
inserting citations is now working). I put both (use-package
oc-natbib) and (use-package oc-biblatex) in my .emacs . (I've used
natbib for years when writing .tex documents; I don't know biblatex.)

The situation is as follows:
-- if I put #+cite_export: natbib at the beginning of my .org file,
then C-c C-e l L gives me a LaTeX file which does *not* specify the
.bib file; it has \citep{} commands where they should be, but of
course bibtex doesn't know what to do with them;
-- if I use #+cite_export: biblatex instead, then the resulting .tex
file does contain the \addbibresource{} line pointing to my .bib , and
\autocite{} commands where citations should be; however, I simply
cannot get this to work: Biber works alright, but eventually pdflatex
gives me the following error:

--------------
ERROR: LaTeX3 Error: Mismatched LaTeX support files detected.

--- TeX said ---
(LaTeX3)        Loading 'l3backend-pdftex.def' aborted!
(LaTeX3)
(LaTeX3)        The L3 programming layer in the LaTeX format
(LaTeX3)        is dated 2021-01-09, but in your TeX tree the files require
(LaTeX3)        at least 2021-02-18.
---------------

which I'm unable to get rid of. (This is of course not a question for
this group but if anyone had similar problems I'd be grateful for
pointers ;-);  fmtutil-sys --all and fmtutil-user --all did nothing to
alleviate this)

So: I'd really like to keep using natbib and make it somehow insert
the information about the .bib file into the .tex when exporting. How
do I do that?

Thank you again for your help!

Best regards,

Leszek.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: New user experience ct'd: exporting citations into LaTeX (9.5)
  2021-10-13 21:23 New user experience ct'd: exporting citations into LaTeX (9.5) Leszek Wroński
@ 2021-10-13 21:34 ` Bruce D'Arcus
  2021-10-13 21:40   ` tumashu
  2021-10-14  9:44   ` Leszek Wroński
  2021-10-13 21:50 ` [OT] Ebib file field [was: New user experience ct'd: exporting citations into LaTeX (9.5)] Joost Kremers
  1 sibling, 2 replies; 5+ messages in thread
From: Bruce D'Arcus @ 2021-10-13 21:34 UTC (permalink / raw)
  To: Leszek Wroński; +Cc: org-mode-email

Try adding this where you want the bibliography.

#+print_bibliography:

On Wed, Oct 13, 2021 at 5:27 PM Leszek Wroński <elwro1@gmail.com> wrote:
>
> Guys,
>
> thank you very much for your responses to my previous query. (I will
> study the ebib package more closely; as of now it does not seem to
> work with the file fields in my Mendeley-created .bib file. (Yes, I
> promise will stop using Mendeley.))
>
> I wanted to try the two LaTeX export processors mentioned in the 15.2
> section of the manual: natbib and biblatex. My .org file has a
> #+bibliography line specifying my .bib (which is correct, since
> inserting citations is now working). I put both (use-package
> oc-natbib) and (use-package oc-biblatex) in my .emacs . (I've used
> natbib for years when writing .tex documents; I don't know biblatex.)
>
> The situation is as follows:
> -- if I put #+cite_export: natbib at the beginning of my .org file,
> then C-c C-e l L gives me a LaTeX file which does *not* specify the
> .bib file; it has \citep{} commands where they should be, but of
> course bibtex doesn't know what to do with them;
> -- if I use #+cite_export: biblatex instead, then the resulting .tex
> file does contain the \addbibresource{} line pointing to my .bib , and
> \autocite{} commands where citations should be; however, I simply
> cannot get this to work: Biber works alright, but eventually pdflatex
> gives me the following error:
>
> --------------
> ERROR: LaTeX3 Error: Mismatched LaTeX support files detected.
>
> --- TeX said ---
> (LaTeX3)        Loading 'l3backend-pdftex.def' aborted!
> (LaTeX3)
> (LaTeX3)        The L3 programming layer in the LaTeX format
> (LaTeX3)        is dated 2021-01-09, but in your TeX tree the files require
> (LaTeX3)        at least 2021-02-18.
> ---------------
>
> which I'm unable to get rid of. (This is of course not a question for
> this group but if anyone had similar problems I'd be grateful for
> pointers ;-);  fmtutil-sys --all and fmtutil-user --all did nothing to
> alleviate this)
>
> So: I'd really like to keep using natbib and make it somehow insert
> the information about the .bib file into the .tex when exporting. How
> do I do that?
>
> Thank you again for your help!
>
> Best regards,
>
> Leszek.
>


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re:Re: New user experience ct'd: exporting citations into LaTeX (9.5)
  2021-10-13 21:34 ` Bruce D'Arcus
@ 2021-10-13 21:40   ` tumashu
  2021-10-14  9:44   ` Leszek Wroński
  1 sibling, 0 replies; 5+ messages in thread
From: tumashu @ 2021-10-13 21:40 UTC (permalink / raw)
  To: Bruce D'Arcus; +Cc: Leszek Wroński, org-mode-email

[-- Attachment #1: Type: text/plain, Size: 2668 bytes --]



#+print_bibliography seem to not document in info.
(require 'oc-csl) is not too.







--
发自我的网易邮箱手机智能版
<br/><br/><br/>


----- Original Message -----
From: "Bruce D'Arcus" <bdarcus@gmail.com>
To: "Leszek Wroński" <elwro1@gmail.com>
Cc: org-mode-email <emacs-orgmode@gnu.org>
Sent: Wed, 13 Oct 2021 17:34:50 -0400
Subject: Re: New user experience ct'd: exporting citations into LaTeX (9.5)

Try adding this where you want the bibliography.


#+print_bibliography:






On Wed, Oct 13, 2021 at 5:27 PM Leszek Wroński <elwro1@gmail.com> wrote:
>
> Guys,
>
> thank you very much for your responses to my previous query. (I will
> study the ebib package more closely; as of now it does not seem to
> work with the file fields in my Mendeley-created .bib file. (Yes, I
> promise will stop using Mendeley.))
>
> I wanted to try the two LaTeX export processors mentioned in the 15.2
> section of the manual: natbib and biblatex. My .org file has a
> #+bibliography line specifying my .bib (which is correct, since
> inserting citations is now working). I put both (use-package
> oc-natbib) and (use-package oc-biblatex) in my .emacs . (I've used
> natbib for years when writing .tex documents; I don't know biblatex.)
>
> The situation is as follows:
> -- if I put #+cite_export: natbib at the beginning of my .org file,
> then C-c C-e l L gives me a LaTeX file which does *not* specify the
> .bib file; it has \citep{} commands where they should be, but of
> course bibtex doesn't know what to do with them;
> -- if I use #+cite_export: biblatex instead, then the resulting .tex
> file does contain the \addbibresource{} line pointing to my .bib , and
> \autocite{} commands where citations should be; however, I simply
> cannot get this to work: Biber works alright, but eventually pdflatex
> gives me the following error:
>
> --------------
> ERROR: LaTeX3 Error: Mismatched LaTeX support files detected.
>
> --- TeX said ---
> (LaTeX3)        Loading 'l3backend-pdftex.def' aborted!
> (LaTeX3)
> (LaTeX3)        The L3 programming layer in the LaTeX format
> (LaTeX3)        is dated 2021-01-09, but in your TeX tree the files require
> (LaTeX3)        at least 2021-02-18.
> ---------------
>
> which I'm unable to get rid of. (This is of course not a question for
> this group but if anyone had similar problems I'd be grateful for
> pointers ;-);  fmtutil-sys --all and fmtutil-user --all did nothing to
> alleviate this)
>
> So: I'd really like to keep using natbib and make it somehow insert
> the information about the .bib file into the .tex when exporting. How
> do I do that?
>
> Thank you again for your help!
>
> Best regards,
>
> Leszek.
>

[-- Attachment #2: Type: text/html, Size: 5274 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [OT] Ebib file field [was: New user experience ct'd: exporting citations into LaTeX (9.5)]
  2021-10-13 21:23 New user experience ct'd: exporting citations into LaTeX (9.5) Leszek Wroński
  2021-10-13 21:34 ` Bruce D'Arcus
@ 2021-10-13 21:50 ` Joost Kremers
  1 sibling, 0 replies; 5+ messages in thread
From: Joost Kremers @ 2021-10-13 21:50 UTC (permalink / raw)
  To: Leszek Wroński; +Cc: emacs-orgmode


On Wed, Oct 13 2021, Leszek Wroński wrote:
> thank you very much for your responses to my previous query. (I will
> study the ebib package more closely; as of now it does not seem to
> work with the file fields in my Mendeley-created .bib file.

This can probably be remedied with a little Elisp. There's a user option
`ebib-file-name-mod-function`, which is called to convert the contents of the
`file` field into a file name that can be passed to a pdf viewer (and vice
versa).

An example is in this Github issue:

https://github.com/joostkremers/ebib/issues/126

If your Elisp fu isn't too strong, I should be able to help.


-- 
Joost Kremers
Life has its moments


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: New user experience ct'd: exporting citations into LaTeX (9.5)
  2021-10-13 21:34 ` Bruce D'Arcus
  2021-10-13 21:40   ` tumashu
@ 2021-10-14  9:44   ` Leszek Wroński
  1 sibling, 0 replies; 5+ messages in thread
From: Leszek Wroński @ 2021-10-14  9:44 UTC (permalink / raw)
  To: Bruce D'Arcus; +Cc: org-mode-email

Thank you very much! For some mistaken reason I assumed this would
only point to the location of the bibliography section of the
generated file, but now I understand that it serves a double role,
specifying the .bib file too.

Thanks again!

Best regards,

Leszek.

On Wed, 13 Oct 2021 at 23:35, Bruce D'Arcus <bdarcus@gmail.com> wrote:
>
> Try adding this where you want the bibliography.
>
> #+print_bibliography:
>
> On Wed, Oct 13, 2021 at 5:27 PM Leszek Wroński <elwro1@gmail.com> wrote:
> >
> > Guys,
> >
> > thank you very much for your responses to my previous query. (I will
> > study the ebib package more closely; as of now it does not seem to
> > work with the file fields in my Mendeley-created .bib file. (Yes, I
> > promise will stop using Mendeley.))
> >
> > I wanted to try the two LaTeX export processors mentioned in the 15.2
> > section of the manual: natbib and biblatex. My .org file has a
> > #+bibliography line specifying my .bib (which is correct, since
> > inserting citations is now working). I put both (use-package
> > oc-natbib) and (use-package oc-biblatex) in my .emacs . (I've used
> > natbib for years when writing .tex documents; I don't know biblatex.)
> >
> > The situation is as follows:
> > -- if I put #+cite_export: natbib at the beginning of my .org file,
> > then C-c C-e l L gives me a LaTeX file which does *not* specify the
> > .bib file; it has \citep{} commands where they should be, but of
> > course bibtex doesn't know what to do with them;
> > -- if I use #+cite_export: biblatex instead, then the resulting .tex
> > file does contain the \addbibresource{} line pointing to my .bib , and
> > \autocite{} commands where citations should be; however, I simply
> > cannot get this to work: Biber works alright, but eventually pdflatex
> > gives me the following error:
> >
> > --------------
> > ERROR: LaTeX3 Error: Mismatched LaTeX support files detected.
> >
> > --- TeX said ---
> > (LaTeX3)        Loading 'l3backend-pdftex.def' aborted!
> > (LaTeX3)
> > (LaTeX3)        The L3 programming layer in the LaTeX format
> > (LaTeX3)        is dated 2021-01-09, but in your TeX tree the files require
> > (LaTeX3)        at least 2021-02-18.
> > ---------------
> >
> > which I'm unable to get rid of. (This is of course not a question for
> > this group but if anyone had similar problems I'd be grateful for
> > pointers ;-);  fmtutil-sys --all and fmtutil-user --all did nothing to
> > alleviate this)
> >
> > So: I'd really like to keep using natbib and make it somehow insert
> > the information about the .bib file into the .tex when exporting. How
> > do I do that?
> >
> > Thank you again for your help!
> >
> > Best regards,
> >
> > Leszek.
> >


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-10-14  9:45 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-13 21:23 New user experience ct'd: exporting citations into LaTeX (9.5) Leszek Wroński
2021-10-13 21:34 ` Bruce D'Arcus
2021-10-13 21:40   ` tumashu
2021-10-14  9:44   ` Leszek Wroński
2021-10-13 21:50 ` [OT] Ebib file field [was: New user experience ct'd: exporting citations into LaTeX (9.5)] Joost Kremers

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).