emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug if `org-refile-use-outline-path' is set to 'file
@ 2009-04-01  7:56 Tassilo Horn
  2009-04-01 12:19 ` Eraldo Helal
  2009-04-01 13:56 ` Carsten Dominik
  0 siblings, 2 replies; 12+ messages in thread
From: Tassilo Horn @ 2009-04-01  7:56 UTC (permalink / raw)
  To: emacs-orgmode

Hi all,

the docs state:

,----[ C-h v org-refile-use-outline-path RET ]
| org-refile-use-outline-path is a variable defined in `org.el'.
| Its value is t
| 
| Documentation:
| Non-nil means, provide refile targets as paths.
| So a level 3 headline will be available as level1/level2/level3.
| When the value is `file', also include the file name (without directory)
| into the path.  When `full-file-path', include the full file path.
`----

With the current setting t I get completions like

     head1/head2 (file1.org)

which is nice, but I'd prefer

     file1.org/head1/head2

To me the docs sound like 'file would do that and the customize option
strengthen this by saying "Start with file".  Unfortunately, then I get
completions like

     file1.org/ (file1.org)

with no headlines at all.

I'm using a current git version on Emacs 23.

Bye,
Tassilo

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01  7:56 Bug if `org-refile-use-outline-path' is set to 'file Tassilo Horn
@ 2009-04-01 12:19 ` Eraldo Helal
  2009-04-01 13:16   ` Tassilo Horn
  2009-04-01 13:56 ` Carsten Dominik
  1 sibling, 1 reply; 12+ messages in thread
From: Eraldo Helal @ 2009-04-01 12:19 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 1690 bytes --]

Hi Tassilo!

I am having the same problem.
I understood the manual it in the same way you did.

I also found out, that if I enter file as the value for that variable...
and then check again what is assigned to it... it shows the path to my
.emacs file!
In other words... it interpretes file as the file I am in when customizing,
instead of the word file.
If I set it to "file" => I get the same as if set to "t" ...I think that is
the same problem you have.

Greetings,
Eraldo

On Wed, Apr 1, 2009 at 09:56, Tassilo Horn <tassilo@member.fsf.org> wrote:

> Hi all,
>
> the docs state:
>
> ,----[ C-h v org-refile-use-outline-path RET ]
> | org-refile-use-outline-path is a variable defined in `org.el'.
> | Its value is t
> |
> | Documentation:
> | Non-nil means, provide refile targets as paths.
> | So a level 3 headline will be available as level1/level2/level3.
> | When the value is `file', also include the file name (without directory)
> | into the path.  When `full-file-path', include the full file path.
> `----
>
> With the current setting t I get completions like
>
>     head1/head2 (file1.org)
>
> which is nice, but I'd prefer
>
>     file1.org/head1/head2
>
> To me the docs sound like 'file would do that and the customize option
> strengthen this by saying "Start with file".  Unfortunately, then I get
> completions like
>
>     file1.org/ (file1.org)
>
> with no headlines at all.
>
> I'm using a current git version on Emacs 23.
>
> Bye,
> Tassilo
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
>

[-- Attachment #1.2: Type: text/html, Size: 2528 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01 12:19 ` Eraldo Helal
@ 2009-04-01 13:16   ` Tassilo Horn
  2009-04-03 22:48     ` Eraldo Helal
  0 siblings, 1 reply; 12+ messages in thread
From: Tassilo Horn @ 2009-04-01 13:16 UTC (permalink / raw)
  To: emacs-orgmode

Eraldo Helal <admin@eraldo.at> writes:

Hi Eraldo,

> I am having the same problem.
> I understood the manual it in the same way you did.
>
> I also found out, that if I enter file as the value for that
> variable...  and then check again what is assigned to it... it shows
> the path to my .emacs file!

How do you set it?  With M-x set-variable RET ..., or with M-: (setq
...)?  In each case you have to quote file, e.g. say 'file.

Bye,
Tassilo
-- 
Some people  wear Linus Torvalds  pyjama's to bed, Linus  Torvalds wears
RMS pyjama's.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01  7:56 Bug if `org-refile-use-outline-path' is set to 'file Tassilo Horn
  2009-04-01 12:19 ` Eraldo Helal
@ 2009-04-01 13:56 ` Carsten Dominik
  2009-04-01 18:37   ` Tassilo Horn
  1 sibling, 1 reply; 12+ messages in thread
From: Carsten Dominik @ 2009-04-01 13:56 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode

Hi Tassilo,

There are two things to this.

First, there was a bug (now fixed) which caused the file name to show  
up twice, both as part of the outline path, and then behind it in  
parenthesis.

Fixed now.

The second part of the story is that you have org-outline-path- 
complete-in-steps
set to t, which means that the first headline level will only show up  
when you have completed the file name.

HTH.

- Carsten

On Apr 1, 2009, at 9:56 AM, Tassilo Horn wrote:

> Hi all,
>
> the docs state:
>
> ,----[ C-h v org-refile-use-outline-path RET ]
> | org-refile-use-outline-path is a variable defined in `org.el'.
> | Its value is t
> |
> | Documentation:
> | Non-nil means, provide refile targets as paths.
> | So a level 3 headline will be available as level1/level2/level3.
> | When the value is `file', also include the file name (without  
> directory)
> | into the path.  When `full-file-path', include the full file path.
> `----
>
> With the current setting t I get completions like
>
>     head1/head2 (file1.org)
>
> which is nice, but I'd prefer
>
>     file1.org/head1/head2
>
> To me the docs sound like 'file would do that and the customize option
> strengthen this by saying "Start with file".  Unfortunately, then I  
> get
> completions like
>
>     file1.org/ (file1.org)
>
> with no headlines at all.
>
> I'm using a current git version on Emacs 23.
>
> Bye,
> Tassilo
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01 13:56 ` Carsten Dominik
@ 2009-04-01 18:37   ` Tassilo Horn
  2009-04-02  7:23     ` Carsten Dominik
  0 siblings, 1 reply; 12+ messages in thread
From: Tassilo Horn @ 2009-04-01 18:37 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <carsten.dominik@gmail.com> writes:

Hi Carsten,

> There are two things to this.
>
> First, there was a bug (now fixed) which caused the file name to show
> up twice, both as part of the outline path, and then behind it in
> parenthesis.
>
> Fixed now.

Great!

> The second part of the story is that you have
> org-outline-path-complete-in-steps set to t, which means that the
> first headline level will only show up when you have completed the
> file name.

Ok, I've set it to nil now, and the completion buffer now shows

    file.org/head1/head2

as I like it.  Great!

With this step-wise completion I only get file.org/ but I cannot select
it.  Completing to file.org/ and hitting RET causes a short flickering,
but no new completion possibilities, e.g. the headlines in file.org.

Anyway, I like the way it works now.

Thanks a lot, Carsten!
Tassilo
-- 
Richard Stallman can touch MC Hammer

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01 18:37   ` Tassilo Horn
@ 2009-04-02  7:23     ` Carsten Dominik
  2009-04-02  8:02       ` Tassilo Horn
  0 siblings, 1 reply; 12+ messages in thread
From: Carsten Dominik @ 2009-04-02  7:23 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode


On Apr 1, 2009, at 8:37 PM, Tassilo Horn wrote:

> Carsten Dominik <carsten.dominik@gmail.com> writes:
>
> Hi Carsten,
>
>> There are two things to this.
>>
>> First, there was a bug (now fixed) which caused the file name to show
>> up twice, both as part of the outline path, and then behind it in
>> parenthesis.
>>
>> Fixed now.
>
> Great!
>
>> The second part of the story is that you have
>> org-outline-path-complete-in-steps set to t, which means that the
>> first headline level will only show up when you have completed the
>> file name.
>
> Ok, I've set it to nil now, and the completion buffer now shows
>
>    file.org/head1/head2
>
> as I like it.  Great!
>
> With this step-wise completion I only get file.org/ but I cannot  
> select
> it.  Completing to file.org/ and hitting RET causes a short  
> flickering,
> but no new completion possibilities, e.g. the headlines in file.org.

The idea is not to select it, but to hit TAB to get to the
next completion step.  So type a few letters of the file
name, TAB to complete the file name, TAB again to see the
top level headings in that file etc.

To me this is how completion works in Emacs - are you using the
mouse?

- Carsten

>
> Anyway, I like the way it works now.
>
> Thanks a lot, Carsten!
> Tassilo
> -- 
> Richard Stallman can touch MC Hammer
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-02  7:23     ` Carsten Dominik
@ 2009-04-02  8:02       ` Tassilo Horn
  2009-04-02  9:45         ` Carsten Dominik
  0 siblings, 1 reply; 12+ messages in thread
From: Tassilo Horn @ 2009-04-02  8:02 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode

Carsten Dominik <carsten.dominik@gmail.com> writes:

Hi Carsten,

>> With this step-wise completion I only get file.org/ but I cannot
>> select it.  Completing to file.org/ and hitting RET causes a short
>> flickering, but no new completion possibilities, e.g. the headlines
>> in file.org.
>
> The idea is not to select it, but to hit TAB to get to the next
> completion step.  So type a few letters of the file name, TAB to
> complete the file name, TAB again to see the top level headings in
> that file etc.

That's what I'm doing.  After I've completed to file.org/ an additional
TAB won't add the headings as new completion possibilities, file.org/ is
the only one.  The same with RET.

> To me this is how completion works in Emacs

Yes, for me, too.  I use ido if it makes a difference, but the refile
completions doesn't use it anyway here.  To be on the safe side I
disabled it when testing and got the same result.

> - are you using the mouse?

The what?!? ;-)

Bye,
Tassilo

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-02  8:02       ` Tassilo Horn
@ 2009-04-02  9:45         ` Carsten Dominik
  2009-04-02 18:52           ` Tassilo Horn
  0 siblings, 1 reply; 12+ messages in thread
From: Carsten Dominik @ 2009-04-02  9:45 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode


On Apr 2, 2009, at 10:02 AM, Tassilo Horn wrote:

> Carsten Dominik <carsten.dominik@gmail.com> writes:
>
> Hi Carsten,
>
>>> With this step-wise completion I only get file.org/ but I cannot
>>> select it.  Completing to file.org/ and hitting RET causes a short
>>> flickering, but no new completion possibilities, e.g. the headlines
>>> in file.org.
>>
>> The idea is not to select it, but to hit TAB to get to the next
>> completion step.  So type a few letters of the file name, TAB to
>> complete the file name, TAB again to see the top level headings in
>> that file etc.
>
> That's what I'm doing.  After I've completed to file.org/ an  
> additional
> TAB won't add the headings as new completion possibilities,  
> file.org/ is
> the only one.  The same with RET.

Very strange.  This does work find for me.  Can you tyr to make a test  
setup with minimal configuration and just 1 or 2 files?

- Carsten

>
>> To me this is how completion works in Emacs
>
> Yes, for me, too.  I use ido if it makes a difference, but the refile
> completions doesn't use it anyway here.  To be on the safe side I
> disabled it when testing and got the same result.
>
>> - are you using the mouse?
>
> The what?!? ;-)

OK, I am relieved to hear that.

>
> Bye,
> Tassilo

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-02  9:45         ` Carsten Dominik
@ 2009-04-02 18:52           ` Tassilo Horn
  2009-04-03  7:49             ` Carsten Dominik
  0 siblings, 1 reply; 12+ messages in thread
From: Tassilo Horn @ 2009-04-02 18:52 UTC (permalink / raw)
  To: emacs-orgmode

Carsten Dominik <carsten.dominik@gmail.com> writes:

Hi Carsten,

>> That's what I'm doing.  After I've completed to file.org/ an
>> additional TAB won't add the headings as new completion
>> possibilities, file.org/ is the only one.  The same with RET.
>
> Very strange.  This does work find for me.  Can you tyr to make a test
> setup with minimal configuration and just 1 or 2 files?

Done that, and this line of my .emacs broke the completion:

  (setq completion-styles (remove 'basic completion-styles))

After deleting it, I can complete in steps as it should be.

>>> - are you using the mouse?
>>
>> The what?!? ;-)
>
> OK, I am relieved to hear that.

;-)

Bye,
Tassilo
-- 
No person,  no idea, and no  religion deserves to be  illegal to insult,
not even the Church of Emacs. (Richard M. Stallman)

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-02 18:52           ` Tassilo Horn
@ 2009-04-03  7:49             ` Carsten Dominik
  2009-04-03  9:03               ` Tassilo Horn
  0 siblings, 1 reply; 12+ messages in thread
From: Carsten Dominik @ 2009-04-03  7:49 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode


On Apr 2, 2009, at 8:52 PM, Tassilo Horn wrote:

> Carsten Dominik <carsten.dominik@gmail.com> writes:
>
> Hi Carsten,
>
>>> That's what I'm doing.  After I've completed to file.org/ an
>>> additional TAB won't add the headings as new completion
>>> possibilities, file.org/ is the only one.  The same with RET.
>>
>> Very strange.  This does work find for me.  Can you tyr to make a  
>> test
>> setup with minimal configuration and just 1 or 2 files?
>
> Done that, and this line of my .emacs broke the completion:
>
>  (setq completion-styles (remove 'basic completion-styles))
>
> After deleting it, I can complete in steps as it should be.

What reason did you have to add this line in the first place?
Just curious.

- Carsten

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-03  7:49             ` Carsten Dominik
@ 2009-04-03  9:03               ` Tassilo Horn
  0 siblings, 0 replies; 12+ messages in thread
From: Tassilo Horn @ 2009-04-03  9:03 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: emacs-orgmode

Carsten Dominik <carsten.dominik@gmail.com> writes:

Hi Carsten,

>> Done that, and this line of my .emacs broke the completion:
>>
>>  (setq completion-styles (remove 'basic completion-styles))
>>
>> After deleting it, I can complete in steps as it should be.
>
> What reason did you have to add this line in the first place?
> Just curious.

Some time ago completion didn't seem to do partial completion if basic
was in that list.  Now I tried again and it seems to work fine even with
basic in it.

Bye,
Tassilo

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Re: Bug if `org-refile-use-outline-path' is set to 'file
  2009-04-01 13:16   ` Tassilo Horn
@ 2009-04-03 22:48     ` Eraldo Helal
  0 siblings, 0 replies; 12+ messages in thread
From: Eraldo Helal @ 2009-04-03 22:48 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 172 bytes --]

>
> How do you set it?  With M-x set-variable RET ..., or with M-: (setq
> ...)?  In each case you have to quote file, e.g. say 'file.
>
Thank you, works like a charm now.

[-- Attachment #1.2: Type: text/html, Size: 377 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2009-04-03 22:49 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-04-01  7:56 Bug if `org-refile-use-outline-path' is set to 'file Tassilo Horn
2009-04-01 12:19 ` Eraldo Helal
2009-04-01 13:16   ` Tassilo Horn
2009-04-03 22:48     ` Eraldo Helal
2009-04-01 13:56 ` Carsten Dominik
2009-04-01 18:37   ` Tassilo Horn
2009-04-02  7:23     ` Carsten Dominik
2009-04-02  8:02       ` Tassilo Horn
2009-04-02  9:45         ` Carsten Dominik
2009-04-02 18:52           ` Tassilo Horn
2009-04-03  7:49             ` Carsten Dominik
2009-04-03  9:03               ` Tassilo Horn

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).