emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Capture template --- :empty-lines 1 results in error
@ 2012-08-14 21:30 Alan E. Davis
  2012-08-15  1:47 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Alan E. Davis @ 2012-08-14 21:30 UTC (permalink / raw)
  To: org-mode

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

This may be a bug?

I have this template in my list of templates, to open the file with my
templates, so I could edit it:

       ("i" "Edit ~/org/capture-templates.2.el" plain (file
"~/org/capture-templates.2.el") "" :empty-lines 1 :unnarrowed t)

I started to get an error when running this template, and a few others.
This started somewhat recently, but I don't know exactly when.

    When I removed the ":empty-lines 1" part, the template worked fine.

        ("i" "Edit ~/org/capture-templates.2.el" plain (file
"~/org/capture-templates.2.el") " "  :unnarrowed t)

I am pretty sure that this is not only from the "empty-lines 1 part.
Another template with this option does work ok, but has ":prepend t".

Alan Davis

[-- Attachment #2: Type: text/html, Size: 905 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Capture template --- :empty-lines 1 results in error
  2012-08-14 21:30 Capture template --- :empty-lines 1 results in error Alan E. Davis
@ 2012-08-15  1:47 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2012-08-15  1:47 UTC (permalink / raw)
  To: Alan E. Davis; +Cc: org-mode

Hi Alan,

"Alan E. Davis" <lngndvs@gmail.com> writes:

> This may be a bug?
>
> I have this template in my list of templates, to open the file with
> my templates, so I could edit it:
>
>        ("i" "Edit ~/org/capture-templates.2.el" plain (file "~/org/
> capture-templates.2.el") "" :empty-lines 1 :unnarrowed t)
>
> I started to get an error when running this template, and a few
> others.  

Can you tell what error?

(setq debug-on-error t)

> This started somewhat recently, but I don't know exactly
> when. 
>
>     When I removed the ":empty-lines 1" part, the template worked
> fine.  
>
>         ("i" "Edit ~/org/capture-templates.2.el" plain (file "~/org/
> capture-templates.2.el") " "  :unnarrowed t)
>
> I am pretty sure that this is not only from the "empty-lines 1
> part.   Another template with this option does work ok, but has
> ":prepend t".

Hard to reproduce... perhaps you can try to bisect and find the 
culprit commit?  Or just rewind a bit and tell what version works
for sure, and what version doesn't?

Thanks in advance,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-08-15  1:47 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-08-14 21:30 Capture template --- :empty-lines 1 results in error Alan E. Davis
2012-08-15  1:47 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).