emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-bibtex-read error calling bibtex-parse-entry
@ 2014-04-24  8:56 Mathäus Meyer
  2014-04-29 12:32 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Mathäus Meyer @ 2014-04-24  8:56 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

I cannot get org-bibtex to work for me. Tried in a clean emacs -Q. Emacs-
Version: 24.4.50, org-vesion: 8.2.6

Calling org-bibtex-read leads, independent of the bibtex entry used on (I 
tried everything, including the example of the org-bibtex-documentation), to 
the following error:

Debugger entered--Lisp error: (wrong-type-argument stringp nil)
  looking-at(nil)
  bibtex-parse-entry()
  org-bibtex-read()
  call-interactively(org-bibtex-read record nil)
  command-execute(org-bibtex-read record)
  execute-extended-command(nil "org-bibtex-read")
  call-interactively(execute-extended-command nil nil)
  command-execute(execute-extended-command)

I am sorry if this is the wrong place, but I am not sure how to test if 
bibtex-parse-entry is the real culprit. I would, of course, understand if I 
cannot get help here for the pre-release snapshot of Emacs I am using.

Mathäus.

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: org-bibtex-read error calling bibtex-parse-entry
  2014-04-24  8:56 org-bibtex-read error calling bibtex-parse-entry Mathäus Meyer
@ 2014-04-29 12:32 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2014-04-29 12:32 UTC (permalink / raw)
  To: Mathäus Meyer; +Cc: emacs-orgmode

Hi Mathäus,

Mathäus Meyer <math.meyer@web.de> writes:

> I cannot get org-bibtex to work for me. Tried in a clean emacs -Q. Emacs-
> Version: 24.4.50, org-vesion: 8.2.6
>
> Calling org-bibtex-read leads, independent of the bibtex entry used on (I 
> tried everything, including the example of the org-bibtex-documentation), to 
> the following error:
>
> Debugger entered--Lisp error: (wrong-type-argument stringp nil)
>   looking-at(nil)
>   bibtex-parse-entry()
>   org-bibtex-read()
>   call-interactively(org-bibtex-read record nil)
>   command-execute(org-bibtex-read record)
>   execute-extended-command(nil "org-bibtex-read")
>   call-interactively(execute-extended-command nil nil)
>   command-execute(execute-extended-command)
>
> I am sorry if this is the wrong place, but I am not sure how to test if 
> bibtex-parse-entry is the real culprit. I would, of course, understand if I 
> cannot get help here for the pre-release snapshot of Emacs I am using.

No worry, this is the right place to ask.

The function `bibtex-parse-entry' is using a regular expression called
`bibtex-entry-maybe-empty-head' to retrieve information from the point
location about the entry to parse.

The "looking-at(nil)" part of your error means this variable is not
set when `bibtex-parse-entry' -- while looking at the docstring of
`bibtex-entry-maybe-empty-head' I found `bibtex-set-dialect'... which
leaves us with the problem of correctly setting the dialect for the
buffer.

I don't know where to go from there, but you surely can dig further,
or someone else can help.

Best,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-04-29 12:33 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-04-24  8:56 org-bibtex-read error calling bibtex-parse-entry Mathäus Meyer
2014-04-29 12:32 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).