emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-odt: turning off section numbering does not work
@ 2011-10-17 14:07 Mehul Sanghvi
  2011-10-17 16:31 ` Christian Moe
  0 siblings, 1 reply; 8+ messages in thread
From: Mehul Sanghvi @ 2011-10-17 14:07 UTC (permalink / raw)
  To: emacs-orgmode

I have the following in my org file:


#+OPTIONS: toc:nil H:10 num:nil



Yet in my ODT file I get numbered sections:

    1. Work Experience

     1.1.1   Company A

     1.1.2   Company B

   2.  Skills

   3.  Education


Am I doing something wrong ?  Or is there another option that I am not
aware of ?

-- 
Mehul N. Sanghvi
email: mehul.sanghvi@gmail.com

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-17 14:07 org-odt: turning off section numbering does not work Mehul Sanghvi
@ 2011-10-17 16:31 ` Christian Moe
  2011-10-17 16:58   ` Mehul Sanghvi
  0 siblings, 1 reply; 8+ messages in thread
From: Christian Moe @ 2011-10-17 16:31 UTC (permalink / raw)
  To: Mehul Sanghvi; +Cc: Org Mode

Hi,

According to this thread, num:nil should work in recent versions of Org:
http://comments.gmane.org/gmane.emacs.orgmode/46058

It works for me.

You might try updating to the most recent version of Org and see if 
that fixes things.

As a one-off fix, in OpenOffice you can turn off the numbering with 
Tools > Outline Numbering. For each of the three heading levels that 
are numbered, you need to set Number to None, and delete the dot in 
Separator After.

Yours,
Christian



On 10/17/11 4:07 PM, Mehul Sanghvi wrote:
> I have the following in my org file:
>
>
> #+OPTIONS: toc:nil H:10 num:nil
>
>
>
> Yet in my ODT file I get numbered sections:
>
>      1. Work Experience
>
>       1.1.1   Company A
>
>       1.1.2   Company B
>
>     2.  Skills
>
>     3.  Education
>
>
> Am I doing something wrong ?  Or is there another option that I am not
> aware of ?
>

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-17 16:31 ` Christian Moe
@ 2011-10-17 16:58   ` Mehul Sanghvi
       [not found]     ` <4443.1318874420@alphaville.americas.hpqcorp.net>
  0 siblings, 1 reply; 8+ messages in thread
From: Mehul Sanghvi @ 2011-10-17 16:58 UTC (permalink / raw)
  To: Org Mode

I have seen that thread before, and am using the latest Org from the
git repository.
That is why I was wondering if I'd missed something or not.

I just tried this with a new Emacs, and the test.org file that comes
with org-odt.

I changed test.org so that num: is nil and it still had section
numbering enabled.

Since I am trying to do this as an automated method, I do not want to
fire up LibreOffice/OpenOffice each time
I make a change to my resume, and lots of times I am doing it over a
ssh connection with no X displaying
back.

cheers,

     mehul

On Mon, Oct 17, 2011 at 12:31, Christian Moe <mail@christianmoe.com> wrote:
> Hi,
>
> According to this thread, num:nil should work in recent versions of Org:
> http://comments.gmane.org/gmane.emacs.orgmode/46058
>
> It works for me.
>
> You might try updating to the most recent version of Org and see if that
> fixes things.
>
> As a one-off fix, in OpenOffice you can turn off the numbering with Tools >
> Outline Numbering. For each of the three heading levels that are numbered,
> you need to set Number to None, and delete the dot in Separator After.
>
> Yours,
> Christian
>
>
>
> On 10/17/11 4:07 PM, Mehul Sanghvi wrote:
>>
>> I have the following in my org file:
>>
>>
>> #+OPTIONS: toc:nil H:10 num:nil
>>
>>
>>
>> Yet in my ODT file I get numbered sections:
>>
>>     1. Work Experience
>>
>>      1.1.1   Company A
>>
>>      1.1.2   Company B
>>
>>    2.  Skills
>>
>>    3.  Education
>>
>>
>> Am I doing something wrong ?  Or is there another option that I am not
>> aware of ?
>>
>
>



-- 
Mehul N. Sanghvi
email: mehul.sanghvi@gmail.com

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
       [not found]     ` <4443.1318874420@alphaville.americas.hpqcorp.net>
@ 2011-10-17 18:31       ` Mehul Sanghvi
  2011-10-17 19:15         ` Christian Moe
  2011-10-18 12:12         ` Jambunathan K
  0 siblings, 2 replies; 8+ messages in thread
From: Mehul Sanghvi @ 2011-10-17 18:31 UTC (permalink / raw)
  To: emacs-orgmode

On Mon, Oct 17, 2011 at 14:00, Nick Dokos <nicholas.dokos@hp.com> wrote:
>
> My (factually-baseless but best-that-I-can-do given the paucity
> of information you provide) guess is that you are not running the
> version you think you are running.
>
> Nick
>


What I have is Org-mode version 7.5 (baseline.533.ga5129.dirty), so it seems
your factually-baseless guess is correct.


% git remote -v
origin	http://repo.or.cz/r/org-mode/org-jambu.git (fetch)
origin	http://repo.or.cz/r/org-mode/org-jambu.git (push)


I have been pulling from the wrong repository.


cheers,

      mehul


-- 
Mehul N. Sanghvi
email: mehul.sanghvi@gmail.com

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-17 18:31       ` Mehul Sanghvi
@ 2011-10-17 19:15         ` Christian Moe
  2011-10-18 12:05           ` Jambunathan K
  2011-10-18 12:12         ` Jambunathan K
  1 sibling, 1 reply; 8+ messages in thread
From: Christian Moe @ 2011-10-17 19:15 UTC (permalink / raw)
  To: Mehul Sanghvi; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1516 bytes --]

That probably explains it, then.

But, uh, can I borrow this thread for a moment?

I find custom styles in ODT export aren't working as per the manual, 
section 12.8.2. Here's what I've done (test files attached; Emacs 
23.3.1; Org 7.7, freshly pulled):

1. Exported test-odt.org to ODT with default settings.
2. In OpenOffice: Changed the Heading 1 style in the exported ODT 
document to red, then saved it as styles.odt.
3. Pointed org-export-odt-styles-file to styles.odt.
4. Exported test-odt.org to test-odt.odt. Result: no headings at all 
-- everything's in the Default style.

This is how I understand the manual, and the thread I referenced 
before, and I remember having tested it before at some point when it 
worked perfectly, so I'm rubbing my eyes and wondering if it's just 
me. Could I ask someone to please check?

Yours,
Christian


On 10/17/11 8:31 PM, Mehul Sanghvi wrote:
> On Mon, Oct 17, 2011 at 14:00, Nick Dokos<nicholas.dokos@hp.com>  wrote:
>>
>> My (factually-baseless but best-that-I-can-do given the paucity
>> of information you provide) guess is that you are not running the
>> version you think you are running.
>>
>> Nick
>>
>
>
> What I have is Org-mode version 7.5 (baseline.533.ga5129.dirty), so it seems
> your factually-baseless guess is correct.
>
>
> % git remote -v
> origin	http://repo.or.cz/r/org-mode/org-jambu.git (fetch)
> origin	http://repo.or.cz/r/org-mode/org-jambu.git (push)
>
>
> I have been pulling from the wrong repository.
>
>
> cheers,
>
>        mehul
>
>


[-- Attachment #2: test-odt.org --]
[-- Type: text/plain, Size: 165 bytes --]

#+title: Test ODT export
#+options: toc:nil num:nil

(setq org-export-odt-styles-file "~/org/odt/styles.odt")

* Heading

Bla bla

* Heading

** Subheading

Bla bla

[-- Attachment #3: test-odt.odt --]
[-- Type: application/vnd.oasis.opendocument.text, Size: 7689 bytes --]

[-- Attachment #4: styles.odt --]
[-- Type: application/vnd.oasis.opendocument.text, Size: 12101 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-17 19:15         ` Christian Moe
@ 2011-10-18 12:05           ` Jambunathan K
  2011-10-18 13:17             ` Christian Moe
  0 siblings, 1 reply; 8+ messages in thread
From: Jambunathan K @ 2011-10-18 12:05 UTC (permalink / raw)
  To: mail; +Cc: emacs-orgmode


Hello Christian

Christian Moe <mail@christianmoe.com> writes:

> That probably explains it, then.
>
> But, uh, can I borrow this thread for a moment?
>
> I find custom styles in ODT export aren't working as per the manual,
> section 12.8.2. Here's what I've done (test files attached; Emacs
> 23.3.1; Org 7.7, freshly pulled):
>
> 1. Exported test-odt.org to ODT with default settings.
> 2. In OpenOffice: Changed the Heading 1 style in the exported ODT
> document to red, then saved it as styles.odt.

When you are generating such a custom styles file for templating
purposes, it is highly desirable that H:10 num:t be option used. This is
because the Org's odt exporter expects that the default styles file has
outline numbering turned on for all levels (Number 10 above being the
max outline levels in styles.xml)

If this assumption is violated - ie if the template file is generated
with num:nil (which is the case with the styles file circulated by you)
- then subsequently changing the

#+OPTIONS: num:t

will continue to produce the unnumbered headings contrary to the
expectations.

I believe the above restriction is not overly restrictive.

> 3. Pointed org-export-odt-styles-file to styles.odt.
> 4. Exported test-odt.org to test-odt.odt. Result: no headings at all
> -- everything's in the Default style.
>
> This is how I understand the manual, and the thread I referenced
> before, and I remember having tested it before at some point when it
> worked perfectly, so I'm rubbing my eyes and wondering if it's just
> me. Could I ask someone to please check?

I have pushed a fix for this moment ago. Hope things are OK with your
setup.

Jambunathan K.

> Yours,
> Christian
>
>
> On 10/17/11 8:31 PM, Mehul Sanghvi wrote:
>> On Mon, Oct 17, 2011 at 14:00, Nick Dokos<nicholas.dokos@hp.com>  wrote:
>>>
>>> My (factually-baseless but best-that-I-can-do given the paucity
>>> of information you provide) guess is that you are not running the
>>> version you think you are running.
>>>
>>> Nick
>>>
>>
>>
>> What I have is Org-mode version 7.5 (baseline.533.ga5129.dirty), so it seems
>> your factually-baseless guess is correct.
>>
>>
>> % git remote -v
>> origin	http://repo.or.cz/r/org-mode/org-jambu.git (fetch)
>> origin	http://repo.or.cz/r/org-mode/org-jambu.git (push)
>>
>>
>> I have been pulling from the wrong repository.
>>
>>
>> cheers,
>>
>>        mehul
>>
>>
>
>
>
>

-- 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-17 18:31       ` Mehul Sanghvi
  2011-10-17 19:15         ` Christian Moe
@ 2011-10-18 12:12         ` Jambunathan K
  1 sibling, 0 replies; 8+ messages in thread
From: Jambunathan K @ 2011-10-18 12:12 UTC (permalink / raw)
  To: Mehul Sanghvi; +Cc: emacs-orgmode


Mehul

> % git remote -v
> origin	http://repo.or.cz/r/org-mode/org-jambu.git (fetch)
> origin	http://repo.or.cz/r/org-mode/org-jambu.git (push)
>
>
> I have been pulling from the wrong repository.

This git repo shouldn't be used at all.

For the sake of convenience, the ELPA tarball under 
http://repo.or.cz/w/org-mode/org-jambu.git/blob_plain/HEAD:/packages/

is still current.

So the above URL can continue to be used for getting the latest org-odt
through the package manager (as of today)

Jambunathan K.

-- 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: org-odt: turning off section numbering does not work
  2011-10-18 12:05           ` Jambunathan K
@ 2011-10-18 13:17             ` Christian Moe
  0 siblings, 0 replies; 8+ messages in thread
From: Christian Moe @ 2011-10-18 13:17 UTC (permalink / raw)
  To: emacs-orgmode

Hi, Jambunathan,

On 10/18/11 2:05 PM, Jambunathan K wrote:
> When you are generating such a custom styles file for templating
> purposes, it is highly desirable that H:10 num:t be option used.
(...)
> I believe the above restriction is not overly restrictive.

No, that makes good sense, and thanks for pointing it out. I can well 
understand that you don't want to handle "num:t isn't working" 
complaints caused by other people's stylesheets.

>> 3. Pointed org-export-odt-styles-file to styles.odt.
>> 4. Exported test-odt.org to test-odt.odt. Result: no headings at all
>> -- everything's in the Default style.
(...)
> I have pushed a fix for this moment ago. Hope things are OK with your
> setup.

Yes, whatever the problem was, it's gone now. Thanks!

Yours,
Christian

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2011-10-18 13:14 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-10-17 14:07 org-odt: turning off section numbering does not work Mehul Sanghvi
2011-10-17 16:31 ` Christian Moe
2011-10-17 16:58   ` Mehul Sanghvi
     [not found]     ` <4443.1318874420@alphaville.americas.hpqcorp.net>
2011-10-17 18:31       ` Mehul Sanghvi
2011-10-17 19:15         ` Christian Moe
2011-10-18 12:05           ` Jambunathan K
2011-10-18 13:17             ` Christian Moe
2011-10-18 12:12         ` Jambunathan K

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).