emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: "info@bastianebeling.org" <info@bastianebeling.org>
To: emacs-orgmode@gnu.org
Cc: maus.david@gmail.com, Nick Dokos <nicholas.dokos@hp.com>,
	Nicholas Putnam <nputnam@gmail.com>
Subject: Re: org-mobile-push problem
Date: Thu, 3 Nov 2011 11:05:13 +0100	[thread overview]
Message-ID: <81CDB125-0A56-4E14-AB62-4A27A8172C92@bastianebeling.org> (raw)
In-Reply-To: <8628.1320280611@alphaville.americas.hpqcorp.net>

Am 03.11.2011 um 01:36 schrieb Nick Dokos:

> info@bastianebeling.org <info@bastianebeling.org> wrote:
> 
>> 
>> Am 03.11.2011 um 00:28 schrieb Nick Dokos:
>> 
>>> info@bastianebeling.org <info@bastianebeling.org> wrote:
>>> 
>>>>> when I run org-mobile-push:
>>>>> 
>>>>> byte-code: Invalid function: org-eval-in-environment
>>>> 
>>> org-eval-in-environment is a macro defined in org-macs.el and macros
>>> sometimes cause problems with compiled code unless some care is taken.
>>> With uncompiled code, you just have to make sure that the macro
>>> definition is loaded, before you do the org-mobile-push: just add
>>> 
>>> (require 'org-macs)
>>> 
>>> after you load org in your .emacs (or wherever).
>>> 
>>> Afaict, it is not called directly from org-mobile-push, but the agenda
>>> code does call it (and does not require it), so maybe the solution is
>>> that the (require 'org-macs) should be added to org-agenda.el; you might
>>> try it and see whether it resolves the problem for you, but I'll let
>>> David Maus or Achim Gratz or some other macro guru have the final word.
>>> 
>>> Nick
>> 
>> Thank you! Unfortunately, adding (require 'org-macs) to my .emacs
>> and/or to my org-agenda.el didn't help. (I checked and the macro isn't
>> defined in my org-macs.el nor does it appear in any other file on my
>> computer.)
>> 
> 
> What does M-x org-version RET say?

It says "Org-mode version 7.7". However, I feel that there was something strange with my installation. I checked my files in my Emacs folder and everything seemed really messed up, so I just reinstalled org from the latest build and now it works! I had tried that before automatically with the package manager but now I used the package manager to install it from the file. I think that is where the strange installation came from originally. 

Nik, I hope you get it fixed as well. 

Nick and David, thanks for your help!

Bastian

  reply	other threads:[~2011-11-03 10:05 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-11-02 16:16 org-mobile-push problem Nicholas Putnam
2011-11-02 16:29 ` info
2011-11-02 23:28   ` Nick Dokos
2011-11-03  0:09     ` info
2011-11-03  0:36       ` Nick Dokos
2011-11-03 10:05         ` info [this message]
2011-11-03 11:03           ` Jambunathan K
2011-11-03  5:26     ` David Maus
2011-11-03 11:43 info
2011-11-03 12:15 ` Jambunathan K
2011-11-05 22:02   ` info
2011-11-06 21:01     ` Jambunathan K
2011-11-06 21:24       ` info
2011-11-06 21:35         ` Jambunathan K

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=81CDB125-0A56-4E14-AB62-4A27A8172C92@bastianebeling.org \
    --to=info@bastianebeling.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=maus.david@gmail.com \
    --cc=nicholas.dokos@hp.com \
    --cc=nputnam@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).