emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: "info@bastianebeling.org" <info@bastianebeling.org>
To: emacs-orgmode@gnu.org
Cc: Jambunathan K <kjambunathan@gmail.com>
Subject: Re: org-mobile-push problem
Date: Thu, 3 Nov 2011 12:43:45 +0100	[thread overview]
Message-ID: <F53BC9E9-E78E-4C7F-9EF0-626903BFEDC7@bastianebeling.org> (raw)

[-- Attachment #1: Type: text/plain, Size: 2556 bytes --]

Am 03.11.2011 um 12:03 schrieb Jambunathan K:

>> It says "Org-mode version 7.7". However, I feel that there was
>> something strange with my installation. I checked my files in my Emacs
>> folder and everything seemed really messed up, so I just reinstalled
>> org from the latest build and now it works! I had tried that before
>> automatically with the package manager but now I used the package
>> manager to install it from the file. I think that is where the strange
>> installation came from originally.
> It is not clear to me what you are saying here:
> Did the package manager solve your problem or it didn't solve your
> problem?
> What version of emacs are you using? There were two previous instances
> where people had issues with org-macs.el not being available when
> certain files were compiled.
> I have a feeling that it is not the problem with the people as such but
> how package manager goes about compiling the files.
> So any information you provide here will help improve the situation for
> other folks.
> -- 

Sorry, I didn't get into too much detail here because I had the feeling that the problem might have been cause by me not being able to use the package manager correctly rather than the package manager itself. But if it could help others, of course, I'm sharing the details as far as I understand them.

I'm using Aquamacs (for Mac OS):

GNU Emacs (i386-apple-darwin9.8.0, NS apple-appkit-949.54)
of 2011-10-25 on braeburn.aquamacs.org - Aquamacs Distribution 2.4
Copyright (C) 2011 Free Software Foundation, Inc.

When I run "package-list-packages", I get the message "Failed to download `Org-mode' archive." (didn't note that before), but it still offered the latest version of Org nevertheless. I could install it from there and Org appeared to be updated to version 7.7, but somehow the macro "org-eval-in-environment" was only found after reloading Org uncompiled after every restart of Emacs. This could be repeated infinitely, i.e., I always got this error message when running "package-list-packages" and it always offered me to install Org. Now I downloaded the tar-file manually and installed it with "package-install-file". Now "org-eval-in-environment" is found normally. After "package-list-files" I still get the message "Failed to download `Org-mode' archive.", but it shows Org as installed and does no longer offer to install it.

I hope that was more helpful. If you need more information, I will be happy to try to provide it. 


[-- Attachment #2: Type: text/html, Size: 3878 bytes --]

             reply	other threads:[~2011-11-03 11:44 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-11-03 11:43 info [this message]
2011-11-03 12:15 ` org-mobile-push problem Jambunathan K
2011-11-05 22:02   ` info
2011-11-06 21:01     ` Jambunathan K
2011-11-06 21:24       ` info
2011-11-06 21:35         ` Jambunathan K
  -- strict thread matches above, loose matches on Subject: below --
2011-11-02 16:16 Nicholas Putnam
2011-11-02 16:29 ` info
2011-11-02 23:28   ` Nick Dokos
2011-11-03  0:09     ` info
2011-11-03  0:36       ` Nick Dokos
2011-11-03 10:05         ` info
2011-11-03 11:03           ` Jambunathan K
2011-11-03  5:26     ` David Maus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=F53BC9E9-E78E-4C7F-9EF0-626903BFEDC7@bastianebeling.org \
    --to=info@bastianebeling.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=kjambunathan@gmail.com \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).