emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Jambunathan K <kjambunathan@gmail.com>
To: "info@bastianebeling.org" <info@bastianebeling.org>
Cc: emacs-orgmode@gnu.org
Subject: Re: org-mobile-push problem
Date: Thu, 03 Nov 2011 17:45:15 +0530	[thread overview]
Message-ID: <81lirxwgfg.fsf@gmail.com> (raw)
In-Reply-To: <F53BC9E9-E78E-4C7F-9EF0-626903BFEDC7@bastianebeling.org> (info@bastianebeling.org's message of "Thu, 3 Nov 2011 12:43:45 +0100")

> Sorry, I didn't get into too much detail here because I had the
> feeling that the problem might have been cause by me not being able
> to use the package manager correctly rather than the package manager
> itself. But if it could help others, of course, I'm sharing the
> details as far as I understand them.
> I'm using Aquamacs (for Mac OS):
> GNU Emacs (i386-apple-darwin9.8.0, NS apple-appkit-949.54)
> of 2011-10-25 on braeburn.aquamacs.org - Aquamacs Distribution 2.4
> Copyright (C) 2011 Free Software Foundation, Inc.
> When I run "package-list-packages", I get the message "Failed to
> download `Org-mode' archive." (didn't note that before), but it still
> offered the latest version of Org nevertheless. 

M-x customize-variable RET package-archives RET

and delete the following "Org-mode" archive from the list:

--8<---------------cut here---------------start------------->8---
(add-to-list 'package-archives 
              '("Org-mode" . "http://orgmode.org/pkg/daily/"))
--8<---------------cut here---------------end--------------->8---

Additionally, you can also look at ~/.emacs.d/elpa/archives/ subdir and
recursively delete the directory corresponding to "Org-mode" archive.

> I could install it from there and Org appeared to be updated to
> version 7.7, but somehow the macro "org-eval-in-environment" was only
> found after reloading Org uncompiled after every restart of
> Emacs. 

> This could be repeated infinitely, i.e., I always got this error
> message when running "package-list-packages" and it always offered me
> to install Org. Now I downloaded the tar-file manually and installed
> it with "package-install-file". Now "org-eval-in-environment" is found
> normally. After "package-list-files" I still get the message "Failed
> to download `Org-mode' archive.", but it shows Org as installed and
> does no longer offer to install it.
> I hope that was more helpful. If you need more information, I will be
> happy to try to provide it. 

I am trying to isolate the root cause of the issue here. Hope you can
help me locate the root cause.

Try the following procedure:

1. Store the org-*.tar that you have downloaded in some safe place.
2. rm -rf ~/.emacs.d/elpa/org-* {BE CAREFUL HERE, YOU ARE DELETING
   - In this step you are deleting your org installed through elpa.
3. Check your .emacs - Does it make have (require 'org-install)? If it
   has this entry remove that line or comment out that line.
4. Restart emacs
5. M-x locate-library RET org RET
6. Note the directory reported. 
   - If it looks like it is coming from your default Emacs installation
     directory then proceed to step 7. 

   - If it looks like it is one of the directories added by you, delete
     that directory from either load-path or simply delete it from the
     disk. (To be safe, instead of deleting you can just rename or move
     the directory somewhere else). Goto step 4.
7. Note the version of Org with M-x org-version RET. Now do a M-x
   package-install-file RET
8. Restart Emacs
9. Now. Do you still run in to the original org-macs issue that you

Extra information for me:
10. What does C-h v package-enable-at-startup RET report?

> Bastian


  reply	other threads:[~2011-11-03 12:15 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-11-03 11:43 org-mobile-push problem info
2011-11-03 12:15 ` Jambunathan K [this message]
2011-11-05 22:02   ` info
2011-11-06 21:01     ` Jambunathan K
2011-11-06 21:24       ` info
2011-11-06 21:35         ` Jambunathan K
  -- strict thread matches above, loose matches on Subject: below --
2011-11-02 16:16 Nicholas Putnam
2011-11-02 16:29 ` info
2011-11-02 23:28   ` Nick Dokos
2011-11-03  0:09     ` info
2011-11-03  0:36       ` Nick Dokos
2011-11-03 10:05         ` info
2011-11-03 11:03           ` Jambunathan K
2011-11-03  5:26     ` David Maus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=81lirxwgfg.fsf@gmail.com \
    --to=kjambunathan@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=info@bastianebeling.org \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).