emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* export options toc:t depends on num:t
@ 2011-04-06  3:04 John Hendy
  2011-04-06  4:48 ` Jambunathan K
  0 siblings, 1 reply; 4+ messages in thread
From: John Hendy @ 2011-04-06  3:04 UTC (permalink / raw)
  To: emacs-orgmode

Hi,


Maybe this is obvious to most, but I was puzzled by it. It seems that
,---
| #+options: toc:t
`---

will not function when paired with:
,---
| #+options: toc:t num:nil
`---

I didn't know that. I say that perhaps it's obvious, because I guess
when the toc does show up, it's format is:
,---
| 1   Section 1      pg#
| 2   Section 2      pg#
| ...
`---

But I wouldn't think it would be impossible to just have:

,---
| Section 1      pg#
| Section 2      pg#
| ...
`---


Anyway, if these two are necessary, perhaps the manual could be
updated (http://orgmode.org/manual/Export-options.html#Export-options):
,---
| toc:       turn on/off table of contents, or set level limit
(integer); requires num:t or no setting (t is default for num)
`---

Or something to that effect.



John

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: export options toc:t depends on num:t
  2011-04-06  3:04 export options toc:t depends on num:t John Hendy
@ 2011-04-06  4:48 ` Jambunathan K
  2011-04-06  9:20   ` Aankhen
  0 siblings, 1 reply; 4+ messages in thread
From: Jambunathan K @ 2011-04-06  4:48 UTC (permalink / raw)
  To: John Hendy; +Cc: emacs-orgmode

John Hendy <jw.hendy@gmail.com> writes:

> Hi,
>
>
> Maybe this is obvious to most, but I was puzzled by it. It seems that
> ,---
> | #+options: toc:t
> `---
>
> will not function when paired with:
> ,---
> | #+options: toc:t num:nil
> `---

> Anyway, if these two are necessary, perhaps the manual could be
> updated (http://orgmode.org/manual/Export-options.html#Export-options):
> ,---
> | toc:       turn on/off table of contents, or set level limit
> (integer); requires num:t or no setting (t is default for num)
> `---
>
> Or something to that effect.

Is this a LaTeX specific behaviour? I don't see anything odd with HTML
export.

Jambunathan K.

-- 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Re: export options toc:t depends on num:t
  2011-04-06  4:48 ` Jambunathan K
@ 2011-04-06  9:20   ` Aankhen
  2011-04-06 16:36     ` John Hendy
  0 siblings, 1 reply; 4+ messages in thread
From: Aankhen @ 2011-04-06  9:20 UTC (permalink / raw)
  To: Jambunathan K, John Hendy, emacs-orgmode

On Wed, Apr 6, 2011 at 10:18, Jambunathan K <kjambunathan@gmail.com> wrote:
> John Hendy <jw.hendy@gmail.com> writes:
> [snip]
>> Maybe this is obvious to most, but I was puzzled by it. It seems that
>> ,---
>> | #+options: toc:t
>> `---
>>
>> will not function when paired with:
>> ,---
>> | #+options: toc:t num:nil
>> `---
> [snip]
>
> Is this a LaTeX specific behaviour? I don't see anything odd with HTML
> export.

It likely is specific to LaTeX.  The starred versions of the
sectioning commands suppress the entry in the TOC as well.  It’s
possible to manually add the entry regardless, so maybe that needs to
be special-cased in the exporter.  It’d look like this:

,----
| \phantomsection                 % to make PDF bookmarks work properly
| \section*{Introduction}
| \addcontentsline{toc}{section}{Introduction}
`----

Alternatively, use the regular sectioning commands but add this before
\begin{document}:

,----
| \setcounter{secnumdepth}{0}
`----

Aankhen

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Re: export options toc:t depends on num:t
  2011-04-06  9:20   ` Aankhen
@ 2011-04-06 16:36     ` John Hendy
  0 siblings, 0 replies; 4+ messages in thread
From: John Hendy @ 2011-04-06 16:36 UTC (permalink / raw)
  To: Aankhen; +Cc: emacs-orgmode, Jambunathan K

On Wed, Apr 6, 2011 at 4:20 AM, Aankhen <aankhen@gmail.com> wrote:
> On Wed, Apr 6, 2011 at 10:18, Jambunathan K <kjambunathan@gmail.com> wrote:
>> John Hendy <jw.hendy@gmail.com> writes:
>> [snip]
>>> Maybe this is obvious to most, but I was puzzled by it. It seems that
>>> ,---
>>> | #+options: toc:t
>>> `---
>>>
>>> will not function when paired with:
>>> ,---
>>> | #+options: toc:t num:nil
>>> `---
>> [snip]
>>
>> Is this a LaTeX specific behaviour? I don't see anything odd with HTML
>> export.
>
> It likely is specific to LaTeX.  The starred versions of the
> sectioning commands suppress the entry in the TOC as well.  It’s
> possible to manually add the entry regardless, so maybe that needs to
> be special-cased in the exporter.  It’d look like this:
>
> ,----
> | \phantomsection                 % to make PDF bookmarks work properly
> | \section*{Introduction}
> | \addcontentsline{toc}{section}{Introduction}
> `----
>
> Alternatively, use the regular sectioning commands but add this before
> \begin{document}:
>
> ,----
> | \setcounter{secnumdepth}{0}
> `----

This works great and is easy to implement. Thanks!


John

>
> Aankhen
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2011-04-06 16:36 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-04-06  3:04 export options toc:t depends on num:t John Hendy
2011-04-06  4:48 ` Jambunathan K
2011-04-06  9:20   ` Aankhen
2011-04-06 16:36     ` John Hendy

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).