emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Command key problem in agenda view
@ 2009-01-15 21:23 Bruce Hackett
  2009-01-16  8:17 ` Daniel Clemente
  0 siblings, 1 reply; 7+ messages in thread
From: Bruce Hackett @ 2009-01-15 21:23 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

I'm learning new things about org-mode all the time. It's great!
However, I have a problem with using some of the command keys in the
agenda view. /, y, G, v and C-u v don't work at all, only giving a
warning that the buffer is read-only. "m" does the same as "M" (phases
of the moon), not the month view. The other keys work correctly (have
tested most of them).

These keys all work correctly in other modes, including org. I have
tried removing everything from my .emacs except the basic org-mode
stuff, to no avail. I have the same problem on two computers running
emacs 22.2 under ubuntu and fc5. On one computer I have a dual boot and
run a win32 emacs under XP; all the offending keys do work there! But my
main OS is linux. I use a Norwegian keyboard on both computers.

This must be a simple problem - embarassingly so, I fear - but I'm at
wits end. It looks like some really nice features I am unable to
utilize.

Any ideas of what this could be or where to dig further would be greatly
appreciated. Sorry to come with such a mundane problem. It's just that
I really am hooked on org-mode.

Best regards,
Bruce Hackett

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-15 21:23 Command key problem in agenda view Bruce Hackett
@ 2009-01-16  8:17 ` Daniel Clemente
  2009-01-16 11:56   ` Bruce Hackett
  0 siblings, 1 reply; 7+ messages in thread
From: Daniel Clemente @ 2009-01-16  8:17 UTC (permalink / raw)
  To: bruce.hackett; +Cc: emacs-orgmode


Hi,

  similar strange things happened to me because Emacs was loading the system org-mode (the one installed by Emacs) instead of the org-mode I had put in my personal directory. Therefore an old version of org-mode was being loaded, with less features than expected.

  Check your configuration; try   M-x org-version   and be sure that you are running the latest org-mode (current one is 6.17c).


  At your ~/.emacs you should have something like

  (add-to-list 'load-path "/somewhere/org-mode/lisp") (require 'org-install)

  And not (require 'org).


  Just an idea.

Daniel

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-16  8:17 ` Daniel Clemente
@ 2009-01-16 11:56   ` Bruce Hackett
  2009-01-16 13:26     ` Daniel Clemente
  0 siblings, 1 reply; 7+ messages in thread
From: Bruce Hackett @ 2009-01-16 11:56 UTC (permalink / raw)
  To: Daniel Clemente; +Cc: emacs-orgmode

Thanks, Daniel,

You were right! Actually, I had thought of your suggestion before and I 
had in fact renamed the system org.elc some time ago to get rid of it. 
Since then, my OS was upgraded from fc5 to ubuntu, and I didn't hit upon 
the possibility that the system org.elc  (v4.67!) was now back in 
business. I did a rename again and now I'm in v6.17.

However, there is another small issue here: Isn't there a better way to 
locally install an updated version of an emacs package that comes with a 
centrally managed OS? In my case, there is an enterprise-wide 
installation of emacs that I cannot change - I had to ask a system 
administrator to make the filename change for me.

Cheers, Bruce

Daniel Clemente wrote:
> Hi,
>
>   similar strange things happened to me because Emacs was loading the system org-mode (the one installed by Emacs) instead of the org-mode I had put in my personal directory. Therefore an old version of org-mode was being loaded, with less features than expected.
>
>   Check your configuration; try   M-x org-version   and be sure that you are running the latest org-mode (current one is 6.17c).
>
>
>   At your ~/.emacs you should have something like
>
>   (add-to-list 'load-path "/somewhere/org-mode/lisp") (require 'org-install)
>
>   And not (require 'org).
>
>
>   Just an idea.
>
> Daniel
>   


-- 
------------------------------------------------------------------------
   Bruce Hackett                         Senior Scientist
   Norwegian Meteorological Institute (met.no), R & D Div.
   P.O. Box 43 - Blindern                e-mail: Bruce.Hackett@met.no
   N-0313 Oslo                           Phone:  +47 22 96 33 39
   NORWAY                                Fax:    +47 22 96 33 80
                                         Mob:    +47 48 048 958
   URL:  http://met.no/english/r_and_d_activities/people/bruceh.html
------------------------------------------------------------------------

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-16 11:56   ` Bruce Hackett
@ 2009-01-16 13:26     ` Daniel Clemente
  2009-01-16 15:37       ` Bruce Hackett
  0 siblings, 1 reply; 7+ messages in thread
From: Daniel Clemente @ 2009-01-16 13:26 UTC (permalink / raw)
  To: Bruce Hackett; +Cc: emacs-orgmode


> However, there is another small issue here: Isn't there a better way to locally
> install an updated version of an emacs package that comes with a centrally
> managed OS? In my case, there is an enterprise-wide installation of emacs that I
> cannot change - I had to ask a system administrator to make the filename change
> for me.

  Well, yes; many people do that. You just install your files in a local directory (I use ~/.emacs.d/, for instance ~/.emacs.d/org-6.17c) and ask Emacs to use it; in your .emacs.el:
  (add-to-list 'load-path "~/.emacs.d/org-6.17c/lisp") (require 'org-install)

  Automatically, Emacs loads the one you specified instead of the global one. I think it is because add-to-list adds elements at the beginning of the list, therefore with more priority. Check: C-h v load-path RET

  I never had the problem of a global file overwriting my settings; Emacs behaves very well with that.


-- Daniel

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-16 13:26     ` Daniel Clemente
@ 2009-01-16 15:37       ` Bruce Hackett
  2009-01-21 11:35         ` Daniel Clemente
  0 siblings, 1 reply; 7+ messages in thread
From: Bruce Hackett @ 2009-01-16 15:37 UTC (permalink / raw)
  To: Daniel Clemente; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/html, Size: 2658 bytes --]

[-- Attachment #2: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-16 15:37       ` Bruce Hackett
@ 2009-01-21 11:35         ` Daniel Clemente
  2009-01-21 11:44           ` Carsten Dominik
  0 siblings, 1 reply; 7+ messages in thread
From: Daniel Clemente @ 2009-01-21 11:35 UTC (permalink / raw)
  To: Bruce Hackett; +Cc: emacs-orgmode


Bruce Hackett <Bruce.Hackett@met.no> writes:
>
> (setq load-path (append load-path '("~/.emacs.d/org/lisp")))
>
> This was something I picked up long, long ago, and never worried about. My guess is that "append" really means just that, and
> that "add-to-list" means prepending.
>
> Anyway, org-mode is working correctly now. Thanks for your help!
> Bruce


Since it's common that users experience strange problems due to an old version of Org being loaded, I wrote an entry about that in the FAQ, in Worg:
http://orgmode.org/worg/org-faq.php#loaded-old-org


-- Daniel

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Command key problem in agenda view
  2009-01-21 11:35         ` Daniel Clemente
@ 2009-01-21 11:44           ` Carsten Dominik
  0 siblings, 0 replies; 7+ messages in thread
From: Carsten Dominik @ 2009-01-21 11:44 UTC (permalink / raw)
  To: Daniel Clemente; +Cc: Bruce Hackett, emacs-orgmode

Hi Daniel,

thank you very much for this useful entry.

- Carsten

On Jan 21, 2009, at 12:35 PM, Daniel Clemente wrote:

>
> Bruce Hackett <Bruce.Hackett@met.no> writes:
>>
>> (setq load-path (append load-path '("~/.emacs.d/org/lisp")))
>>
>> This was something I picked up long, long ago, and never worried  
>> about. My guess is that "append" really means just that, and
>> that "add-to-list" means prepending.
>>
>> Anyway, org-mode is working correctly now. Thanks for your help!
>> Bruce
>
>
> Since it's common that users experience strange problems due to an  
> old version of Org being loaded, I wrote an entry about that in the  
> FAQ, in Worg:
> http://orgmode.org/worg/org-faq.php#loaded-old-org
>
>
> -- Daniel
>
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2009-01-21 11:44 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-15 21:23 Command key problem in agenda view Bruce Hackett
2009-01-16  8:17 ` Daniel Clemente
2009-01-16 11:56   ` Bruce Hackett
2009-01-16 13:26     ` Daniel Clemente
2009-01-16 15:37       ` Bruce Hackett
2009-01-21 11:35         ` Daniel Clemente
2009-01-21 11:44           ` Carsten Dominik

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).