emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Problem with org-startup-indented
@ 2011-10-18 17:30 Andrei Jirnyi
  2011-10-18 17:37 ` Andrei Jirnyi
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Andrei Jirnyi @ 2011-10-18 17:30 UTC (permalink / raw)
  To: emacs-orgmode

Hi all,

There is a major issue with org-indent-mode under org-mode 7.7 
(downloaded today with Emacs PPM, dated 2011-10-18) and Emacs 23.2. 

When org-startup-indented is set to "t", on opening any .org file the 
cursor immediately jumps to the end of file, and it is impossible to move 
it from there. Same happens if it is set to nil and I turn org-indent-
mode on manually. It does seem to work under Emacs 23.3 though. 

A sample .emacs file (in its entirety) is below:
(setq load-path (cons "~/elisp" load-path))
(require 'package)
(package-initialize)  ; causes major trouble... Investigate!
(setq org-startup-indented t)

--aj

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-startup-indented
  2011-10-18 17:30 Problem with org-startup-indented Andrei Jirnyi
@ 2011-10-18 17:37 ` Andrei Jirnyi
  2011-10-18 21:20 ` Nicolas Goaziou
  2011-10-24 23:40 ` Fixed!! (was: Re: Problem with org-startup-indented) Andrei Jirnyi
  2 siblings, 0 replies; 7+ messages in thread
From: Andrei Jirnyi @ 2011-10-18 17:37 UTC (permalink / raw)
  To: emacs-orgmode

On Tue, 18 Oct 2011 17:30:17 +0000, Andrei Jirnyi wrote:
> There is a major issue with org-indent-mode under org-mode 7.7
> (downloaded today with Emacs PPM, dated 2011-10-18) and Emacs 23.2.

As noted, it works under 7.7 and 23.3; it also works fine with 7.01trans 
and 23.2.

--aj

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-startup-indented
  2011-10-18 17:30 Problem with org-startup-indented Andrei Jirnyi
  2011-10-18 17:37 ` Andrei Jirnyi
@ 2011-10-18 21:20 ` Nicolas Goaziou
  2011-10-19 13:11   ` Andrei Jirnyi
  2011-10-24 23:40 ` Fixed!! (was: Re: Problem with org-startup-indented) Andrei Jirnyi
  2 siblings, 1 reply; 7+ messages in thread
From: Nicolas Goaziou @ 2011-10-18 21:20 UTC (permalink / raw)
  To: Andrei Jirnyi; +Cc: emacs-orgmode

Hello,

Andrei Jirnyi <a-jirnyi@northwestern.edu> writes:

> There is a major issue with org-indent-mode under org-mode 7.7 
> (downloaded today with Emacs PPM, dated 2011-10-18) and Emacs 23.2. 
>
> When org-startup-indented is set to "t", on opening any .org file the 
> cursor immediately jumps to the end of file, and it is impossible to move 
> it from there. Same happens if it is set to nil and I turn org-indent-
> mode on manually. It does seem to work under Emacs 23.3 though. 

Unfortunately, I'm not running 23.2. A backtrace produced with
toggle-debug-on-quit and C-g may be helpful though. Could you provide
one?

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-startup-indented
  2011-10-18 21:20 ` Nicolas Goaziou
@ 2011-10-19 13:11   ` Andrei Jirnyi
  2011-10-19 15:07     ` Nicolas Goaziou
  0 siblings, 1 reply; 7+ messages in thread
From: Andrei Jirnyi @ 2011-10-19 13:11 UTC (permalink / raw)
  To: emacs-orgmode

> Unfortunately, I'm not running 23.2. A backtrace produced with
> toggle-debug-on-quit and C-g may be helpful though. Could you provide
> one?

I'm not familiar with the Emacs debugger, so I'm not sure if I am doing 
it right -- please let me know if I should do something else. 
If (when in the .org buffer, with cursor at the end) I enter M-x toggle-
demand-on-quit [RET] C-g, I get the following in the *Backtrace* buffer 
(I repeated the above procedure three times; the output also contained 
some non-ascii characters in the "byte-code" sequence which have been removed):

Debugger entered--Lisp error: (quit)
  signal(quit nil)
  keyboard-quit()
  call-interactively(keyboard-quit nil nil)
  recursive-edit()
  byte-code("\306	@\307=\203!\310\311\312\"\210\313\311!\211A@)\242
\314=\203!\310\315\312\"\210\316!\210\317 \210\320	!\210\f\203d\321ed
\"V\203Web\210\322\245y\210`db\210\322\245Zy\210`|\210)\323c\210eb\210\324
\325\326 \"\210\327\306!\210\324\330!\210\331\312\324\330!\210\212\332 
\210+\331\207" [unread-command-char debugger-args x debugger-buffer 
noninteractive debugger-batch-max-lines -1 debug backtrace-debug 4 t 
backtrace-frame lambda 5 pop-to-buffer debugger-mode debugger-setup-
buffer count-lines 2 "...\n" message "%s" buffer-string kill-emacs "" nil 
recursive-edit middlestart buffer-read-only standard-output] 4)
  debug(error (quit))
  signal(quit nil)
  keyboard-quit()
  call-interactively(keyboard-quit nil nil)
  recursive-edit()
  byte-code("\306	@\307=\203!\310\311\312\"\210\313\311!\211A@)\242
\314=\203!\310\315\312\"\210\316!\210\317 \210\320	!\210\f\203d\321ed
\"V\203Web\210\322\245y\210`db\210\322\245Zy\210`|\210)\323c\210eb\210\324
\325\326 \"\210\327\306!\210\324\330!\210\331\312\324\330!\210\212\332 
\210+\331\207" [unread-command-char debugger-args x debugger-buffer 
noninteractive debugger-batch-max-lines -1 debug backtrace-debug 4 t 
backtrace-frame lambda 5 pop-to-buffer debugger-mode debugger-setup-
buffer count-lines 2 "...\n" message "%s" buffer-string kill-emacs "" nil 
recursive-edit middlestart buffer-read-only standard-output] 4)
  debug(error (quit))
  signal(quit nil)
  keyboard-quit()
  call-interactively(keyboard-quit nil nil)

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-startup-indented
  2011-10-19 13:11   ` Andrei Jirnyi
@ 2011-10-19 15:07     ` Nicolas Goaziou
  2011-10-19 16:06       ` Andrei Jirnyi
  0 siblings, 1 reply; 7+ messages in thread
From: Nicolas Goaziou @ 2011-10-19 15:07 UTC (permalink / raw)
  To: Andrei Jirnyi; +Cc: emacs-orgmode

Andrei Jirnyi <a-jirnyi@northwestern.edu> writes:

>> Unfortunately, I'm not running 23.2. A backtrace produced with
>> toggle-debug-on-quit and C-g may be helpful though. Could you provide
>> one?
>
> I'm not familiar with the Emacs debugger, so I'm not sure if I am doing 
> it right -- please let me know if I should do something else. 
> If (when in the .org buffer, with cursor at the end) I enter M-x toggle-
> demand-on-quit [RET] C-g, I get the following in the *Backtrace* buffer 
> (I repeated the above procedure three times; the output also contained 
> some non-ascii characters in the "byte-code" sequence which have been
> removed):


[...]

I forgot to tell you to reload Org uncompiled first, with C-u M-x
org-reload. Then use M-x toggle-debug-on-quit. Reproduce the freeze with
M-x org-indent-mode. Hit C-g. Finally report the backtrace.

Thanks.

Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-startup-indented
  2011-10-19 15:07     ` Nicolas Goaziou
@ 2011-10-19 16:06       ` Andrei Jirnyi
  0 siblings, 0 replies; 7+ messages in thread
From: Andrei Jirnyi @ 2011-10-19 16:06 UTC (permalink / raw)
  To: emacs-orgmode

Notably, the problem disappears if I re-evaluate org-indent.el -- I 
wonder if the bug may be with the package loading?

Also, when the issue is present, turning org-indent-mode off manually 
fixes it, but also produces an error message: 
"org-indent-mode: Invalid function: org-with-wide-buffer"

--aj

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Fixed!! (was: Re: Problem with org-startup-indented)
  2011-10-18 17:30 Problem with org-startup-indented Andrei Jirnyi
  2011-10-18 17:37 ` Andrei Jirnyi
  2011-10-18 21:20 ` Nicolas Goaziou
@ 2011-10-24 23:40 ` Andrei Jirnyi
  2 siblings, 0 replies; 7+ messages in thread
From: Andrei Jirnyi @ 2011-10-24 23:40 UTC (permalink / raw)
  To: emacs-orgmode

On Tue, 18 Oct 2011 17:30:17 +0000, Andrei Jirnyi wrote:

> There is a major issue with org-indent-mode under org-mode 7.7
> (downloaded today with Emacs PPM, dated 2011-10-18) and Emacs 23.2.

It seems that whatever the issue was, it could be fixed by either:
- forcing byte-compile on the downloaded package files by smth like   
  M-: (byte-recompile-directory "~/.emacs.d/elpa/org/[whatever]" 0 t)
- loading the newer (2011-10-24) distribution.

Perhaps it was related to the ELPA thing somehow.
I wonder if the order of compilation might matter for org-mode?
I think in the comments in package.el someone mentions that it currently 
has issues with tramp because tramp requires a specific order of 
compilation.

--aj

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2011-10-24 23:40 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-10-18 17:30 Problem with org-startup-indented Andrei Jirnyi
2011-10-18 17:37 ` Andrei Jirnyi
2011-10-18 21:20 ` Nicolas Goaziou
2011-10-19 13:11   ` Andrei Jirnyi
2011-10-19 15:07     ` Nicolas Goaziou
2011-10-19 16:06       ` Andrei Jirnyi
2011-10-24 23:40 ` Fixed!! (was: Re: Problem with org-startup-indented) Andrei Jirnyi

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).