emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Re: Bug in LaTeX export
       [not found] <.u63ka5qed@de.bosch.com>
@ 2009-01-20  9:51 ` Carsten Dominik
  0 siblings, 0 replies; 9+ messages in thread
From: Carsten Dominik @ 2009-01-20  9:51 UTC (permalink / raw)
  To: Thomas Holst; +Cc: emacs-orgmode

This has already been addressed and should work in the 6.18 release.

- Carsten

On Jan 20, 2009, at 9:32 AM, Thomas Holst wrote:

> Hello,
>
> when I call `org-export-region-as-latex' emacs enters a ininite
> loop. When I call a HTML export command prior to
> `org-export-region-as-latex' everything works fine with LaTeX export
> commands.
>
> As I found out `org-maybe-keyword-time-regexp' is not set when  
> calling a
> LaTeX export command. It is set, when calling a HTML command.
>
> I am using emacs version: 22.2.1 on WinXP
> org-mode-version: 6.17c
>
> org related settings in .emacs
> -----------------8x--------------x8-----------------------------------
> (require 'org-install)
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> (define-key global-map "\C-cl" 'org-store-link)
> (define-key global-map "\C-ca" 'org-agenda)
> ;; "\C-co" ist global auf occur-at-point gesetzt, also für org-mode
> ;; zurücksetzen
> (eval-after-load "org"
>  '(progn
>     (define-key org-mode-map "\C-co" 'org-open-at-point)
>     )
>  )
>
> (setq org-log-done t)
> (defun gtd ()
>  (interactive)
>  (find-file "U:/Org/MyGTD.org")
>  )
>
> ;; Einstellungen für remember
> (require 'remember) ; rember laden
>
> (org-remember-insinuate)
> (setq org-directory "c:/daten/users/DE_hts2fe/Org")
> (setq org-default-notes-file (concat org-directory "/MyNotes.org"))
> (define-key global-map "\C-cr" 'org-remember)
> -----------------8x--------------x8-----------------------------------
>
> Thomas
> -- 
> "Das Leben ist so einfach,
> dass es schon wieder schwierig ist!"
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Bug in latex export
@ 2011-11-28 14:57 Markus Grebenstein
  0 siblings, 0 replies; 9+ messages in thread
From: Markus Grebenstein @ 2011-11-28 14:57 UTC (permalink / raw)
  To: emacs-orgmode

Nobody out there able to reproduce? I still have trouble with this on  
org-mode 7.7 and ubuntu 11.10.

Best Markus

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Bug in latex export
@ 2011-11-12 11:13 Markus Grebenstein
  0 siblings, 0 replies; 9+ messages in thread
From: Markus Grebenstein @ 2011-11-12 11:13 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 359 bytes --]

Dear list,

I found a problem with the latex exporter when exporting bold font:

*this is a text* is exported as \textbf{this is a text\} with an extra \ 
which disables the }after it and causes a latex error.


I use org-mode 7.7 from githhub updated on tuesday or wednesday using 
org-tracks.

Please find the tex and the org file attached.

Best,

Markus


[-- Attachment #2: textbferror.tex --]
[-- Type: text/x-tex, Size: 627 bytes --]

% Created 2011-11-12 Sa 12:09
\documentclass{book}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{float}\input{Templates/book_header.tex}
\input{Templates/grebi-settings-macros.tex}
\usepackage[style=authoryear-comp,backend=biber]{biblatex}
\bibliography{Diss-zotero}

\title{A title}
\author{The Author}
\date{12 November 2011}

\begin{document}

\maketitle

\setcounter{tocdepth}{4}
\tableofcontents
\vspace*{1cm}





\part{Introduction :First Draft:}
\label{sec-1}

\chapter{Preface}
\label{sec-1.1}

\section{I. INTRODUCTION}
\label{sec-1.2}

Here is a text: 

\textbf{Here is some bold text\}
 

\end{document}

[-- Attachment #3: textbferror.org --]
[-- Type: text/plain, Size: 814 bytes --]

#+STARTUP: hidestars
#+STARTUP: indent
#+STARTUP: oddeven
#+TODO: TODO | DONE
#+TODO: Missing FirstDraft RevisedDraft | final
#### (only to two levels in TOC)
#+OPTIONS: toc:4  *:t tags:nil H:6        
##+OPTIONS: toc:nil        (no TOC at all)
#+LaTeX_CMD: xelatex
#+LaTeX_CLASS: book
#+LaTeX_CLASS_OPTIONS: [a4paper,10pt]
#+LaTeX_HEADER: \input{Templates/book_header.tex}
#+LATEX_HEADER: \input{Templates/grebi-settings-macros.tex}
#+LATEX_HEADER: \usepackage[style=authoryear-comp,backend=biber]{biblatex}
#+LaTeX_HEADER: \bibliography{Diss-zotero}

#+DRAWERS: HIDDEN PROPERTIES NOTES SYNOPSIS
#+AUTHOR: The Author
###### General Shortcuts


##### End ACRONYM Shortcuts
#+TITLE: A title


* Introduction :First Draft: 
** Preface
*** I. INTRODUCTION 					    :aTag:
Here is a text: 

*Here is some bold text*
 

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Bug in LaTeX export
       [not found] <nneething-c:/daten/users/DE_hts2fe/Mail/org-answers/001.txt@FE-Z1102>
@ 2009-07-17 10:46 ` Thomas Holst
  0 siblings, 0 replies; 9+ messages in thread
From: Thomas Holst @ 2009-07-17 10:46 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: bastienguerry

Hi Bastien,

  Bastien wrote:
> "Holst Thomas (DS-ET/ECF1)" <Thomas.Holst@de.bosch.com> writes:
>
>> I think I discoverd a bug in LaTeX export. I mark a subtree with C-c @
>> and then export it to LaTeX with C-c C-e L.
>>
>> If the subtree has no further subtrees the LaTeX-file not only contains
>> the region, but also the rest of the document to the end.
>
> Fixed, thanks!

I tested it with my org-files and it works perfectly. Thanks!

Thomas

-- 
"Das Leben ist so einfach,
 dass es schon wieder schwierig ist!"

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Bug in LaTeX export
  2009-07-10 10:50 Holst Thomas (DS-ET/ECF1)
  2009-07-10 12:19 ` Matthew Lundin
  2009-07-10 12:45 ` Matthew Lundin
@ 2009-07-16 19:43 ` Bastien
  2 siblings, 0 replies; 9+ messages in thread
From: Bastien @ 2009-07-16 19:43 UTC (permalink / raw)
  To: Holst Thomas (DS-ET/ECF1); +Cc: emacs-orgmode

"Holst Thomas (DS-ET/ECF1)" <Thomas.Holst@de.bosch.com> writes:

> I think I discoverd a bug in LaTeX export. I mark a subtree with C-c @
> and then export it to LaTeX with C-c C-e L.
>
> If the subtree has no further subtrees the LaTeX-file not only contains
> the region, but also the rest of the document to the end.

Fixed, thanks!

-- 
 Bastien

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Bug in LaTeX export
  2009-07-10 10:50 Holst Thomas (DS-ET/ECF1)
  2009-07-10 12:19 ` Matthew Lundin
@ 2009-07-10 12:45 ` Matthew Lundin
  2009-07-16 19:43 ` Bastien
  2 siblings, 0 replies; 9+ messages in thread
From: Matthew Lundin @ 2009-07-10 12:45 UTC (permalink / raw)
  To: Holst Thomas (DS-ET/ECF1); +Cc: emacs-orgmode

"Holst Thomas (DS-ET/ECF1)" <Thomas.Holst@de.bosch.com> writes:

> I think I discoverd a bug in LaTeX export. I mark a subtree with C-c @
> and then export it to LaTeX with C-c C-e L.
>
> If the subtree has no further subtrees the LaTeX-file not only contains
> the region, but also the rest of the document to the end.
>
> Here is an example:
>
> ,----[ test.org ]
> | * Kapitel 1
> | ** Kapitel 1.1
> |    foo bar
> | * Kapitel 2
> |   bar foo
> `----
>
> If the Kapitel 1.1 subtree is marked the LaTeX output looks like this:
>
> ,----[ LaTeX output ]
> | % Created 2009-07-10 Fr 12:33
> | \documentclass[11pt,a4paper]{article}
> | \usepackage[latin1]{inputenc}
> | \usepackage[T1]{fontenc}
> | \usepackage{hyperref}
> |
> |
> | \title{Kapitel 1.1}
> | \author{Holst Thomas}
> | \date{10 Juli 2009}
> |
> | \begin{document}
> |
> | \textbf{Kapitel 1.1}
> |
> | \setcounter{tocdepth}{3}
> | \tableofcontents
> | \vspace*{1cm}
> |    foo bar
> | \begin{itemize}
> | \item Kapitel 2
> |   bar foo
> | \end{itemize}
> |
> | \end{document}
> `----
>
> Kapitel 2 is also included. This does not happen if the subtree has
> additonal subtrees. If I mark the Kapitel 1 subtree the output is as
> expected.
>
> When the bug happens, `org-export-latex-default-class' does not work.
> Instead the class 'article' is used.
>
> It does not happen if the region is exported to ASCII or HTML.
>
> My setup is:
>
> emacs 22.2.1, WinXP, org-mode 6.28trans from yesterday.

Do you have transient-mark-mode enabled? I tested this with Emacs 22 and
when transient-mark-mode was enabled, it exported correctly (i.e., just
the 1st tree). When transient-mark-mode was turned off, I got the
results you describe above.

Just a thought...

Best,
Matt

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Bug in LaTeX export
  2009-07-10 10:50 Holst Thomas (DS-ET/ECF1)
@ 2009-07-10 12:19 ` Matthew Lundin
  2009-07-10 12:45 ` Matthew Lundin
  2009-07-16 19:43 ` Bastien
  2 siblings, 0 replies; 9+ messages in thread
From: Matthew Lundin @ 2009-07-10 12:19 UTC (permalink / raw)
  To: Holst Thomas (DS-ET/ECF1); +Cc: emacs-orgmode

"Holst Thomas (DS-ET/ECF1)" <Thomas.Holst@de.bosch.com> writes:

> Hello,
>
> I think I discoverd a bug in LaTeX export. I mark a subtree with C-c @
> and then export it to LaTeX with C-c C-e L.
>
> If the subtree has no further subtrees the LaTeX-file not only contains
> the region, but also the rest of the document to the end.
>
> Here is an example:
>
> ,----[ test.org ]
> | * Kapitel 1
> | ** Kapitel 1.1
> |    foo bar
> | * Kapitel 2
> |   bar foo
> `----
>
> If the Kapitel 1.1 subtree is marked the LaTeX output looks like this:
>
> ,----[ LaTeX output ]
> | % Created 2009-07-10 Fr 12:33
> | \documentclass[11pt,a4paper]{article}
> | \usepackage[latin1]{inputenc}
> | \usepackage[T1]{fontenc}
> | \usepackage{hyperref}
> |
> |
> | \title{Kapitel 1.1}
> | \author{Holst Thomas}
> | \date{10 Juli 2009}
> |
> | \begin{document}
> |
> | \textbf{Kapitel 1.1}
> |
> | \setcounter{tocdepth}{3}
> | \tableofcontents
> | \vspace*{1cm}
> |    foo bar
> | \begin{itemize}
> | \item Kapitel 2
> |   bar foo
> | \end{itemize}
> |
> | \end{document}
> `----

I can't reproduce this. Here is the output when I type C-c @ and C-c C-e
L. (I just pulled the most recent org from the git repo for emacs 22):

--8<---------------cut here---------------start------------->8---
% Created 2009-07-10 Fri 07:10
\documentclass[11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{hyperref}


\title{Kapitel 1}
\author{Matthew Lundin}
\date{10 July 2009}

\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{Kapitel 1.1}
\label{sec-1}

  foo bar
\end{document}
--8<---------------cut here---------------end--------------->8---

What are your other org-latex settings?

Best,
Matt

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Bug in LaTeX export
@ 2009-07-10 10:50 Holst Thomas (DS-ET/ECF1)
  2009-07-10 12:19 ` Matthew Lundin
                   ` (2 more replies)
  0 siblings, 3 replies; 9+ messages in thread
From: Holst Thomas (DS-ET/ECF1) @ 2009-07-10 10:50 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

I think I discoverd a bug in LaTeX export. I mark a subtree with C-c @
and then export it to LaTeX with C-c C-e L.

If the subtree has no further subtrees the LaTeX-file not only contains
the region, but also the rest of the document to the end.

Here is an example:

,----[ test.org ]
| * Kapitel 1
| ** Kapitel 1.1
|    foo bar
| * Kapitel 2
|   bar foo
`----

If the Kapitel 1.1 subtree is marked the LaTeX output looks like this:

,----[ LaTeX output ]
| % Created 2009-07-10 Fr 12:33
| \documentclass[11pt,a4paper]{article}
| \usepackage[latin1]{inputenc}
| \usepackage[T1]{fontenc}
| \usepackage{hyperref}
|
|
| \title{Kapitel 1.1}
| \author{Holst Thomas}
| \date{10 Juli 2009}
|
| \begin{document}
|
| \textbf{Kapitel 1.1}
|
| \setcounter{tocdepth}{3}
| \tableofcontents
| \vspace*{1cm}
|    foo bar
| \begin{itemize}
| \item Kapitel 2
|   bar foo
| \end{itemize}
|
| \end{document}
`----

Kapitel 2 is also included. This does not happen if the subtree has
additonal subtrees. If I mark the Kapitel 1 subtree the output is as
expected.

When the bug happens, `org-export-latex-default-class' does not work.
Instead the class 'article' is used.

It does not happen if the region is exported to ASCII or HTML.

My setup is:

emacs 22.2.1, WinXP, org-mode 6.28trans from yesterday.

I also observed this bug with org-mode 6.28b. And when I start emacs
with the option '-Q'.


Thomas

--
"Das Leben ist so einfach,
 dass es schon wieder schwierig ist!"

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Bug in LaTeX export
@ 2009-01-20  8:32 Thomas Holst
  0 siblings, 0 replies; 9+ messages in thread
From: Thomas Holst @ 2009-01-20  8:32 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

when I call `org-export-region-as-latex' emacs enters a ininite
loop. When I call a HTML export command prior to
`org-export-region-as-latex' everything works fine with LaTeX export
commands.

As I found out `org-maybe-keyword-time-regexp' is not set when calling a
LaTeX export command. It is set, when calling a HTML command.

I am using emacs version: 22.2.1 on WinXP
org-mode-version: 6.17c

org related settings in .emacs
-----------------8x--------------x8-----------------------------------
(require 'org-install)
(add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
(define-key global-map "\C-cl" 'org-store-link)
(define-key global-map "\C-ca" 'org-agenda)
;; "\C-co" ist global auf occur-at-point gesetzt, also für org-mode
;; zurücksetzen
(eval-after-load "org"
  '(progn
     (define-key org-mode-map "\C-co" 'org-open-at-point)
     )
  )

(setq org-log-done t)
(defun gtd ()
  (interactive)
  (find-file "U:/Org/MyGTD.org")
  )

;; Einstellungen für remember
(require 'remember) ; rember laden

(org-remember-insinuate)
(setq org-directory "c:/daten/users/DE_hts2fe/Org")
(setq org-default-notes-file (concat org-directory "/MyNotes.org"))
(define-key global-map "\C-cr" 'org-remember)
-----------------8x--------------x8-----------------------------------

Thomas
-- 
"Das Leben ist so einfach,
 dass es schon wieder schwierig ist!"

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2011-11-28 14:57 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <.u63ka5qed@de.bosch.com>
2009-01-20  9:51 ` Bug in LaTeX export Carsten Dominik
2011-11-28 14:57 Bug in latex export Markus Grebenstein
  -- strict thread matches above, loose matches on Subject: below --
2011-11-12 11:13 Markus Grebenstein
     [not found] <nneething-c:/daten/users/DE_hts2fe/Mail/org-answers/001.txt@FE-Z1102>
2009-07-17 10:46 ` Bug in LaTeX export Thomas Holst
2009-07-10 10:50 Holst Thomas (DS-ET/ECF1)
2009-07-10 12:19 ` Matthew Lundin
2009-07-10 12:45 ` Matthew Lundin
2009-07-16 19:43 ` Bastien
2009-01-20  8:32 Thomas Holst

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).