emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Brice Waegeneire <liberdiko@gmail.com>
To: emacs-orgmode@gnu.org
Subject: Re: Error after moving from 7.9.4 to 8.0: Cannot open load file org-element
Date: Wed, 24 Apr 2013 00:58:42 +0200	[thread overview]
Message-ID: <CAJOziUb1HpL3Cd9Ub0_sTVJxqvy9C1WR+8=-Amg7rJnw59i-Kg@mail.gmail.com> (raw)

Hello,

I have did the same process with the same type of configuration but
with the minimal requirement to install org-mode. Unfortunately I keep
stumbling on the same error, when I reload my configuration (after an
edit) with org-mode 8.0, which is not the case with org-mode 7.9.4.
It looks like org-babel didn't process my org configuration file in a
emacs-lisp file.

The configuration is here :
;;; init.el
;;
;; This is the first thing to get loaded.
;;
(add-to-list 'load-path "~/.emacs.d/el-get/org-mode/contrib/lisp")
(add-to-list 'load-path "~/.emacs.d/el-get/org-mode/lisp")

(require 'org)
(org-babel-load-file "~/.emacs.d/ldk-emacs.org")

;;; init.el ends here

;;; ldk-emacs.el
;;
;; Emacs configuration
;;
* el-get
** Auto-install el-get
If el-get is not installed it will be in the next start

#+begin_src emacs-lisp
(add-to-list 'load-path "~/.emacs.d/el-get/el-get")

(unless (require 'el-get nil 'noerror)
  (with-current-buffer
      (url-retrieve-synchronously
       "https://raw.github.com/dimitri/el-get/master/el-get-install.el")
    (goto-char (point-max))
    (eval-print-last-sexp)))

(setq el-get-dir "~/.emacs.d/el-get")
(setq el-get-install-dir "~/.emacs.d/el-get/el-get")
#+end_src

** Recipes
*** org-mode
#+BEGIN_SRC emacs-lisp
    (add-to-list
     'el-get-sources
     '(:name org-mode
             :checkout "release_8.0"))
#+END_SRC

** Initalized package
List of packages which are installed and initialized by el-get.

#+begin_src emacs-lisp
  (setq my-packages
        '(el-get
          org-mode
          ))

  (el-get 'sync my-packages)
#+end_src

;;; ldk-emacs.el ends here


Can someone help me with this or orient me to do a better report ?

Thanks.


2013/4/21 Brice Waegeneire <liberdiko@gmail.com>:
> Hello org-mode users,
>
> In moving from 7.9.4 to 8.0 org-mode I stumbled upon the following
> error (emacs --debug-init). The "[...]" is a portion i couldn't copy:
>
> Debugger entered--Lisp error: (file-error "Cannot open load file"
> "org-mode/lisp/org-element")
> org-element-at-point()
> org-store-link(nil)
> org-babel-tangle-single-block(1)
> org-babel-tangle-collect-blocks("emacs-lisp" nil)
> org-babel-tangle(nil "~/.emacs.d/ldk-emacs.el" "emacs-lisp")
> org-babel-tangle-file("~/.emacs.d/ldk-emacs.org"
> "~/.emacs.d/ldk-emacs.el" "emacs-lisp")
> org-babel-load-file("~/.emacs.d/ldk-emacs.org")
> eval-buffer(#<buffer *load*> nil "/home/lambda/.emacs.d/init.el" nil
> t) ; Reading at buffer position 397
> load-with-code-conversion("/home/lambda/.emacs.d/init.el"
> "/home/lambda/.emacs.d/init.el" t t)
> load("/home/lambda/.emacs.d/init" t t)
> #[0 " \205\262
>
> [...]
>
> [init-file-user system-type delayed-warnings-list user-init-file
> inhibit-default-init inhibit-startup-screen ms-dos "~" "/_emacs"
> windows-nt "/.emacs" directory-files nil "^\\.emacs\\(\\.elc?\\)?$"
> "~/.emacs" "^_emacs\\(\\.elc?\\)?$" (initialization "`_emacs' init
> file is deprecated, please use `.emacs'") "~/_emacs" t load
> expand-file-name "init" file-name-as-directory "/.emacs.d"
> file-name-extension "elc" file-name-sans-extension ".el" file-exists-p
> file-newer-than-file-p message "Warning: %s is newer than %s" sit-for
> 1 "default"] 7 "\n\n(fn)"]()
> command-line()
> normal-top-level()
>
> For the upgrade I've deleted the org-mode folder, replaced in my emacs
> configuration file "release_7.9.4" by "release_8.0" and then restarted
> emacs. el-get had then installed org-mode 8.0, after that I don't have
> the issue yet but it occurs after I had modified my emacs'
> configurartion  (whatever the modification) and restarted it.
>
> You can find my emacs configuration here :
> https://gist.github.com/korthaerd/27877114462e2475f82e#file-emacs-debug-init-8-0
>
> Can some help me with that ?
>
> Coridally, liberdiko.

             reply	other threads:[~2013-04-23 22:59 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-23 22:58 Brice Waegeneire [this message]
  -- strict thread matches above, loose matches on Subject: below --
2013-04-21 16:26 Brice Waegeneire

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAJOziUb1HpL3Cd9Ub0_sTVJxqvy9C1WR+8=-Amg7rJnw59i-Kg@mail.gmail.com' \
    --to=liberdiko@gmail.com \
    --cc=emacs-orgmode@gnu.org \
    --subject='Re: Error after moving from 7.9.4 to 8.0: Cannot open load file org-element' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).