emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Adding new heading results in "not in an item"
@ 2013-04-23 14:41 Johan Ekh
  2013-04-23 20:36 ` Marc-Oliver Ihm
  2013-04-23 21:15 ` Viktor Rosenfeld
  0 siblings, 2 replies; 6+ messages in thread
From: Johan Ekh @ 2013-04-23 14:41 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 160 bytes --]

Hi all,
I've installed version 8 of org-mode and now I get the message "not in an
item" when I try to add new headings with "M-RET". What is wrong?

BR / Johan

[-- Attachment #2: Type: text/html, Size: 252 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Adding new heading results in "not in an item"
  2013-04-23 14:41 Adding new heading results in "not in an item" Johan Ekh
@ 2013-04-23 20:36 ` Marc-Oliver Ihm
  2013-04-23 21:15 ` Viktor Rosenfeld
  1 sibling, 0 replies; 6+ messages in thread
From: Marc-Oliver Ihm @ 2013-04-23 20:36 UTC (permalink / raw)
  To: Johan Ekh; +Cc: emacs-orgmode

Am 23.04.2013 16:41, schrieb Johan Ekh:
> Hi all,
> I've installed version 8 of org-mode and now I get the message "not in an item" when I try to add new headings with "M-RET". What is wrong?
>
> BR / Johan


Hi Johan !


Well, tried but it just works fine for me (which is a very big relief :-)

Which of the installation methodes as sketched in http://orgmode.org/Changes.html (First section, "Installation")
did you use ?

Do you see any old (i.e. pre-8) lisp-directories in your load-path ? Do you find any old lisp-files within
the directories, where you put the files from version 8 ?


regards, Marc

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Adding new heading results in "not in an item"
  2013-04-23 14:41 Adding new heading results in "not in an item" Johan Ekh
  2013-04-23 20:36 ` Marc-Oliver Ihm
@ 2013-04-23 21:15 ` Viktor Rosenfeld
  2013-04-24  6:18   ` Johan Ekh
  1 sibling, 1 reply; 6+ messages in thread
From: Viktor Rosenfeld @ 2013-04-23 21:15 UTC (permalink / raw)
  To: Johan Ekh; +Cc: emacs-orgmode

Hi Johan,

this is fixed in master. The relevant commit is here:
http://orgmode.org/cgit.cgi/org-mode.git/commit/?id=0fff0ba6da30e4ced73f84c8305d80c955bae132

Cheers,
Viktor

Johan Ekh wrote:

> Hi all,
> I've installed version 8 of org-mode and now I get the message "not in an
> item" when I try to add new headings with "M-RET". What is wrong?
> 
> BR / Johan

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Adding new heading results in "not in an item"
  2013-04-23 21:15 ` Viktor Rosenfeld
@ 2013-04-24  6:18   ` Johan Ekh
  2013-04-24  7:39     ` Bastien
  0 siblings, 1 reply; 6+ messages in thread
From: Johan Ekh @ 2013-04-24  6:18 UTC (permalink / raw)
  To: emacs-orgmode, marc, listuser36

[-- Attachment #1: Type: text/plain, Size: 864 bytes --]

Thanks guys,

Marc: I use git for installation and I don't think I have any old files in
my load path. I have the files in my home directory but the compiled files
are installed in the system emacs/site-lisp.

Victor: Good, but please help a newbie. How do I apply this patch?

Finally, I noticed that adding a new heading works with Ctrl-RET. But I
still want M-RET to work!

BR / Johan



On Tue, Apr 23, 2013 at 11:15 PM, Viktor Rosenfeld <listuser36@gmail.com>wrote:

> Hi Johan,
>
> this is fixed in master. The relevant commit is here:
>
> http://orgmode.org/cgit.cgi/org-mode.git/commit/?id=0fff0ba6da30e4ced73f84c8305d80c955bae132
>
> Cheers,
> Viktor
>
> Johan Ekh wrote:
>
> > Hi all,
> > I've installed version 8 of org-mode and now I get the message "not in an
> > item" when I try to add new headings with "M-RET". What is wrong?
> >
> > BR / Johan
>

[-- Attachment #2: Type: text/html, Size: 1536 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Adding new heading results in "not in an item"
  2013-04-24  6:18   ` Johan Ekh
@ 2013-04-24  7:39     ` Bastien
  2013-04-24 13:28       ` Johan Ekh
  0 siblings, 1 reply; 6+ messages in thread
From: Bastien @ 2013-04-24  7:39 UTC (permalink / raw)
  To: Johan Ekh; +Cc: marc, emacs-orgmode

Hi Johan,

Johan Ekh <ekh.johan@gmail.com> writes:

> Marc: I use git for installation and I don't think I have any old
> files in my load path. I have the files in my home directory but the
> compiled files are installed in the system emacs/site-lisp.

The compiled files *are* in your load-path, because Emacs loads them
when you launch it.  This is in /usr/.../emacs/lisp/loaddefs.el, which
contains pointers to the autoloaded functions.  Some Org's functions
are autoloaded by Emacs, and these are functions from an older version
than the one you installed manually.

> Victor: Good, but please help a newbie. How do I apply this patch?

You don't need to install this particular patch, you just need to
updated your Git installation.

~$ cd org-mode/  [change with the relevant path]
~$ git pull
~$ make

This pull latest master branch and compile Org.

Or you can do:

~$ cd org-mode/  [change with the relevant path]
~$ make update

> Finally, I noticed that adding a new heading works with Ctrl-RET. But
> I still want M-RET to work!

Please follow the instructions above and report any problem you may
have afterwards.

HTH,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Adding new heading results in "not in an item"
  2013-04-24  7:39     ` Bastien
@ 2013-04-24 13:28       ` Johan Ekh
  0 siblings, 0 replies; 6+ messages in thread
From: Johan Ekh @ 2013-04-24 13:28 UTC (permalink / raw)
  To: Bastien; +Cc: marc, emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1340 bytes --]

Thank you!
It worked again after a "make up2".

BR / Johan


On Wed, Apr 24, 2013 at 9:39 AM, Bastien <bzg@gnu.org> wrote:

> Hi Johan,
>
> Johan Ekh <ekh.johan@gmail.com> writes:
>
> > Marc: I use git for installation and I don't think I have any old
> > files in my load path. I have the files in my home directory but the
> > compiled files are installed in the system emacs/site-lisp.
>
> The compiled files *are* in your load-path, because Emacs loads them
> when you launch it.  This is in /usr/.../emacs/lisp/loaddefs.el, which
> contains pointers to the autoloaded functions.  Some Org's functions
> are autoloaded by Emacs, and these are functions from an older version
> than the one you installed manually.
>
> > Victor: Good, but please help a newbie. How do I apply this patch?
>
> You don't need to install this particular patch, you just need to
> updated your Git installation.
>
> ~$ cd org-mode/  [change with the relevant path]
> ~$ git pull
> ~$ make
>
> This pull latest master branch and compile Org.
>
> Or you can do:
>
> ~$ cd org-mode/  [change with the relevant path]
> ~$ make update
>
> > Finally, I noticed that adding a new heading works with Ctrl-RET. But
> > I still want M-RET to work!
>
> Please follow the instructions above and report any problem you may
> have afterwards.
>
> HTH,
>
> --
>  Bastien
>

[-- Attachment #2: Type: text/html, Size: 2007 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2013-04-24 13:58 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-04-23 14:41 Adding new heading results in "not in an item" Johan Ekh
2013-04-23 20:36 ` Marc-Oliver Ihm
2013-04-23 21:15 ` Viktor Rosenfeld
2013-04-24  6:18   ` Johan Ekh
2013-04-24  7:39     ` Bastien
2013-04-24 13:28       ` Johan Ekh

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).