emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Emacs brings itself to the foreground when preparing agenda with org-agenda-include-diary t
@ 2020-05-29  8:16 Friedrich Delgado
  2020-09-05 13:58 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Friedrich Delgado @ 2020-05-29  8:16 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 1737 bytes --]

Hi!

I've set up my emacs to prepare the org-agenda whenever I start it up.

While emacs starts up, I'm doing other things and it's frequently annoying
me that emacs brings itself to the foreground (with qtile, if that's
relevant).

I've come up with the following minimal configuration that reproduces the
issue for me (via emacs -Q -l ~/minimal-org.el):


,----[ minimal-org.el ]
(require 'package)
(add-to-list 'package-archives '("org" . "https://orgmode.org/elpa/") t)
(package-initialize)
(add-to-list 'load-path "~/lib/emacs/use-package/")
(require 'use-package)

(use-package org
:ensure org-plus-contrib)

(define-key global-map "\C-ca" 'org-agenda)
(custom-set-variables
'(org-agenda-files (quote ("~/Org/Collect.org" "~/Org/Common.org"
"~/Org/Rechner.org" "~/Org/home/Familie.org" "~/Org/home/Haus.org"
"~/Org/home/Gesundheit.org" "~/Org/home/Musik.org" "~/Org/home/Rechner.org"
"~/Org/home/Sonstiges.org" "~/Org/home/Weiterentwicklung.org"
"~/Org/work/Cert.org")))
'(org-agenda-include-diary t))
`----

When I comment out org-agenda-include-diary or set it to nil, the behaviour
disappears.

When I comment out my extensive set of large org-mode files, the behaviour
disappears as well, but maybe just because I'm not fast enough to switch
away from emacs before it happens.

I'd like to be able to use org-agenda-include-diary but disable the
behaviour that emacs raises itself.

Please CC me in replies, as I'm not subscribed to this list.

For completeness, I've been asked to file an issue against qtile, because
they want to be able to prevent such behaviour from clients on the window
manager side, and they're also dealing with focus problems recently.
https://github.com/qtile/qtile/issues/1756

Best regards
Friedel

[-- Attachment #2: Type: text/html, Size: 2442 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Emacs brings itself to the foreground when preparing agenda with org-agenda-include-diary t
  2020-05-29  8:16 Emacs brings itself to the foreground when preparing agenda with org-agenda-include-diary t Friedrich Delgado
@ 2020-09-05 13:58 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2020-09-05 13:58 UTC (permalink / raw)
  To: Friedrich Delgado; +Cc: emacs-orgmode

Hi Friedrich,

Friedrich Delgado <taupan@gmail.com> writes:

> I'd like to be able to use org-agenda-include-diary but disable the
> behaviour that emacs raises itself.

My guess is that the Emacs window pops up becaus of diary, not 
because of Org.

> Please CC me in replies, as I'm not subscribed to this list.
>
> For completeness, I've been asked to file an issue against qtile,
> because they want to be able to prevent such behaviour from clients
> on the window manager side, and they're also dealing with focus
> problems recently. https://github.com/qtile/qtile/issues/1756

I think this kind of configuration should happen on the window-manager
side indeed.

Best,

-- 
 Bastien


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-09-05 13:59 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-29  8:16 Emacs brings itself to the foreground when preparing agenda with org-agenda-include-diary t Friedrich Delgado
2020-09-05 13:58 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).