emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Problems with executing babel code
@ 2011-07-13 12:19 Christopher Witte
  2011-07-13 14:39 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Christopher Witte @ 2011-07-13 12:19 UTC (permalink / raw)
  To: Org Mode

[-- Attachment #1: Type: text/plain, Size: 1092 bytes --]

After a recent git pull, I've been having some problems executing and
editing babel code.  The following will execute:

#+srcname: Blah1
#+begin_src emacs-lisp :results value
  (concat "" "works")

#+results: Blah1
: works

#+call: Blah1(x=1) :results value raw

#+results: Blah1(x=1)

#+srcname: Blah4(x)

#+begin_src emacs-lisp
  (concat "" "works")

: works

#+call: Blah4(x=1) :results value raw

#+results: Blah4(x=1)

but this

#+srcname: Blah2(x)
#+begin_src emacs-lisp :results value
  (concat "doesn't" "work")

#+call: Blah2(x=1) :results value raw

fails with the error message "setf: Wrong type argument: consp, nil", when
it had previously worked.  nb. the only difference between Blah4 and Blah2,
is the white space between the srcname and begin_src.  I get the same error
when I try and edit the code with C-'.  I'm not sure exactly when this
started, this was probably the first git pull I have done in a month or so.
Sorry I can't help track down this problem further, my lisp skills are slim
to none.


[-- Attachment #2: Type: text/html, Size: 1334 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-07-13 14:39 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-07-13 12:19 Problems with executing babel code Christopher Witte
2011-07-13 14:39 ` Bastien

Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).