emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* using Cygwin Gnuplot with org-babel-gnuplot
@ 2011-09-29  2:53 Alexander Vorobiev
  2011-09-29 12:55 ` Eric Schulte
  0 siblings, 1 reply; 2+ messages in thread
From: Alexander Vorobiev @ 2011-09-29  2:53 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

It is mentioned in
http://orgmode.org/worg/org-contrib/babel/languages/ob-doc-gnuplot.html#sec-2_1
that there were some problems with gnuplot on Windows machines. I came
up with a small fix which makes it possible to use Cygwin version of
gnuplot with org-mode. The change is in the org-babel-execute:gnuplot
function where I added passing of optional argument to
org-babel-process-file-name:

before:
(org-babel-process-file-name script-file))))

after:
(org-babel-process-file-name script-file t))))

The argument forces the function not to add backslash prior to ":"
character which prevented gnuplot from finding the script for
execution. I hope somebody will find the fix useful. Unfortunately I
don't know if the fix breaks anything on Unix/Linux/Mac.

Thanks
Alex Vorobiev

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: using Cygwin Gnuplot with org-babel-gnuplot
  2011-09-29  2:53 using Cygwin Gnuplot with org-babel-gnuplot Alexander Vorobiev
@ 2011-09-29 12:55 ` Eric Schulte
  0 siblings, 0 replies; 2+ messages in thread
From: Eric Schulte @ 2011-09-29 12:55 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: emacs-orgmode

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> Hi,
>
> It is mentioned in
> http://orgmode.org/worg/org-contrib/babel/languages/ob-doc-gnuplot.html#sec-2_1
> that there were some problems with gnuplot on Windows machines. I came
> up with a small fix which makes it possible to use Cygwin version of
> gnuplot with org-mode. The change is in the org-babel-execute:gnuplot
> function where I added passing of optional argument to
> org-babel-process-file-name:
>
> before:
> (org-babel-process-file-name script-file))))
>
> after:
> (org-babel-process-file-name script-file t))))
>
> The argument forces the function not to add backslash prior to ":"
> character which prevented gnuplot from finding the script for
> execution. I hope somebody will find the fix useful. Unfortunately I
> don't know if the fix breaks anything on Unix/Linux/Mac.
>

Hi Alex,

I've added this change behind a guard so that it should only be applied
on windows systems.

Thanks for suggesting this fix!  Please let me know if my patch doesn't
work as expected.

Best -- Eric

>
> Thanks
> Alex Vorobiev
>

-- 
Eric Schulte
http://cs.unm.edu/~eschulte/

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-09-29 12:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-29  2:53 using Cygwin Gnuplot with org-babel-gnuplot Alexander Vorobiev
2011-09-29 12:55 ` Eric Schulte

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).