emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-agenda is not working after org-mode update
@ 2013-04-21 12:28 Sergey Pashinin
  2013-04-21 13:26 ` Bastien
  0 siblings, 1 reply; 2+ messages in thread
From: Sergey Pashinin @ 2013-04-21 12:28 UTC (permalink / raw)
  To: emacs-orgmode

I updated org-mode yesterday through Melpa.
After that org-agenda stopped working for me.

It says:

Invalid function: org-with-silent-modifications

In my script I had this:

(org-agenda nil "n")

Trying to execute it now gives:

Debugger entered--Lisp error: (invalid-function 
org-with-silent-modifications)
   org-with-silent-modifications(nil)
   org-refresh-category-properties()
   byte-code("\306\b!\203\.....
   org-agenda-prepare-buffers(("/data/org/work.org" ...))
   org-agenda-prepare("Agenda and all TODO's")
   (let nil (org-agenda-prepare name))
   eval((let nil (org-agenda-prepare name)))
   org-let(nil (org-agenda-prepare name))
   org-agenda-run-series("Agenda and all TODO's" (((agenda "") (alltodo 
""))))
   org-agenda(nil "n")
   eval((org-agenda nil "n") nil)
   eval-last-sexp-1(nil)
   eval-last-sexp(nil)
   call-interactively(eval-last-sexp nil nil)
   command-execute(eval-last-sexp)

-------------------------

Also have to add:

I had only "(require 'org)" in my file and it started to complain: "I 
don't know org-agenda-buffer-name variable"

So I had to add:

(require 'org)
(require 'org-agenda)
;;(require 'org-compat)

But still got an error I described above.
Looks like a bug

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: org-agenda is not working after org-mode update
  2013-04-21 12:28 org-agenda is not working after org-mode update Sergey Pashinin
@ 2013-04-21 13:26 ` Bastien
  0 siblings, 0 replies; 2+ messages in thread
From: Bastien @ 2013-04-21 13:26 UTC (permalink / raw)
  To: Sergey Pashinin; +Cc: emacs-orgmode

Hi Sergey,

Sergey Pashinin <sergey@pashinin.com> writes:

> I updated org-mode yesterday through Melpa.
> After that org-agenda stopped working for me.

Please read the release notes carefully:

  http://orgmode.org/Changes.html

When installing from Melpa (or GNU ELPA, or Org ELPA),
this needs to be done in a fresh Emacs session.

I hope this fixes your problem.

-- 
 Bastien

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2013-04-21 13:26 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-04-21 12:28 org-agenda is not working after org-mode update Sergey Pashinin
2013-04-21 13:26 ` Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).