emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
@ 2021-05-26 22:53 Richard Stanton
  2021-05-27  6:56 ` Tim Cross
  2021-05-27  7:19 ` Tim Cross
  0 siblings, 2 replies; 7+ messages in thread
From: Richard Stanton @ 2021-05-26 22:53 UTC (permalink / raw)
  To: orgmode

[-- Attachment #1: Type: text/plain, Size: 2111 bytes --]

Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     https://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org mailing list.
------------------------------------------------------------------------

Everything worked fine until yesterday, but today when I try to export an org file that contains the line

#+SETUPFILE: https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup <https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup>

I get the following error:

Debugger entered--Lisp error: (void-function org-url-p)
  org-url-p("https://fniessen.github.io/org-html-themes/org/the...")
  org--collect-keywords-1(("SETUPFILE" "FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES") nil nil nil)
  org-collect-keywords(("FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES"))
  org-set-regexps-and-options()
  org-mode()
  org-export--prepare-file-contents("/Users/stanton/.org/setup" nil 0 1 1 #<hash-table equal 0/65 0x1fe65e6c9285> "/Users/stanton/teaching/MFE230I/mfe230i.org")
  org-export-expand-include-keyword()
  org-export-as(latex nil nil nil (:output-file "mfe230i.tex"))
  org-export-to-file(latex "mfe230i.tex" nil nil nil nil nil #f(compiled-function (file) #<bytecode 0x1fe65e28d06d>))
  org-latex-export-to-pdf(nil nil nil nil)
  org-export-dispatch(nil)
  funcall-interactively(org-export-dispatch nil)
  call-interactively(org-export-dispatch nil nil)
  command-execute(org-export-dispatch)

Thanks for any suggestions.


Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin20.3.0, Carbon Version 164 AppKit 2022.3)
 of 2021-04-06
Package: Org mode version 9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)




[-- Attachment #2: Type: text/html, Size: 3542 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
  2021-05-26 22:53 [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)] Richard Stanton
@ 2021-05-27  6:56 ` Tim Cross
  2021-05-27  7:19 ` Tim Cross
  1 sibling, 0 replies; 7+ messages in thread
From: Tim Cross @ 2021-05-27  6:56 UTC (permalink / raw)
  To: emacs-orgmode


Richard Stanton <rhstanton@berkeley.edu> writes:

> Remember to cover the basics, that is, what you expected to happen and
> what in fact did happen.  You don't know how to make a good report?  See
>
>      https://orgmode.org/manual/Feedback.html#Feedback
>
> Your bug report will be posted to the Org mailing list.
> ------------------------------------------------------------------------
>
> Everything worked fine until yesterday, but today when I try to export an org file that contains the line
>
> #+SETUPFILE: https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup
>
> I get the following error:
>
> Debugger entered--Lisp error: (void-function org-url-p)
>   org-url-p("https://fniessen.github.io/org-html-themes/org/the...")
>   org--collect-keywords-1(("SETUPFILE" "FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES"
> "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES") nil nil nil)
>   org-collect-keywords(("FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY" "SEQ_TODO"
> "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES"))
>   org-set-regexps-and-options()
>   org-mode()
>   org-export--prepare-file-contents("/Users/stanton/.org/setup" nil 0 1 1 #<hash-table equal 0/65 0x1fe65e6c9285>
> "/Users/stanton/teaching/MFE230I/mfe230i.org")
>   org-export-expand-include-keyword()
>   org-export-as(latex nil nil nil (:output-file "mfe230i.tex"))
>   org-export-to-file(latex "mfe230i.tex" nil nil nil nil nil #f(compiled-function (file) #<bytecode 0x1fe65e28d06d>))
>   org-latex-export-to-pdf(nil nil nil nil)
>   org-export-dispatch(nil)
>   funcall-interactively(org-export-dispatch nil)
>   call-interactively(org-export-dispatch nil nil)
>   command-execute(org-export-dispatch)
>
> Thanks for any suggestions.
>
> Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin20.3.0, Carbon Version 164 AppKit 2022.3)
>  of 2021-04-06
> Package: Org mode version 9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)

Doing a grep for org-url-p in the org-plus-contrib package *.el files
finds no reference to org-url-p (no calls, no definition). Could this
perhaps be from some add on package rather than part of org?


-- 
Tim Cross


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
  2021-05-26 22:53 [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)] Richard Stanton
  2021-05-27  6:56 ` Tim Cross
@ 2021-05-27  7:19 ` Tim Cross
  1 sibling, 0 replies; 7+ messages in thread
From: Tim Cross @ 2021-05-27  7:19 UTC (permalink / raw)
  To: emacs-orgmode


OK, think I've worked out what the problem is.

The function org-url-p is defined in org 9.5, but not org 9.4. Your
running org 9.4.6, which does not have that function. The fact something
in your install is trying to call org-url-p would indicate you have a
mixed or messed up installation of org (i.e. your setup is loading code
from 2 different versions).

It is very important when upgrading or installing org that no org
functionality is yet loaded to avoid this type of issue. Your best bet
is to remove all org related packages and then try installing org again.
If your using package.el to install org, make sure the call to install
it is early in your init file (before any functionality is loaded which
depends on org). I also find the use-pacakge macro very useful in this
regard as you can also setup things so that no org functionality is
loaded until you try to use something which depends on org. This means
you can typically start Emacs and immediately install/upgrade org
without any issues. Where people tend to come undone is when they have
been running Emacs for a while, have been using org and then to a
package update and the system tries to install a new version of org
(usually only an issue with new major versions rather than patch fix
version updates). 

Richard Stanton <rhstanton@berkeley.edu> writes:

> Remember to cover the basics, that is, what you expected to happen and
> what in fact did happen.  You don't know how to make a good report?  See
>
>      https://orgmode.org/manual/Feedback.html#Feedback
>
> Your bug report will be posted to the Org mailing list.
> ------------------------------------------------------------------------
>
> Everything worked fine until yesterday, but today when I try to export an org file that contains the line
>
> #+SETUPFILE: https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup
>
> I get the following error:
>
> Debugger entered--Lisp error: (void-function org-url-p)
>   org-url-p("https://fniessen.github.io/org-html-themes/org/the...")
>   org--collect-keywords-1(("SETUPFILE" "FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES"
> "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES") nil nil nil)
>   org-collect-keywords(("FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY" "SEQ_TODO"
> "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES"))
>   org-set-regexps-and-options()
>   org-mode()
>   org-export--prepare-file-contents("/Users/stanton/.org/setup" nil 0 1 1 #<hash-table equal 0/65 0x1fe65e6c9285>
> "/Users/stanton/teaching/MFE230I/mfe230i.org")
>   org-export-expand-include-keyword()
>   org-export-as(latex nil nil nil (:output-file "mfe230i.tex"))
>   org-export-to-file(latex "mfe230i.tex" nil nil nil nil nil #f(compiled-function (file) #<bytecode 0x1fe65e28d06d>))
>   org-latex-export-to-pdf(nil nil nil nil)
>   org-export-dispatch(nil)
>   funcall-interactively(org-export-dispatch nil)
>   call-interactively(org-export-dispatch nil nil)
>   command-execute(org-export-dispatch)
>
> Thanks for any suggestions.
>
> Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin20.3.0, Carbon Version 164 AppKit 2022.3)
>  of 2021-04-06
> Package: Org mode version 9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)


-- 
Tim Cross


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting  to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
  2021-05-29  6:41   ` Ihor Radchenko
@ 2021-05-29  7:18     ` Richard Stanton
  0 siblings, 0 replies; 7+ messages in thread
From: Richard Stanton @ 2021-05-29  7:18 UTC (permalink / raw)
  To: Ihor Radchenko; +Cc: Tim Cross, orgmode

On May 28, 2021, at 11:41 PM, Ihor Radchenko <yantar92@gmail.com> wrote:
> 
> Richard Stanton <rhstanton@berkeley.edu> writes:
>> I currently load org using straight.el as follows:
>> ...
>> (use-package org-contrib
>>  :after org
>> ...
>> (use-package org
>>  :after (jupyter)
> 
> I suspect that something else is pulling built-in org version before
> jupyter gets loaded. To make sure that the straight version of Org mode
> is loaded, I recommend putting the following at the beginning of your
> init.el:
> 
> (straight-use-package '(org :type git :repo "https://code.orgmode.org/bzg/org-mode.git"))
> (straight-use-package '(org-contrib :type git :repo "https://git.sr.ht/~bzg/org-contrib"))
> 
> To debug similar issues, you might set use-package-verbose to t at the
> beginning of your init.el and examine the *Messages* buffer after
> startup.

Thanks for the suggestion, Ihor. I’ll experiment.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting  to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
  2021-05-27 17:12 ` Richard Stanton
  2021-05-28  0:00   ` Tim Cross
@ 2021-05-29  6:41   ` Ihor Radchenko
  2021-05-29  7:18     ` Richard Stanton
  1 sibling, 1 reply; 7+ messages in thread
From: Ihor Radchenko @ 2021-05-29  6:41 UTC (permalink / raw)
  To: Richard Stanton; +Cc: Tim Cross, orgmode

Richard Stanton <rhstanton@berkeley.edu> writes:
> I currently load org using straight.el as follows:
> ...
> (use-package org-contrib
>   :after org
> ...
> (use-package org
>   :after (jupyter)

I suspect that something else is pulling built-in org version before
jupyter gets loaded. To make sure that the straight version of Org mode
is loaded, I recommend putting the following at the beginning of your
init.el:

(straight-use-package '(org :type git :repo "https://code.orgmode.org/bzg/org-mode.git"))
(straight-use-package '(org-contrib :type git :repo "https://git.sr.ht/~bzg/org-contrib"))

To debug similar issues, you might set use-package-verbose to t at the
beginning of your init.el and examine the *Messages* buffer after
startup.

Best,
Ihor


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting  to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)]
  2021-05-27 17:12 ` Richard Stanton
@ 2021-05-28  0:00   ` Tim Cross
  2021-05-29  6:41   ` Ihor Radchenko
  1 sibling, 0 replies; 7+ messages in thread
From: Tim Cross @ 2021-05-28  0:00 UTC (permalink / raw)
  To: Richard Stanton; +Cc: orgmode


Unfortunately, I don't know anything about straight.el. However, I note
that the very first line of your grep is a line from the org-compat.el
for version 9.5, so you are still getting mixed versions.

My guess is that straight.el is installing from the master branch of the
org repo rather than the maint branch. You then also install the contrib
package from non-gnu ELPA, which has a dependency on org (the ELPA or
orgmode.org version, which is 9.4).

My advice would be to not use straight.el and just use the org package
from ELPA (which will be in sync with the contrib package from nongnu
ELPA) or use striaght.el for both org and contrib or ensure straight.el
is using the maint branch and not the master branch.

Richard Stanton <rhstanton@berkeley.edu> writes:

> Thanks, Tim. 
>
> I deleted all org-related files and started again, with the same result. 
>
> Oddly, I do find reference to org-url-p in my basic org setup:
>
> Richards-Mac-Pro:~/.emacs.d/straight/repos/org/lisp stanton$ grep -i org-url-p *.el  
> org-compat.el:(define-obsolete-function-alias 'org-file-url-p 'org-url-p "9.5")
> org-lint.el:   (and (not (org-url-p file))
> org-macs.el:(defun org-url-p (s)
> org.el:   (uri-is-url (org-url-p uri))
> org.el:  (let* ((is-url (org-url-p file))
> org.el:   (when (org-url-p file)
> Richards-Mac-Pro:~/.emacs.d/straight/repos/org/lisp stanton$ 
>
> I currently load org using straight.el as follows:
>
> (setq package-archives
>     '(("melpa" . "http://melpa.org/packages/")
>       ("gnu" . "http://elpa.gnu.org/packages/")
>       ("nongnu" . "http://elpa.gnu.org/nongnu/")))
> ;;;      ("org" . "http://orgmode.org/elpa/")))
>
> (use-package org-contrib
>   :after org
>   :config
>   (require 'ox-extra)
>   (ox-extras-activate '(ignore-headlines))
> )
>
> (use-package org
>   :after (jupyter)
>   :straight t
>   :mode (("\\.org$" . org-mode))
> ;  :ensure org-plus-contrib
>   :config
>   (org-babel-do-load-languages
>    'org-babel-load-languages
>    '((jupyter . t)))
>   :bind
>   ("C-c l" . org-store-link)
>   ("C-c a" . org-agenda)
>   :init
>   (add-hook 'org-mode-hook (lambda () (setq-local company-minimum-prefix-length 0)))
>
> Best,
>
> Richard
>
>  From: Tim Cross <theophilusx@gmail.com>
>  To: emacs-orgmode@gnu.org
>  Subject: Re: [BUG] New error: (void-function org-url-p) when exporting
>  to LaTeX [9.4.6 (9.4.6-gc5573b @
>  /Users/stanton/.emacs.d/straight/build/org/)]
>  Message-ID: <87tumomy05.fsf@gmail.com>
>  Content-Type: text/plain
>
>  OK, think I've worked out what the problem is.
>
>  The function org-url-p is defined in org 9.5, but not org 9.4. Your
>  running org 9.4.6, which does not have that function. The fact something
>  in your install is trying to call org-url-p would indicate you have a
>  mixed or messed up installation of org (i.e. your setup is loading code
>  from 2 different versions).
>
>  It is very important when upgrading or installing org that no org
>  functionality is yet loaded to avoid this type of issue. Your best bet
>  is to remove all org related packages and then try installing org again.
>  If your using package.el to install org, make sure the call to install
>  it is early in your init file (before any functionality is loaded which
>  depends on org). I also find the use-pacakge macro very useful in this
>  regard as you can also setup things so that no org functionality is
>  loaded until you try to use something which depends on org. This means
>  you can typically start Emacs and immediately install/upgrade org
>  without any issues. Where people tend to come undone is when they have
>  been running Emacs for a while, have been using org and then to a
>  package update and the system tries to install a new version of org
>  (usually only an issue with new major versions rather than patch fix
>  version updates). 
>
>  Richard Stanton <rhstanton@berkeley.edu> writes:
>
>  Remember to cover the basics, that is, what you expected to happen and
>  what in fact did happen.  You don't know how to make a good report?  See
>
>      https://orgmode.org/manual/Feedback.html#Feedback
>
>  Your bug report will be posted to the Org mailing list.
>  ------------------------------------------------------------------------
>
>  Everything worked fine until yesterday, but today when I try to export an org file that contains the line
>
>  #+SETUPFILE: https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup
>
>  I get the following error:
>
>  Debugger entered--Lisp error: (void-function org-url-p)
>   org-url-p("https://fniessen.github.io/org-html-themes/org/the...")
>   org--collect-keywords-1(("SETUPFILE" "FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES"
>  "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES") nil nil nil)
>   org-collect-keywords(("FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY"
>  "SEQ_TODO"
>  "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES"))
>   org-set-regexps-and-options()
>   org-mode()
>   org-export--prepare-file-contents("/Users/stanton/.org/setup" nil 0 1 1 #<hash-table equal 0/65 0x1fe65e6c9285>
>  "/Users/stanton/teaching/MFE230I/mfe230i.org")
>   org-export-expand-include-keyword()
>   org-export-as(latex nil nil nil (:output-file "mfe230i.tex"))
>   org-export-to-file(latex "mfe230i.tex" nil nil nil nil nil #f(compiled-function (file) #<bytecode 0x1fe65e28d06d>))
>   org-latex-export-to-pdf(nil nil nil nil)
>   org-export-dispatch(nil)
>   funcall-interactively(org-export-dispatch nil)
>   call-interactively(org-export-dispatch nil nil)
>   command-execute(org-export-dispatch)
>
>  Thanks for any suggestions.
>
>  Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin20.3.0, Carbon Version 164 AppKit 2022.3)
>  of 2021-04-06
>  Package: Org mode version 9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)
>
>  -- 
>  Tim Cross


-- 
Tim Cross


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [BUG] New error: (void-function org-url-p) when exporting  to LaTeX [9.4.6 (9.4.6-gc5573b @  /Users/stanton/.emacs.d/straight/build/org/)]
       [not found] <mailman.45.1622131210.31880.emacs-orgmode@gnu.org>
@ 2021-05-27 17:12 ` Richard Stanton
  2021-05-28  0:00   ` Tim Cross
  2021-05-29  6:41   ` Ihor Radchenko
  0 siblings, 2 replies; 7+ messages in thread
From: Richard Stanton @ 2021-05-27 17:12 UTC (permalink / raw)
  To: orgmode; +Cc: Tim Cross

[-- Attachment #1: Type: text/plain, Size: 5270 bytes --]

Thanks, Tim. 

I deleted all org-related files and started again, with the same result. 

Oddly, I do find reference to org-url-p in my basic org setup:

Richards-Mac-Pro:~/.emacs.d/straight/repos/org/lisp stanton$ grep -i org-url-p *.el  
org-compat.el:(define-obsolete-function-alias 'org-file-url-p 'org-url-p "9.5")
org-lint.el:	  (and (not (org-url-p file))
org-macs.el:(defun org-url-p (s)
org.el:			  (uri-is-url (org-url-p uri))
org.el:  (let* ((is-url (org-url-p file))
org.el:	   (when (org-url-p file)
Richards-Mac-Pro:~/.emacs.d/straight/repos/org/lisp stanton$ 

I currently load org using straight.el as follows:

(setq package-archives
    '(("melpa" . "http://melpa.org/packages/")
      ("gnu" . "http://elpa.gnu.org/packages/")
      ("nongnu" . "http://elpa.gnu.org/nongnu/")))
;;;      ("org" . "http://orgmode.org/elpa/")))

(use-package org-contrib
  :after org
  :config
  (require 'ox-extra)
  (ox-extras-activate '(ignore-headlines))
)

(use-package org
  :after (jupyter)
  :straight t
  :mode (("\\.org$" . org-mode))
;  :ensure org-plus-contrib
  :config
  (org-babel-do-load-languages
   'org-babel-load-languages
   '((jupyter . t)))
  :bind
  ("C-c l" . org-store-link)
  ("C-c a" . org-agenda)
  :init
  (add-hook 'org-mode-hook (lambda () (setq-local company-minimum-prefix-length 0)))

Best,

Richard



> From: Tim Cross <theophilusx@gmail.com>
> To: emacs-orgmode@gnu.org
> Subject: Re: [BUG] New error: (void-function org-url-p) when exporting
> 	to LaTeX [9.4.6 (9.4.6-gc5573b @
> 	/Users/stanton/.emacs.d/straight/build/org/)]
> Message-ID: <87tumomy05.fsf@gmail.com>
> Content-Type: text/plain
> 
> 
> OK, think I've worked out what the problem is.
> 
> The function org-url-p is defined in org 9.5, but not org 9.4. Your
> running org 9.4.6, which does not have that function. The fact something
> in your install is trying to call org-url-p would indicate you have a
> mixed or messed up installation of org (i.e. your setup is loading code
> from 2 different versions).
> 
> It is very important when upgrading or installing org that no org
> functionality is yet loaded to avoid this type of issue. Your best bet
> is to remove all org related packages and then try installing org again.
> If your using package.el to install org, make sure the call to install
> it is early in your init file (before any functionality is loaded which
> depends on org). I also find the use-pacakge macro very useful in this
> regard as you can also setup things so that no org functionality is
> loaded until you try to use something which depends on org. This means
> you can typically start Emacs and immediately install/upgrade org
> without any issues. Where people tend to come undone is when they have
> been running Emacs for a while, have been using org and then to a
> package update and the system tries to install a new version of org
> (usually only an issue with new major versions rather than patch fix
> version updates). 
> 
> Richard Stanton <rhstanton@berkeley.edu> writes:
> 
>> Remember to cover the basics, that is, what you expected to happen and
>> what in fact did happen.  You don't know how to make a good report?  See
>> 
>>     https://orgmode.org/manual/Feedback.html#Feedback
>> 
>> Your bug report will be posted to the Org mailing list.
>> ------------------------------------------------------------------------
>> 
>> Everything worked fine until yesterday, but today when I try to export an org file that contains the line
>> 
>> #+SETUPFILE: https://fniessen.github.io/org-html-themes/org/theme-readtheorg.setup
>> 
>> I get the following error:
>> 
>> Debugger entered--Lisp error: (void-function org-url-p)
>>  org-url-p("https://fniessen.github.io/org-html-themes/org/the...")
>>  org--collect-keywords-1(("SETUPFILE" "FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES"
>> "PROPERTY" "SEQ_TODO" "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES") nil nil nil)
>>  org-collect-keywords(("FILETAGS" "TAGS" "ARCHIVE" "CATEGORY" "COLUMNS" "CONSTANTS" "LINK" "OPTIONS" "PRIORITIES" "PROPERTY" "SEQ_TODO"
>> "STARTUP" "TODO" "TYP_TODO") ("ARCHIVE" "CATEGORY" "COLUMNS" "PRIORITIES"))
>>  org-set-regexps-and-options()
>>  org-mode()
>>  org-export--prepare-file-contents("/Users/stanton/.org/setup" nil 0 1 1 #<hash-table equal 0/65 0x1fe65e6c9285>
>> "/Users/stanton/teaching/MFE230I/mfe230i.org")
>>  org-export-expand-include-keyword()
>>  org-export-as(latex nil nil nil (:output-file "mfe230i.tex"))
>>  org-export-to-file(latex "mfe230i.tex" nil nil nil nil nil #f(compiled-function (file) #<bytecode 0x1fe65e28d06d>))
>>  org-latex-export-to-pdf(nil nil nil nil)
>>  org-export-dispatch(nil)
>>  funcall-interactively(org-export-dispatch nil)
>>  call-interactively(org-export-dispatch nil nil)
>>  command-execute(org-export-dispatch)
>> 
>> Thanks for any suggestions.
>> 
>> Emacs  : GNU Emacs 27.2 (build 1, x86_64-apple-darwin20.3.0, Carbon Version 164 AppKit 2022.3)
>> of 2021-04-06
>> Package: Org mode version 9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)
> 
> 
> -- 
> Tim Cross


[-- Attachment #2: Type: text/html, Size: 9942 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-05-29  7:20 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-26 22:53 [BUG] New error: (void-function org-url-p) when exporting to LaTeX [9.4.6 (9.4.6-gc5573b @ /Users/stanton/.emacs.d/straight/build/org/)] Richard Stanton
2021-05-27  6:56 ` Tim Cross
2021-05-27  7:19 ` Tim Cross
     [not found] <mailman.45.1622131210.31880.emacs-orgmode@gnu.org>
2021-05-27 17:12 ` Richard Stanton
2021-05-28  0:00   ` Tim Cross
2021-05-29  6:41   ` Ihor Radchenko
2021-05-29  7:18     ` Richard Stanton

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).