emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-fill-paragraph crashes at eob
@ 2012-08-19  0:44 Samuel Wales
  2012-08-19  7:53 ` Nicolas Goaziou
  2012-08-19 11:48 ` Nicolas Goaziou
  0 siblings, 2 replies; 3+ messages in thread
From: Samuel Wales @ 2012-08-19  0:44 UTC (permalink / raw)
  To: emacs-orgmode

Cannot debug it, but when org-fill-paragraph is called on a paragraph
with no final newline.  Top:

Debugger entered--Lisp error: (args-out-of-range 1179 1263)
  buffer-substring-no-properties(1179 1263)
  (replace-regexp-in-string "	" (make-string tab-width 32)
(buffer-substring-no-properties (point) end))

Thanks.

Samuel

-- 
The Kafka Pandemic: http://thekafkapandemic.blogspot.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-fill-paragraph crashes at eob
  2012-08-19  0:44 org-fill-paragraph crashes at eob Samuel Wales
@ 2012-08-19  7:53 ` Nicolas Goaziou
  2012-08-19 11:48 ` Nicolas Goaziou
  1 sibling, 0 replies; 3+ messages in thread
From: Nicolas Goaziou @ 2012-08-19  7:53 UTC (permalink / raw)
  To: Samuel Wales; +Cc: emacs-orgmode

Hello,

Samuel Wales <samologist@gmail.com> writes:

> Cannot debug it, but when org-fill-paragraph is called on a paragraph
> with no final newline.  Top:
>
> Debugger entered--Lisp error: (args-out-of-range 1179 1263)
>   buffer-substring-no-properties(1179 1263)
>   (replace-regexp-in-string "	" (make-string tab-width 32)
> (buffer-substring-no-properties (point) end))

I cannot reproduce it, but it looks like an error in
`org-element--parse-objects'.

Could you reproduce here the paragraph triggering the problem? It may
contain an object not correctly parsed.


Thanks,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-fill-paragraph crashes at eob
  2012-08-19  0:44 org-fill-paragraph crashes at eob Samuel Wales
  2012-08-19  7:53 ` Nicolas Goaziou
@ 2012-08-19 11:48 ` Nicolas Goaziou
  1 sibling, 0 replies; 3+ messages in thread
From: Nicolas Goaziou @ 2012-08-19 11:48 UTC (permalink / raw)
  To: Samuel Wales; +Cc: emacs-orgmode

Hello,

Samuel Wales <samologist@gmail.com> writes:

> Cannot debug it, but when org-fill-paragraph is called on a paragraph
> with no final newline.  Top:
>
> Debugger entered--Lisp error: (args-out-of-range 1179 1263)
>   buffer-substring-no-properties(1179 1263)
>   (replace-regexp-in-string "	" (make-string tab-width 32)
> (buffer-substring-no-properties (point) end))

After some investigation, it seems that the error was returned when
filling a narrowed buffer.

It should be fixed now. Thank you for reporting this.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2012-08-19 11:52 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-08-19  0:44 org-fill-paragraph crashes at eob Samuel Wales
2012-08-19  7:53 ` Nicolas Goaziou
2012-08-19 11:48 ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).