emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: org-babel-ref-resolve does not find refs in a COMMENT'ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)]
@ 2020-06-05 16:05 Ken Mankoff
  2020-06-05 16:49 ` Nicolas Goaziou
  0 siblings, 1 reply; 2+ messages in thread
From: Ken Mankoff @ 2020-06-05 16:05 UTC (permalink / raw)
  To: emacs-orgmode

Hello,

I think this is a recent change in behavior. I can no longer eval Babel blocks that expect table inputs via :var when they are in a section with a COMMENT status.



Here is an MWE org file:

=== BEGIN ===

* COMMENT Tables not found when section is commented

#+NAME: table
| foo |

(org-babel-ref-resolve "table")

=== END ===




When I try to eval (org-babel-ref-resolve "table"), Org reports:

org-babel-ref-resolve: Reference ‘table’ not found in this buffer

If I remove the "COMMENT" state on the heading, then the table is found.

I do not recall this happening in earlier versions of Org, but does now with the latest version from melpa.





Tested with /usr/bin/emacs -Q -l ~/.emacs.d/DEBUG.el ~/.emacs.d/DEBUG.org with DEBUG.org above and DEBUG.el containing:


(setq package-user-dir (expand-file-name "elpa" "~/.emacs.d/DEBUG"))
(require 'package)
(setq package-enable-at-startup nil)
(add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/") t)
(add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t)
(package-initialize)
(unless (package-installed-p 'use-package)
  (package-refresh-contents)
  (package-install 'use-package))
(setq package-enable-at-startup nil)
(defvar use-package-verbose t)
(require 'use-package)
(setq use-package-always-ensure t)

(use-package org
  :ensure org-plus-contrib
  :config
  (setq org-confirm-babel-evaluate nil)
  (org-babel-do-load-languages
   'org-babel-load-languages
   '((shell . t))))


  -k.


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Bug: org-babel-ref-resolve does not find refs in a COMMENT'ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)]
  2020-06-05 16:05 Bug: org-babel-ref-resolve does not find refs in a COMMENT'ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)] Ken Mankoff
@ 2020-06-05 16:49 ` Nicolas Goaziou
  0 siblings, 0 replies; 2+ messages in thread
From: Nicolas Goaziou @ 2020-06-05 16:49 UTC (permalink / raw)
  To: Ken Mankoff; +Cc: emacs-orgmode

Hello,

Ken Mankoff <mankoff@gmail.com> writes:

> I think this is a recent change in behavior. I can no longer eval Babel blocks that expect table inputs via :var when they are in a section with a COMMENT status.
>
>
>
> Here is an MWE org file:
>
> === BEGIN ===
>
> * COMMENT Tables not found when section is commented
>
> #+NAME: table
> | foo |
>
> (org-babel-ref-resolve "table")
>
> === END ===
>
>
>
>
> When I try to eval (org-babel-ref-resolve "table"), Org reports:
>
> org-babel-ref-resolve: Reference ‘table’ not found in this buffer
>
> If I remove the "COMMENT" state on the heading, then the table is
> found.

This sounds correct. A commented section is dead code, after all.

Regards,

-- 
Nicolas Goaziou


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-06-05 16:50 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-05 16:05 Bug: org-babel-ref-resolve does not find refs in a COMMENT'ed section [9.3.7 (9.3.7-elpaplus @ /home/kdm/.emacs.d/DEBUG/elpa/org-plus-contrib-20200602/)] Ken Mankoff
2020-06-05 16:49 ` Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).