emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* minted in Org 8.6
@ 2014-04-29 14:53 Ken Mankoff
  2014-04-29 15:43 ` Richard Lawrence
  0 siblings, 1 reply; 2+ messages in thread
From: Ken Mankoff @ 2014-04-29 14:53 UTC (permalink / raw)
  To: emacs-orgmode


When I export w/ the latest Org all code environments are verbatim, not
minted. I'm using a test example from
https://lists.gnu.org/archive/html/emacs-orgmode/2011-11/msg00585.html
which is:

#+begin_src emacs-lisp
;; minted latex export
(setq org-export-latex-listings 'minted
      org-export-latex-minted-options
      '(("frame" "lines")
        ("fontsize" "\\scriptsize")
        ("linenos" "")))
#+end_src


If I test this with "emacs -Q", it works. If I test it with my default,
code is exported as "verbatim". This suggests the bug is in an init file
of mine.

However, I have removed all Org sections of my init file. I am fairly
confident this is not a setting of mine, since if I look at the current
state included in a "org-submit-bug-report", the state is almost the
same between "emacs" and "emacs -Q", the only difference being Org 7.9 v.
Org 8.6, and a few default settings that have changed between the two.

Could this be a setting set somewhere else that is not included in the
bug report? How would I find it? Or is it a bug w/ minted export in the
latest Org? 

Thanks,

  -k.

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: minted in Org 8.6
  2014-04-29 14:53 minted in Org 8.6 Ken Mankoff
@ 2014-04-29 15:43 ` Richard Lawrence
  0 siblings, 0 replies; 2+ messages in thread
From: Richard Lawrence @ 2014-04-29 15:43 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: Ken Mankoff

Hi Ken,

Ken Mankoff <mankoff@gmail.com> writes:

> #+begin_src emacs-lisp
> ;; minted latex export
> (setq org-export-latex-listings 'minted
>       org-export-latex-minted-options
>       '(("frame" "lines")
>         ("fontsize" "\\scriptsize")
>         ("linenos" "")))
> #+end_src
>
> If I test this with "emacs -Q", it works. If I test it with my default,
> code is exported as "verbatim". This suggests the bug is in an init file
> of mine.
>
> However, I have removed all Org sections of my init file. I am fairly
> confident this is not a setting of mine, since if I look at the current
> state included in a "org-submit-bug-report", the state is almost the
> same between "emacs" and "emacs -Q", the only difference being Org 7.9 v.
> Org 8.6, and a few default settings that have changed between the two.

The new exporter, which arrived in 8.0, renamed most variables related
to export.  I think the variables you are setting here are now named:

org-latex-listings
org-latex-minted-options

My guess is that renaming them in your init file will fix the problem.

-- 
Best,
Richard

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-04-29 15:45 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-04-29 14:53 minted in Org 8.6 Ken Mankoff
2014-04-29 15:43 ` Richard Lawrence

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).