emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive
       [not found] <5A1A94B2-B206-4068-87C8-138E6D202BDE@sanityinc.com>
@ 2016-01-11  4:19 ` Andrew Hyatt
       [not found] ` <m2k2ng9299.fsf@gmail.com>
  2020-05-22 11:42 ` bug#2409: Status: " Bastien
  2 siblings, 0 replies; 5+ messages in thread
From: Andrew Hyatt @ 2016-01-11  4:19 UTC (permalink / raw)
  To: Steve Purcell; +Cc: 2409


I can't reproduce this under Emacs 25. As this bug is a bit old, I'm
guessing it has been fixed in the meantime. Please let me know if you
can still reproduce it, though. I'll mark this as unreproducible now,
and close it in a few weeks if you can't reproduce it either under Emacs
25.

Steve Purcell <steve@sanityinc.com> writes:

> Typing into an org buffer becomes very unresponsive under viper-mode. The input
> cursor flickers rapidly between windows, and entered characters are not
> immediately displayed.
>
> I could not reproduce this bug via "emacsclient -t" -- it appears to affect only
> my Emacs' main NS frame.
>
> How to reproduce:
>
> Fire up emacs with -q.
>
> Start viper-mode (M-x viper-mode, then 'n', '5', 'n').
>
> Open an org document.  Split the window, e.g. with C-x 2, so that the org doc is
> in one window, and a different buffer (e.g. *scratch*) is in the other window.
> You'll need to "M-x viper-mode" in the *scratch* buffer to flip it into viper
> mode too.
>
> Now, enter insert mode in *scratch* (i) and type a few words.  The typing should
> be responsive, with no cursor flicker.
>
> Now switch to the org buffer and try the same.  The typing becomes unresponsive,
> with a delay before the characters/words appear, and the cursor will flicker
> rapidly between the two buffers.
>
> The lack of responsiveness has caused me to give up on CVS Emacs for now, since
> I'm so reliant on org-mode, and although I looked briefly in the org code for a
> possible cause, I didn't discover anything.
>
> I've observed the flickering from non-org buffers, but not to the same extent,
> and I haven't detected a pattern.
>
> If I remember correctly, this started sometime in January; I update my Emacs and
> Org from CVS/git almost daily, so either could be at fault.
>
>
>
> In GNU Emacs 23.0.90.1 (i386-apple-darwin9.6.0, NS apple-appkit-949.43)
>  of 2009-02-20 on mandala.as24.local
> Windowing system distributor `Apple', version 10.3.949
> configured using `configure  '--with-ns''
>
> Important settings:
>   value of $LC_ALL: nil
>   value of $LC_COLLATE: nil
>   value of $LC_CTYPE: en_US.UTF-8
>   value of $LC_MESSAGES: nil
>   value of $LC_MONETARY: nil
>   value of $LC_NUMERIC: nil
>   value of $LC_TIME: nil
>   value of $LANG: en_US
>   value of $XMODIFIERS: nil
>   locale-coding-system: utf-8-unix
>   default-enable-multibyte-characters: t
>
> Major mode: Help
>
> Minor modes in effect:
>   tooltip-mode: t
>   mouse-wheel-mode: t
>   menu-bar-mode: t
>   file-name-shadow-mode: t
>   global-font-lock-mode: t
>   font-lock-mode: t
>   global-auto-composition-mode: t
>   auto-composition-mode: t
>   auto-encryption-mode: t
>   auto-compression-mode: t
>   line-number-mode: t
>   transient-mark-mode: t
>   view-mode: t
>
> Recent input:
>
> Recent messages:
> For information about GNU Emacs and the GNU system, type C-h C-a.
> Quit
> Loading url...done
> Loading vc-git...done
> View mode: type C-h for help, h for commands, q to quit.
> Buffer is read-only: #<buffer HELLO>
> Type C-x 1 to delete the help window.
> Quit
> Making completion list... [3 times]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#2409:  bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive
       [not found] ` <m2k2ng9299.fsf@gmail.com>
@ 2016-01-11 22:43   ` Michael Brand
       [not found]   ` <CALn3zoggG_+3pgp9qagDNKpUGtApqw-aYMvPatu60BQiOeM6vA@mail.gmail.com>
  1 sibling, 0 replies; 5+ messages in thread
From: Michael Brand @ 2016-01-11 22:43 UTC (permalink / raw)
  To: Andrew Hyatt; +Cc: Steve Purcell, 2409

[-- Attachment #1: Type: text/plain, Size: 834 bytes --]

Hi Andrew

I would like to give some feedback to what you originally asked Steve:

On Mon, Jan 11, 2016 at 5:19 AM, Andrew Hyatt <ahyatt@gmail.com> wrote:
> I can't reproduce this under Emacs 25. As this bug is a bit old, I'm
> guessing it has been fixed in the meantime. Please let me know if you
> can still reproduce it, though. I'll mark this as unreproducible now,
> and close it in a few weeks if you can't reproduce it either under Emacs
> 25.

Did you check on OS X?

On GNU/Linux I never saw the issue, on OS X regularly under certain
circumstances which are not clear to me. With the recipe of Steve I
can reproduce on build GNU Emacs 25.1.50.1 (x86_64-apple-darwin13.4.0,
NS appkit-1265.21 Version 10.9.5 (Build 13F1507)) from
http://emacsformacosx.com/emacs-builds/Emacs-2016-01-11_01-40-53-eb0643c-universal.dmg

Michael

[-- Attachment #2: Type: text/html, Size: 1093 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#2409:  bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive
       [not found]   ` <CALn3zoggG_+3pgp9qagDNKpUGtApqw-aYMvPatu60BQiOeM6vA@mail.gmail.com>
@ 2016-01-12  1:57     ` Andrew Hyatt
       [not found]     ` <CAM6wYYJJcaUYT5evtLw3mBHa7TXref35HO2OphAeinFeSQRdzg@mail.gmail.com>
  1 sibling, 0 replies; 5+ messages in thread
From: Andrew Hyatt @ 2016-01-12  1:57 UTC (permalink / raw)
  To: Michael Brand; +Cc: Steve Purcell, 2409

[-- Attachment #1: Type: text/plain, Size: 1070 bytes --]

On Mon, Jan 11, 2016 at 5:43 PM Michael Brand <michael.ch.brand@gmail.com>
wrote:

> Hi Andrew
>
> I would like to give some feedback to what you originally asked Steve:
>
>
> On Mon, Jan 11, 2016 at 5:19 AM, Andrew Hyatt <ahyatt@gmail.com> wrote:
> > I can't reproduce this under Emacs 25. As this bug is a bit old, I'm
> > guessing it has been fixed in the meantime. Please let me know if you
> > can still reproduce it, though. I'll mark this as unreproducible now,
> > and close it in a few weeks if you can't reproduce it either under Emacs
> > 25.
>
> Did you check on OS X?
>
> On GNU/Linux I never saw the issue, on OS X regularly under certain
> circumstances which are not clear to me. With the recipe of Steve I
> can reproduce on build GNU Emacs 25.1.50.1 (x86_64-apple-darwin13.4.0,
> NS appkit-1265.21 Version 10.9.5 (Build 13F1507)) from
>
> http://emacsformacosx.com/emacs-builds/Emacs-2016-01-11_01-40-53-eb0643c-universal.dmg
>
>
Seeing as you can reproduce, I'll consider this reproducible... but I
cannot reproduce it myself on OS X.


>
> Michael
>

[-- Attachment #2: Type: text/html, Size: 1807 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#2409:  bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive
       [not found]     ` <CAM6wYYJJcaUYT5evtLw3mBHa7TXref35HO2OphAeinFeSQRdzg@mail.gmail.com>
@ 2016-05-17 17:35       ` Michael Brand
  0 siblings, 0 replies; 5+ messages in thread
From: Michael Brand @ 2016-05-17 17:35 UTC (permalink / raw)
  To: 2409

Hi all

I did some trials in lisp/org/org.el with
- Emacs on OS X built with configure --with-ns, 24.5 and today's
  master
- Org from today's master

1) Removing the line containing org-self-insert-command from

       (org-remap org-mode-map
                  'self-insert-command 'org-self-insert-command
                  'delete-char 'org-delete-char
                  'delete-backward-char 'org-delete-backward-char)

   lets the issue disappear. So the issue seems at least _related_ to
   org-self-insert-command.

2) When I instead remove all forms that contain
   org-self-insert-command or orgtbl-self-insert-command and then add

       ;; Reduce to a passing through to `self-insert-command'.
       (defun org-self-insert-command (N)
         (interactive "p")
         (self-insert-command N))
       ;; Leave this as it was originally.
       (org-remap org-mode-map
                  'self-insert-command 'org-self-insert-command
                  'delete-char 'org-delete-char
                  'delete-backward-char 'org-delete-backward-char)

   the issue remains but I expect it to disappear. Did I not replace
   self-insert-command just with itself and it should behave the same
   way as with change 1)?

Michael

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#2409: Status: 23.0.90; org-mode + viper-mode + ns make typing unresponsive
       [not found] <5A1A94B2-B206-4068-87C8-138E6D202BDE@sanityinc.com>
  2016-01-11  4:19 ` bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive Andrew Hyatt
       [not found] ` <m2k2ng9299.fsf@gmail.com>
@ 2020-05-22 11:42 ` Bastien
  2 siblings, 0 replies; 5+ messages in thread
From: Bastien @ 2020-05-22 11:42 UTC (permalink / raw)
  To: bug#2409

bug#2409 <2409@debbugs.gnu.org> writes:

> retitle 2409 23.0.90; org-mode + viper-mode + ns make typing unresponsive
> reassign 2409 emacs,org-mode
> submitter 2409 Steve Purcell <steve@sanityinc.com>
> severity 2409 normal

The bug was considered by several people in this thread as
non-reproducible.  Although I am not entirely it is not reproducible,
I close it, considering it is quite old now.

Steven, feel free to report the bug to emacs-orgmode@gnu.org is it is
still there.

-- 
 Bastien




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-05-22 11:43 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <5A1A94B2-B206-4068-87C8-138E6D202BDE@sanityinc.com>
2016-01-11  4:19 ` bug#2409: 23.0.90; org-mode + viper-mode + ns make typing unresponsive Andrew Hyatt
     [not found] ` <m2k2ng9299.fsf@gmail.com>
2016-01-11 22:43   ` bug#2409: " Michael Brand
     [not found]   ` <CALn3zoggG_+3pgp9qagDNKpUGtApqw-aYMvPatu60BQiOeM6vA@mail.gmail.com>
2016-01-12  1:57     ` Andrew Hyatt
     [not found]     ` <CAM6wYYJJcaUYT5evtLw3mBHa7TXref35HO2OphAeinFeSQRdzg@mail.gmail.com>
2016-05-17 17:35       ` Michael Brand
2020-05-22 11:42 ` bug#2409: Status: " Bastien

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).