emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* LaTeX export problem
@ 2012-09-12 16:47 Gary Oberbrunner
  2012-09-19  7:57 ` Bastien
  0 siblings, 1 reply; 29+ messages in thread
From: Gary Oberbrunner @ 2012-09-12 16:47 UTC (permalink / raw)
  To: Orgmode Mailing List

Using a recent git checkout of org-mode (f51c405), the following small
org-mode file produces invalid LaTeX.  I'm pretty sure it used to
work.  The \alpha and \beta seem to be what confuses it.

-------------------snip
* Scorecards
** Product Releases
| *Product* | *\alpha* | *\beta* | *Release* | *Status* |
|-----------+----------+---------+-----------+----------|
| test      | a        | b       | c         | d        |
-------------------snip

Open this with emacs -Q (emacs 24), load org-mode, and C-c C-e C-d to
export as LaTeX, you get the following error:

! Missing $ inserted.
<inserted text>
                $
l.44  \textbf{Product}  &  \textbf{\alpha}
                                            &  \textbf{\beta}  &  \textbf{Re...


I'm no LaTeX guru, but here's the generated file:

% Created 2012-09-12 Wed 12:37
\documentclass[11pt]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{fixltx2e}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{float}
\usepackage{wrapfig}
\usepackage{soul}
\usepackage{textcomp}
\usepackage{marvosym}
\usepackage{wasysym}
\usepackage{latexsym}
\usepackage{amssymb}
\usepackage{hyperref}
\tolerance=1000
\providecommand{\alert}[1]{\textbf{#1}}

\title{foo}
\author{}
\date{\today}
\hypersetup{
  pdfkeywords={},
  pdfsubject={},
  pdfcreator={Emacs Org-mode version 7.9.1}}

\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{Scorecards}
\label{sec-1}
\subsection{Product Releases}
\label{sec-1-1}


\begin{center}
\begin{tabular}{lllll}
 \textbf{Product}  &  \textbf{\alpha}  &  \textbf{\beta}  &
\textbf{Release}  &  \textbf{Status}  \\
\hline
 test              &  a                &  b               &  c
        &  d                \\
\end{tabular}
\end{center}

\end{document}


-- 
Gary

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-12 16:47 LaTeX export problem Gary Oberbrunner
@ 2012-09-19  7:57 ` Bastien
  2012-09-20 14:59   ` Alexander Vorobiev
  0 siblings, 1 reply; 29+ messages in thread
From: Bastien @ 2012-09-19  7:57 UTC (permalink / raw)
  To: Gary Oberbrunner; +Cc: Orgmode Mailing List

Hi Gary,

Gary Oberbrunner <garyo@oberbrunner.com> writes:

> Using a recent git checkout of org-mode (f51c405), the following small
> org-mode file produces invalid LaTeX.  I'm pretty sure it used to
> work.  The \alpha and \beta seem to be what confuses it.
>
> -------------------snip
> * Scorecards
> ** Product Releases
> | *Product* | *\alpha* | *\beta* | *Release* | *Status* |
> |-----------+----------+---------+-----------+----------|
> | test      | a        | b       | c         | d        |
> -------------------snip
>
> Open this with emacs -Q (emacs 24), load org-mode, and C-c C-e C-d to
> export as LaTeX, you get the following error:

The new LaTeX exporter does the right thing here.

You can experiment with it or wait until it is part of core.

Thanks,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-19  7:57 ` Bastien
@ 2012-09-20 14:59   ` Alexander Vorobiev
  2012-09-21  8:48     ` Bastien
  0 siblings, 1 reply; 29+ messages in thread
From: Alexander Vorobiev @ 2012-09-20 14:59 UTC (permalink / raw)
  To: Bastien; +Cc: Orgmode Mailing List, Gary Oberbrunner

Hi,

I am having similar problems with LaTeX export. I am exporting source
code snippets (XML) which has many variables with underscores in their
names. At some point in the process of switching to more recent Org
the export started producing incorrect LaTeX so the generation of PDF
fails, therefore the functionality is unusable for me.

Could you point us to any documentation on how to switch to the new
exporter? Is the tutorial
http://orgmode.org/worg/org-tutorials/org-latex-export.html still
relevant?

Thanks
Alex

On Wed, Sep 19, 2012 at 2:57 AM, Bastien <bzg@altern.org> wrote:
> Hi Gary,
>
> Gary Oberbrunner <garyo@oberbrunner.com> writes:
>
>> Using a recent git checkout of org-mode (f51c405), the following small
>> org-mode file produces invalid LaTeX.  I'm pretty sure it used to
>> work.  The \alpha and \beta seem to be what confuses it.
>>
>> -------------------snip
>> * Scorecards
>> ** Product Releases
>> | *Product* | *\alpha* | *\beta* | *Release* | *Status* |
>> |-----------+----------+---------+-----------+----------|
>> | test      | a        | b       | c         | d        |
>> -------------------snip
>>
>> Open this with emacs -Q (emacs 24), load org-mode, and C-c C-e C-d to
>> export as LaTeX, you get the following error:
>
> The new LaTeX exporter does the right thing here.
>
> You can experiment with it or wait until it is part of core.
>
> Thanks,
>
> --
>  Bastien
>

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-20 14:59   ` Alexander Vorobiev
@ 2012-09-21  8:48     ` Bastien
  2012-09-21 19:47       ` Alexander Vorobiev
  0 siblings, 1 reply; 29+ messages in thread
From: Bastien @ 2012-09-21  8:48 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: Gary Oberbrunner, Orgmode Mailing List

Hi Alexander,

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> Could you point us to any documentation on how to switch to the new
> exporter? 

Add contrib/lisp to your load-path.

(require 'org-e-latex)

then M-x org-export-dispatch RET to get a menu and be able to 
export to LaTeX from here.

> Is the tutorial
> http://orgmode.org/worg/org-tutorials/org-latex-export.html still
> relevant?

No, this tutorial is valid for the current exporter, not for 
Nicolas exporter.

HTH,

-- 
 Bastien

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-21  8:48     ` Bastien
@ 2012-09-21 19:47       ` Alexander Vorobiev
  2012-09-21 21:21         ` Thomas S. Dye
  2012-09-22  8:07         ` Nicolas Goaziou
  0 siblings, 2 replies; 29+ messages in thread
From: Alexander Vorobiev @ 2012-09-21 19:47 UTC (permalink / raw)
  To: Bastien; +Cc: Gary Oberbrunner, Orgmode Mailing List

I tried the new exporter (using today's snapshot of the sources) and
it produced invalid LaTeX (it calls hypersetup without loading
hyperref package). It also ignored the #+LaTeX_CLASS: and all the
#+LaTeX_HEADER:lines in my file. Are there any examples of org files
which show how to customize the new LaTeX exporter?

Thanks
Alex

On Fri, Sep 21, 2012 at 3:48 AM, Bastien <bzg@altern.org> wrote:
> Hi Alexander,
>
> Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:
>
>> Could you point us to any documentation on how to switch to the new
>> exporter?
>
> Add contrib/lisp to your load-path.
>
> (require 'org-e-latex)
>
> then M-x org-export-dispatch RET to get a menu and be able to
> export to LaTeX from here.
>
>> Is the tutorial
>> http://orgmode.org/worg/org-tutorials/org-latex-export.html still
>> relevant?
>
> No, this tutorial is valid for the current exporter, not for
> Nicolas exporter.
>
> HTH,
>
> --
>  Bastien

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-21 19:47       ` Alexander Vorobiev
@ 2012-09-21 21:21         ` Thomas S. Dye
  2012-09-22  8:01           ` Nicolas Goaziou
  2012-09-22  8:07         ` Nicolas Goaziou
  1 sibling, 1 reply; 29+ messages in thread
From: Thomas S. Dye @ 2012-09-21 21:21 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: Bastien, Orgmode Mailing List, Gary Oberbrunner

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> I tried the new exporter (using today's snapshot of the sources) and
> it produced invalid LaTeX (it calls hypersetup without loading
> hyperref package). It also ignored the #+LaTeX_CLASS: and all the
> #+LaTeX_HEADER:lines in my file. Are there any examples of org files
> which show how to customize the new LaTeX exporter?
>
> Thanks
> Alex

Aloha Alex,

I've been exploring the new exporter with a recent project. I have the
following probably too complex setup that lets me use biblatex in
conjunction with ebib.  I'm also using a customized setup for the Lucida
fonts (packages tsdlucida and lucidabr), which you'll most likely want
to change.

* Org-mode setup                                                   :noexport:
This is a setup for Nicolas Goaziou's new exporter

#+name: setup
#+begin_src emacs-lisp :noweb yes :results silent
    (require 'org-export)
    (require 'org-e-latex)
    (require 'org-e-html)
    (setq org-export-latex-packages-alist nil)
    (add-to-list 'org-export-latex-packages-alist '("colorlinks=true,urlcolor=SteelBlue4,linkcolor=Firebrick4,citecolor=Green4" "hyperref"))
    (add-to-list 'org-export-latex-packages-alist '("style=authoryear-comp,backend=bibtex8" "biblatex"))
    (add-to-list 'org-export-latex-packages-alist '("x11names" "xcolor"))
    (add-to-list 'org-export-latex-packages-alist '("" "microtype"))
    (add-to-list 'org-export-latex-packages-alist '("" "graphicx"))
    (add-to-list 'org-export-latex-packages-alist '("" "ragged2e"))
    (add-to-list 'org-export-latex-packages-alist '("" "booktabs"))
    (add-to-list 'org-export-latex-packages-alist '("" "tabularx"))
    (add-to-list 'org-export-latex-packages-alist '("" "tsdlucida"))
    (add-to-list 'org-export-latex-packages-alist '("" "wasysym"))
    (add-to-list 'org-export-latex-packages-alist '("" "paralist"))
    (add-to-list 'org-export-latex-packages-alist '("altbullet,lucidasmallscale,expert,vargreek" "lucidabr"))
    (add-to-list 'org-export-latex-packages-alist '("T1" "fontenc"))
    (add-to-list 'org-export-latex-packages-alist '("AUTO" "inputenc"))
    (setq org-entities-user nil) 
    (add-to-list 'org-entities-user '("space" "\\ " nil " " " " " " " "))
    (add-to-list 'org-entities-user '("amacron" "\\={a}" nil "&#0257" "a" "a" "ā"))
    (add-to-list 'org-entities-user '("emacron" "\\={e}" nil "&#0275" "e" "e" "ē"))
    (add-to-list 'org-entities-user '("imacron" "\\={i}" nil "&#0299" "i" "i" "ī"))
    (add-to-list 'org-entities-user '("omacron" "\\={o}" nil "&#0333" "o" "o" "ō"))
    (add-to-list 'org-entities-user '("umacron" "\\={u}" nil "&#0363" "u" "u" "ū"))
    (add-to-list 'org-entities-user '("Amacron" "\\={A}" nil "&#0256" "A" "A" "Ā"))
    (add-to-list 'org-entities-user '("Emacron" "\\={E}" nil "&#0274" "E" "E" "Ē"))
    (add-to-list 'org-entities-user '("Imacron" "\\={I}" nil "&#0298" "I" "I" "Ī"))
    (add-to-list 'org-entities-user '("Omacron" "\\={O}" nil "&#0332" "O" "O" "Ō"))
    (add-to-list 'org-entities-user '("Umacron" "\\={U}" nil "&#0362" "U" "U" "Ū"))
    (setq org-e-latex-pdf-process '("texi2dvi --pdf --clean --verbose --batch %f"))
    (require 'org-special-blocks)
    (define-key org-mode-map (kbd "C-c e") 'org-export-dispatch)
    (setq org-e-latex-tables-booktabs t)
    (setq org-export-latex-hyperref-format "\\ref{%s}")
    (setq org-e-latex-remove-logfiles nil)
    (setq org-e-latex-toc-command "\\tableofcontents\n\n")
    (add-to-list 'org-e-latex-classes
                 '("koma-article"
                   "\\documentclass{scrartcl}
      [NO-DEFAULT-PACKAGES]
      [PACKAGES]
      [EXTRA]
      \\let\\itemize\\compactitem
      \\let\\description\\compactdesc
      \\let\\enumerate\\compactenum
      \\bibliography{local}
      \\newcolumntype{Y}{>{\\RaggedRight\\arraybackslash}X}"
                   ("\\section{%s}" . "\\section*{%s}")
                   ("\\subsection{%s}" . "\\subsection*{%s}")
                   ("\\subsubsection{%s}" . "\\subsubsection*{%s}")
                   ("\\paragraph{%s}" . "\\paragraph*{%s}")
                   ("\\subparagraph{%s}" . "\\subparagraph*{%s}")))
    <<ngz-nbsp>>
    <<define-standard-biblatex-commands>>
    <<define-style-specific-biblatex-commands>>
#+end_src

** Standard Biblatex citation commands

#+name: define-standard-biblatex-commands
#+begin_src emacs-lisp :noweb yes :results silent :exports none
  <<define-biblatex-cite-link>>
  <<define-biblatex-cap-cite-link>>
  <<define-biblatex-parencite-link>>
  <<define-biblatex-cap-parencite-link>>
  <<define-biblatex-footcite-link>>
  <<define-biblatex-footcitetext-link>>

#+end_src

#+name: define-biblatex-cite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "cite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "cite:" desc)))
           (format "\\cite{%s}" path)
         (format "\\cite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-cap-cite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "Cite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "Cite:" desc)))
           (format "\\Cite{%s}" path)
         (format "\\Cite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-parencite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "parencite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "parencite:" desc)))
           (format "\\parencite{%s}" path)
         (format "\\parencite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-cap-parencite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "Parencite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "Parencite:" desc)))
           (format "\\Parencite{%s}" path)
         (format "\\Parencite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-footcite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "footcite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "footcite:" desc)))
           (format "\\footcite{%s}" path)
         (format "\\footcite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-footcitetext-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "footcitetext" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "footcitetext:" desc)))
           (format "\\footcitetext{%s}" path)
         (format "\\footcitetext[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

** Style-specific biblatex commands

#+name: define-style-specific-biblatex-commands
#+begin_src emacs-lisp :noweb yes :results silent :exports none
  <<define-biblatex-textcite-link>>
  <<define-biblatex-cap-textcite-link>>
  <<define-biblatex-smartcite-link>>
  <<define-biblatex-cap-smartcite-link>>
  <<define-biblatex-citestar-link>>
  <<define-biblatex-parencitestar-link>>
  <<define-biblatex-supercite-link>>
  <<define-biblatex-multicite-link>>
#+end_src

#+name: define-biblatex-multicite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "multicite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "multicite:" desc)))
           (format "{%s}" path)
         (format "[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
  
#+end_src

#+name: define-biblatex-textcite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "textcite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "textcite:" desc)))
           (format "\\textcite{%s}" path)
         (format "\\textcite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-cap-textcite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "Textcite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "Textcite:" desc)))
           (format "\\Textcite{%s}" path)
         (format "\\Textcite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-smartcite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "smartcite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "smartcite:" desc)))
           (format "\\smartcite{%s}" path)
         (format "\\smartcite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-cap-smartcite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "Smartcite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "Smartcite:" desc)))
           (format "\\Smartcite{%s}" path)
         (format "\\Smartcite[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-citestar-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "cite*" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "cite*:" desc)))
           (format "\\cite*{%s}" path)
         (format "\\cite*[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-parencitestar-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "parencite*" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (if (or (not desc) (equal 0 (search "parencite*:" desc)))
           (format "\\parencite*{%s}" path)
         (format "\\parencite*[%s][%s]{%s}"
                 (cadr (split-string desc ";"))
                 (car (split-string desc ";"))  path))))))
#+end_src

#+name: define-biblatex-supercite-link
#+begin_src emacs-lisp :results silent :exports none
  (org-add-link-type 
   "supercite" 'ebib
   (lambda (path desc format)
     (cond
      ((eq format 'html)
       (format "(<cite>%s</cite>)" path))
      ((eq format 'latex)
       (format "\\cite*{%s}" path)))))
#+end_src

** Nicolas Goaziou's filter for non-breaking spaces
#+name: ngz-nbsp
#+begin_src emacs-lisp
(defun ngz-latex-filter-nobreaks (text backend info)
  "Ensure \"_\" are properly handled in Beamer/LaTeX export."
  (when (memq backend '(e-beamer e-latex))
    (replace-regexp-in-string " " "~" text)))
(add-to-list 'org-export-filter-plain-text-functions
             'ngz-latex-filter-nobreaks)
#+end_src
 

The header of my org file looks like this:

#+TITLE:     A Regional Chronology of Leeward North Kohala District, Hawai`i Island
#+AUTHOR:    Thomas Dye
#+DATE:   
#+LANGUAGE:  en
#+OPTIONS:   H:3 num:t toc:1 \n:nil @:t ::t |:t ^:t -:t f:t *:t <:t
#+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc
#+EXPORT_SELECT_TAGS: export
#+EXPORT_EXCLUDE_TAGS: noexport
#+LaTeX_CLASS: koma-article 
#+LaTeX_HEADER: \subtitle{Draft: Not for citation}
#+startup: fnadjust
#+TOC: figures
#+TOC: tables

Currently, I'm exporting with org-export-dispatch, but eventually I'll
tangle the setup into an init.el file and have a makefile that launches
emacs -q so I can be certain nothing in my .emacs has an influence.

Right now, though, I'm quite happy with the new exporter.

hth,
Tom

> On Fri, Sep 21, 2012 at 3:48 AM, Bastien <bzg@altern.org> wrote:
>> Hi Alexander,
>>
>> Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:
>>
>>> Could you point us to any documentation on how to switch to the new
>>> exporter?
>>
>> Add contrib/lisp to your load-path.
>>
>> (require 'org-e-latex)
>>
>> then M-x org-export-dispatch RET to get a menu and be able to
>> export to LaTeX from here.
>>
>>> Is the tutorial
>>> http://orgmode.org/worg/org-tutorials/org-latex-export.html still
>>> relevant?
>>
>> No, this tutorial is valid for the current exporter, not for
>> Nicolas exporter.
>>
>> HTH,
>>
>> --
>>  Bastien
>
>

-- 
Thomas S. Dye
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-21 21:21         ` Thomas S. Dye
@ 2012-09-22  8:01           ` Nicolas Goaziou
  0 siblings, 0 replies; 29+ messages in thread
From: Nicolas Goaziou @ 2012-09-22  8:01 UTC (permalink / raw)
  To: Thomas S. Dye
  Cc: Bastien, Gary Oberbrunner, Orgmode Mailing List, Alexander Vorobiev

Hello,

tsd@tsdye.com (Thomas S. Dye) writes:

>     (require 'org-special-blocks)

You can remove this line. `org-special-blocks' is obsolete with the new
exporter.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-21 19:47       ` Alexander Vorobiev
  2012-09-21 21:21         ` Thomas S. Dye
@ 2012-09-22  8:07         ` Nicolas Goaziou
  2012-09-24 16:40           ` Alexander Vorobiev
  1 sibling, 1 reply; 29+ messages in thread
From: Nicolas Goaziou @ 2012-09-22  8:07 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: Bastien, Orgmode Mailing List, Gary Oberbrunner

Hello,

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> I tried the new exporter (using today's snapshot of the sources) and
> it produced invalid LaTeX (it calls hypersetup without loading
> hyperref package).

The export back-end doesn't load any package on its own. You have to
make sure hyperref is properly loaded (AFAIK, it is by default).

> It also ignored the #+LaTeX_CLASS: and all the
> #+LaTeX_HEADER:lines in my file.

Those lines shouldn't be ignored. You probably don't have any matching
entry in `org-e-latex-classes' for your #+LATEX_CLASS: specification.

I'm not sure about #+LaTeX_HEADER: lines. Do you have an example?

> Are there any examples of org files which show how to customize the
> new LaTeX exporter?

Try first:

M-x customize-group RET org-export-e-latex RET


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-22  8:07         ` Nicolas Goaziou
@ 2012-09-24 16:40           ` Alexander Vorobiev
  2012-09-24 21:15             ` Nicolas Goaziou
  0 siblings, 1 reply; 29+ messages in thread
From: Alexander Vorobiev @ 2012-09-24 16:40 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: Bastien, Orgmode Mailing List, Gary Oberbrunner

Nicolas,

Here is my configuration section (it goes at the end of the org file).
Nothing in the LaTeX_HEADER lines gets inserted into output tex
document. The old exporter just inserted them all verbatim.

#+STARTUP:    align fold nodlcheck hidestars oddeven lognotestate
#+PROPERTY: exports results
#+TITLE:     Test document
#+AUTHOR:
#+EMAIL:     myemail@gmail.com
#+DATE:
#+DESCRIPTION:
#+KEYWORDS:
#+LANGUAGE:  en
#+OPTIONS:   H:3 num:nil toc:nil \n:nil @:t ::t |:t ^:nil -:t f:t *:t <:t
#+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc
#+INFOJS_OPT: view:nil toc:nil ltoc:t mouse:underline buttons:0
path:http://orgmode.org/org-info.js
#+EXPORT_SELECT_TAGS: export
#+EXPORT_EXCLUDE_TAGS: noexport
#+LINK_UP:
#+LINK_HOME:
#+XSLT:
#+LANGUAGE:   en
#+LaTeX_CLASS:koma-article
#+LaTeX_HEADER:\usepackage{color}
#+LaTeX_HEADER:\definecolor{spot}{rgb}{0,0.2,0.6}
#+LaTeX_HEADER:\definecolor{TUgreen}{RGB}{41,93,80}
#+LaTeX_HEADER:\setkomafont{section}{\color{TUgreen}\sffamily\bfseries}
#+LaTeX_HEADER:\renewcommand{\sfdefault}{jvn}
#+LaTeX_HEADER:\renewcommand*\familydefault{\sfdefault}
#+LaTeX_HEADER:\usepackage[automark,nouppercase]{scrpage2}
#+LaTeX_HEADER:\clearscrheadfoot
#+LaTeX_HEADER:\setheadwidth{paper}
#+LaTeX_HEADER:\setfootwidth{paper}
#+LaTeX_HEADER:\cohead[]{
#+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyHeader.jpg}
#+LaTeX_HEADER:}
#+LaTeX_HEADER:\cofoot[]{
#+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyFooter.png}
#+LaTeX_HEADER:}
#+LaTeX_HEADER:\pagestyle{scrplain}
#+LaTeX_HEADER:\AtBeginDocument{\vspace*{5\baselineskip}\thispagestyle{scrheadings}}
#+LaTeX_HEADER:\setlength{\topmargin}{-0.80in}
#+LaTeX_HEADER:\setlength{\textheight}{730pt}
#+LaTeX_HEADER:\makeatletter
#+LaTeX_HEADER:\renewcommand{\maketitle}{
#+LaTeX_HEADER:% \vspace*{5\baselineskip}%
#+LaTeX_HEADER: \vskip 2em%
#+LaTeX_HEADER: \begin{center}%
#+LaTeX_HEADER:  {\LARGE \@title \par}%
#+LaTeX_HEADER: \end{center}%
#+LaTeX_HEADER: \par} \makeatother

The new tex file just starts like this

% Created 2012-09-24 Mon 11:31
\author{}
\date{}
\title{Test document}
\hypersetup{
  pdfkeywords={},
  pdfsubject={},
  pdfcreator={Generated by Org mode 7.9.1 in Emacs 24.2.1.}}
\begin{document}

\maketitle

Thanks
Alex

On Sat, Sep 22, 2012 at 3:07 AM, Nicolas Goaziou <n.goaziou@gmail.com> wrote:
> Hello,
>
> Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:
>
>> I tried the new exporter (using today's snapshot of the sources) and
>> it produced invalid LaTeX (it calls hypersetup without loading
>> hyperref package).
>
> The export back-end doesn't load any package on its own. You have to
> make sure hyperref is properly loaded (AFAIK, it is by default).
>
>> It also ignored the #+LaTeX_CLASS: and all the
>> #+LaTeX_HEADER:lines in my file.
>
> Those lines shouldn't be ignored. You probably don't have any matching
> entry in `org-e-latex-classes' for your #+LATEX_CLASS: specification.
>
> I'm not sure about #+LaTeX_HEADER: lines. Do you have an example?
>
>> Are there any examples of org files which show how to customize the
>> new LaTeX exporter?
>
> Try first:
>
> M-x customize-group RET org-export-e-latex RET
>
>
> Regards,
>
> --
> Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-24 16:40           ` Alexander Vorobiev
@ 2012-09-24 21:15             ` Nicolas Goaziou
  2012-09-24 21:32               ` Alexander Vorobiev
  0 siblings, 1 reply; 29+ messages in thread
From: Nicolas Goaziou @ 2012-09-24 21:15 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: Bastien, Gary Oberbrunner, Orgmode Mailing List

Hello,

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> Here is my configuration section (it goes at the end of the org file).
> Nothing in the LaTeX_HEADER lines gets inserted into output tex
> document. The old exporter just inserted them all verbatim.
>
> #+STARTUP:    align fold nodlcheck hidestars oddeven lognotestate
> #+PROPERTY: exports results
> #+TITLE:     Test document
> #+AUTHOR:
> #+EMAIL:     myemail@gmail.com
> #+DATE:
> #+DESCRIPTION: #+KEYWORDS:
> #+LANGUAGE:  en
> #+OPTIONS:   H:3 num:nil toc:nil \n:nil @:t ::t |:t ^:nil -:t f:t *:t <:t
> #+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc
> #+INFOJS_OPT: view:nil toc:nil ltoc:t mouse:underline buttons:0
> path:http://orgmode.org/org-info.js
> #+EXPORT_SELECT_TAGS: export
> #+EXPORT_EXCLUDE_TAGS: noexport
> #+LINK_UP:
> #+LINK_HOME:
> #+XSLT:
> #+LANGUAGE:   en
> #+LaTeX_CLASS:koma-article
> #+LaTeX_HEADER:\usepackage{color}
> #+LaTeX_HEADER:\definecolor{spot}{rgb}{0,0.2,0.6}
> #+LaTeX_HEADER:\definecolor{TUgreen}{RGB}{41,93,80}
> #+LaTeX_HEADER:\setkomafont{section}{\color{TUgreen}\sffamily\bfseries}
> #+LaTeX_HEADER:\renewcommand{\sfdefault}{jvn}
> #+LaTeX_HEADER:\renewcommand*\familydefault{\sfdefault}
> #+LaTeX_HEADER:\usepackage[automark,nouppercase]{scrpage2}
> #+LaTeX_HEADER:\clearscrheadfoot
> #+LaTeX_HEADER:\setheadwidth{paper}
> #+LaTeX_HEADER:\setfootwidth{paper}
> #+LaTeX_HEADER:\cohead[]{
> #+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyHeader.jpg}
> #+LaTeX_HEADER:}
> #+LaTeX_HEADER:\cofoot[]{
> #+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyFooter.png}
> #+LaTeX_HEADER:}
> #+LaTeX_HEADER:\pagestyle{scrplain}
> #+LaTeX_HEADER:\AtBeginDocument{\vspace*{5\baselineskip}\thispagestyle{scrheadings}}
> #+LaTeX_HEADER:\setlength{\topmargin}{-0.80in}
> #+LaTeX_HEADER:\setlength{\textheight}{730pt}
> #+LaTeX_HEADER:\makeatletter
> #+LaTeX_HEADER:\renewcommand{\maketitle}{
> #+LaTeX_HEADER:% \vspace*{5\baselineskip}%
> #+LaTeX_HEADER: \vskip 2em%
> #+LaTeX_HEADER: \begin{center}%
> #+LaTeX_HEADER:  {\LARGE \@title \par}%
> #+LaTeX_HEADER: \end{center}%
> #+LaTeX_HEADER: \par} \makeatother
>
> The new tex file just starts like this
>
> % Created 2012-09-24 Mon 11:31
> \author{}
> \date{}
> \title{Test document}
> \hypersetup{
>   pdfkeywords={},
>   pdfsubject={},
>   pdfcreator={Generated by Org mode 7.9.1 in Emacs 24.2.1.}}
> \begin{document}
>
> \maketitle

You need a space after the colons in #+LATEX_HEADER: and #+LATEX_CLASS
lines.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-24 21:15             ` Nicolas Goaziou
@ 2012-09-24 21:32               ` Alexander Vorobiev
  2012-09-26 18:48                 ` Nicolas Goaziou
  0 siblings, 1 reply; 29+ messages in thread
From: Alexander Vorobiev @ 2012-09-24 21:32 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: Bastien, Gary Oberbrunner, Orgmode Mailing List

Hi Nicolas,

Thanks a lot for the help, I configured the org-e-latex-classes and
now am getting somewhere - at least my LaTeX settings appear in the
output. The next problem I have is babel-related. I create results of
execution of my source blocks in org format so they are enclosed in
#+BEGIN_ORG ... #END_ORG which gets translated by the new exporter
into \begin{org} \end{org} - which makes pdflatex unhappy because the
"org environment" is not defined anywhere. The old exported did not do
anything like that. What do I have to do to make it work in the new
exporter?

Thanks
Alex

On Mon, Sep 24, 2012 at 4:15 PM, Nicolas Goaziou <n.goaziou@gmail.com> wrote:
> Hello,
>
> Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:
>
>> Here is my configuration section (it goes at the end of the org file).
>> Nothing in the LaTeX_HEADER lines gets inserted into output tex
>> document. The old exporter just inserted them all verbatim.
>>
>> #+STARTUP:    align fold nodlcheck hidestars oddeven lognotestate
>> #+PROPERTY: exports results
>> #+TITLE:     Test document
>> #+AUTHOR:
>> #+EMAIL:     myemail@gmail.com
>> #+DATE:
>> #+DESCRIPTION: #+KEYWORDS:
>> #+LANGUAGE:  en
>> #+OPTIONS:   H:3 num:nil toc:nil \n:nil @:t ::t |:t ^:nil -:t f:t *:t <:t
>> #+OPTIONS:   TeX:t LaTeX:t skip:nil d:nil todo:t pri:nil tags:not-in-toc
>> #+INFOJS_OPT: view:nil toc:nil ltoc:t mouse:underline buttons:0
>> path:http://orgmode.org/org-info.js
>> #+EXPORT_SELECT_TAGS: export
>> #+EXPORT_EXCLUDE_TAGS: noexport
>> #+LINK_UP:
>> #+LINK_HOME:
>> #+XSLT:
>> #+LANGUAGE:   en
>> #+LaTeX_CLASS:koma-article
>> #+LaTeX_HEADER:\usepackage{color}
>> #+LaTeX_HEADER:\definecolor{spot}{rgb}{0,0.2,0.6}
>> #+LaTeX_HEADER:\definecolor{TUgreen}{RGB}{41,93,80}
>> #+LaTeX_HEADER:\setkomafont{section}{\color{TUgreen}\sffamily\bfseries}
>> #+LaTeX_HEADER:\renewcommand{\sfdefault}{jvn}
>> #+LaTeX_HEADER:\renewcommand*\familydefault{\sfdefault}
>> #+LaTeX_HEADER:\usepackage[automark,nouppercase]{scrpage2}
>> #+LaTeX_HEADER:\clearscrheadfoot
>> #+LaTeX_HEADER:\setheadwidth{paper}
>> #+LaTeX_HEADER:\setfootwidth{paper}
>> #+LaTeX_HEADER:\cohead[]{
>> #+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyHeader.jpg}
>> #+LaTeX_HEADER:}
>> #+LaTeX_HEADER:\cofoot[]{
>> #+LaTeX_HEADER:  \includegraphics[width=7.75in]{MyFooter.png}
>> #+LaTeX_HEADER:}
>> #+LaTeX_HEADER:\pagestyle{scrplain}
>> #+LaTeX_HEADER:\AtBeginDocument{\vspace*{5\baselineskip}\thispagestyle{scrheadings}}
>> #+LaTeX_HEADER:\setlength{\topmargin}{-0.80in}
>> #+LaTeX_HEADER:\setlength{\textheight}{730pt}
>> #+LaTeX_HEADER:\makeatletter
>> #+LaTeX_HEADER:\renewcommand{\maketitle}{
>> #+LaTeX_HEADER:% \vspace*{5\baselineskip}%
>> #+LaTeX_HEADER: \vskip 2em%
>> #+LaTeX_HEADER: \begin{center}%
>> #+LaTeX_HEADER:  {\LARGE \@title \par}%
>> #+LaTeX_HEADER: \end{center}%
>> #+LaTeX_HEADER: \par} \makeatother
>>
>> The new tex file just starts like this
>>
>> % Created 2012-09-24 Mon 11:31
>> \author{}
>> \date{}
>> \title{Test document}
>> \hypersetup{
>>   pdfkeywords={},
>>   pdfsubject={},
>>   pdfcreator={Generated by Org mode 7.9.1 in Emacs 24.2.1.}}
>> \begin{document}
>>
>> \maketitle
>
> You need a space after the colons in #+LATEX_HEADER: and #+LATEX_CLASS
> lines.
>
>
> Regards,
>
> --
> Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-09-24 21:32               ` Alexander Vorobiev
@ 2012-09-26 18:48                 ` Nicolas Goaziou
  0 siblings, 0 replies; 29+ messages in thread
From: Nicolas Goaziou @ 2012-09-26 18:48 UTC (permalink / raw)
  To: Alexander Vorobiev; +Cc: Bastien, Orgmode Mailing List, Gary Oberbrunner

Hello,

Alexander Vorobiev <alexander.vorobiev@gmail.com> writes:

> The next problem I have is babel-related. I create results of
> execution of my source blocks in org format so they are enclosed in
> #+BEGIN_ORG ... #END_ORG which gets translated by the new exporter
> into \begin{org} \end{org} - which makes pdflatex unhappy because the
> "org environment" is not defined anywhere. The old exported did not do
> anything like that. What do I have to do to make it work in the new
> exporter?

Nothing. New exporter doesn't support #+begin_org blocks, which should
be removed in master anyway.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2014-07-16 14:36 ` Nicolas Goaziou
@ 2014-07-16 16:35   ` Thomas S. Dye
  0 siblings, 0 replies; 29+ messages in thread
From: Thomas S. Dye @ 2014-07-16 16:35 UTC (permalink / raw)
  To: Org-mode

Aloha Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Hello,
>
> tsd@tsdye.com (Thomas S. Dye) writes:
>
>> With a recent Org from git and this source:
>>
>>   #+attr_latex: :width 0.8\textwidth :placement [htb]
>>   #+name: fig:harris-errors
>>   #+caption[Structural effects of false transitives]: Structural effects of false transitives with the stratigraphic section in Figure [[fig:fig12-open]]:
>
>> I get this incorrect LaTeX output:
>
> [...]
>
>> If I place a space between the final colon and the link on the
>> first #+caption: line, then I get the output I'm expecting (although
>> there is the extraneous space):
>
> [...]
>
>
> This is because regexp finding short captions is greedy. It thus catches
> everything up to the last "]:" in the first line, making the link
> invalid.
>
>> Is there a work-around?
>
> Just make sure the line containing the short caption doesn't end with
> "]:", e.g.,
>
>   ...
>   #+caption[Structural effects of false transitives]:
>   #+caption: Structural effects of false transitives with the stratigraphic section in Figure [[fig:fig12-open]]:
>   ...

Perfect.  Thanks!

All the best,
Tom

-- 
T.S. Dye & Colleagues, Archaeologists
735 Bishop St, Suite 315, Honolulu, HI 96813
Tel: 808-529-0866, Fax: 808-529-0884
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2014-07-13 21:25 Thomas S. Dye
@ 2014-07-16 14:36 ` Nicolas Goaziou
  2014-07-16 16:35   ` Thomas S. Dye
  0 siblings, 1 reply; 29+ messages in thread
From: Nicolas Goaziou @ 2014-07-16 14:36 UTC (permalink / raw)
  To: Thomas S. Dye; +Cc: Org-mode

Hello,

tsd@tsdye.com (Thomas S. Dye) writes:

> With a recent Org from git and this source:
>
>   #+attr_latex: :width 0.8\textwidth :placement [htb]
>   #+name: fig:harris-errors
>   #+caption[Structural effects of false transitives]: Structural effects of false transitives with the stratigraphic section in Figure [[fig:fig12-open]]:

> I get this incorrect LaTeX output:

[...]

> If I place a space between the final colon and the link on the
> first #+caption: line, then I get the output I'm expecting (although
> there is the extraneous space):

[...]


This is because regexp finding short captions is greedy. It thus catches
everything up to the last "]:" in the first line, making the link
invalid.

> Is there a work-around?

Just make sure the line containing the short caption doesn't end with
"]:", e.g.,

  ...
  #+caption[Structural effects of false transitives]:
  #+caption: Structural effects of false transitives with the stratigraphic section in Figure [[fig:fig12-open]]:
  ...


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 29+ messages in thread

* LaTeX export problem
@ 2014-07-13 21:25 Thomas S. Dye
  2014-07-16 14:36 ` Nicolas Goaziou
  0 siblings, 1 reply; 29+ messages in thread
From: Thomas S. Dye @ 2014-07-13 21:25 UTC (permalink / raw)
  To: Org-mode

Aloha all,

With a recent Org from git and this source:

  #+attr_latex: :width 0.8\textwidth :placement [htb]
  #+name: fig:harris-errors
  #+caption[Structural effects of false transitives]: Structural effects of false transitives with the stratigraphic section in Figure [[fig:fig12-open]]:
  #+caption: /left/, a Harris Matrix of contexts adjacent to Context 1 with false transitives for Contexts 5 and 6;
  #+caption: /right/, a directed graph of contexts adjacent to Context 1 that excludes false transitives.
  #+caption: The observed stratigraphic relationships for the two diagrams are shown on Table [[tab:harris-errors]].
  [[file:~/Public/projects/936-harris-matrix/figure/fig-12-harris-td-adj-1-tred-edited.pdf]]

I get this incorrect LaTeX output:

  \begin{figure}[htb]
  \centering
  \includegraphics[width=0.8\textwidth]{/Users/dk/Public/projects/936-harris-matrix/figure/fig-12-harris-td-adj-1-tred-edited.pdf}
  \caption[Structural effects of false transitives]: Structural effects of false transitives with the stratigraphic section in Figure~[[fig:fig12-open]]{\label{fig:harris-errors}\emph{left}, a Harris Matrix of contexts adjacent to Context 1 with false transitives for Contexts 5 and 6; \emph{right}, a directed graph of contexts adjacent to Context 1 that excludes false transitives. The observed stratigraphic relationships for the two diagrams are shown on Table~\ref{tab:harris-errors}.}
  \end{figure}

If I place a space between the final colon and the link on the
first #+caption: line, then I get the output I'm expecting (although
there is the extraneous space):

 \begin{figure}[htb]
 \centering
 \includegraphics[width=0.8\textwidth]{/Users/dk/Public/projects/936-harris-matrix/figure/fig-12-harris-td-adj-1-tred-edited.pdf}
 \caption[Structural effects of false transitives]{\label{fig:harris-errors}Structural effects of false transitives with the stratigraphic section in Figure~\ref{fig:fig12-open} : \emph{left}, a Harris Matrix of contexts adjacent to Context 1 with false transitives for Contexts 5 and 6; \emph{right}, a directed graph of contexts adjacent to Context 1 that excludes false transitives. The observed stratigraphic relationships for the two diagrams are shown on Table~\ref{tab:harris-errors}.}
 \end{figure}

Is there a work-around?

All the best,
Tom

-- 
T.S. Dye & Colleagues, Archaeologists
735 Bishop St, Suite 315, Honolulu, HI 96813
Tel: 808-529-0866, Fax: 808-529-0884
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-01-17 13:35   ` Piotr Kaźmierczak
  2012-01-17 17:00     ` Nick Dokos
@ 2012-01-17 20:45     ` Eric S Fraga
  1 sibling, 0 replies; 29+ messages in thread
From: Eric S Fraga @ 2012-01-17 20:45 UTC (permalink / raw)
  To: Piotr Kaźmierczak; +Cc: nicholas.dokos, emacs-orgmode

Piotr Kaźmierczak <p.h.kazmierczak@gmail.com> writes:

> Wiadomość napisana przez Nick Dokos w dniu 10 sty 2012, o godz. 01:13:
>
>> Have you tried exporting a simple file to latex? Perhaps something as simple
>> as:
>> 
>> ---------------------------------------------------------------------------
>> * Foo
>> Bar
>> ---------------------------------------------------------------------------
>> 
>> 
>> Nick
>
> Yes I have, it still produces a one-line TeX file. 

can you, just in case, post to the mailing list with both org and
resulting tex files attached?

Also, what do "M-x find-library RET org RET" and "M-x org-version RET"
say?

What operating system are you using?  I'm assuming a Mac from your
previous message.

-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.0.92.1
: using Org-mode version 7.8.03 (release_7.8.03.144.g7233)

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-01-17 17:00     ` Nick Dokos
@ 2012-01-17 19:00       ` Piotr Kaźmierczak
  0 siblings, 0 replies; 29+ messages in thread
From: Piotr Kaźmierczak @ 2012-01-17 19:00 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: emacs-orgmode

Wiadomość napisana przez Nick Dokos w dniu 17 sty 2012, o godz. 18:00:

> In that case, it seems like your orgmode install is hosed - have you tried
> reinstalling from scratch?

I did, but no luck. There must be something else I'm missing here, but I don't have time to investigate now. 

Thanks for your help, I'll post a solution here once I find one.

Piotr

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-01-17 13:35   ` Piotr Kaźmierczak
@ 2012-01-17 17:00     ` Nick Dokos
  2012-01-17 19:00       ` Piotr Kaźmierczak
  2012-01-17 20:45     ` Eric S Fraga
  1 sibling, 1 reply; 29+ messages in thread
From: Nick Dokos @ 2012-01-17 17:00 UTC (permalink / raw)
  To: =?iso-8859-2?Q?Piotr_Ka=BCmierczak?=; +Cc: nicholas.dokos, emacs-orgmode

Piotr Kaźmierczak <p.h.kazmierczak@gmail.com> wrote:

> Wiadomość napisana przez Nick Dokos w dniu 10 sty 2012, o godz. 01:13:
> 
> > Have you tried exporting a simple file to latex? Perhaps something as simple
> > as:
> > 
> > ---------------------------------------------------------------------------
> > * Foo
> > Bar
> > ---------------------------------------------------------------------------
> > 
> > 
> > Nick
> 
> Yes I have, it still produces a one-line TeX file. 

In that case, it seems like your orgmode install is hosed - have you tried
reinstalling from scratch?

Nick

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-01-10  0:13 ` Nick Dokos
@ 2012-01-17 13:35   ` Piotr Kaźmierczak
  2012-01-17 17:00     ` Nick Dokos
  2012-01-17 20:45     ` Eric S Fraga
  0 siblings, 2 replies; 29+ messages in thread
From: Piotr Kaźmierczak @ 2012-01-17 13:35 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: emacs-orgmode

Wiadomość napisana przez Nick Dokos w dniu 10 sty 2012, o godz. 01:13:

> Have you tried exporting a simple file to latex? Perhaps something as simple
> as:
> 
> ---------------------------------------------------------------------------
> * Foo
> Bar
> ---------------------------------------------------------------------------
> 
> 
> Nick

Yes I have, it still produces a one-line TeX file. 

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: LaTeX export problem
  2012-01-09 15:45 Piotr Kaźmierczak
@ 2012-01-10  0:13 ` Nick Dokos
  2012-01-17 13:35   ` Piotr Kaźmierczak
  0 siblings, 1 reply; 29+ messages in thread
From: Nick Dokos @ 2012-01-10  0:13 UTC (permalink / raw)
  To: =?utf-8?Q?Piotr_Ka=C5=BAmierczak?=; +Cc: emacs-orgmode


Piotr Kaźmierczak <p.h.kazmierczak@gmail.com> wrote:


> I have a very strange problem: I can no longer process an org file
> with all my notes to LaTeX. I've been using org-mode this way for some
> time now, and I was always able to get a nice tex file I could later
> process to PDF. Now all I get is a TeX file with absolutely no
> new-line symbols (a huge one-line file), and pdflatex obviously can't
> process that. I haven't updated org for a while, and it doesn't seem
> to matter which Emacs version I try (GNU 23, GNU 24, Aquamacs 2.4), I
> still can't get the correct output. The only difference from the last
> time I managed to get a correct tex output is that I added some more
> notes to the org file.
> 

Have you tried exporting a simple file to latex? Perhaps something as simple
as:

---------------------------------------------------------------------------
* Foo
Bar
---------------------------------------------------------------------------


Nick

^ permalink raw reply	[flat|nested] 29+ messages in thread

* LaTeX export problem
@ 2012-01-09 15:45 Piotr Kaźmierczak
  2012-01-10  0:13 ` Nick Dokos
  0 siblings, 1 reply; 29+ messages in thread
From: Piotr Kaźmierczak @ 2012-01-09 15:45 UTC (permalink / raw)
  To: emacs-orgmode

Hi,   

I have a very strange problem: I can no longer process an org file with all my notes to LaTeX. I've been using org-mode this way for some time now, and I was always able to get a nice tex file I could later process to PDF. Now all I get is a TeX file with absolutely no new-line symbols (a huge one-line file), and pdflatex obviously can't process that. I haven't updated org for a while, and it doesn't seem to matter which Emacs version I try (GNU 23, GNU 24, Aquamacs 2.4), I still can't get the correct output. The only difference from the last time I managed to get a correct tex output is that I added some more notes to the org file.  

I'm using Org 7.8.

Any ideas?

regards,
Piotr Kaźmierczak

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-10-01 11:38         ` Jörg Hagmann
@ 2010-10-01 12:05           ` Jörg Hagmann
  0 siblings, 0 replies; 29+ messages in thread
From: Jörg Hagmann @ 2010-10-01 12:05 UTC (permalink / raw)
  To: Noorul Islam; +Cc: Emacs-orgmode

  And an update:

It also doesn't work on my Mac with Emacs 24 (GNU Emacs 24.0.50.1 
(x86_64-apple-darwin, NS apple-appkit-1038.32) of 2010-10-01 on 
black.porkrind.org

Summary:

Works on
- GNU Emacs 24.0.50.1 (i686-pc-linux-gnu) (Noorul)
- GNU Emacs 23.1.1 (i486 pc-linux-gnu) (Jörg)

Error on:
- GNU Emacs 23.1.1 (i686-pc-linux-gnu) (Noorul)
- GNU Emacs 23.2.1 (powerpc-apple-darwin9.8.0) (Christian)
- GNU Emacs 23.2.1 (x86_64-apple-darwin) (Jörg)
- GNU Emacs 24.0.50.1 (x86_64-apple-darwin) (Jörg)

But, to repeat myself, it might not depend on the Emacs version. In my 
case, it used to work with GNU Emacs 23.2.1 (x86_64-apple-darwin)...

Thanks and regards, Jörg

On 10/1/10 1:38 PM, Jörg Hagmann wrote:
>
>
> On 10/1/10 11:17 AM, Noorul Islam wrote:
>>> I have on my machine:
>>>
>>> Org-mode version 7.01trans (release_7.01h.609.gc4916)
>>> GNU Emacs 24.0.50.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12)
>>>   of 2010-09-29 on noorul
>>>
>>> Thanks and Regards
>>> Noorul
>> On emacs
>>
>> GNU Emacs 23.1.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12) of
>> 2010-01-30 on noorul
>>
>>
>> I get the following error
>>
>> Debugger entered--Lisp error: (wrong-type-argument stringp nil)
>>    get-file-buffer(nil)
>>    org-babel-exp-src-blocks(#("\\input gentium-ge" 0 17 (fontified nil
>> font-lock-fontified t)) #("latex" 0 5 (font-lock-fontified t fontified
>> nil)))
>>    apply(org-babel-exp-src-blocks #("\\input gentium-ge" 0 17
>> (fontified nil font-lock-fontified t)) #("latex" 0 5
>> (font-lock-fontified t fontified nil)))
>>    byte-code("ÆÇ\x18\x19\x1a^[\x1c\x1d\x1e%\x1e&\x1e'\x1e(ÈÉ!\x1e)#
>>
>> Thanks and Regards
>> Noorul
> I now tried it on linux (23.1.1 i486 pc-linux-gnu, GTK+ version 
> 2.20.0) ...
> ... and there it works!
>
> Kind regards, Jörg
>>>>> Jörg Hagmann<joerg.hagmann@unibas.ch>    writes:
>>>>>
>>>>>>    Dear list,
>>>>>>
>>>>>> I have an org file named "test.org" structured as follows 
>>>>>> (minimal example):
>>>>>>
>>>>>> ------minimal example------------
>>>>>> * Head
>>>>>>     text
>>>>>>
>>>>>> * Second head
>>>>>>     :PROPERTIES:
>>>>>>     :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} 
>>>>>> -:t f:t
>>>>>> *:t skip:nil d:nil tags:nil
>>>>>>     :EXPORT_TITLE: My Title
>>>>>>     :EXPORT_FILE_NAME: scripts/filename
>>>>>>     :END:
>>>>>>
>>>>>>
>>>>>> #+begin_src latex
>>>>>> \input gentium-ge
>>>>>> #+end_src
>>>>>>
>>>>>> ** section
>>>>>>      text
>>>>>> ------end of minimal example-----------
>>>>>>
>>>>>> I export the second head to a filename.tex file in a subdirectory 
>>>>>> (and
>>>>>> convert it later to ConTeXt code, but that shouldn't matter here). I
>>>>>> swear that this worked -- I have everything pertaining to my 
>>>>>> lectures
>>>>>> in this file.
>>>>>> However, it stopped working recently (without updating org-mode). 
>>>>>> All
>>>>>> I get when I export "Second Head" to latex is:
>>>>>> "No such file: /Users/me/test.org"
>>>>>> The cause is the #+begin_src ... #+end_src block

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-10-01  9:17       ` Noorul Islam
@ 2010-10-01 11:38         ` Jörg Hagmann
  2010-10-01 12:05           ` Jörg Hagmann
  0 siblings, 1 reply; 29+ messages in thread
From: Jörg Hagmann @ 2010-10-01 11:38 UTC (permalink / raw)
  To: Noorul Islam; +Cc: Emacs-orgmode



On 10/1/10 11:17 AM, Noorul Islam wrote:
>> I have on my machine:
>>
>> Org-mode version 7.01trans (release_7.01h.609.gc4916)
>> GNU Emacs 24.0.50.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12)
>>   of 2010-09-29 on noorul
>>
>> Thanks and Regards
>> Noorul
> On emacs
>
> GNU Emacs 23.1.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12) of
> 2010-01-30 on noorul
>
>
> I get the following error
>
> Debugger entered--Lisp error: (wrong-type-argument stringp nil)
>    get-file-buffer(nil)
>    org-babel-exp-src-blocks(#("\\input gentium-ge" 0 17 (fontified nil
> font-lock-fontified t)) #("latex" 0 5 (font-lock-fontified t fontified
> nil)))
>    apply(org-babel-exp-src-blocks #("\\input gentium-ge" 0 17
> (fontified nil font-lock-fontified t)) #("latex" 0 5
> (font-lock-fontified t fontified nil)))
>    byte-code("ÆÇ\x18\x19\x1a^[\x1c\x1d\x1e%\x1e&\x1e'\x1e(ÈÉ!\x1e)#
>
> Thanks and Regards
> Noorul
I now tried it on linux (23.1.1 i486 pc-linux-gnu, GTK+ version 2.20.0) ...
... and there it works!

Kind regards, Jörg
>>>> Jörg Hagmann<joerg.hagmann@unibas.ch>    writes:
>>>>
>>>>>    Dear list,
>>>>>
>>>>> I have an org file named "test.org" structured as follows (minimal example):
>>>>>
>>>>> ------minimal example------------
>>>>> * Head
>>>>>     text
>>>>>
>>>>> * Second head
>>>>>     :PROPERTIES:
>>>>>     :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t
>>>>> *:t skip:nil d:nil tags:nil
>>>>>     :EXPORT_TITLE: My Title
>>>>>     :EXPORT_FILE_NAME: scripts/filename
>>>>>     :END:
>>>>>
>>>>>
>>>>> #+begin_src latex
>>>>> \input gentium-ge
>>>>> #+end_src
>>>>>
>>>>> ** section
>>>>>      text
>>>>> ------end of minimal example-----------
>>>>>
>>>>> I export the second head to a filename.tex file in a subdirectory (and
>>>>> convert it later to ConTeXt code, but that shouldn't matter here). I
>>>>> swear that this worked -- I have everything pertaining to my lectures
>>>>> in this file.
>>>>> However, it stopped working recently (without updating org-mode). All
>>>>> I get when I export "Second Head" to latex is:
>>>>> "No such file: /Users/me/test.org"
>>>>> The cause is the #+begin_src ... #+end_src block

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-10-01  9:03     ` Noorul Islam K M
@ 2010-10-01  9:17       ` Noorul Islam
  2010-10-01 11:38         ` Jörg Hagmann
  0 siblings, 1 reply; 29+ messages in thread
From: Noorul Islam @ 2010-10-01  9:17 UTC (permalink / raw)
  To: Jörg Hagmann; +Cc: Emacs-orgmode

On Fri, Oct 1, 2010 at 2:33 PM, Noorul Islam K M <noorul@noorul.com> wrote:
> Jörg Hagmann <joerg.hagmann@unibas.ch> writes:
>
>>  org-version: yesterday's pull
>> emacs: 23.2.1 (x86_64-apple-darwin, NS apple-appkit-1038.29)
>>  of 2010-05-09
>>
>
> I copied your example to a file /tmp/test.org and with the cursor on
> Second head I did "C-c C-e 1 l". It did generate output file
> /tmp/scripts/filename.tex and I did not get any error.
>
> Is it related to Mac? I am not sure though
>
> I have on my machine:
>
> Org-mode version 7.01trans (release_7.01h.609.gc4916)
> GNU Emacs 24.0.50.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12)
>  of 2010-09-29 on noorul
>
> Thanks and Regards
> Noorul
>
>

On emacs

GNU Emacs 23.1.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12) of
2010-01-30 on noorul


I get the following error

Debugger entered--Lisp error: (wrong-type-argument stringp nil)
  get-file-buffer(nil)
  org-babel-exp-src-blocks(#("\\input gentium-ge" 0 17 (fontified nil
font-lock-fontified t)) #("latex" 0 5 (font-lock-fontified t fontified
nil)))
  apply(org-babel-exp-src-blocks #("\\input gentium-ge" 0 17
(fontified nil font-lock-fontified t)) #("latex" 0 5
(font-lock-fontified t fontified nil)))
  byte-code("ÆÇ\x18\x19\x1a^[\x1c\x1d\x1e%\x1e&\x1e'\x1e(ÈÉ!\x1e)#

Thanks and Regards
Noorul

>> On 10/1/10 9:32 AM, Noorul Islam K M wrote:
>>> Jörg Hagmann<joerg.hagmann@unibas.ch>  writes:
>>>
>>>>   Dear list,
>>>>
>>>> I have an org file named "test.org" structured as follows (minimal example):
>>>>
>>>> ------minimal example------------
>>>> * Head
>>>>    text
>>>>
>>>> * Second head
>>>>    :PROPERTIES:
>>>>    :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t
>>>> *:t skip:nil d:nil tags:nil
>>>>    :EXPORT_TITLE: My Title
>>>>    :EXPORT_FILE_NAME: scripts/filename
>>>>    :END:
>>>>
>>>>
>>>> #+begin_src latex
>>>> \input gentium-ge
>>>> #+end_src
>>>>
>>>> ** section
>>>>     text
>>>> ------end of minimal example-----------
>>>>
>>>> I export the second head to a filename.tex file in a subdirectory (and
>>>> convert it later to ConTeXt code, but that shouldn't matter here). I
>>>> swear that this worked -- I have everything pertaining to my lectures
>>>> in this file.
>>>> However, it stopped working recently (without updating org-mode). All
>>>> I get when I export "Second Head" to latex is:
>>>> "No such file: /Users/me/test.org"
>>>> The cause is the #+begin_src ... #+end_src block
>>>>
>>> Can you please tell us which version of emacs and org-mode are you
>>> using?
>>>
>>> M-x org-version
>>> M-x emacs-version
>>>
>>> Thanks and Regards
>>> Noorul
>

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-10-01  7:40   ` Jörg Hagmann
@ 2010-10-01  9:03     ` Noorul Islam K M
  2010-10-01  9:17       ` Noorul Islam
  0 siblings, 1 reply; 29+ messages in thread
From: Noorul Islam K M @ 2010-10-01  9:03 UTC (permalink / raw)
  To: Jörg Hagmann; +Cc: Emacs-orgmode

Jörg Hagmann <joerg.hagmann@unibas.ch> writes:

>  org-version: yesterday's pull
> emacs: 23.2.1 (x86_64-apple-darwin, NS apple-appkit-1038.29)
>  of 2010-05-09
>

I copied your example to a file /tmp/test.org and with the cursor on
Second head I did "C-c C-e 1 l". It did generate output file
/tmp/scripts/filename.tex and I did not get any error.

Is it related to Mac? I am not sure though

I have on my machine:

Org-mode version 7.01trans (release_7.01h.609.gc4916)
GNU Emacs 24.0.50.1 (i686-pc-linux-gnu, GTK+ Version 2.12.12)
 of 2010-09-29 on noorul

Thanks and Regards
Noorul


> On 10/1/10 9:32 AM, Noorul Islam K M wrote:
>> Jörg Hagmann<joerg.hagmann@unibas.ch>  writes:
>>
>>>   Dear list,
>>>
>>> I have an org file named "test.org" structured as follows (minimal example):
>>>
>>> ------minimal example------------
>>> * Head
>>>    text
>>>
>>> * Second head
>>>    :PROPERTIES:
>>>    :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t
>>> *:t skip:nil d:nil tags:nil
>>>    :EXPORT_TITLE: My Title
>>>    :EXPORT_FILE_NAME: scripts/filename
>>>    :END:
>>>
>>>
>>> #+begin_src latex
>>> \input gentium-ge
>>> #+end_src
>>>
>>> ** section
>>>     text
>>> ------end of minimal example-----------
>>>
>>> I export the second head to a filename.tex file in a subdirectory (and
>>> convert it later to ConTeXt code, but that shouldn't matter here). I
>>> swear that this worked -- I have everything pertaining to my lectures
>>> in this file.
>>> However, it stopped working recently (without updating org-mode). All
>>> I get when I export "Second Head" to latex is:
>>> "No such file: /Users/me/test.org"
>>> The cause is the #+begin_src ... #+end_src block
>>>
>> Can you please tell us which version of emacs and org-mode are you
>> using?
>>
>> M-x org-version
>> M-x emacs-version
>>
>> Thanks and Regards
>> Noorul

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-10-01  7:32 ` Noorul Islam K M
@ 2010-10-01  7:40   ` Jörg Hagmann
  2010-10-01  9:03     ` Noorul Islam K M
  0 siblings, 1 reply; 29+ messages in thread
From: Jörg Hagmann @ 2010-10-01  7:40 UTC (permalink / raw)
  To: Noorul Islam K M; +Cc: Emacs-orgmode

  org-version: yesterday's pull
emacs: 23.2.1 (x86_64-apple-darwin, NS apple-appkit-1038.29)
  of 2010-05-09

On 10/1/10 9:32 AM, Noorul Islam K M wrote:
> Jörg Hagmann<joerg.hagmann@unibas.ch>  writes:
>
>>   Dear list,
>>
>> I have an org file named "test.org" structured as follows (minimal example):
>>
>> ------minimal example------------
>> * Head
>>    text
>>
>> * Second head
>>    :PROPERTIES:
>>    :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t
>> *:t skip:nil d:nil tags:nil
>>    :EXPORT_TITLE: My Title
>>    :EXPORT_FILE_NAME: scripts/filename
>>    :END:
>>
>>
>> #+begin_src latex
>> \input gentium-ge
>> #+end_src
>>
>> ** section
>>     text
>> ------end of minimal example-----------
>>
>> I export the second head to a filename.tex file in a subdirectory (and
>> convert it later to ConTeXt code, but that shouldn't matter here). I
>> swear that this worked -- I have everything pertaining to my lectures
>> in this file.
>> However, it stopped working recently (without updating org-mode). All
>> I get when I export "Second Head" to latex is:
>> "No such file: /Users/me/test.org"
>> The cause is the #+begin_src ... #+end_src block
>>
> Can you please tell us which version of emacs and org-mode are you
> using?
>
> M-x org-version
> M-x emacs-version
>
> Thanks and Regards
> Noorul

-- 
Prof. Jörg Hagmann-Zanolari MD
University of Basel
Department of Biomedicine
Institute of Biochemistry and Genetics
Mattenstrasse 28
CH-4058 Basel
Switzerland
Phone +41 (0)61 267 3565

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
  2010-09-30 14:55 latex " Jörg Hagmann
       [not found] ` <4CA4C29B.1060404@christianmoe.com>
@ 2010-10-01  7:32 ` Noorul Islam K M
  2010-10-01  7:40   ` Jörg Hagmann
  1 sibling, 1 reply; 29+ messages in thread
From: Noorul Islam K M @ 2010-10-01  7:32 UTC (permalink / raw)
  To: Jörg Hagmann; +Cc: Emacs-orgmode

Jörg Hagmann <joerg.hagmann@unibas.ch> writes:

>  Dear list,
>
> I have an org file named "test.org" structured as follows (minimal example):
>
> ------minimal example------------
> * Head
>   text
>
> * Second head
>   :PROPERTIES:
>   :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t
> *:t skip:nil d:nil tags:nil
>   :EXPORT_TITLE: My Title
>   :EXPORT_FILE_NAME: scripts/filename
>   :END:
>
>
> #+begin_src latex
> \input gentium-ge
> #+end_src
>
> ** section
>    text
> ------end of minimal example-----------
>
> I export the second head to a filename.tex file in a subdirectory (and
> convert it later to ConTeXt code, but that shouldn't matter here). I
> swear that this worked -- I have everything pertaining to my lectures
> in this file.
> However, it stopped working recently (without updating org-mode). All
> I get when I export "Second Head" to latex is:
> "No such file: /Users/me/test.org"
> The cause is the #+begin_src ... #+end_src block
>

Can you please tell us which version of emacs and org-mode are you
using? 

M-x org-version
M-x emacs-version

Thanks and Regards
Noorul

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: latex export problem
       [not found] ` <4CA4C29B.1060404@christianmoe.com>
@ 2010-10-01  7:30   ` Jörg Hagmann
  0 siblings, 0 replies; 29+ messages in thread
From: Jörg Hagmann @ 2010-10-01  7:30 UTC (permalink / raw)
  To: mail; +Cc: Emacs-orgmode

  Hi Christian,

On 9/30/10 7:02 PM, Christian Moe wrote:
> The exact error message is "No such file: /Users/me/test.org::" with 
> two colons at the end, right? 
You are right, I forgot the colons.
> I reported the same problem on 23 September ("Bug: subtree export 
> fails with src block"), but others were not able to reproduce it.
I can understand that. In my case it worked for at least a month. I have 
no idea why it stopped doing so.
> As I wrote at the time, it looks like the problem comes to a head in 
> this part of org-babel-exp-src-blocks
>
> :       (link (org-make-link-string
> :          (concat
> :           org-current-export-file
> :           "::"
> :           (nth 4 (ignore-errors (org-heading-components))))))
>
> and that org-heading-components fails to return the heading text. I'm 
> not lisp-canny enough to see why. Maybe something to do with the 
> active region?
I don't know enough lisp either. But it would be nice if it could be 
corrected; the (working) alternative is to have all the lines in the 
source block preceded by "#+LATEX: " which is less convenient.

> On 9/30/10 4:55 PM, Jörg Hagmann wrote:
>> Dear list,
>>
>> I have an org file named "test.org" structured as follows (minimal
>> example):
>>
>> ------minimal example------------
>> * Head
>> text
>>
>> * Second head
>> :PROPERTIES:
>> :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t *:t
>> skip:nil d:nil tags:nil
>> :EXPORT_TITLE: My Title
>> :EXPORT_FILE_NAME: scripts/filename
>> :END:
>>
>>
>> #+begin_src latex
>> \input gentium-ge
>> #+end_src
>>
>> ** section
>> text
>> ------end of minimal example-----------
>>
>> I export the second head to a filename.tex file in a subdirectory (and
>> convert it later to ConTeXt code, but that shouldn't matter here). I
>> swear that this worked -- I have everything pertaining to my lectures
>> in this file.
>> However, it stopped working recently (without updating org-mode). All
>> I get when I export "Second Head" to latex is:
>> "No such file: /Users/me/test.org"
>> The cause is the #+begin_src ... #+end_src block
>>
>> Did I inadvertently change some parameter? Or is it a bug (less likely)?
>>
>> Thanks for your suggestions, Jörg

^ permalink raw reply	[flat|nested] 29+ messages in thread

* latex export problem
@ 2010-09-30 14:55 Jörg Hagmann
       [not found] ` <4CA4C29B.1060404@christianmoe.com>
  2010-10-01  7:32 ` Noorul Islam K M
  0 siblings, 2 replies; 29+ messages in thread
From: Jörg Hagmann @ 2010-09-30 14:55 UTC (permalink / raw)
  To: Emacs-orgmode

  Dear list,

I have an org file named "test.org" structured as follows (minimal example):

------minimal example------------
* Head
   text

* Second head
   :PROPERTIES:
   :EXPORT_OPTIONS: H:5 num:nil toc:t \n:nil @:t ::t |:t ^:{} -:t f:t 
*:t skip:nil d:nil tags:nil
   :EXPORT_TITLE: My Title
   :EXPORT_FILE_NAME: scripts/filename
   :END:


#+begin_src latex
\input gentium-ge
#+end_src

** section
    text
------end of minimal example-----------

I export the second head to a filename.tex file in a subdirectory (and 
convert it later to ConTeXt code, but that shouldn't matter here). I 
swear that this worked -- I have everything pertaining to my lectures in 
this file.
However, it stopped working recently (without updating org-mode). All I 
get when I export "Second Head" to latex is:
"No such file: /Users/me/test.org"
The cause is the #+begin_src ... #+end_src block

Did I inadvertently change some parameter? Or is it a bug (less likely)?

Thanks for your suggestions, Jörg

^ permalink raw reply	[flat|nested] 29+ messages in thread

end of thread, other threads:[~2014-07-16 16:35 UTC | newest]

Thread overview: 29+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-09-12 16:47 LaTeX export problem Gary Oberbrunner
2012-09-19  7:57 ` Bastien
2012-09-20 14:59   ` Alexander Vorobiev
2012-09-21  8:48     ` Bastien
2012-09-21 19:47       ` Alexander Vorobiev
2012-09-21 21:21         ` Thomas S. Dye
2012-09-22  8:01           ` Nicolas Goaziou
2012-09-22  8:07         ` Nicolas Goaziou
2012-09-24 16:40           ` Alexander Vorobiev
2012-09-24 21:15             ` Nicolas Goaziou
2012-09-24 21:32               ` Alexander Vorobiev
2012-09-26 18:48                 ` Nicolas Goaziou
  -- strict thread matches above, loose matches on Subject: below --
2014-07-13 21:25 Thomas S. Dye
2014-07-16 14:36 ` Nicolas Goaziou
2014-07-16 16:35   ` Thomas S. Dye
2012-01-09 15:45 Piotr Kaźmierczak
2012-01-10  0:13 ` Nick Dokos
2012-01-17 13:35   ` Piotr Kaźmierczak
2012-01-17 17:00     ` Nick Dokos
2012-01-17 19:00       ` Piotr Kaźmierczak
2012-01-17 20:45     ` Eric S Fraga
2010-09-30 14:55 latex " Jörg Hagmann
     [not found] ` <4CA4C29B.1060404@christianmoe.com>
2010-10-01  7:30   ` Jörg Hagmann
2010-10-01  7:32 ` Noorul Islam K M
2010-10-01  7:40   ` Jörg Hagmann
2010-10-01  9:03     ` Noorul Islam K M
2010-10-01  9:17       ` Noorul Islam
2010-10-01 11:38         ` Jörg Hagmann
2010-10-01 12:05           ` Jörg Hagmann

Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).