emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* LaTeX Headers not in partial export
@ 2020-10-23  2:22 Mike Gauland
  2020-10-23 15:00 ` Eric S Fraga
  0 siblings, 1 reply; 5+ messages in thread
From: Mike Gauland @ 2020-10-23  2:22 UTC (permalink / raw)
  To: emacs-orgmode

Not sure if I'm doing something wrong, or this is expected.

I have a number of #+LATEX directives at the top of my org file, for 
configuring the minted package.

When I export the whole thing to LaTeX, the source blocks are formatted 
with the desired minted options.

If I export only part of the document--either my marking it, or by 
adding an "export" tag--the source blocks are *not* formatted with the 
desired options. On looking at the generated tex file, I find that the 
options from the top of the org file are missing.

Does this sound like a bug, or user (possibly local configuration) 
error? If the former, I'll generate a small file that demonstrates the 
problem.

Kind regards,

MIke




^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: LaTeX Headers not in partial export
  2020-10-23  2:22 LaTeX Headers not in partial export Mike Gauland
@ 2020-10-23 15:00 ` Eric S Fraga
  2020-10-25  2:38   ` Michael Gauland
  0 siblings, 1 reply; 5+ messages in thread
From: Eric S Fraga @ 2020-10-23 15:00 UTC (permalink / raw)
  To: Mike Gauland; +Cc: emacs-orgmode

On Friday, 23 Oct 2020 at 15:22, Mike Gauland wrote:
> I have a number of #+LATEX directives at the top of my org file, for
> configuring the minted package.

Could you maybe post a minimal example?

-- 
: Eric S Fraga via Emacs 28.0.50, Org release_9.4-61-ga88806.dirty


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: LaTeX Headers not in partial export
  2020-10-23 15:00 ` Eric S Fraga
@ 2020-10-25  2:38   ` Michael Gauland
  2020-10-25  2:45     ` Kyle Meyer
  0 siblings, 1 reply; 5+ messages in thread
From: Michael Gauland @ 2020-10-25  2:38 UTC (permalink / raw)
  To: emacs-orgmode

On 24/10/20 4:00 am, Eric S Fraga wrote:
> On Friday, 23 Oct 2020 at 15:22, Mike Gauland wrote:
>> I have a number of #+LATEX directives at the top of my org file, for
>> configuring the minted package.
> Could you maybe post a minimal example?
>
This file demonstrates the problem, at least on my systems:

------start of file------

#+LATEX: \setminted{frame=single,framerule=1pt}


* Section
  #+begin_src sh :exports code
  echo "This is a code block
  #+end_src

------end of file------


When I export the file to LaTeX, this line is inclued after
\begin{document}:

\setminted{frame=single,framerule=1pt}

When I export only the section--either by selecting it explicitly, or by
adding a "export" tag, that line is missing.





^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: LaTeX Headers not in partial export
  2020-10-25  2:38   ` Michael Gauland
@ 2020-10-25  2:45     ` Kyle Meyer
  2020-10-25  3:00       ` Michael Gauland
  0 siblings, 1 reply; 5+ messages in thread
From: Kyle Meyer @ 2020-10-25  2:45 UTC (permalink / raw)
  To: Michael Gauland; +Cc: emacs-orgmode

Michael Gauland writes:

> ------start of file------
>
> #+LATEX: \setminted{frame=single,framerule=1pt}
>
>
> * Section
>   #+begin_src sh :exports code
>   echo "This is a code block
>   #+end_src
>
> ------end of file------
>
>
> When I export the file to LaTeX, this line is inclued after
> \begin{document}:
>
> \setminted{frame=single,framerule=1pt}
>
> When I export only the section--either by selecting it explicitly, or by
> adding a "export" tag, that line is missing.

Should that be #+LATEX_HEADER: instead of #+LATEX:?


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: LaTeX Headers not in partial export
  2020-10-25  2:45     ` Kyle Meyer
@ 2020-10-25  3:00       ` Michael Gauland
  0 siblings, 0 replies; 5+ messages in thread
From: Michael Gauland @ 2020-10-25  3:00 UTC (permalink / raw)
  To: Kyle Meyer; +Cc: emacs-orgmode


On 25/10/20 3:45 pm, Kyle Meyer wrote:
> Michael Gauland writes:
>
>> ------start of file------
>>
>> #+LATEX: \setminted{frame=single,framerule=1pt}
>>
>>
>> * Section
>>   #+begin_src sh :exports code
>>   echo "This is a code block
>>   #+end_src
>>
>> ------end of file------
>>
>>
>> When I export the file to LaTeX, this line is inclued after
>> \begin{document}:
>>
>> \setminted{frame=single,framerule=1pt}
>>
>> When I export only the section--either by selecting it explicitly, or by
>> adding a "export" tag, that line is missing.
> Should that be #+LATEX_HEADER: instead of #+LATEX:?

Yes--that fixes it. Thanks for spotting that.




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-10-25  3:01 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-23  2:22 LaTeX Headers not in partial export Mike Gauland
2020-10-23 15:00 ` Eric S Fraga
2020-10-25  2:38   ` Michael Gauland
2020-10-25  2:45     ` Kyle Meyer
2020-10-25  3:00       ` Michael Gauland

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).