emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [bug] Problem when tangling into LaTeX
@ 2012-01-30 21:03 Sebastien Vauban
  2012-01-31  1:40 ` Eric Schulte
  0 siblings, 1 reply; 6+ messages in thread
From: Sebastien Vauban @ 2012-01-30 21:03 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

#+TITLE:     Noweb references in LaTeX document
#+DATE:      2012-01-30

* Summary

** Problem

I use 3 chunks of LaTeX code which I wanna insert in a LaTeX document.

While 1 of them is correctly tangled into the LaTeX document, the 2 others
generate errors when C-c C-v C-t'ing:

    "if: reference '<<who' not found in this buffer"

and, if I temporarily replace `<<who()>>' by `<<who>>', I get the next error:

    "if: reference '    <<solde' not found in this buffer"

What I don't understand is that there is no -- sorry, I mean: I don't see --
the difference between the 3 noweb references. They all seem correctly
written...

** Note

Remember that, up to now, such a document *must be first tangled* and then
post-processed via =PDFLaTeX=. It can not be exported directly to PDF/HTML (=args
out of range= error).

* Example

** Part 1
#+name: who
#+begin_src org :results latex
1111ToMe
#+end_src

** Part 2
#+name: before
#+begin_src org :results latex
2222BeforeDate
#+end_src

** Part 3
#+name: solde
#+begin_src org :results latex
3333Rest
#+end_src

** Composed letter
#+begin_src latex :noweb yes :tangle yes
\documentclass{article}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}

\begin{document}

\begin{textblock}{85}(98,35)
\titlebox{9.4cm}{Foo}{% HERE 1111 <<<<
<<who()>>
}
\end{textblock}

\begin{textblock}{110}(25,195)
    Some sentence
    <<before()>> \hfill{}% HERE 2222 <<<<
    <<solde()>> EUR% HERE 3333 <<<<
\end{textblock}

\end{document}
#+end_src

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2012-02-01 17:54 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-01-30 21:03 [bug] Problem when tangling into LaTeX Sebastien Vauban
2012-01-31  1:40 ` Eric Schulte
2012-01-31  8:11   ` Sebastien Vauban
2012-01-31 13:16     ` Eric S Fraga
2012-02-01 17:52       ` Sebastien Vauban
2012-02-01 17:54     ` Sebastien Vauban

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).