emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Problem loading a symlink'ed file in Emacs batch
@ 2012-03-08 14:12 Sebastien Vauban
  2012-03-08 17:54 ` Achim Gratz
  0 siblings, 1 reply; 3+ messages in thread
From: Sebastien Vauban @ 2012-03-08 14:12 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hello,

I have a `org-init.el' file in my home directory, with common settings used
when in batch mode.

That works well when that file is a regular file:

--8<---------------cut here---------------start------------->8---
sva@MEDIACENTER$ make html
Exporting file /cygdrive/c/home/sva/file.txt to HTML...
emacs --batch -Q --eval "(setq debug-on-error t) (add-to-list 'load-path \""~/src/org-mode/lisp"\") (add-to-list 'load-path \""~/src/org-mode/contrib/lisp"\")" -l "~/org-init.el" file.txt -f org-export-as-html
Emacs 24.0.93.1
Org-mode version 7.8.03
OVERVIEW
Loading vc-svn...
Loading vc-git...
Exporting...
Exporting...
Saving file c:/home/sva/file.html...
Wrote c:/home/sva/file.html
HTML export done, pushed to kill ring and clipboard
--8<---------------cut here---------------end--------------->8---

However, if I put it somewhere, and make a symlink from my home directory to
its real place, Emacs fails loading it:

--8<---------------cut here---------------start------------->8---
sva@MEDIACENTER$ make html
Exporting file /cygdrive/c/home/sva/file.txt to HTML...
emacs --batch -Q --eval "(setq debug-on-error t) (add-to-list 'load-path \""~/src/org-mode/lisp"\") (add-to-list 'load-path \""~/src/org-mode/contrib/lisp"\")" -l "~/org-init.el" file.txt -f org-export-as-html
Debugger entered--Lisp error: (void-variable !<symlink>ÿþ/)
  eval-buffer(#<buffer  *load*> nil "c:/home/sva/org-init.el" nil t)  ; Reading at buffer position 14
  load-with-code-conversion("c:/home/sva/org-init.el" "c:/home/sva/org-init.el" nil t)
  load("c:/home/sva/org-init.el" nil t)
  command-line-1(("--eval" "(setq debug-on-error t) (add-to-list 'load-path \"~/src/org-mode/lisp\") (add-to-list 'load-path \"~/src/org-mode/contrib/lisp\")" "-l" "~/org-init.el" "file.txt" "-f" "org-export-as-html"))
  command-line()
  normal-top-level()

Makefile:33: recipe for target `file.html' failed
make: *** [file.html] Error 127
--8<---------------cut here---------------end--------------->8---

I find this very strange, as I thought the symlink feature would be
transparent for upper applications. This does not seem to be the case, though.

Any idea on how to circumvent this, if possible?

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Problem loading a symlink'ed file in Emacs batch
  2012-03-08 14:12 Problem loading a symlink'ed file in Emacs batch Sebastien Vauban
@ 2012-03-08 17:54 ` Achim Gratz
  2012-03-09 12:12   ` Sebastien Vauban
  0 siblings, 1 reply; 3+ messages in thread
From: Achim Gratz @ 2012-03-08 17:54 UTC (permalink / raw)
  To: emacs-orgmode


If you are using NTemacs rather than the one supplied by Cygwin it
simply doesn't know about symlinks.

 
Regards,
Achim.
-- 
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptation for Waldorf Blofeld V1.15B11:
http://Synth.Stromeko.net/Downloads.html#WaldorfSDada

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Problem loading a symlink'ed file in Emacs batch
  2012-03-08 17:54 ` Achim Gratz
@ 2012-03-09 12:12   ` Sebastien Vauban
  0 siblings, 0 replies; 3+ messages in thread
From: Sebastien Vauban @ 2012-03-09 12:12 UTC (permalink / raw)
  To: emacs-orgmode-mXXj517/zsQ

Hi Achim,

Achim Gratz wrote:
> If you are using NTemacs rather than the one supplied by Cygwin it simply
> doesn't know about symlinks.

I was using an official GNU Emacs binary for Windows (found on
http://alpha.gnu.org/gnu/emacs/windows/).

Anyway, switching to Cygwin Emacs does resolve the symlink problem. Thanks a
lot for your answer!

Best regards,
  Seb

-- 
Sebastien Vauban

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2012-03-09 12:12 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-03-08 14:12 Problem loading a symlink'ed file in Emacs batch Sebastien Vauban
2012-03-08 17:54 ` Achim Gratz
2012-03-09 12:12   ` Sebastien Vauban

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).