emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Minor bug in footnotes
@ 2009-01-05  1:14 Matthew Lundin
  2009-01-05 12:28 ` Carsten Dominik
  0 siblings, 1 reply; 2+ messages in thread
From: Matthew Lundin @ 2009-01-05  1:14 UTC (permalink / raw)
  To: emacs-orgmode


Hi Carsten,

After some additional testing of footnote options, I discovered
another minor quirk. It occurs when org-footnote-section is set to a
value such as "Footnotes" (the default value). When
org-footnote-action is called for the very first time in an org
buffer, the "Footnotes" headline is automatically created, but the
footnote is placed above the headline.

I believe this occurs when the "Footnotes" headline is the last line
in the buffer, which is the case when the headline is automatically
created. Once an empty line is placed beneath the "Footnotes"
headline, new footnotes are correctly placed beneath it.

The example below illustrates the behavior.

Thanks,

Matt

----begin org file--------

* Headline one

The first footnote.[fn:1] The second footnote.[fn:2] Now I will add a
an empty line beneath the "Footnotes" section.[fn:3]

[fn:1] Notice that this footnote is inserted above the "Footnotes"
section.

[fn:2] The same behavior.

* Footnotes

[fn:3] Notice that the footnote is now placed below the footnote
section. 

-----end org file-----

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Minor bug in footnotes
  2009-01-05  1:14 Minor bug in footnotes Matthew Lundin
@ 2009-01-05 12:28 ` Carsten Dominik
  0 siblings, 0 replies; 2+ messages in thread
From: Carsten Dominik @ 2009-01-05 12:28 UTC (permalink / raw)
  To: Matthew Lundin; +Cc: emacs-orgmode

Fixed, thanks.

- Carsten

On Jan 5, 2009, at 2:14 AM, Matthew Lundin wrote:

>
> Hi Carsten,
>
> After some additional testing of footnote options, I discovered
> another minor quirk. It occurs when org-footnote-section is set to a
> value such as "Footnotes" (the default value). When
> org-footnote-action is called for the very first time in an org
> buffer, the "Footnotes" headline is automatically created, but the
> footnote is placed above the headline.
>
> I believe this occurs when the "Footnotes" headline is the last line
> in the buffer, which is the case when the headline is automatically
> created. Once an empty line is placed beneath the "Footnotes"
> headline, new footnotes are correctly placed beneath it.
>
> The example below illustrates the behavior.
>
> Thanks,
>
> Matt
>
> ----begin org file--------
>
> * Headline one
>
> The first footnote.[fn:1] The second footnote.[fn:2] Now I will add a
> an empty line beneath the "Footnotes" section.[fn:3]
>
> [fn:1] Notice that this footnote is inserted above the "Footnotes"
> section.
>
> [fn:2] The same behavior.
>
> * Footnotes
>
> [fn:3] Notice that the footnote is now placed below the footnote
> section.
>
> -----end org file-----
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2009-01-05 12:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-05  1:14 Minor bug in footnotes Matthew Lundin
2009-01-05 12:28 ` Carsten Dominik

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).