emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* [Orgmode] Bug: LaTeX export of subscripts and superscripts in Tables. [7.9.1]
@ 2012-09-04  8:07 gyaman333
  2012-09-05  8:01 ` [Orgmode] [SOLVED] " Giovanni Ridolfi
  0 siblings, 1 reply; 2+ messages in thread
From: gyaman333 @ 2012-09-04  8:07 UTC (permalink / raw)
  To: emacs-orgmode

Using the following orgmode text:
* table 
- table
  |--------|
  | 10^{3} |
  | H_{2}O |
  |--------|

- 10^{3} 
- H_{2}O

==EOF==



the LaTeX exporter produces in version 7.9.1:

\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{table}
\label{sec-1}

\begin{itemize}
\item table

\begin{center}
\begin{tabular}{l}
\hline
 10^\{3\}  \\      % may be Bug
 H_\{2\}O  \\      %
\hline
\end{tabular}
\end{center}


\item 10$^{3}$
\item H$_{2}$O
\end{itemize}

==EOF==

\end{document}


The HTML export works fine!

Emacs: GNU Emacs 24.2.1 (x86_64-apple-darwin12.1.0, NS apple-appkit-1187.00)





the LaTeX exporter produces in version 7.8.11:
\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{table}
\label{sec-1}

\begin{itemize}
\item table

\begin{center}
\begin{tabular}{l}
\hline
 10$^{3}$  \\
 H$_{2}$O  \\
\hline
\end{tabular}
\end{center}


\item 10$^{3}$
\item H$_{2}$O
\end{itemize}

==EOF==

\end{document}




-- 
=== gyaman333@gmail.com ===

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [Orgmode] [SOLVED] Bug: LaTeX export of subscripts and superscripts in Tables. [7.9.1]
  2012-09-04  8:07 [Orgmode] Bug: LaTeX export of subscripts and superscripts in Tables. [7.9.1] gyaman333
@ 2012-09-05  8:01 ` Giovanni Ridolfi
  0 siblings, 0 replies; 2+ messages in thread
From: Giovanni Ridolfi @ 2012-09-05  8:01 UTC (permalink / raw)
  To: gyaman333, emacs-orgmode

The new exporter exports the table correctly:

\begin{tabular}{l}
\hline
10$^3$\\
H$_2$O\\
\hline
\end{tabular}

please use it as suggested in the Release notes[1]


cheers,
Giovanni

[1] http://orgmode.org/Changes.html


Make sure contrib/lisp/ is in your load-path
M-: (require 'org-export) RET
M-: (require 'org-e-latex) RET ; or any other library
M-x org-export-dispatch RET




----- Messaggio originale -----
Da: "gyaman333@gmail.com" <gyaman333@gmail.com>
A: emacs-orgmode@gnu.org
Cc: 
Inviato: Martedì 4 Settembre 2012 10:07
Oggetto: [O] [Orgmode] Bug: LaTeX export of subscripts and superscripts in Tables. [7.9.1]

Using the following orgmode text:
* table 
- table
  |--------|
  | 10^{3} |
  | H_{2}O |
  |--------|

- 10^{3} 
- H_{2}O

==EOF==



the LaTeX exporter produces in version 7.9.1:

\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{table}
\label{sec-1}

\begin{itemize}
\item table

\begin{center}
\begin{tabular}{l}
\hline
10^\{3\}  \\      % may be Bug
H_\{2\}O  \\      %
\hline
\end{tabular}
\end{center}


\item 10$^{3}$
\item H$_{2}$O
\end{itemize}

==EOF==

\end{document}


Emacs: GNU Emacs 24.2.1 (x86_64-apple-darwin12.1.0, NS apple-appkit-1187.00)

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-09-05  8:01 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-09-04  8:07 [Orgmode] Bug: LaTeX export of subscripts and superscripts in Tables. [7.9.1] gyaman333
2012-09-05  8:01 ` [Orgmode] [SOLVED] " Giovanni Ridolfi

Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).