emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* inconsistent export of R results in orgmode 7.3,
@ 2010-11-22 18:37 Ian Kennedy
  2010-11-22 18:43 ` Erik Iverson
  0 siblings, 1 reply; 2+ messages in thread
From: Ian Kennedy @ 2010-11-22 18:37 UTC (permalink / raw)
  To: emacs-orgmode


Since upgrading to org-mode 7.3 I have had inconsistent export of R code
block results. Sometimes the results appear in the exported document,
sometimes they don't. I've included the simplest example I've been able to
come up with below. When I export this file the data frame is exported
about half the time. The example below is about the shortest I've come up
with that shows inconsistent export. I usually have the problem with more
complex documents, which use R only, and  which have R read in data from
external files.

I do not have the problem if I use org-mode 7.01h. I am running emacs 23.2
on Windows XP with R 2.12.0. My apologies if this has already been
discussed (if it has, maybe somebody can point me to the discussion I
missed).

Here's the example:
* Ditaa Example
  #+BEGIN_SRC ditaa :file dit.png :width 300 :height 300  :exports results
    +-------------------------------+
    |                               |
    |            Block 1            |
    |                               |
    +---------------+---------------+
                    |
                    |
                    v
    +-------------------------------+
    |                               |
    |            Block 2            |
    |                               |
    +-------------------------------+

  #+END_SRC
* R example
** Something  in R

   #+BEGIN_SRC R :session *R* :exports none
     x <- 1:5
     y <- data.frame(A=x, B=round(sin(x/3.3),3))
   #+END_SRC

** A table which is often not exported
   #+BEGIN_SRC R :session *R* :exports results :colnames yes
     y
   #+END_SRC


Thanks,
Ian

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: inconsistent export of R results in orgmode 7.3,
  2010-11-22 18:37 inconsistent export of R results in orgmode 7.3, Ian Kennedy
@ 2010-11-22 18:43 ` Erik Iverson
  0 siblings, 0 replies; 2+ messages in thread
From: Erik Iverson @ 2010-11-22 18:43 UTC (permalink / raw)
  To: Ian Kennedy; +Cc: emacs-orgmode

Ian,

What does your *R* session buffer look like
when this does and does not work?  The same?

Perhaps the prompt is getting confused at some point?

Your example has worked 4 times in a row for me...

--Erik

Ian Kennedy wrote:
> Since upgrading to org-mode 7.3 I have had inconsistent export of R code
> block results. Sometimes the results appear in the exported document,
> sometimes they don't. I've included the simplest example I've been able to
> come up with below. When I export this file the data frame is exported
> about half the time. The example below is about the shortest I've come up
> with that shows inconsistent export. I usually have the problem with more
> complex documents, which use R only, and  which have R read in data from
> external files.
> 
> I do not have the problem if I use org-mode 7.01h. I am running emacs 23.2
> on Windows XP with R 2.12.0. My apologies if this has already been
> discussed (if it has, maybe somebody can point me to the discussion I
> missed).
> 
> Here's the example:
> * Ditaa Example
>   #+BEGIN_SRC ditaa :file dit.png :width 300 :height 300  :exports results
>     +-------------------------------+
>     |                               |
>     |            Block 1            |
>     |                               |
>     +---------------+---------------+
>                     |
>                     |
>                     v
>     +-------------------------------+
>     |                               |
>     |            Block 2            |
>     |                               |
>     +-------------------------------+
> 
>   #+END_SRC
> * R example
> ** Something  in R
> 
>    #+BEGIN_SRC R :session *R* :exports none
>      x <- 1:5
>      y <- data.frame(A=x, B=round(sin(x/3.3),3))
>    #+END_SRC
> 
> ** A table which is often not exported
>    #+BEGIN_SRC R :session *R* :exports results :colnames yes
>      y
>    #+END_SRC
> 
> 
> Thanks,
> Ian
> 
> 
> _______________________________________________
> Emacs-orgmode mailing list
> Please use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2010-11-22 18:43 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-11-22 18:37 inconsistent export of R results in orgmode 7.3, Ian Kennedy
2010-11-22 18:43 ` Erik Iverson

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).