emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* setting default BibTex file
@ 2012-04-02 11:49 Julian Burgos
  2012-04-02 13:53 ` suvayu ali
  0 siblings, 1 reply; 4+ messages in thread
From: Julian Burgos @ 2012-04-02 11:49 UTC (permalink / raw)
  To: emacs-orgmode

Dear list,

This should be pretty easy to answer.  I am having some problems 
defining a default BibTex file.  If I put this at the end of my org file,

\bibliographystyle{plain}
\bibliography{/home/julian/Documents/Refs/BibTex/References}

everything works with no problem.  But if I add this to my .emacs file

(setq reftex-default-bibliography 
(quote("home/julian/Documents/Refs/BibTex/References")))

and this to the end of my org file

\bibliographystyle{plain}
\bibliography{}

When I do the LaTex export I get an "undefined citations" error.
Any ideas?

Julian

-- 
Julian Mariano Burgos, PhD
Hafrannsóknastofnunin/Marine Research Institute
Skúlagata 4, 121 Reykjavík, Iceland
Sími/Telephone : +354-5752037
Bréfsími/Telefax:  +354-5752001
Netfang/Email: julian@hafro.is

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: setting default BibTex file
  2012-04-02 11:49 setting default BibTex file Julian Burgos
@ 2012-04-02 13:53 ` suvayu ali
  2012-04-02 15:10   ` Nick Dokos
  0 siblings, 1 reply; 4+ messages in thread
From: suvayu ali @ 2012-04-02 13:53 UTC (permalink / raw)
  To: Julian Burgos; +Cc: emacs-orgmode

Hey Julian,

On Mon, Apr 2, 2012 at 13:49, Julian Burgos <julian@hafro.is> wrote:
> But if I add this to my .emacs file
>
> (setq reftex-default-bibliography
> (quote("home/julian/Documents/Refs/BibTex/References")))
>
> and this to the end of my org file
>
> \bibliographystyle{plain}
> \bibliography{}
>
> When I do the LaTex export I get an "undefined citations" error.
> Any ideas?

Org-mode doesn't use reftex for its export. Unless that setting
actually includes the \bibliography{..} in the exported tex file, I
don't think that will have any effect. Actually in the docstring for
the variable I see it says:

  *List of BibTeX database files which should be used if none are
  specified. When `reftex-citation' is called from a document which has
  neither a `\bibliography{..}' statement nor a `thebibliography'
  environment, RefTeX will scan these files instead. Intended for using
  `reftex-citation' in non-LaTeX files. The files will be searched along
  the BIBINPUTS or TEXBIB path.

I think this *only* helps you insert the citations with reftex, you
still have to have that line in the tex file.

Hope this helps.

-- 
Suvayu

Open source is the future. It sets us free.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: setting default BibTex file
  2012-04-02 13:53 ` suvayu ali
@ 2012-04-02 15:10   ` Nick Dokos
  2012-04-25 11:36     ` Eric Fraga
  0 siblings, 1 reply; 4+ messages in thread
From: Nick Dokos @ 2012-04-02 15:10 UTC (permalink / raw)
  To: suvayu ali; +Cc: Julian Burgos, nicholas.dokos, emacs-orgmode

suvayu ali <fatkasuvayu+linux@gmail.com> wrote:

> Hey Julian,
> 
> On Mon, Apr 2, 2012 at 13:49, Julian Burgos <julian@hafro.is> wrote:
> > But if I add this to my .emacs file
> >
> > (setq reftex-default-bibliography
> > (quote("home/julian/Documents/Refs/BibTex/References")))
> >
> > and this to the end of my org file
> >
> > \bibliographystyle{plain}
> > \bibliography{}
> >
> > When I do the LaTex export I get an "undefined citations" error.
> > Any ideas?
> 
> Org-mode doesn't use reftex for its export. Unless that setting
> actually includes the \bibliography{..} in the exported tex file, I
> don't think that will have any effect. Actually in the docstring for
> the variable I see it says:
> 
>   *List of BibTeX database files which should be used if none are
>   specified. When `reftex-citation' is called from a document which has
>   neither a `\bibliography{..}' statement nor a `thebibliography'
>   environment, RefTeX will scan these files instead. Intended for using
>   `reftex-citation' in non-LaTeX files. The files will be searched along
>   the BIBINPUTS or TEXBIB path.
> 
> I think this *only* helps you insert the citations with reftex, you
> still have to have that line in the tex file.
> 

... but you can shorten it by setting BIBINPUTS in your .profile/.login/whatever
and then using

\bibliography{References}

in your .org/.tex files.

Nick

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: setting default BibTex file
  2012-04-02 15:10   ` Nick Dokos
@ 2012-04-25 11:36     ` Eric Fraga
  0 siblings, 0 replies; 4+ messages in thread
From: Eric Fraga @ 2012-04-25 11:36 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: Julian Burgos, emacs-orgmode

Nick Dokos <nicholas.dokos@hp.com> writes:


[...]

> ... but you can shorten it by setting BIBINPUTS in your .profile/.login/whatever
> and then using
>
> \bibliography{References}
>
> in your .org/.tex files.

On TeX systems based on kpathsea and texmf, there are defaults which are
quite reasonable.  On Debian/Ubuntu, at the very least, you can put your
files under ~/texmf in an appropriate subdirectory.  Specifically, bib
files can go in ~/texmf/bibtex/bib and they will automatically be found
by bibtex.  Similar directories exist for .bst, .sty and .cls files,
etc.

The actual paths searched by latex et al. are defined by the texmf
configuration, usually found in /etc/texmf/texmf.cnf (again, on Debian
systems; YMMV).  This file is worth looking at as it is better
documented than the man pages etc!  In any case, that configuration file
defines the default settings for BIBINPUTS, BSTINPUTS and so on.

-- 
: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs 24.1.50.1
: using Org-mode version 7.8.06 (release_7.8.06.181.g67694.dirty)

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2012-04-25 11:36 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-02 11:49 setting default BibTex file Julian Burgos
2012-04-02 13:53 ` suvayu ali
2012-04-02 15:10   ` Nick Dokos
2012-04-25 11:36     ` Eric Fraga

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).