emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* odt export not working
@ 2013-04-21 13:42 Manfred Lotz
  2013-04-21 14:29 ` Eric Abrahamsen
  0 siblings, 1 reply; 13+ messages in thread
From: Manfred Lotz @ 2013-04-21 13:42 UTC (permalink / raw)
  To: emacs-orgmode

Hi there,
Using org-mode 8.0-2-g77476c (fedora 18 system) exporting to odt
doesn't work. zip program is available. When I do =C-c C-e= the
*Org Export Dispatcher* buffer pops up but showing nothing related to
odt. When now typing =o o= I get =Invalid Key=.

Any idea what's going wrong.

-- 
Thanks,
Manfred

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-04-21 13:42 odt export not working Manfred Lotz
@ 2013-04-21 14:29 ` Eric Abrahamsen
  2013-04-21 14:31   ` Manfred Lotz
  0 siblings, 1 reply; 13+ messages in thread
From: Eric Abrahamsen @ 2013-04-21 14:29 UTC (permalink / raw)
  To: emacs-orgmode

Manfred Lotz <manfred.lotz@arcor.de> writes:

> Hi there,
> Using org-mode 8.0-2-g77476c (fedora 18 system) exporting to odt
> doesn't work. zip program is available. When I do =C-c C-e= the
> *Org Export Dispatcher* buffer pops up but showing nothing related to
> odt. When now typing =o o= I get =Invalid Key=.
>
> Any idea what's going wrong.

Are you calling (require 'ox-odt) somewhere in your config? Or
configuring `org-export-backends'? ODT export isn't loaded by default,
you'll have to load it explicitly by one of those two methods.

Hope that's the extent of the problem,

Eric

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-04-21 14:29 ` Eric Abrahamsen
@ 2013-04-21 14:31   ` Manfred Lotz
  2013-05-07 11:01     ` Julian Burgos
  0 siblings, 1 reply; 13+ messages in thread
From: Manfred Lotz @ 2013-04-21 14:31 UTC (permalink / raw)
  To: emacs-orgmode

On Sun, 21 Apr 2013 22:29:10 +0800
Eric Abrahamsen <eric@ericabrahamsen.net> wrote:

> Manfred Lotz <manfred.lotz@arcor.de> writes:
> 
> > Hi there,
> > Using org-mode 8.0-2-g77476c (fedora 18 system) exporting to odt
> > doesn't work. zip program is available. When I do =C-c C-e= the
> > *Org Export Dispatcher* buffer pops up but showing nothing related
> > to odt. When now typing =o o= I get =Invalid Key=.
> >
> > Any idea what's going wrong.
> 
> Are you calling (require 'ox-odt) somewhere in your config? Or
> configuring `org-export-backends'? ODT export isn't loaded by default,
> you'll have to load it explicitly by one of those two methods.
> 
> Hope that's the extent of the problem,
> 
> Eric
> 
> 
> 

Yep, that was it. I didn't know that.

Thanks a lot, Eric.


-- 
Manfred

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-04-21 14:31   ` Manfred Lotz
@ 2013-05-07 11:01     ` Julian Burgos
  2013-05-07 13:59       ` Nicolas Goaziou
  0 siblings, 1 reply; 13+ messages in thread
From: Julian Burgos @ 2013-05-07 11:01 UTC (permalink / raw)
  To: emacs-orgmode

Manfred Lotz <manfred.lotz <at> arcor.de> writes:


> > Are you calling (require 'ox-odt) somewhere in your config? Or
> > configuring `org-export-backends'? ODT export isn't loaded by default,
> > you'll have to load it explicitly by one of those two methods.


This should be included in the manual.  From all the export options listed
in the manual (iCalendar, HTML, LaTex, Plain Text, Publish), ODT export is
the only (I think) that is not on by default.  The manual should explain
clearly (perhaps in section 12.9.1) what you need to do to activate this option.

Cheers! :)

Julian

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 11:01     ` Julian Burgos
@ 2013-05-07 13:59       ` Nicolas Goaziou
  2013-05-07 14:58         ` Julian M. Burgos
  0 siblings, 1 reply; 13+ messages in thread
From: Nicolas Goaziou @ 2013-05-07 13:59 UTC (permalink / raw)
  To: Julian Burgos; +Cc: emacs-orgmode

Hello,

Julian Burgos <julian@hafro.is> writes:

> Manfred Lotz <manfred.lotz <at> arcor.de> writes:
>
>
>> > Are you calling (require 'ox-odt) somewhere in your config? Or
>> > configuring `org-export-backends'? ODT export isn't loaded by default,
>> > you'll have to load it explicitly by one of those two methods.
>
>
> This should be included in the manual.  From all the export options listed
> in the manual (iCalendar, HTML, LaTex, Plain Text, Publish), ODT export is
> the only (I think) that is not on by default.  The manual should explain
> clearly (perhaps in section 12.9.1) what you need to do to activate
> this option.

This is already explained in 12.2.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 13:59       ` Nicolas Goaziou
@ 2013-05-07 14:58         ` Julian M. Burgos
  2013-05-07 15:33           ` Julian M. Burgos
  2013-05-07 15:52           ` Nicolas Goaziou
  0 siblings, 2 replies; 13+ messages in thread
From: Julian M. Burgos @ 2013-05-07 14:58 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Right... I did not saw it.  And even if I did, I would not know that the
package needed for loading the back-end for ODT is called ox-odt.

Nicolas Goaziou writes:

> Hello,
>
> Julian Burgos <julian@hafro.is> writes:
>
>> Manfred Lotz <manfred.lotz <at> arcor.de> writes:
>>
>>
>>> > Are you calling (require 'ox-odt) somewhere in your config? Or
>>> > configuring `org-export-backends'? ODT export isn't loaded by default,
>>> > you'll have to load it explicitly by one of those two methods.
>>
>>
>> This should be included in the manual.  From all the export options listed
>> in the manual (iCalendar, HTML, LaTex, Plain Text, Publish), ODT export is
>> the only (I think) that is not on by default.  The manual should explain
>> clearly (perhaps in section 12.9.1) what you need to do to activate
>> this option.
>
> This is already explained in 12.2.
>
>
> Regards,


-- 
Julian Mariano Burgos, PhD
Hafrannsóknastofnunin/Marine Research Institute
Skúlagata 4, 121 Reykjavík, Iceland
Sími/Telephone : +354-5752037
Bréfsími/Telefax:  +354-5752001
Netfang/Email: julian@hafro.is

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 14:58         ` Julian M. Burgos
@ 2013-05-07 15:33           ` Julian M. Burgos
  2013-05-07 15:52           ` Nicolas Goaziou
  1 sibling, 0 replies; 13+ messages in thread
From: Julian M. Burgos @ 2013-05-07 15:33 UTC (permalink / raw)
  To: Julian M. Burgos; +Cc: emacs-orgmode, Nicolas Goaziou

Just thinking how to things easier for noobs like me. :)

Julian M. Burgos writes:

> Right... I did not saw it.  And even if I did, I would not know that the
> package needed for loading the back-end for ODT is called ox-odt.
>
> Nicolas Goaziou writes:
>
>> Hello,
>>
>> Julian Burgos <julian@hafro.is> writes:
>>
>>> Manfred Lotz <manfred.lotz <at> arcor.de> writes:
>>>
>>>
>>>> > Are you calling (require 'ox-odt) somewhere in your config? Or
>>>> > configuring `org-export-backends'? ODT export isn't loaded by default,
>>>> > you'll have to load it explicitly by one of those two methods.
>>>
>>>
>>> This should be included in the manual.  From all the export options listed
>>> in the manual (iCalendar, HTML, LaTex, Plain Text, Publish), ODT export is
>>> the only (I think) that is not on by default.  The manual should explain
>>> clearly (perhaps in section 12.9.1) what you need to do to activate
>>> this option.
>>
>> This is already explained in 12.2.
>>
>>
>> Regards,


-- 
Julian Mariano Burgos, PhD
Hafrannsóknastofnunin/Marine Research Institute
Skúlagata 4, 121 Reykjavík, Iceland
Sími/Telephone : +354-5752037
Bréfsími/Telefax:  +354-5752001
Netfang/Email: julian@hafro.is

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 14:58         ` Julian M. Burgos
  2013-05-07 15:33           ` Julian M. Burgos
@ 2013-05-07 15:52           ` Nicolas Goaziou
  2013-05-07 16:07             ` Julian M. Burgos
  1 sibling, 1 reply; 13+ messages in thread
From: Nicolas Goaziou @ 2013-05-07 15:52 UTC (permalink / raw)
  To: Julian M. Burgos; +Cc: emacs-orgmode

"Julian M. Burgos" <julian@hafro.is> writes:

> Right... I did not saw it.  And even if I did, I would not know that the
> package needed for loading the back-end for ODT is called ox-odt.

You don't need to know that. The manual tells you to customize
`org-export-backends' instead.


Regards,

-- 
Nicolas Goaziou

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 15:52           ` Nicolas Goaziou
@ 2013-05-07 16:07             ` Julian M. Burgos
  2013-05-07 16:32               ` Nick Dokos
  0 siblings, 1 reply; 13+ messages in thread
From: Julian M. Burgos @ 2013-05-07 16:07 UTC (permalink / raw)
  To: Nicolas Goaziou; +Cc: emacs-orgmode

Ok, I see what you mean.  So I should do 
(setq org-export-backends '(odt)) or something like that.  Fair enough. :)


Nicolas Goaziou writes:

> "Julian M. Burgos" <julian@hafro.is> writes:
>
>> Right... I did not saw it.  And even if I did, I would not know that the
>> package needed for loading the back-end for ODT is called ox-odt.
>
> You don't need to know that. The manual tells you to customize
> `org-export-backends' instead.
>
>
> Regards,


-- 
Julian Mariano Burgos, PhD
Hafrannsóknastofnunin/Marine Research Institute
Skúlagata 4, 121 Reykjavík, Iceland
Sími/Telephone : +354-5752037
Bréfsími/Telefax:  +354-5752001
Netfang/Email: julian@hafro.is

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 16:07             ` Julian M. Burgos
@ 2013-05-07 16:32               ` Nick Dokos
  2013-05-07 18:46                 ` John Hendy
  2013-05-10 10:10                 ` Julian M. Burgos
  0 siblings, 2 replies; 13+ messages in thread
From: Nick Dokos @ 2013-05-07 16:32 UTC (permalink / raw)
  To: emacs-orgmode

"Julian M. Burgos" <julian@hafro.is> writes:

> Ok, I see what you mean.  So I should do 
> (setq org-export-backends '(odt)) or something like that.  Fair enough. :)
>

That's *not* what Nicolas suggested and it's *not* what you should do.

Just do

C-h v org-export-backends

and click the Customize link, then mark all the (additional) backends
you want to use. Please read the documentation of the variable: simply
setting it in the middle of an emacs session will *not* work.

Nick

>
> Nicolas Goaziou writes:
>
>> "Julian M. Burgos" <julian@hafro.is> writes:
>>
>>> Right... I did not saw it.  And even if I did, I would not know that the
>>> package needed for loading the back-end for ODT is called ox-odt.
>>
>> You don't need to know that. The manual tells you to customize
>> `org-export-backends' instead.
>>
>>
>> Regards,

-- 
Nick

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 16:32               ` Nick Dokos
@ 2013-05-07 18:46                 ` John Hendy
  2013-05-07 20:02                   ` Nick Dokos
  2013-05-10 10:10                 ` Julian M. Burgos
  1 sibling, 1 reply; 13+ messages in thread
From: John Hendy @ 2013-05-07 18:46 UTC (permalink / raw)
  To: Nick Dokos; +Cc: emacs-orgmode

On Tue, May 7, 2013 at 11:32 AM, Nick Dokos <ndokos@gmail.com> wrote:
> "Julian M. Burgos" <julian@hafro.is> writes:
>
>> Ok, I see what you mean.  So I should do
>> (setq org-export-backends '(odt)) or something like that.  Fair enough. :)
>>
>
> That's *not* what Nicolas suggested and it's *not* what you should do.
>
> Just do
>
> C-h v org-export-backends
>
> and click the Customize link, then mark all the (additional) backends
> you want to use. Please read the documentation of the variable: simply
> setting it in the middle of an emacs session will *not* work.

Though, know that there's a difference in how backends are treated
when loading them via the two methods:[1]

#+begin_quote

3 Installation

══════════════

There are two ways to install export back-ends.

1. You may customize `org-export-backends' variable. It contains the
list of back-ends that should always be available.

2. You can also simply require the back-end libraries (e.g. `(require
'ox-icalendar)' for the iCalendar back-end). Note that with method 1,
the back-ends will be loaded only when the export framework is used
for the first time.

#+end_quote

[1] http://article.gmane.org/gmane.emacs.orgmode/65574

If you customize =org-export-backends=, the actual backend is not
loaded until you export for the first time per new Emacs session.
Mostly not a big deal, but try this out with the following minimal
config:

#+begin_src emacs-config-method-1

;; set load paths
;; set load dirs and global config options
(add-to-list 'load-path "~/.elisp/org.git/lisp/")
(add-to-list 'load-path "~/.elisp/org.git/contrib/lisp")

(setq org-export-backends (quote (odt)))

#+end_src

- emacs -Q
- M-x load-file RET ~/path/to/min-config
- M-x help RET v org-odt-TAB
- Note completions

Now try this:

#+begin_src emacs-config-method-2

;; set load paths
;; set load dirs and global config options
(add-to-list 'load-path "~/.elisp/org.git/lisp/")
(add-to-list 'load-path "~/.elisp/org.git/contrib/lisp")

(require 'ox-odt)

#+end_src

Repeat the steps above and note the difference. If you want to do any
customizing or (like me) use =C-h v= or =M-x help= to remember the
name of the variable you're looking for, you won't get auto-completion
as Org isn't aware of the variable until you actually use the exporter
the first time (use the first minimal config, export to ODT, and then
repeat the steps described and you'll see that the variables are now
known).

Anyway, just wanted to make sure this was well known. I've taken to
using a =(require 'ox-backend)= line for every exporter I want vs. the
org-export-backends variable for this reason.



John


>
> Nick
>
>>
>> Nicolas Goaziou writes:
>>
>>> "Julian M. Burgos" <julian@hafro.is> writes:
>>>
>>>> Right... I did not saw it.  And even if I did, I would not know that the
>>>> package needed for loading the back-end for ODT is called ox-odt.
>>>
>>> You don't need to know that. The manual tells you to customize
>>> `org-export-backends' instead.
>>>
>>>
>>> Regards,
>
> --
> Nick
>
>

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 18:46                 ` John Hendy
@ 2013-05-07 20:02                   ` Nick Dokos
  0 siblings, 0 replies; 13+ messages in thread
From: Nick Dokos @ 2013-05-07 20:02 UTC (permalink / raw)
  To: emacs-orgmode

John Hendy <jw.hendy@gmail.com> writes:

> #+begin_quote
>
> 3 Installation
>
> PPPPPPPPPPPPPP
>
> There are two ways to install export back-ends.
>
> 1. You may customize `org-export-backends' variable. It contains the
> list of back-ends that should always be available.
>
> 2. You can also simply require the back-end libraries (e.g. `(require
> 'ox-icalendar)' for the iCalendar back-end). Note that with method 1,
> the back-ends will be loaded only when the export framework is used
> for the first time.
>
> #+end_quote
>
> [1] http://article.gmane.org/gmane.emacs.orgmode/65574
>
> If you customize =org-export-backends=, the actual backend is not
> loaded until you export for the first time per new Emacs session.
>
> ...
>
> Repeat the steps above and note the difference. If you want to do any
> customizing or (like me) use =C-h v= or =M-x help= to remember the
> name of the variable you're looking for, you won't get auto-completion
> as Org isn't aware of the variable until you actually use the exporter
> the first time (use the first minimal config, export to ODT, and then
> repeat the steps described and you'll see that the variables are now
> known).
>
> Anyway, just wanted to make sure this was well known. I've taken to
> using a =(require 'ox-backend)= line for every exporter I want vs. the
> org-export-backends variable for this reason.
>

This is the usual trade-off between convenience and speed and is
certainly not specific to this case: you can either load into emacs the
kitchen sink at startup time and wait for all of that to finish before
you can start work, or you can initialize things on demand (or do
something in between: see below). That's exactly the difference between
``require'' (or load-file/load-library) and ``autoload''.

If you have a simple initialization file and/or a fast machine and/or
you start emacs once in a blue moon and keep it running, choosing the
"load the kitchen sink" approach might make sense. If not, you can
autoload everything (fastest init but emacs will not know about things
it has not loaded yet until you use them). Or you can ``require'' the things
that you *know* you are going to use and let the rest be autoloaded
(slower init, but more convenience - the case John describes above).

So there is almost a continuum of choices: which one you use is entirely
up to you.

Nick

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: odt export not working
  2013-05-07 16:32               ` Nick Dokos
  2013-05-07 18:46                 ` John Hendy
@ 2013-05-10 10:10                 ` Julian M. Burgos
  1 sibling, 0 replies; 13+ messages in thread
From: Julian M. Burgos @ 2013-05-10 10:10 UTC (permalink / raw)
  To: Nick Dokos; +Cc: emacs-orgmode


Nick, I meant to include (setq org-export-backends '(odt)) in my .emacs
file.  I did that, and now I get the odt exporter as an option when I do
C-c C-e.  

I usually try no to use things that make changes to my .emacs file
direcly because I generate my .emacs file from an .org file (through
tangling).  Any customization would get lost next time I make a change
and tangle my .emacs file (which is quite often!).

Julian


Nick Dokos writes:

> "Julian M. Burgos" <julian@hafro.is> writes:
>
>> Ok, I see what you mean.  So I should do 
>> (setq org-export-backends '(odt)) or something like that.  Fair enough. :)
>>
>
> That's *not* what Nicolas suggested and it's *not* what you should do.
>
> Just do
>
> C-h v org-export-backends
>
> and click the Customize link, then mark all the (additional) backends
> you want to use. Please read the documentation of the variable: simply
> setting it in the middle of an emacs session will *not* work.
>
> Nick
>
>>
>> Nicolas Goaziou writes:
>>
>>> "Julian M. Burgos" <julian@hafro.is> writes:
>>>
>>>> Right... I did not saw it.  And even if I did, I would not know that the
>>>> package needed for loading the back-end for ODT is called ox-odt.
>>>
>>> You don't need to know that. The manual tells you to customize
>>> `org-export-backends' instead.
>>>
>>>
>>> Regards,


-- 
Julian Mariano Burgos, PhD
Hafrannsóknastofnunin/Marine Research Institute
Skúlagata 4, 121 Reykjavík, Iceland
Sími/Telephone : +354-5752037
Bréfsími/Telefax:  +354-5752001
Netfang/Email: julian@hafro.is

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2013-05-10 10:10 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-04-21 13:42 odt export not working Manfred Lotz
2013-04-21 14:29 ` Eric Abrahamsen
2013-04-21 14:31   ` Manfred Lotz
2013-05-07 11:01     ` Julian Burgos
2013-05-07 13:59       ` Nicolas Goaziou
2013-05-07 14:58         ` Julian M. Burgos
2013-05-07 15:33           ` Julian M. Burgos
2013-05-07 15:52           ` Nicolas Goaziou
2013-05-07 16:07             ` Julian M. Burgos
2013-05-07 16:32               ` Nick Dokos
2013-05-07 18:46                 ` John Hendy
2013-05-07 20:02                   ` Nick Dokos
2013-05-10 10:10                 ` Julian M. Burgos

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).