emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* latex-export of first-column-starting emphasis broken
@ 2013-01-16 15:54 Marijn
  2013-01-16 19:26 ` Thomas S. Dye
  2013-01-16 19:50 ` Nick Dokos
  0 siblings, 2 replies; 4+ messages in thread
From: Marijn @ 2013-01-16 15:54 UTC (permalink / raw)
  To: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

While visiting a file with just these two lines:

* S
/s ()/

export to latex: C-c C-e p.

Resulting tex file fails to compile due to the presence of:

\emph{s ()\}

instead of

\emph{s ()}

If you add a space to the beginning of the second line, then it works
as expected. I am using this work-around for now. I'm using emacs-24.2

Marijn

PS Please CC me in responses, as I'm not subsscribed.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlD2zTsACgkQp/VmCx0OL2yGBQCfWJ1XxQOzZvLRNkepyC8GbI2G
SOAAoKKgVv2fgouo/7ZjChSPztiIkHaC
=i1dg
-----END PGP SIGNATURE-----

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: latex-export of first-column-starting emphasis broken
  2013-01-16 15:54 latex-export of first-column-starting emphasis broken Marijn
@ 2013-01-16 19:26 ` Thomas S. Dye
  2013-01-16 19:50 ` Nick Dokos
  1 sibling, 0 replies; 4+ messages in thread
From: Thomas S. Dye @ 2013-01-16 19:26 UTC (permalink / raw)
  To: Marijn; +Cc: emacs-orgmode

Aloha Marijn,

Marijn <hkBst@gentoo.org> writes:

> While visiting a file with just these two lines:
>
> * S
> /s ()/
>
> export to latex: C-c C-e p.
>
> Resulting tex file fails to compile due to the presence of:
>
> \emph{s ()\}
>
> instead of
>
> \emph{s ()}
>
> If you add a space to the beginning of the second line, then it works
> as expected. I am using this work-around for now. I'm using emacs-24.2
>
> Marijn
>
> PS Please CC me in responses, as I'm not subsscribed.

I'm not able to reproduce the problem with Org-mode version 7.9.3b
(release_7.9.3b-811-g0c9579 @ /Users/dk/.emacs.d/src/org-mode/lisp/).  I
don't think I have anything in my setup that accounts for the different
result. 

Here is the exported file:

% Created 2013-01-16 Wed 09:22
\documentclass[11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{fixltx2e}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{float}
\usepackage{wrapfig}
\usepackage{soul}
\usepackage{textcomp}
\usepackage{marvosym}
\usepackage{wasysym}
\usepackage{latexsym}
\usepackage{amssymb}
\usepackage{hyperref}
\tolerance=1000
\providecommand{\alert}[1]{\textbf{#1}}

\title{marijn}
\author{Thomas Dye}
\date{\today}
\hypersetup{
  pdfkeywords={},
  pdfsubject={},
  pdfcreator={Emacs Org-mode version 7.9.3b}}

\begin{document}

\maketitle

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}
\section{S}
\label{sec-1}

\emph{s ()}

\end{document}

All the best,
Tom

-- 
Thomas S. Dye
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: latex-export of first-column-starting emphasis broken
  2013-01-16 15:54 latex-export of first-column-starting emphasis broken Marijn
  2013-01-16 19:26 ` Thomas S. Dye
@ 2013-01-16 19:50 ` Nick Dokos
  2013-02-20  8:35   ` Marijn
  1 sibling, 1 reply; 4+ messages in thread
From: Nick Dokos @ 2013-01-16 19:50 UTC (permalink / raw)
  To: Marijn; +Cc: emacs-orgmode

Marijn <hkBst@gentoo.org> wrote:

> While visiting a file with just these two lines:
> 
> * S
> /s ()/
> 
> export to latex: C-c C-e p.
> 
> Resulting tex file fails to compile due to the presence of:
> 
> \emph{s ()\}
> 
> instead of
> 
> \emph{s ()}
> 
> If you add a space to the beginning of the second line, then it works
> as expected. I am using this work-around for now. I'm using emacs-24.2
> 

Works correctly for me with either the old or the new exporter:

Org-mode version 7.9.3d (release_7.9.3d-826-gbe0d87.dirty)

Nick

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: latex-export of first-column-starting emphasis broken
  2013-01-16 19:50 ` Nick Dokos
@ 2013-02-20  8:35   ` Marijn
  0 siblings, 0 replies; 4+ messages in thread
From: Marijn @ 2013-02-20  8:35 UTC (permalink / raw)
  To: emacs-orgmode

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 16-01-13 20:50, Nick Dokos wrote:
> Marijn <hkBst@gentoo.org> wrote:
> 
>> While visiting a file with just these two lines:
>> 
>> * S /s ()/
>> 
>> export to latex: C-c C-e p.
>> 
>> Resulting tex file fails to compile due to the presence of:
>> 
>> \emph{s ()\}
>> 
>> instead of
>> 
>> \emph{s ()}
>> 
>> If you add a space to the beginning of the second line, then it
>> works as expected. I am using this work-around for now. I'm using
>> emacs-24.2

I think the problem was that I was using the org-mode that's included
with emacs-24.2 (version 6 something?). Using a more recent external
version I also cannot reproduce the problem.

Thank to you both for testing and sorry for the noise.

Marijn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlEkirUACgkQp/VmCx0OL2zOWwCfXIflOHqgF4Fe4cwtWrDRtHCn
cwAAnRdRhAy79MylqKN8K58IwNW5F0+o
=XXjb
-----END PGP SIGNATURE-----

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2013-02-20  8:26 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-01-16 15:54 latex-export of first-column-starting emphasis broken Marijn
2013-01-16 19:26 ` Thomas S. Dye
2013-01-16 19:50 ` Nick Dokos
2013-02-20  8:35   ` Marijn

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).