emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: "Thomas S. Dye" <tsd@tsdye.com>
To: John Hendy <jw.hendy@gmail.com>
Cc: mariomu@ieee.org, emacs-orgmode@gnu.org
Subject: Re: org-article setup
Date: Wed, 17 Nov 2010 11:40:51 -1000	[thread overview]
Message-ID: <0C743517-2912-4D0C-8CE4-5FD1F9192650@tsdye.com> (raw)
In-Reply-To: <AANLkTinPifN=Zqn4kHZkwBrWQBOU_wcYMaihXjzY1=bh@mail.gmail.com>


[-- Attachment #1.1: Type: text/plain, Size: 4939 bytes --]

Hi John,

Perhaps this is missing:

   (require 'org-latex)

Let me know if that fixes your problem and I'll add it to the  
instructions.

All the best,
Tom

On Nov 17, 2010, at 11:07 AM, John Hendy wrote:

> Thanks, Tom.
>
> I'm getting an error, though. I tried both settings from Section 1.2  
> (http://orgmode.org/worg/org-contrib/babel/examples/article-class.php#sec-1_2 
> ) and get this error when I start emacs:
>
> ,-----
> | Symbol's value as variable is void: org-export-latex-classes
> `-----
>
> I just did a fresh git pull, make clean, make && make install just  
> to be sure it wasn't just my version.
>
> What am I goofing up?
>
>
> Thanks,
> John
>
> On Wed, Nov 17, 2010 at 12:58 AM, Thomas S. Dye <tsd@tsdye.com> wrote:
> Aloha John and Mario,
>
> I've moved my buggy development efforts to a branch and you can now  
> pull a stable version of Org-article if you're so inclined.
>
> All the best,
> Tom
>
> On Nov 16, 2010, at 7:11 PM, John Hendy wrote:
>
>> On Tue, Nov 16, 2010 at 5:46 PM, Mario E. Munich <mariomu@ieee.org>  
>> wrote:
>> Dear all,
>>
>> I am trying to use the org-article class created by Tomas Dye. As  
>> you might guess, I am having some trouble and thus the email. I am  
>> using emacs 23.1.1 on Ubuntu 10.10 and org-mode verision TAG=7.3.
>>
>> I have followed the instructions on worg:
>>
>> http://orgmode.org/worg/org-contrib/babel/examples/article-class.php
>>
>> up to the point in which I need to tangle the org document.
>>
>> If I try to run the tangle command: M-x org-babel-tangle RET, I get  
>> the following error: No org-bable-execute function for python!
>>
>> I think that  the problem is that I do not have any setup for Babel  
>> in my .emacs, so I went to look for the standard Babel setup in the  
>> org manual and in worg.
>>
>> Yup -- that's the error.
>>
>>
>> - In the org Manual, I see chapter 14 devoted to Babel, but I do  
>> not see any information on how to set it up in my .emacs (maybe it  
>> is enabled by default since Babel is included in org, but I am not  
>> sure).
>>
>>
>> I concur and think that's weird. Even if it is on worg... perhaps  
>> the manual should point there? There's a decent amount on babel in  
>> the manual so I found it a bit odd that it didn't provide the setup  
>> syntax (like Thomas did).
>>
>> - In worg, there is a page for Babel: http://orgmode.org/worg/org-contrib/babel/index.php 
>>  and a corresponding Introductory Tutorial. In this page, there is  
>> a section called Initial Configuration in which there is a mention  
>> of a "five-step process", but the corresponding list of steps only  
>> have 3 items.
>>
>> 5 vs. 3 is kind of funny. Some of those aren't really even steps.  
>> For your case it's as easy as opening up .emacs and adding this:
>>
>> (org-babel-do-load-languages
>>  'org-babel-load-languages
>>  '((python . t)))
>>
>> Though as Thomas listed, you can have more. It looks like he  
>> actually puts his right into the org file itself with a #+src block.
>>
>> As for the rest of the steps, I actually wasn't able to get it to  
>> compile. I get a bunch of these errors:
>>
>> ,-----
>> | SyntaxError: invalid syntax
>> | File "<stdin>", line 17
>> |    print res
>> |            ^
>> | SyntaxError: invalid syntax
>> `-----
>>
>> I think I get those to go away with "print (res)" instead of res by  
>> itself. I think I've had that error before and it's a python  
>> version issue. I'd suggest changing it if it's accepted by older  
>> versions since python is perhaps moving that direction? I run Arch  
>> Linux and would guess that I may be on a later version than a lot  
>> of distros.
>>
>> I also get this at the end in the minibuffer at the very end:
>> ,-----
>> | reference "gantttest" not found in this buffer
>> `-----
>>
>> I get not class file.
>>
>>
>> I would appreciate if somebody could guide me towards a simple  
>> Babel configuration that would help me tangle the org-article.org  
>> document.
>>
>>
>> It'd probably be a good idea for someone to clean up worg and the  
>> manual a bit. I can do some of those things -- Thomas, perhaps you  
>> want to handle the org-article specific things if there are some  
>> compilation issues on my end that find fixes and I can make worg a  
>> little clearer about babel setup? Not sure who oversees the manual,  
>> but a redirect at the least to worg for .emacs configuration would  
>> be helpful.
>>
>>
>> John
>>
>> Thanks a lot for all the help!
>>
>> -Mario
>>
>>
>> _______________________________________________
>> Emacs-orgmode mailing list
>> Please use `Reply All' to send replies to the list.
>> Emacs-orgmode@gnu.org
>> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
>>
>>
>> _______________________________________________
>> Emacs-orgmode mailing list
>> Please use `Reply All' to send replies to the list.
>> Emacs-orgmode@gnu.org
>> http://lists.gnu.org/mailman/listinfo/emacs-orgmode
>
>


[-- Attachment #1.2: Type: text/html, Size: 7646 bytes --]

[-- Attachment #2: Type: text/plain, Size: 201 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

  reply	other threads:[~2010-11-17 21:41 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-16 23:46 Mario E. Munich
2010-11-17  0:24 ` Thomas S. Dye
2010-11-17  5:11 ` John Hendy
2010-11-17  5:37   ` Thomas S. Dye
2010-11-17  6:58   ` Thomas S. Dye
2010-11-17 21:07     ` John Hendy
2010-11-17 21:40       ` Thomas S. Dye [this message]
     [not found]         ` <AANLkTinOZrEUS4RxsMKUW7Jy+4s+Tjh9i+iANiUBpvsz@mail.gmail.com>
2010-11-17 22:47           ` Thomas S. Dye
2010-11-17 23:07             ` John Hendy
2010-11-22  8:09         ` Mario E. Munich
2010-11-22 17:04           ` Thomas S. Dye
2010-11-17  7:18 ` Thomas S. Dye

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0C743517-2912-4D0C-8CE4-5FD1F9192650@tsdye.com \
    --to=tsd@tsdye.com \
    --cc=emacs-orgmode@gnu.org \
    --cc=jw.hendy@gmail.com \
    --cc=mariomu@ieee.org \
    --subject='Re: org-article setup' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).